Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 31-03-2009 20:20:26

takanuva
Membre
Inscription : 18-02-2009

Prosper latex

Bonjour,
Cette après-midi j'ai entrepris de faire des transparents donc j'ai regarder ce que proposait les classes beamer, slides... Pour finalement me décider pour prosper.
Mais voila rien ne compile!
Donc au début, il n'allait pas chercher les styles sous le bon nom. D'après "prosper.cls", il allait chercher les styles sous le nom PPR\style alors que tout les styles commence par HAP. J'ai donc fait la modification, ensuite il allait bien chercher le bon style.
Par contre, ça ne compilait toujours pas! Donc petite recherche, le log me dit

Undefined control sequence \ifHAP@portrait


J'ai fait quelque test comme enlever les HAP dans les style.sty mais ça ne change rien, pas de compilation!

Je seche et j'aurai bien besoin d'un coup de main!!
merci d'avance

Hors ligne

#2 29-04-2009 09:06:54

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : Prosper latex

Bonjour,

Je prends connaissance de votre message avec beaucoup de retard. Votre problème est peut-être résolu?

Je me demande si ce n'est pas plutôt une question liée à votre installation de TeX et LaTeX, car Prosper n'est qu'une classe de LaTeX. Est-ce LaTeX qui ne compile pas? Personnellement j'utilise Prosper depuis plusieurs années et je n'ai pas rencontré ce problème.

J'utilise Kile comme "frontend" de mon installation de TeX et c'est très commode. Vous pourriez essayer de rafraîchir votre installation avec les commandes (en root)

apt-get update
aptitude install kile

Cela installe non seulement kile mais tout ce qu'il faut pour le faire fonctionner, y compris TeX, LaTeX, etc. Peut-être même prosper. Si prosper n'est pas parmi les fichiers installés tapez

aptitude install prosper.

Puis essayez de compiler (à partir de kile, qui comporte dans sa barre d'outils des boutons pour compiler par Latex, ou plain Tex)
un fichier d'exemples simple: on en trouve un peu partout sur internet.

Cordialement,

C.-M. M.

Hors ligne

#3 29-04-2009 09:22:53

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Prosper latex

Aaaaah ! En voilà des indications formidables... smile

Est-ce intentionnelle CMM que tu aies mis un coup apt-get pour update et aptitude pour install ? roll

Perso, j'évite cela, bien qu'il semble que cela ne pose plus les mêmes problème qu'avant Lenny...

Ce Lenny est une avancée formidable pour le système Debian, belle approche pour les personnes un peu tentées du côté du libre, bravo aux développeurs !

Amitié, Joel

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#4 29-04-2009 10:01:25

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : Prosper latex

Bonjour Joël

(si je peux me permettre une note personnelle, j'ai un fils qui s'appelle aussi Joël)

Je n'ai pas encore très bien compris la différence entre apt-get et aptitude. Mais j'apprends!

Toutefois, cela n'est pas vraiment en rapport avec le problème de takanuva

Amicalement,

C.-M. M.

Hors ligne

#5 29-04-2009 10:53:37

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Prosper latex

Salut papa ! wink

Wouap... Je taquine hein ? Pas d'offense... smile

La différence entre apt-get et aptitude est dans la gestion des paquets dépendants...
Certains, installés avec l'un, peuvent être effacer ou non reconnu comme nécessaire par un nettoyage de l'autre... Ainsi, il m'est arrivé de devoir réinstaller gnome lors d'installation/désinstallation avec aptitude.

C'est une question de gestion des bibliothèques crois-je en gros...

Pour la résolution du post en cours de takanuva, oui, ce débat de fond ne modifie rien de ton eclaircissement, c'était pour le shmilili... mishlui... shmilishimil... shmilblick seulement...

Je reste interessé par l'usage de Latex, qui m'est largement conseillé d'un peu partout. Jamais réussi à accrocher le morceau fonctionnellement... Un peu de temps plus tard, je m'y collerai pour de bon... des dimanches neigeux et venteux de l'hivers prochain... Hein Chris ?
Pour les non-initiés, là :
http://debian-facile.org/forum/viewtopi … 7038#p7038  et tout le post.... Tsop !
Mouaaaaah !

Amitié, Joel

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#6 29-04-2009 11:19:52

takanuva
Membre
Inscription : 18-02-2009

Re : Prosper latex

Finalement j'ai fait ces transparents avec beamer. J'avais essayé de desinstaller, supprimer les paquets puis reinstaller mais ça n'avait rien donné donc j'avais abandonner.

Sinon j'utilise gedit avec ses plugins qui s'integre mieu dans gnome que kile. Il propose moin d'aide mais me convient parfaitement.

Hors ligne

Pied de page des forums