Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-10-2015 00:27:02

Coolhand
Membre
Distrib. : jessie
Inscription : 27-09-2012

Dualboot windows10 ubuntu 15.10 sans passer par grub

Bonjour,

Je viens vers debian facile car il m'arrive un truc assez marrant mais je ne trouve trop rien à ce sujet sur le net.

Voilà mon ordre de boot après installation d'un dualboot, et grub visiblement n'éxiste pas(ou en tout cas je ne le vois pas)

mini_151024015936955008.jpg

Quand je veux changer d'OS je dois aller dans l'uefi, en fait je sais pas trop comment j'en suis arrivé là, mais c'est la première fois que je vois ça.

(Oups oui je suis sous ubuntu en ce moment, un peu la flème tongue... je sais big_smile c'est mal lol)

En tout les cas voilà le lien vers un post que j'ai ouvert sur le forum ubuntu:

https://forum.ubuntu-fr.org/viewtopic.p … #p20849101

Et si quelqu'un a un lien pour expliquer comment choisir ou installer un os (debian, ubuntu ou autre)avec un grub ou dans uefi, je suis preneur

merki
@+

Dernière modification par Coolhand (25-10-2015 00:29:34)

Hors ligne

#2 25-10-2015 16:20:38

raleur
Membre
Inscription : 03-10-2014

Re : Dualboot windows10 ubuntu 15.10 sans passer par grub

Quand tu sélectionnes "ubuntu", tu n'as pas de GRUB qui se lance ?


Comme c'est Ubuntu qui a installé GRUB, l'entrée d'amorçage EFI s'appelle "ubuntu". Si tu avais installé Debian, elle s'appellerait "debian".
A moins qu'Ubuntu déclare directement le noyau Linux (qui est amorçable directement par un firmware UEFI sans passer par un chargeur comme GRUB), mais ça m'étonnerait car cela ne permettrait pas de faire du multiboot via GRUB.


Qu'affiche la commande suivante ? Elle affiche les entrées d'amorçage du firmware EFI de façon plus détaillée que le menu du firmware.

efibootmgr -v

Dernière modification par raleur (25-10-2015 16:22:00)

Hors ligne

#3 26-10-2015 11:37:30

Coolhand
Membre
Distrib. : jessie
Inscription : 27-09-2012

Re : Dualboot windows10 ubuntu 15.10 sans passer par grub

Voilà le résultat:

efibootmgr -v


BootCurrent: 0003
Timeout: 2 seconds
BootOrder: 0003,0001,0000,0002
Boot0000* CD/DVD Drive  BBS(CDROM,,0x0)
Boot0001* Hard Drive  BBS(HD,,0x0)
Boot0002* Windows Boot Manager  HD(2,GPT,bab992b2-cc6a-4fb1-9108-63d34a3988de,0xe1800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...d................
Boot0003* ubuntu  HD(2,GPT,bab992b2-cc6a-4fb1-9108-63d34a3988de,0xe1800,0x32000)/File(\EFI\ubuntu\shimx64.efi)
 



Et effectivement ubuntu semble être directement dans EFI, en tout cas c'est ce que j'en comprend.

Dernière modification par Coolhand (26-10-2015 11:39:36)

Hors ligne

#4 26-10-2015 13:24:00

raleur
Membre
Inscription : 03-10-2014

Re : Dualboot windows10 ubuntu 15.10 sans passer par grub

On voit que l'entrée "ubuntu" ne lance pas directement GRUB ou un noyau Linux mais shimx64.efi, dont le rôle est d'assurer la compatibilité avec le secure boot d'UEFI. Pour information, Debian ne contient pas cette couche intermédiaire et n'est donc pas compatible nativement avec le secure boot, qu'il faut désactiver. Ensuite, que lance shimx64.efi, on ne le voit pas ici. Tu peux regarder dans la partition système EFI qui doit être montée sur /boot/efi, si le répertoire EFI/ubuntu contient un fichier grubx64.efi ce qui indiquerait la présence de GRUB.

Je repose la question à laquelle tu n'as pas répondu : quand tu sélectionnes "ubuntu", tu n'as pas de GRUB qui se lance ? Il se peut que le menu de GRUB ne s'affiche pas par défaut (je connais mal Ubuntu), dans ce cas il faut généralement appuyer sur une certaine touche pour l'afficher.

Par contre d'après la ligne BootOrder, l'entrée "ubuntu" (Boot0003) devrait être en premier dans l'ordre de priorité d'amorçage et Windows (Boot0002) en dernier. Pourtant le firmware l'affiche en second après Windows. Qu'est-ce qui se lance si tu laisse l'ordinateur démarrer sans rien faire ?

Hors ligne

#5 26-10-2015 14:40:59

Coolhand
Membre
Distrib. : jessie
Inscription : 27-09-2012

Re : Dualboot windows10 ubuntu 15.10 sans passer par grub

Ah oui oups je suis allez un peu vite ce matin, donc au démarrage:
- je passe par l'uefi dans lequel je choisi l'OS
- je choisi ubuntu
- on voit juste un écran violet du style de grub vide d'inscription quelques instants
mini_151026021245469319.jpg
- et ensuite on voit ubuntu qui se lance avec son splashscreen

sinon voilà le contenu de mon fichier effectivement on y trouve bien un fichier grub64.efi

root@monpc:/boot/efi/EFI/ubuntu#

ls -l



total 3436
-rwx------ 1 root root     117 oct.  26 11:42 grub.cfg
-rwx------ 1 root root  955256 oct.  26 11:42 grubx64.efi
-rwx------ 1 root root 1271672 oct.  26 11:42 MokManager.efi
-rwx------ 1 root root 1289424 oct.  26 11:42 shimx64.efi
 



Je viens de connecter deux clefs usb et je redémarre et voila le résultat dans l'uefi

mini_151026015809530154.jpg

et avec la commande

efibootmgr -v



BootCurrent: 0003
Timeout: 2 seconds
BootOrder: 0003,0001,0000,0002,0004,0005
Boot0000* CD/DVD Drive    BBS(CDROM,,0x0)
Boot0001* Hard Drive    BBS(HD,,0x0)
Boot0002* Windows Boot Manager    HD(2,GPT,bab992b2-cc6a-4fb1-9108-63d34a3988de,0xe1800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...d................
Boot0003* ubuntu    HD(2,GPT,bab992b2-cc6a-4fb1-9108-63d34a3988de,0xe1800,0x32000)/File(\EFI\ubuntu\shimx64.efi)
Boot0004* UEFI: KingstonDataTraveler 3.0PMAP    PciRoot(0x0)/Pci(0x1d,0x0)/USB(1,0)/USB(7,0)/HD(1,MBR,0x80,0x800,0x1d4d800)
Boot0005* UEFI: Lexar JD FireFly 1100    PciRoot(0x0)/Pci(0x1d,0x0)/USB(1,0)/USB(8,0)/HD(1,MBR,0x4294967220,0x22c86c,0x11c0)
 



Donc le boot order doit corespondre à mon choix à moi et les boot0000*, boot0001*, .... doivent correspondre à ce que voit l'ordinateur, enfin c'est ce que j'en comprend.

Et du coup si je boot sans rien faire c'est ubuntu qui se lance

Dernière modification par Coolhand (26-10-2015 15:09:02)

Hors ligne

#6 26-10-2015 15:15:30

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Dualboot windows10 ubuntu 15.10 sans passer par grub

@Coolhand
Petite correction en douce sur tes posts afin de faire apparaître au mieux les commandes que tu indiques accompagnées de leurs résultats.
Tu peux voir comment on pratique en ouvrant tes posts par Modifier.

Pour te renseigner davantage sur les balises du forum df :
Voir le tuto : Le code, ça pique moins les yeux en couleur smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#7 26-10-2015 16:43:37

raleur
Membre
Inscription : 03-10-2014

Re : Dualboot windows10 ubuntu 15.10 sans passer par grub

Coolhand a écrit :

- je passe par l'uefi dans lequel je choisi l'OS


Pourquoi passes-tu par l'UEFI ? Que se passe-t-il si tu laisses le PC démarrer sans rien faire ?

Coolhand a écrit :

- on voit juste un écran violet du style de grub vide d'inscription quelques instants


GRUB est peut-être configuré pour ne pas afficher le menu par défaut (option GRUB_HIDDEN_TIMEOUT dans /etc/default/grub). Tu as essayé d'appuyer sur une touche du clavier à ce moment ?

Coolhand a écrit :

Je viens de connecter deux clefs usb et je redémarre et voila le résultat dans l'uefi


On voit bien les deux clés USB Kingston et Lexar dans le menu de l'UEFI ainsi que dans la sortie d'efibootmgr. On voit aussi l'ensemble fakeRAID (Intel RAID0) et le lecteur de DVD (P6: ATAPI). Par contre maintenant l'entrée ubuntu apparaît en première position, ce qui est conforme à l'ordre de boot affiché par efibootmgr. As-tu changé quelque chose ?

Note : la numérotation des entrées Boot0000, Boot0001... est arbitraire et indépendante de l'ordre de boot qui est fixé par l'ordre dans lequel elles figurent dans la ligne BootOrder.

Hors ligne

#8 28-10-2015 10:59:11

Coolhand
Membre
Distrib. : jessie
Inscription : 27-09-2012

Re : Dualboot windows10 ubuntu 15.10 sans passer par grub

Ok bien reçu smolski smile

Hors ligne

#9 28-10-2015 11:09:47

Coolhand
Membre
Distrib. : jessie
Inscription : 27-09-2012

Re : Dualboot windows10 ubuntu 15.10 sans passer par grub

raleur a écrit :

Pourquoi passes-tu par l'UEFI ? Que se passe-t-il si tu laisses le PC démarrer sans rien faire ?



SI je laisse le pc démarrer sans rien faire, il démarre avec mon premier choix mis dans l'ordre de boot, ubuntu en ce moment.


raleur a écrit :

GRUB est peut-être configuré pour ne pas afficher le menu par défaut (option GRUB_HIDDEN_TIMEOUT dans /etc/default/grub). Tu as essayé d'appuyer sur une touche du clavier à ce moment ?



Du coup j'ai essayé et il ne se passe rien de spéciale.



raleur a écrit :

On voit bien les deux clés USB Kingston et Lexar dans le menu de l'UEFI ainsi que dans la sortie d'efibootmgr. On voit aussi l'ensemble fakeRAID (Intel RAID0) et le lecteur de DVD (P6: ATAPI). Par contre maintenant l'entrée ubuntu apparaît en première position, ce qui est conforme à l'ordre de boot affiché par efibootmgr. As-tu changé quelque chose ?



Oui j'ai changer plusieurs fois l'ordre de boot en fonction de l'os que je voulais lancer.


Et au final à mon sens, je pense qu'il s'agit d'un bug d'affichage d'ubuntu(sous ubuntu grub possède un fond d'écran violet comme montré plus haut), histroire de faire avancer le schmilblick, j'ai fait de la place et j'ai installé une jessie à côté. Et maintenant au démarrage je vois enfin grub quand je boot sous jessie. (windows n’apparaît pas mais ça c'est un autre problème et ce n'est pas le sujet de ce post smile). Donc c'est juste moi qui bug smile.

Voilou.

Merki et @+

Dernière modification par Coolhand (28-10-2015 16:41:40)

Hors ligne

Pied de page des forums