Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-11-2015 01:03:18

tourbinux
Membre
Distrib. : Debian 8.6 (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : KDE 4.14.2
Inscription : 03-11-2015

KDE 4 - Nvidia - Très légère latence lors du déplacement des fenêtres

Bonjour,


Je rencontre un très léger problème qui sera sans doute un détail pour vous, mais pour moi qui veut dire beaucoup (dixit France Gall wink).
Lorsque j'ouvre une application comme par exemple KWrite et que je clique en haut de la fenêtre pour la déplacer, il y a une très légère latence lors de ce déplacement.
Comme si la fenêtre était lourde. Si je vous montre cela sur une vidéo, je ne pense pas que ce soit visible. C'est en quelque sorte un ressenti entre le déplacement de la souris et l'affichage de la fenêtre qui se déplace.

Ce type de problème est souvent difficile à résoudre par une recherche sur Google mad


J'ai trouvé une solution qui fonctionne mais qui n'est pas très propre et surtout pas très pratique et je n'arrive pas à m'expliquer pourquoi.
Dans Configuration du système -> Effets de bureau -> il est indiqué que le raccourci clavier Alt+Maj+F12 permet d'activer ou de désactiver les effets de bureau.


En faisant ce raccourci une 1ère fois, les effets se désactivent et le déplacement des fenêtres ne présente plus de légère latence smile
En le faisant une seconde fois, les effets se réactivent et les fenêtres se déplacent toujours aussi bien, c'est à dire que le problème ne réapparaît pas. smile
Donc en gros, après un redémarrage de la machine, il faut faire cette manip pour que ce soit ok.


Vous trouverez ci-dessous toutes les informations qui pourront peut-être vous aider à trouver une solution cool


Configuration de la machine


  • Processeur : Intel Core i5 4570

  • Mémoire vive : 8 Go

  • Système d'exploitation : Debian GNU/Linux 8.2 (Jessie)

  • Noyau : Linux 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1+deb8u5 (2015-10-09) x86_64 GNU/Linux

  • Écran : Nec MultiSync EA244WMi (résolution de 1920 x 1200 pixels)

  • Environnement de bureau : KDE 4.14.2

  • Carte graphique : Nvidia GeForce GTX 750 Ti (2 Go DDR5) NVIDIA Corporation GM107 [GeForce GTX 750 Ti] [10de:1380] (rev a2)

  • Pilote graphique : propriétaire Nvidia 340.65




Installation du pilote propriétaire Nvidia


apt-get install nvidia-kernel-dkms nvidia-settings nvidia-driver linux-headers-$(uname -r)




Installation du paquet nvidia-xconfig et lancement de celui-ci.
Cet outil créé le fichier /etc/X11/xorg.conf et le configure pour utiliser le pilote Nvidia que nous venons d'installer.
Redémarrage de la machine pour activer le blacklistage du pilote libre Nouveau.
Depuis le menu de KDE, lancement de Paramètres du serveur X NVIDIA (= nvidia-settings).
La version du pilote Nvidia est la 340.65 c'est à dire celle des dépôts Debian Jessie.


Problème de tearing


Un problème de cisaillement de l'image (décalage horizontal) apparaissait lors de :




Problème résolu en suivant le wiki de Debian Facile smile : https://debian-facile.org/doc:materiel: … nt-tearing
(en créant le fichier /etc/profile.d/tearing.sh)


Autres informations


Dans les effets de bureau de KDE :

  • Effets activés au démarrage

  • Gestion améliorée des fenêtres : coché

  • Pas beaucoup d'effets sélectionnés

  • Mode d'affichage composite : OpenGL 3.1 (autres choix possibles : OpenGL 2.0, OpenGL 1.2, XRender)

  • Système graphique Qt : Raster (autre choix possible : Natif)

  • Méthode de mise à l'échelle : Précise (autres choix possibles : Direct, Avec lissage)

  • Prévention de déchirement (Vsync) : Automatique (4 autres choix possibles)




Dans les paramètres Nvidia :

  • Sync to VBlank : coché

  • Allow Flipping : coché

  • Image Settings : High Quality

  • PowerMizer Settings : Preferred Mode : Auto





Merci d'avance pour vos réponses wink

Hors ligne

#2 05-11-2015 09:46:56

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : KDE 4 - Nvidia - Très légère latence lors du déplacement des fenêtres

Bonjour,

Tu te trouves peut-être dans la même situation que moi. Sous Wheezy, à l'époque, j'avais le même "ressenti"
Sous nouveau, avant d'avoir installé les pilotes proprio du dépôt, le problème était-il présent ? j'en doute.
As-tu remarqué une sensation de retard quand tu utilises ton clavier pour taper un message dans ton navigateur comme pour poster le message sur le forum par exemple.
Ton navigateur, le trouves tu plus lourd à l'utilisation ?
Le Tearing, c'est réglé donc on laisse. C'était la bonne méthode pour éliminer le truc.
Je vois le pilote du dépôt, qui pour certain (comme moi) ne convenait pas pour ma configuration matériel. Ça arrive. Moi, ce que j'ai fait.
Un clonage de mon système avant toute chose.
Une désinstallation du pilote proprio pour revenir sur nouveau.
Vérifier qu'avec nouveau, le problème est bien disparu.
Et ( je vais m'attirer peut-être les foudres des membres, mais on leur dira pas wink installer le dernier run du site Nvidia.
Et là tu pourras vérifier si le problème est toujours présent.

J'insiste sur le point de la sauvegarde. Évite de pourrir ton système wink
C'est ma méthode, chez moi en tout cas.
Ha oui, une chose chez moi. Contrairement à toi, sous Jessie, je n'ai pas eu ce problème.

EDIT:
Mode d'affichage composite : OpenGL 3.1 (autres choix possibles : OpenGL 2.0, OpenGL 1.2, XRender)
Système graphique Qt : Raster (autre choix possible : Natif)

Essaies pour voir avant de bidouiller :
OpenGL 2.0
Natif

Dernière modification par golgot200 (05-11-2015 09:51:07)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#3 08-11-2015 23:49:30

tourbinux
Membre
Distrib. : Debian 8.6 (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : KDE 4.14.2
Inscription : 03-11-2015

Re : KDE 4 - Nvidia - Très légère latence lors du déplacement des fenêtres

Bonjour,

Sous nouveau, avant d'avoir installé les pilotes proprio du dépôt, le problème était-il présent ? j'en doute.


A la fin de l'installation de Jessie, la machine a redémarré. Après ce premier démarrage, j'avais une résolution "d'aveugle" : tout était gros et flou et la résolution maximale détectée dans KDE était petite. Je précise que mon écran est branché en DVI (DVI-D).

As-tu remarqué une sensation de retard quand tu utilises ton clavier pour taper un message dans ton navigateur comme pour poster le message sur le forum par exemple.


Non, pas du tout.

Ton navigateur, le trouves tu plus lourd à l'utilisation ?


Non, pas spécialement.

Un clonage de mon système avant toute chose.


Avec le Live CD Clonezilla par exemple ?
En faisant une image juste de la partition système / ? (pas besoin des /home et autres partitions)

Vérifier qu'avec nouveau, le problème est bien disparu.


Oui ça permettrait d'être sûr que le problème vient du driver Nvidia. Mais bon, après le premier reboot, j'avais une de ces résolutions avec Nouveau yikes. Et pi je souhaite le driver Nvidia pour avoir les effets 3D (Cube, etc...) smile

Et ( je vais m'attirer peut-être les foudres des membres, mais on leur dira pas wink installer le dernier run du site Nvidia.
Et là tu pourras vérifier si le problème est toujours présent.


Au travail, j'ai exactement le même PC (mais lui depuis août 2014) et j'avais dès le début installé le driver Nvidia depuis le .run. Il faudrait que je regarde la version. Bref, je n'ai jamais rencontré ce problème avec ce PC. Mais un autre problème que je n'ai pas sous Jessie : lors d'un clic dans un logiciel (exemples : LibreOffice, FileZilla, Icedove) : j'ai le menu qui se déroule mais son affichage est parfois transparent et quand on déplace la souris pour descendre dans le menu, le menu s'affiche petit à petit yikes

Ha oui, une chose chez moi. Contrairement à toi, sous Jessie, je n'ai pas eu ce problème.


Tu as quoi comme carte graphique/pilote ?

Essaies pour voir avant de bidouiller :
OpenGL 2.0
Natif


Cela semble avoir corrigé le problème.
Mais pour l'instant, je ne crie pas victoire trop vite car je n'ai pas testé de redémarrer. Je vais tester ça.

Pourquoi il y a t-il plusieurs version de OpenGL ? Plus la version est élevée, mieux c'est ?
D'après les spécifications de ma carte graphique sur le site de Nvidia, ma carte est compatible OpenGL 4.4.
Mais cette version n'est pour l'instant pas intégrée dans Jessie/KDE. Qui peut le plus peut le moins ? cool


Mon pilote est le 340.65 (du dépot Jessie non-free) sorti d'après Nvidia le 08/12/2014.
Je peux éventuellement tester 2 choses :

  • installer le pilote 340.93 des Backports sorti le 02/09/2015

  • installer le pilote 352.55 sorti le 14/10/2015



Ma carte étant compatible CUDA, il n'y a rien à installer vis à vis de ça ?

Existerait t-il un logiciel ou une commande qui permettrait de tester que tout se passe bien pour l'affichage et que la carte graphique est pleinement et correctement utilisée ?
En tout cas, l'affichage du Cube (CTRL+F11) fonctionne bien cool

Hors ligne

#4 11-11-2015 23:45:03

tourbinux
Membre
Distrib. : Debian 8.6 (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : KDE 4.14.2
Inscription : 03-11-2015

Re : KDE 4 - Nvidia - Très légère latence lors du déplacement des fenêtres

J'ai regardé ce que j'ai au travail sous Wheezy (même PC avec même carte graphique). Le driver Nvidia des dépôts était le 304.117 (décembre 2013) mais il ne supportait pas la carte graphique alors j'avais installé (avec le .run) le 340.32 (août 2014) qui lui la supportait. Le dernier que j'ai installé est le 346.35 (janvier 2015).

Finalement (à la maison), le mode d'affichage composite OpenGL 2.0 avec le Système graphique Qt Natif ne résolvent pas le problème.

Ce que je ne comprends pas, c'est pourquoi mon problème se résout après avoir désactivé puis réactivé les effets de bureau. Normalement, cette manipulation ne touche pas à la conf et pourtant, il y a quelque chose qui change, mais quoi ? hmm

Est-ce que cela viendrait de OpenGL qui est mal utilisé, ou bien d'un paramètre Nvidia ou KDE mal positionné ou alors mon /etc/X11/xorg.conf mal configuré ?
Difficile de savoir hmm

Par contre, je constate 3 choses "bizarres" :

  • Dans Configuration du système, la couleur du fond n'est pas totalement blanche : on dirait un gris clair qui s'arrondit vers la droite de la fenêtre

  • Le contour d'une fenêtre sur un fond blanc est très "large"

  • Dans KInfoCenter -> OpenGL -> Accélérateur 3D : il est écrit "inconnu"



Ci-dessous 2 screenshots qui montrent en image ces 3 points (lien vers ImageBin.ca)
- http://ibin.co/2ME4t7lk7lQ0
- http://ibin.co/2ME5Yxg0coSp

Hors ligne

#5 28-11-2015 17:35:00

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : KDE 4 - Nvidia - Très légère latence lors du déplacement des fenêtres

Bonjour
tu a 2 options (3 si tu vire kde tongue  ok => []   )

soit tu passe à stretch (attention enleve le driver proprio avant ) et tu installe le driver non free comme tu a fait pour jessie.
tu aura un noyau plus performant et un driver version 340.96

soit tu installe le .run du constructeur

ps: jessie ne prend pas en charge les gpu maxwell , d ailleur je suis étonné que le bureau fonctionne.
pour nvidia , chez debian le cuda est a part  (le .run il est integré avec le driver ) si tu a besoin il faudra l installer
pour kde le bureau est lourd ça m etonne pas que tu est du lag

Hors ligne

#6 28-11-2015 19:05:13

tourbinux
Membre
Distrib. : Debian 8.6 (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : KDE 4.14.2
Inscription : 03-11-2015

Re : KDE 4 - Nvidia - Très légère latence lors du déplacement des fenêtres

Je souhaite rester sur la Stable Jessie.

robert2a a écrit :

ps: jessie ne prend pas en charge les gpu maxwell , d ailleur je suis étonné que le bureau fonctionne.

Avec le pilote 340.65 des dépôts, oui ça fonctionne. D'après Nvidia, cette version du pilote prend en charge cette carte graphique. Donc on pourrait en conclure que le 340.65 de Nvidia (.run) n'est pas exactement le même que le 340.65 des dépôts Debian ?

robert2a a écrit :

pour nvidia , chez debian le cuda est a part  (le .run il est integré avec le driver ) si tu a besoin il faudra l installer

Quelle est son utilité ? Si ça améliore les performances graphiques, pourquoi pas. Si par  contre c'est pour faire du calcul non pas sur le CPU mais sur le GPU, alors je n'en ai pas besoin.

robert2a a écrit :

pour kde le bureau est lourd ça m etonne pas que tu est du lag

Je ne sais pas si ça vient vraiment de KDE car comme je l'ai dis dans mon 1er message, après avoir désactivé/réactivé les effets graphiques, le problème n'est plus présent.

Je pense que je vais donc passer par le .run.
Avant son install, je dois juste supprimer les paquets nvidia que j'ai installé (voir 1er message) ?

Merci smile

Hors ligne

#7 29-11-2015 04:56:13

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : KDE 4 - Nvidia - Très légère latence lors du déplacement des fenêtres

Bonsoir
il faut chercher un post de Guppy sur une carte GTX970 et le .run
oui il faut purger tout les pilotes nvidia .
je te conseille aussi de lire la doc du site nvidia pour linux (pour les paquets necessaires et les versions ).
sinon c est assez simple.
verifier aussi que jessie est bien a jour avant de commencer.

voici le lien des infos pour installer le .run => https://debian-facile.org/viewtopic.php?id=12119

ps: pour le 340.65  normalement oui correspond a celui du constructeur , pour la prise en charge je sais pas si il parle d une 750 maxwell ou kepler (version d avant ).
avec une Msi GTX750TI (Maxwell) moi cela ne fonctionne pas sur Jessie (toutes mes Jessie ont le .run )

pour le cuda c'est selon les applications , sinon nvidia utilise OpenGL sous linux. (il n est pas obligatoire si tu n utilise pas de programmes (ou jeux) qui l utilise)

Dernière modification par robert2a (29-11-2015 05:09:49)

Hors ligne

#8 30-11-2015 13:53:42

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : KDE 4 - Nvidia - Très légère latence lors du déplacement des fenêtres

tourbinux a écrit :

Je souhaite rester sur la Stable Jessie.

robert2a a écrit :

pour kde le bureau est lourd ça m etonne pas que tu est du lag

Je ne sais pas si ça vient vraiment de KDE car comme je l'ai dis dans mon 1er message, après avoir désactivé/réactivé les effets graphiques, le problème n'est plus présent.

Je pense que je vais donc passer par le .run.
Avant son install, je dois juste supprimer les paquets nvidia que j'ai installé (voir 1er message) ?

Merci smile


Salut,

Regarde la liste des processus qui tournent, (par exemple, installe et lance htop), et vois s'il y en a que tu pourrais désactiver dans la liste. Htop peut être lancé en simple utilisateur ou en root, au choix, selon les besoins.


le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#9 30-11-2015 21:56:46

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : KDE 4 - Nvidia - Très légère latence lors du déplacement des fenêtres

à mon avis tourbinux étudie la procédure avant de passer a l acte smile , une GTX750TI avec le .run , meme le bureau KDE en 3D ça ne lui fait pas peur  tongue  ou alors le bureau utilise pas bien la carte.

Hors ligne

#10 10-12-2015 00:31:29

tourbinux
Membre
Distrib. : Debian 8.6 (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : KDE 4.14.2
Inscription : 03-11-2015

Re : KDE 4 - Nvidia - Très légère latence lors du déplacement des fenêtres

robert2a a écrit :

à mon avis tourbinux étudie la procédure avant de passer a l acte smile

C'est dans le sens qu'il faut que j'y réfléchisse à 2 fois avant de le faire ou bien le fait que je n'ai pas répondu sur ce topic depuis un ptit moment ?
J'ai dû mettre ça de côté mais il faut que je m'y remette wink

Merci pour vos réponses.
Je pense que je testerai le .run en vérifiant bien sur la doc officielle que j'ai bien les éléments requis :
http://fr.download.nvidia.com/XFree86/L … ments.html

Avant, je ferai une image ghost de ma partition / avec Clonezilla.
Le /home, ce n'est pas la peine ?

Dernière modification par tourbinux (10-12-2015 00:33:56)

Hors ligne

Pied de page des forums