Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-11-2015 20:10:15

Ir0nsh007er
Membre
Lieu : Montréal, PQ, Canada
Distrib. : Debian GNU/Linux 9.0 Stretch/Sid
Noyau : 4.7.0-1-amd64 #1 SMP Debian 4.7.5-1 (2016-09-26) x
(G)UI : Xfce 4.12.3
Inscription : 30-04-2015
Site Web

Résolu Démarrage automatique SSH bug

Voila a chaque reboot de mon système je dois faire

service ssh restart

qui ne fonctionne pas pour pouvoir utiliser mon ssh a distance ..
dans mon systemd

systemctl


? ssh.service                loaded failed failed    OpenBSD Secure Shell server


J'ai aussi ssh.socket qui est installer non loader au démarrage. Je dois le démarrez manuellement et si je veux qu'il load au démarrage j'ai cette erreur :

Failed to save systemd service : Systemd service ssh.socket cannot be created unless a command is given



Des piste pour une solution viables svp les zamis.

Marci

Dernière modification par Ir0nsh007er (10-11-2015 00:14:18)


Moé avec mon P4: Intel(R) Pentium(R) 4 CPU 3.40GHz, Mémoire: 6G DDR2, Carte Graphique: NVIDIA Corp GT216 [GeForce GT 220] (rev a2)
Ir0nsh007er (49 72 30 6E 73 68 30 30 37 65 72).  Mon CV
Noob un jour, noob toujours cool
01001001 01110010 00110000 01101110 01110011 01101000 00110000 00110000 00110111 01100101 01110010

Hors ligne

#2 09-11-2015 23:56:39

tourbinux
Membre
Distrib. : Debian 8.6 (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : KDE 4.14.2
Inscription : 03-11-2015

Re : Résolu Démarrage automatique SSH bug

Bonsoir,

Sous Jessie, j'ai ça :

systemctl | grep "ssh"


ssh.service                                                                               loaded active running   OpenBSD Secure Shell server



et

systemctl status sshd


ssh.service - OpenBSD Secure Shell server
   Loaded: loaded (/lib/systemd/system/ssh.service; enabled)
   Active: active (running) since lun. 2015-11-09 21:59:16 CET; 52min ago
   Process: 898 ExecReload=/bin/kill -HUP $MAINPID (code=exited, status=0/SUCCESS)
  Main PID: 512 (sshd)
   CGroup: /system.slice/ssh.service
           ??512 /usr/sbin/sshd -D




Pour le démarrer manuellement :

systemctl start sshd




Pour l'activer définitivement au démarrage du système :

systemctl enable sshd




Est-ce que cela fonctionne ?

Hors ligne

#3 10-11-2015 00:12:06

Ir0nsh007er
Membre
Lieu : Montréal, PQ, Canada
Distrib. : Debian GNU/Linux 9.0 Stretch/Sid
Noyau : 4.7.0-1-amd64 #1 SMP Debian 4.7.5-1 (2016-09-26) x
(G)UI : Xfce 4.12.3
Inscription : 30-04-2015
Site Web

Re : Résolu Démarrage automatique SSH bug

tourbinux a écrit :

Bonsoir,

Sous Jessie, j'ai ça :

systemctl | grep "ssh"


ssh.service                                                                               loaded active running   OpenBSD Secure Shell server



et

systemctl status sshd


ssh.service - OpenBSD Secure Shell server
   Loaded: loaded (/lib/systemd/system/ssh.service; enabled)
   Active: active (running) since lun. 2015-11-09 21:59:16 CET; 52min ago
   Process: 898 ExecReload=/bin/kill -HUP $MAINPID (code=exited, status=0/SUCCESS)
  Main PID: 512 (sshd)
   CGroup: /system.slice/ssh.service
           ??512 /usr/sbin/sshd -D




Pour le démarrer manuellement :

systemctl start sshd



Pour l'activer définitivement au démarrage du système :

systemctl enable sshd




Est-ce que cela fonctionne ?


Merci pour ton aide; Problème réglé avec la soluce a cemoi :

apt remove --purge openssh-server


ensuite réinstallation openssh-serveur


Moé avec mon P4: Intel(R) Pentium(R) 4 CPU 3.40GHz, Mémoire: 6G DDR2, Carte Graphique: NVIDIA Corp GT216 [GeForce GT 220] (rev a2)
Ir0nsh007er (49 72 30 6E 73 68 30 30 37 65 72).  Mon CV
Noob un jour, noob toujours cool
01001001 01110010 00110000 01101110 01110011 01101000 00110000 00110000 00110111 01100101 01110010

Hors ligne

Pied de page des forums