Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#126 06-12-2015 15:16:13

enicnath
Membre
Inscription : 28-04-2012

Re : Dépendances non satisfaites

Voici les retours :

apt-get install -sf


enicnath@Ordi:~$ sudo apt-get install -sf
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  aisleriot argyll baobab browser-plugin-gnash caribou caribou-antler cheese evince-common file-roller finger
  fonts-cantarell fonts-sil-gentium fonts-sil-gentium-basic gcalctool gdebi gir1.2-clutter-gst-1.0 gir1.2-gdata-0.0
  gir1.2-gtkclutter-1.0 gir1.2-gtop-2.0 gir1.2-tracker-0.14 glchess glines gnash gnash-common gnect gnibbles gnobots2
  gnome-backgrounds gnome-color-manager gnome-dictionary gnome-disk-utility gnome-font-viewer gnome-games gnome-games-data
  gnome-games-extra-data gnome-icon-theme-extras gnome-nettool gnome-packagekit gnome-packagekit-data gnome-screenshot
  gnome-shell-extensions gnome-sudoku gnome-system-log gnome-tweak-tool gnome-video-effects gnomine gnotravex gnotski
  gnuchess gnuchess-book gtali gucharmap guile-2.0-libs hamster-applet hplip-data iagno iputils-tracepath libblas3gf
  libboost-program-options1.49.0 libboost-thread1.49.0 libcaribou-gtk-module libcaribou-gtk3-module libcolamd2.7.1
  libgdict-1.0-6 libgdict-common libgdu-gtk0 libgupnp-dlna-1.0-2 libgutenprint2 libgxps2 libicc2 libimdi0 libkpathsea6
  liblinear-tools liblinear1 libminiupnpc5 libnatpmp1 libplot2c2 libpstoedit0c2a libreoffice libreoffice-calc
  libreoffice-draw libreoffice-evolution libreoffice-filter-mobiledev libreoffice-gnome libreoffice-gtk
  libreoffice-help-en-us libreoffice-impress libreoffice-report-builder-bin libslp1 libsofia-sip-ua-glib3 libsofia-sip-ua0
  libsvm-tools libt1-5 libvisio-0.0-0 libwnck-common libwnck22 lightsoff lp-solve mahjongg minissdpd
  mobile-broadband-provider-info network-manager-gnome nmap p7zip-full python-gconf python-gnome2 python-imaging
  python-pexpect python-pyorbit python-renderpm python-reportlab python-reportlab-accel python-wnck quadrapassel rygel
  rygel-playbin rygel-preferences rygel-tracker seahorse simple-scan smbclient sound-juicer ssl-cert swell-foop
  telepathy-rakia transmission-common transmission-gtk ttf-liberation ttf-sil-gentium-basic unoconv xdg-user-dirs-gtk
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  libcups2 libcupsimage2 libgs9 libgs9-common
Les NOUVEAUX paquets suivants seront installés :
  libcupsimage2 libgs9
Les paquets suivants seront mis à jour :
  libcups2 libgs9-common
2 mis à jour, 2 nouvellement installés, 0 à enlever et 176 non mis à jour.
43 partiellement installés ou enlevés.
Conf debconf (1.5.49 Debian:7.9/oldstable [all]) [gimp:i386 ]
Inst libcups2 [1.5.3-5+deb7u4] (1.5.3-5+deb7u6 Debian-Security:7.0/oldstable, Debian:7.9/oldstable [i386]) [gimp:i386 ]
Inst libcupsimage2 (1.5.3-5+deb7u6 Debian-Security:7.0/oldstable, Debian:7.9/oldstable [i386]) [gimp:i386 ]
Inst libgs9-common [9.05~dfsg-6.3+deb7u1] (9.05~dfsg-6.3+deb7u2 Debian-Security:7.0/oldstable, Debian:7.9/oldstable [all]) [gimp:i386 ]
Inst libgs9 (9.05~dfsg-6.3+deb7u2 Debian-Security:7.0/oldstable, Debian:7.9/oldstable [i386])
Conf libgmp10 (2:6.0.0+dfsg-6  [i386])
Conf libnettle4 (2.7.1-5  [i386])
Conf libhogweed2 (2.7.1-5  [i386])
Conf libffi6 (3.1-2+b2  [i386])
Conf libp11-kit0 (0.20.7-1  [i386])
Conf libtasn1-6 (4.2-3+deb8u1  [i386])
Conf libgnutls-deb0-28 (3.3.8-6+deb8u1  [i386])
Conf libkeyutils1 (1.5.9-5+b1  [i386])
Conf libkrb5support0 (1.12.1+dfsg-19  [i386])
Conf libk5crypto3 (1.12.1+dfsg-19  [i386])
Conf libkrb5-3 (1.12.1+dfsg-19  [i386])
Conf libgssapi-krb5-2 (1.12.1+dfsg-19  [i386])
Conf libtirpc1 (0.2.5-1  [i386])
Conf gnome-menus (3.4.2-5 Debian:7.9/oldstable [i386])
Conf libisl10 (0.12.2-2  [i386])
Conf libcloog-isl4 (0.18.2-1+b2  [i386])
Conf libdbus-1-3 (1.8.18-0+deb8u1  [i386])
Conf libquadmath0 (4.9.2-10  [i386])
Conf libgfortran3 (4.9.2-10  [i386])
Conf libgomp1 (4.9.2-10  [i386])
Conf libjbig0 (2.1-3.1  [i386])
Conf libmpfr4 (3.1.2-2  [i386])
Conf libpng12-0 (1.2.50-2+b2  [i386])
Conf libjpeg62-turbo (1:1.3.1-12  [i386])
Conf libtiff5 (4.0.3-12.3  [i386])
Conf libc6-i686 (2.19-18  [i386])
Conf libmpc3 (1.0.2-1  [i386])
Conf libnfnetlink0 (1.0.1-3  [i386])
Conf iproute2 (3.16.0-2  [i386])
Conf iproute (1:3.16.0-2  [all])
Conf ifupdown (0.7.53.1  [i386])
Conf netbase (5.3  [all])
Conf libxtables10 (1.4.21-2+b1  [i386])
Conf iptables (1.4.21-2+b1  [i386])
Conf nfs-common (1:1.2.8-9  [i386])
Conf cpp-4.9 (4.9.2-10  [i386])
Conf cpp (4:4.9.2-2  [i386])
Conf fonts-dejavu-core (2.34-1  [all])
Conf libcups2 (1.5.3-5+deb7u6 Debian-Security:7.0/oldstable, Debian:7.9/oldstable [i386])
Conf libcupsimage2 (1.5.3-5+deb7u6 Debian-Security:7.0/oldstable, Debian:7.9/oldstable [i386])
Conf libgs9-common (9.05~dfsg-6.3+deb7u2 Debian-Security:7.0/oldstable, Debian:7.9/oldstable [all])
Conf libgs9 (9.05~dfsg-6.3+deb7u2 Debian-Security:7.0/oldstable, Debian:7.9/oldstable [i386])
Conf gimp (2.8.2-2+deb7u1 Debian-Security:7.0/oldstable, Debian:7.9/oldstable [i386])
Conf kbd (1.15.5-2  [i386])
Conf rstudio (0.99.484  [i386])
Conf ttf-dejavu-core (2.34-1  [all])
enicnath@Ordi:~$



apt-get upgrade -s


enicnath@Ordi:~$ sudo apt-get upgrade -s
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 gimp : Dépend: libgs9 (>= 8.61.dfsg.1) mais il n'est pas installé
        Recommande: ghostscript mais il n'est pas installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.
enicnath@Ordi:~$

Hors ligne

#127 06-12-2015 18:57:19

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Dépendances non satisfaites

Curieux.

apt-get install -f


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#128 06-12-2015 20:10:34

enicnath
Membre
Inscription : 28-04-2012

Re : Dépendances non satisfaites

paskal a écrit :

Curieux.

apt-get install -f

Franchement, j'ai l'impression de ne pas avancer !

Voici le résultat de la commande :

enicnath@Ordi:~$ sudo apt-get install -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  aisleriot argyll baobab browser-plugin-gnash caribou caribou-antler cheese evince-common file-roller finger
  fonts-cantarell fonts-sil-gentium fonts-sil-gentium-basic gcalctool gdebi gir1.2-clutter-gst-1.0 gir1.2-gdata-0.0
  gir1.2-gtkclutter-1.0 gir1.2-gtop-2.0 gir1.2-tracker-0.14 glchess glines gnash gnash-common gnect gnibbles gnobots2
  gnome-backgrounds gnome-color-manager gnome-dictionary gnome-disk-utility gnome-font-viewer gnome-games gnome-games-data
  gnome-games-extra-data gnome-icon-theme-extras gnome-nettool gnome-packagekit gnome-packagekit-data gnome-screenshot
  gnome-shell-extensions gnome-sudoku gnome-system-log gnome-tweak-tool gnome-video-effects gnomine gnotravex gnotski
  gnuchess gnuchess-book gtali gucharmap guile-2.0-libs hamster-applet hplip-data iagno iputils-tracepath libblas3gf
  libboost-program-options1.49.0 libboost-thread1.49.0 libcaribou-gtk-module libcaribou-gtk3-module libcolamd2.7.1
  libgdict-1.0-6 libgdict-common libgdu-gtk0 libgupnp-dlna-1.0-2 libgutenprint2 libgxps2 libicc2 libimdi0 libkpathsea6
  liblinear-tools liblinear1 libminiupnpc5 libnatpmp1 libplot2c2 libpstoedit0c2a libreoffice libreoffice-calc
  libreoffice-draw libreoffice-evolution libreoffice-filter-mobiledev libreoffice-gnome libreoffice-gtk
  libreoffice-help-en-us libreoffice-impress libreoffice-report-builder-bin libslp1 libsofia-sip-ua-glib3 libsofia-sip-ua0
  libsvm-tools libt1-5 libvisio-0.0-0 libwnck-common libwnck22 lightsoff lp-solve mahjongg minissdpd
  mobile-broadband-provider-info network-manager-gnome nmap p7zip-full python-gconf python-gnome2 python-imaging
  python-pexpect python-pyorbit python-renderpm python-reportlab python-reportlab-accel python-wnck quadrapassel rygel
  rygel-playbin rygel-preferences rygel-tracker seahorse simple-scan smbclient sound-juicer ssl-cert swell-foop
  telepathy-rakia transmission-common transmission-gtk ttf-liberation ttf-sil-gentium-basic unoconv xdg-user-dirs-gtk
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  libcups2 libcupsimage2 libgs9 libgs9-common
Les NOUVEAUX paquets suivants seront installés :
  libcupsimage2 libgs9
Les paquets suivants seront mis à jour :
  libcups2 libgs9-common
2 mis à jour, 2 nouvellement installés, 0 à enlever et 176 non mis à jour.
43 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/4 397 ko dans les archives.
Après cette opération, 9 342 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? O
Traceback (most recent call last):
  File "/usr/bin/apt-listchanges", line 28, in <module>
    import apt_pkg
ImportError: No module named apt_pkg
dpkg: erreur de traitement de debconf (--configure) :
 Le paquet est dans un état vraiment incohérent - vous devriez
 le réinstaller avant de tenter de le configurer.
Des erreurs ont été rencontrées pendant l'exécution :
 debconf
E: Sub-process /usr/bin/dpkg returned an error code (1)
enicnath@Ordi:~$

Hors ligne

#129 06-12-2015 20:17:40

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Dépendances non satisfaites

apt-get clean


apt-get install --reinstall debconf


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#130 06-12-2015 22:20:21

enicnath
Membre
Inscription : 28-04-2012

Re : Dépendances non satisfaites

paskal a écrit :

apt-get clean


apt-get install --reinstall debconf

Et voilà l'travail :

enicnath@Ordi:~$ sudo apt-get install --reinstall debconf
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 gimp : Dépend: libgs9 (>= 8.61.dfsg.1) mais ne sera pas installé
        Recommande: ghostscript mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
enicnath@Ordi:~$

Ca ressemble à ce qu'on a déjà eu, n fois.

Hors ligne

#131 06-12-2015 22:32:51

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Dépendances non satisfaites

Quel a été le retour de ton #124 ? Pour mémoire :

apt-get -f remove gimp


Apparemment, ça avait échoué, non ?


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#132 06-12-2015 22:43:26

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Dépendances non satisfaites

Que retourne :

cat /var/lib/dpkg/info/gimp.postrm


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#133 06-12-2015 23:07:11

enicnath
Membre
Inscription : 28-04-2012

Re : Dépendances non satisfaites

paskal a écrit :

Quel a été le retour de ton #124 ? Pour mémoire :

apt-get -f remove gimp


Apparemment, ça avait échoué, non ?

Oui, voici le retour :

enicnath@Ordi:~$ sudo apt-get -f remove gimp
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  aisleriot argyll baobab browser-plugin-gnash caribou caribou-antler cheese evince-common file-roller finger
  fonts-cantarell fonts-droid fonts-sil-gentium fonts-sil-gentium-basic gcalctool gdebi gir1.2-clutter-gst-1.0
  gir1.2-gdata-0.0 gir1.2-gtkclutter-1.0 gir1.2-gtop-2.0 gir1.2-tracker-0.14 glchess glines gnash gnash-common gnect
  gnibbles gnobots2 gnome-backgrounds gnome-color-manager gnome-dictionary gnome-disk-utility gnome-font-viewer gnome-games
  gnome-games-data gnome-games-extra-data gnome-icon-theme-extras gnome-nettool gnome-packagekit gnome-packagekit-data
  gnome-screenshot gnome-shell-extensions gnome-sudoku gnome-system-log gnome-tweak-tool gnome-video-effects gnomine
  gnotravex gnotski gnuchess gnuchess-book gtali gucharmap guile-2.0-libs hamster-applet hplip-data iagno iputils-tracepath
  libblas3gf libboost-program-options1.49.0 libboost-thread1.49.0 libcaribou-gtk-module libcaribou-gtk3-module
  libcolamd2.7.1 libgdict-1.0-6 libgdict-common libgdu-gtk0 libgs9-common libgupnp-dlna-1.0-2 libgutenprint2 libgxps2
  libicc2 libimdi0 libjbig2dec0 libkpathsea6 liblinear-tools liblinear1 libminiupnpc5 libnatpmp1 libplot2c2 libpstoedit0c2a
  libreoffice libreoffice-calc libreoffice-draw libreoffice-evolution libreoffice-filter-mobiledev libreoffice-gnome
  libreoffice-gtk libreoffice-help-en-us libreoffice-impress libreoffice-report-builder-bin libslp1 libsofia-sip-ua-glib3
  libsofia-sip-ua0 libsvm-tools libt1-5 libvisio-0.0-0 libwnck-common libwnck22 lightsoff lp-solve mahjongg minissdpd
  mobile-broadband-provider-info network-manager-gnome nmap p7zip-full python-gconf python-gnome2 python-imaging
  python-pexpect python-pyorbit python-renderpm python-reportlab python-reportlab-accel python-wnck quadrapassel rygel
  rygel-playbin rygel-preferences rygel-tracker seahorse simple-scan smbclient sound-juicer ssl-cert swell-foop
  telepathy-rakia transmission-common transmission-gtk ttf-liberation ttf-sil-gentium-basic unoconv xdg-user-dirs-gtk
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  gimp
0 mis à jour, 0 nouvellement installés, 1 à enlever et 178 non mis à jour.
43 partiellement installés ou enlevés.
Il est nécessaire de prendre 171 ko dans les archives.
Après cette opération, 15,6 Mo d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ? O
Réception de : 1 http://ftp.fr.debian.org/debian/ wheezy/main debconf all 1.5.49 [171 kB]
171 ko réceptionnés en 0s (255 ko/s)
Traceback (most recent call last):
  File "/usr/bin/apt-listchanges", line 28, in <module>
    import apt_pkg
ImportError: No module named apt_pkg
(Lecture de la base de données... 134949 fichiers et répertoires déjà installés.)
Suppression de gimp ...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: erreur de traitement de gimp (--remove) :
 le sous-processus script pre-removal installé a retourné une erreur de sortie d'état 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named ConfigParser
dpkg : erreur lors du nettoyage :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 gimp
E: Sub-process /usr/bin/dpkg returned an error code (1)
enicnath@Ordi:~$



Et voici le retour de la commande suivante que tu demandais :

cat /var/lib/dpkg/info/gimp.postrm


enicnath@Ordi:~$ cat /var/lib/dpkg/info/gimp.postrm
#!/bin/sh
set -e
# Automatically added by dh_installmenu
if [ -x "`which update-menus 2>/dev/null`" ]; then update-menus ; fi
# End automatically added section
enicnath@Ordi:~$

Hors ligne

#134 06-12-2015 23:09:40

enicnath
Membre
Inscription : 28-04-2012

Re : Dépendances non satisfaites

Si je relance une session, je vais donc être sous Wheezy. Ok.
A ton avis, j'aurais quand même une session qui tourne ?

Hors ligne

#135 06-12-2015 23:14:34

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Dépendances non satisfaites

Ne sors surtout pas de la session si tu veux faire tourner gnome car tu ne pourras pas le relancer.

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#136 06-12-2015 23:16:29

enicnath
Membre
Inscription : 28-04-2012

Re : Dépendances non satisfaites

paskal a écrit :

Ne sors surtout pas de la session si tu veux faire tourner gnome car tu ne pourras pas le relancer.


Oui, mais jusqu'à quand ?
Que faut-il faire pour ravoir une session normale (tant pis pour gimp) ?

Hors ligne

#137 06-12-2015 23:19:19

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Dépendances non satisfaites

Gimp n'est pas un soucis mais le symptôme d'un grave problème.
Il faut réinstaller l'installateur/configurateur de paquets qui a été endommagé ... ça se mord un peu la queue  sad

Que donne :

dpkg -P --force-all debconf


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#138 06-12-2015 23:24:39

enicnath
Membre
Inscription : 28-04-2012

Re : Dépendances non satisfaites

paskal a écrit :

Gimp n'est pas un soucis mais le symptôme d'un grave problème.
Il faut réinstaller l'installateur/configurateur de paquets qui a été endommagé ... ça se mord un peu la queue  sad
Que donne :

dpkg -P --force-all debconf


Ca : enicnath@Ordi:~$

sudo dpkg -P --force-all debconf



dpkg: debconf : problème de dépendance, mais suppression comme demandé :
 ca-certificates dépend de debconf (>= 0.5) | debconf-2.0 ; cependant :
  Le paquet debconf doit être supprimé.
  Le paquet debconf-2.0 n'est pas installé.
  Le paquet debconf qui fournit debconf-2.0 doit être supprimé.
 util-linux dépend de debconf (>= 0.5) | debconf-2.0 ; cependant :
  Le paquet debconf doit être supprimé.
  Le paquet debconf-2.0 n'est pas installé.
  Le paquet debconf qui fournit debconf-2.0 doit être supprimé.
 exim4-base dépend de debconf (>= 0.5) | debconf-2.0 ; cependant :
  Le paquet debconf doit être supprimé.
  Le paquet debconf-2.0 n'est pas installé.
  Le paquet debconf qui fournit debconf-2.0 doit être supprimé.
 discover dépend de debconf (>= 0.5) | debconf-2.0 ; cependant :
  Le paquet debconf doit être supprimé.
  Le paquet debconf-2.0 n'est pas installé.
  Le paquet debconf qui fournit debconf-2.0 doit être supprimé.
 udev dépend de debconf (>= 1.4.69) | debconf-2.0 ; ce
dpkg : avertissement : problème contourné par utilisation de --force :
 Le paquet est dans un état incohérent - vous devriez
 le réinstaller avant d'essayer de le supprimer.
(Lecture de la base de données... 134949 fichiers et répertoires déjà installés.)
Suppression de debconf ...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: erreur de traitement de debconf (--purge) :
 le sous-processus script pre-removal installé a retourné une erreur de sortie d'état 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named ConfigParser
dpkg : erreur lors du nettoyage :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 debconf
enicnath@Ordi:~$



Edit - smolski qui espère un sursaut de bonne volonté de la part de enicnath
Mise en conformité les balises commandes et retour de commande en séparant les deux.

Hors ligne

#139 06-12-2015 23:36:33

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Dépendances non satisfaites

Oui, ça coince de tous les côtés.
On pourrait éviter l'erreur de sortie d'état 1 mais j'ai peur que ça se répercute ailleurs.

Comme tu le vois, on tourne en rond depuis de nombreuses opérations.
Je te conseille de te préparer à réinstaller une Wheezy de zéro, ce qui pourrait être une solution plus rapide.
Donc, de profiter que le système fonctionne encore pour faire les dernières sauvegardes de donnée, des fichiers de configuration importants, de la liste des paquets installés ...

Cela dit, ce n'est que mon avis.

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#140 06-12-2015 23:42:49

enicnath
Membre
Inscription : 28-04-2012

Re : Dépendances non satisfaites

paskal a écrit :

Oui, ça coince de tous les côtés.
On pourrait éviter l'erreur de sortie d'état 1 mais j'ai peur que ça se répercute ailleurs.

Comme tu le vois, on tourne en rond depuis de nombreuses opérations.
Je te conseille de te préparer à réinstaller une Wheezy de zéro, ce qui pourrait être une solution plus rapide.
Donc, de profiter que le système fonctionne encore pour faire les dernières sauvegardes de donnée, des fichiers de configuration importants, de la liste des paquets installés ...

Cela dit, ce n'est que mon avis.


Mais alors, pourquoi ne pas réinstaller directement une Jessie de zéro ?

Hors ligne

#141 06-12-2015 23:46:57

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Dépendances non satisfaites

Oui installer Jessie est aussi une possibilité.
J'en était resté à Wheezy parce que c'est le système fonctionnel dont tu étais parti.

Encore une fois, ce n'est que mon point de vue.
D'autres personnes verront peut-être les choses autrement pour réparer ton système.

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#142 06-12-2015 23:51:40

enicnath
Membre
Inscription : 28-04-2012

Re : Dépendances non satisfaites

Bon, je vais me coucher, car demain je commence tôt.
Merci pour tes recommandations.
Demain est un autre jour, j'essaierai de voir comment tout réinstaller.
Bonne soirée

Hors ligne

#143 06-12-2015 23:53:32

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Dépendances non satisfaites

Tu as raison, bonne nuit.  smile

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#144 07-12-2015 07:32:07

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Dépendances non satisfaites

enicnath Ouvre ton post 138 par Modifier en bas à droite et regarde comment t'est-ce que la présentation des commandes se sépare du retour de commande ainsi que ce que les balises encadre sans y mettre du superflu.

Ceci n'est pas dirigé à ton encontre, c'est juste que ce forum développe en premier lieu une vocation de pédagogue et que chaque post du forum se doit d'être clair pour tous les visiteurs, et surtout les visiteurs les moins aguerris aux lignes de commande.
La coloration syntaxique est barbante mais si tu as une solution qui le serait beaucoup moins, pas de problème, tu fais part du code que tu proposes à la place de celui que nous avons mis en place après beaucoup d'heures fournies bénévolement pour y parvenir.

Tu peux aussi rémunérer un codeur pour qu'il le fasse à ta place, mais sinon, tu utilises la coloration syntaxique comme indiqué dans le post ci-dessous :

Voir le tuto : Le code, ça pique moins les yeux en couleur

Si tu as un problème de compréhension, tu en fais le retour et nous verrons avec ton aide ce que nous pouvons améliorer dans ce tuto pour l'ouvrir davantage à tous.
Pass'que là, de ta part, ça l'fait pas.

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#145 07-12-2015 15:47:11

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Dépendances non satisfaites

si je peu donner mon avis hmm   (pas frapper roll )
si c est pour gagner du temps oui une installation neuve c est le mieux.

par contre il y a toujours moyen de ce sortir d affaire , debian est tres robuste.

1) garder la main en graphique => tentavive d installer mate-core
2) faire une purge de gnome dans les regles
3) mettre wheezy (la base) a jour => vers jessie (ça veut dire remplacer tout le systeme , a part les users et leur dossier)

peut etre que j'ai tout faux , en général pour ma connaissance personnelle je vais jusqu au bout.
pour le dist-upgrade de wheezy le mieux est installation minimale et en console , j en ai fait pas mal.
la suppression de gnome ne touche pas au dossier user
les logiciels tiers ne disparaissent  pas
si il n y a pas eu de --purge les config et preferrences sont toujour la
bref debian est robuste .

ps: je pense que je vais me faire lincher roll , mais ce que j'ai ecrit est pas totalement faux
et puis apres tout le monde n a pas le courage ou l envie de passer du temps a "bidouiller" sa debian
bon je => []

Hors ligne

#146 07-12-2015 19:35:35

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Dépendances non satisfaites

Je sais que c'est bientôt Noël mais j'ai passé l'âge depuis un certain temps ...  roll
Comment tu fais quand dpkg et debconf en ont pris un sérieux coup dans l'aile ?  hmm

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#147 07-12-2015 22:22:25

enicnath
Membre
Inscription : 28-04-2012

Re : Dépendances non satisfaites

Bonjour Robert2a
Plein de questions suite à ton dernier post

robert2a a écrit :

1) garder la main en graphique => tentavive d installer mate-core
2) faire une purge de gnome dans les regles
3) mettre wheezy (la base) a jour => vers jessie (ça veut dire remplacer tout le systeme , a part les users et leur dossier)
pour le dist-upgrade de wheezy le mieux est installation minimale et en console , ...


Concrètement, comment fais-tu ?
1) Ca veut dire quoi installer le mate-core. Quelles sont les commandes ?
2) Faire une purge dans les règles. Est-ce que c'est un apt-get --purge ?
3) Mettre la base Wheezy à jour, comment ?
4) dist-upgrade wheezy en console, comment ?
5) Et après, comment redémarrer une configuration normale ?

Je crains de ne pas être au bout de mes peines !

Hors ligne

#148 07-12-2015 23:11:37

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Dépendances non satisfaites

pour commencer il faut que tu sois motiver puisque c est toi qui va le faire.
ensuite comme l a ecrit pascal c est peut etre mort (pas faisable)
il faut que tu est sache travailler sans  bureau graphique ( une autre machine pour un acces au forum ? )
pour mesurer la temperature teste cette ligne:


apt-get install mate-core lightdm iceweasel
 


si comme le dit pascal dpkg et debconf est endommagé ça va pas marché
il te faut un sources.list correct , je pense qu il est en jessie actuellement avec contrib et non free et tu n y touche plus.
interdit d utilisé --purge comme parametre
si tu a un autre pc on a pas besoin d installer le bureau mate.
actuellement tu n éteint  pas le pc ?

Hors ligne

#149 08-12-2015 00:29:43

Atys
Membre
Distrib. : Debian GNU/Linux unstable (sid)
Noyau : Linux 4.8.0-1-amd64
(G)UI : Fluxbox - Xfce
Inscription : 28-02-2015

Re : Dépendances non satisfaites

Bonsoir

J'essaie de suivre depuis le début du post, je ne fais qu'apprendre d'avantage sur ma nouvelle distrib.

#1

enicnath a écrit :

Je suis sous Debian Jessie.
J'ai lancé une mise à jour par

apt-get dist-upgrade


, mais le système me dit que j'ai des dépendances non satisfaites.


#9

loreleil a écrit :

Il semblerait que ta migration vers Jessie fût prématurée.
Il te fallait avant toute chose, mettre à jour Wheezy, ce qui n'est pas le cas.



Un système propre des le départ pour une migration, que je n'es personnellement jamais réalisé sous GNU/Debian.

aptitude update


aptitude safe-upgrade



reboot



Modifier /etc/apt/sources.list


aptitude update


aptitude dist-upgrade



Il me semble que la commande aptitude est ton ami pour la suite !

Et peu être certains problèmes possibles à connaître avant, aussi ! Informations sur la version « Jessie » de Debian

Après, c'est vrais que donner une (solution) qui peu (fonctionner) comme exemple, alors que le débat est bien lancé ...

Je lis ça ici http://crunchbang-fr.org/wiki/crunchban … se_waldorf 3.1 - Eviter de rétrograder

Tu veux faire quoi au juste maintenant ?

Dernière modification par Atys (08-12-2015 00:49:49)

Hors ligne

#150 08-12-2015 02:44:23

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Dépendances non satisfaites

ce n est pas un probleme de mise a jour de wheezy , le probleme si j ai bien compris vient des manipulation que j ai proposé
pour aptitude , c est pas moi qui le dit il est fortement recommandé de ne pas l utiliser pour migrer wheezy.

maintenant il lui reste 2 choses.
soit partir de zero et installé jessie
soit on tente quelques manipulations pour voir si l erreur peut etre réparé
pour paskal les carrotes sont cuites tongue
eviter de lui mettre des commandes qui sont tres fortement déconseiller par debian wink
si demain il me dit que l installation de mate donne des erreurs on tentera un nettoyage en douceur en esperant  que l on puisse mettre a jour vers jessie.
mon idee c est de revenir vers wheezy minimum (plus de bureau ) et de tenter de relancer une mise a jour vers jessie..
si ça fonctionne remettre gnome c est plus un probleme

lien => https://www.debian.org/releases/stable/ … ng.fr.html

a lire



4.4.5. Mettre à niveau le système

Vous êtes maintenant prêt à continuer avec la partie principale de la mise à niveau. Exécutez :

# apt-get dist-upgrade

[Note]  Note

Nous recommandions d'utiliser aptitude lors du processus de mise à niveau pour certaines versions précédentes. Cet outil n'est pas recommandé pour les mises à niveau de Wheezy à Jessie.
 



si enicnath n a pas d autres machines pour venir poster sur le forum ça va peu etre pas etre possible roll

Dernière modification par robert2a (08-12-2015 02:55:01)

Hors ligne

Pied de page des forums