Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-12-2015 09:03:22

Ir0nsh007er
Membre
Lieu : Montréal, PQ, Canada
Distrib. : Debian GNU/Linux 9.0 Stretch/Sid
Noyau : 4.7.0-1-amd64 #1 SMP Debian 4.7.5-1 (2016-09-26) x
(G)UI : Xfce 4.12.3
Inscription : 30-04-2015
Site Web

Essai de config MTU pour accélérer mon reseau local

Voila; Jai lu que je pouvait modifier mon MTU pour augmenter les trames transmise entre mes pc.
Vu sur forum.hardware.fr
Le mot pc = WINCHOSE ... DSL sad

traceroute 192.168.1.6 --mtu


traceroute to 192.168.1.6 (192.168.1.6), 30 hops max, 65000 byte packets
 1  * F=1500 * *
 


J'ai installer iperf qui peut m'aider a trouver le mtu maximale sur ma debian mais j'ai plusieurs bug rencontré.
1er bug :

iperf -s


------------------------------------------------------------
Server listening on TCP port 5001
TCP window size: 85.3 KByte (default)
------------------------------------------------------------
[  4] local 192.168.1.176 port 5001 connected with 192.168.1.6 port 57226


Ne fonctionne pas, il ne se passe rien  alors peut-être du a mon firewall ?? Sur l'autre pc non plus avec la commande

iperf -c 192.168.1.176 -w2M -r -p 5001


Lorsque je ferme le premier pc sur ma debian j'ai :

[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-256.9 sec  14.0 Bytes  0.44 bits/sec


Si je fais le contraire :

iperf -c 192.168.1.6 -w2M -R -p 5201


------------------------------------------------------------
Client connecting to 192.168.1.6, TCP port 5201
TCP window size:  416 KByte (WARNING: requested 2.00 MByte)
------------------------------------------------------------
[  3] local 192.168.1.176 port 47802 connected with 192.168.1.6 port 5201
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec  0.00  s  0.00 Bytes/sec


Sur le win7 j'ai:

ipferf3: error - unable to receive parameters from client:


2e bug :

ifconfig eth0 mtu 8192


SIOCSIFMTU: Argument invalide



Mon fichier /etc/network/interfaces.d/:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback
        post-up iptables-restore < /etc/iptables.up.rules


iface virtual inet6 manual
        pre-up /sbin/modprobe -q ipv6 ; /bin/true
 


Moé avec mon P4: Intel(R) Pentium(R) 4 CPU 3.40GHz, Mémoire: 6G DDR2, Carte Graphique: NVIDIA Corp GT216 [GeForce GT 220] (rev a2)
Ir0nsh007er (49 72 30 6E 73 68 30 30 37 65 72).  Mon CV
Noob un jour, noob toujours cool
01001001 01110010 00110000 01101110 01110011 01101000 00110000 00110000 00110111 01100101 01110010

Hors ligne

#2 11-12-2015 09:26:03

Ir0nsh007er
Membre
Lieu : Montréal, PQ, Canada
Distrib. : Debian GNU/Linux 9.0 Stretch/Sid
Noyau : 4.7.0-1-amd64 #1 SMP Debian 4.7.5-1 (2016-09-26) x
(G)UI : Xfce 4.12.3
Inscription : 30-04-2015
Site Web

Re : Essai de config MTU pour accélérer mon reseau local

ifconfig eth0 192.168.1.176 mtu 7000 up


A fonctionner mais tjrs pas de résultat iperf

Ping de mon pc a debian =

ping 192.168.1.176 -f -l 7000


Fonctionne sans perte de paquets !!
Débian retourne une erreur:

WARNING: probably, rcvbuf is not enough to hold preload.
PING 192.168.1.6 (192.168.1.6) 56(84) bytes of data.
^C                                                                                                                          
--- 192.168.1.6 ping statistics ---
2271999 packets transmitted, 71502 received, 96% packet loss, time 55708ms
rtt min/avg/max/mdev = 0.099/99.665/324.557/55.587 ms, pipe 7002, ipg/ewma 0.024/150.934 ms
 


Avec l'option -s j'ai pu de packet loss mais le ping est très long.

Mais est-ce que cette config restera permanent sur ma Débian ??


Moé avec mon P4: Intel(R) Pentium(R) 4 CPU 3.40GHz, Mémoire: 6G DDR2, Carte Graphique: NVIDIA Corp GT216 [GeForce GT 220] (rev a2)
Ir0nsh007er (49 72 30 6E 73 68 30 30 37 65 72).  Mon CV
Noob un jour, noob toujours cool
01001001 01110010 00110000 01101110 01110011 01101000 00110000 00110000 00110111 01100101 01110010

Hors ligne

#3 11-12-2015 09:46:20

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : Essai de config MTU pour accélérer mon reseau local


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#4 11-12-2015 14:05:27

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Essai de config MTU pour accélérer mon reseau local

Tu a le paquet Wondershaper qui permet de limiter le débit en dessous le maximum de ton adsl .

Hors ligne

Pied de page des forums