Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 15-12-2015 00:55:30

tonydeb
Membre
Inscription : 29-03-2015

probleme pour installer redmine sur debian 7

Bonjour à tous,
j'ai un souci sur mon serveur plesk 12 debian 7 , j'avais redmine d'installer sur mon plesk 9 (pas installé par moi) , et j'essaye de le restaurer sur ce nouveau serveur. j'ai copié le repertoire des fichiers résent sur l'ancien vers le nouveau sur :  var/www/vhost/domaine/redmine ,j'ai créé la base de donnée 'redmine'  et importé le dump, j'ai installé  ruby 1.9.1 , gems, passenger_module (il tourne), mon document root est DocumentRoot ”/var/www/vhosts/domaine/redmine/public”  dans le  httpd.conf , mais chaque fois que j'appelle http://redmine.domaine.fr/ , j'ai :

Forbidden
You don’t have permission to access / on this server.

sur error.log : Directory index forbidden by Options directive: /var/www/vhosts/domaine.fr/redmine/public/

j'ai fais chmod 755 et meme  777 sur le repertoire redmine , essayé de défiinr le  www-data pour user:group ou psacln ou psasrv (groupe plesk classique pour les sites que j'héberge a coté ou meme pour phpmyadmin ) …mais rien à faire. je peux afficher des documents via leur path direct mais pas lancer l'application..

Si quelqu'un à une idée ou autre , j'en serai très reconnaissant , MERCI d'AVANCE


mon httpd.conf :

<VirtualHost 151.80.36.112:80 >
    ServerName "redmine.domaine.fr:80"
    ServerAlias "[url=http://www.redmine.domaine.fr]www.redmine.domaine.fr[/url]"
    ServerAlias "ipv4.redmine.domaine.fr"
    ServerAdmin "ovh@domaine.fr"
    UseCanonicalName Off

    DocumentRoot "/var/www/vhosts/domaine.fr/redmine/public"
    CustomLog /var/www/vhosts/system/redmine.domaine.fr/logs/access_log plesklog
    ErrorLog "/var/www/vhosts/system/redmine.domaine.fr/logs/error_log"

    <IfModule mod_suexec.c>
        SuexecUserGroup "gweb" "psacln"
    </IfModule>

    <IfModule mod_userdir.c>
        UserDir "/var/www/vhosts/domaine.fr/web_users"
    </IfModule>

    <IfModule mod_sysenv.c>
        SetSysEnv PP_VHOST_ID "959038f0-ed42-4582-8311-9f40cc903eed"
    </IfModule>

    ScriptAlias "/cgi-bin/" "/var/www/vhosts/domaine.fr/redmine/public/cgi-bin/"

    Redirect permanent /plesk-stat [url]https://redmine.domaine.fr/plesk-stat[/url]
    Redirect permanent /webstat [url]https://redmine.domaine.fr/webstat[/url]
    Redirect permanent /webstat-ssl [url]https://redmine.domaine.fr/webstat-ssl[/url]
    Redirect permanent /ftpstat [url]https://redmine.domaine.fr/ftpstat[/url]
    Redirect permanent /anon_ftpstat [url]https://redmine.domaine.fr/anon_ftpstat[/url]
    Redirect permanent /awstats-icon [url]https://redmine.domaine.fr/awstats-icon[/url]

    <IfModule mod_ssl.c>
        SSLEngine off
    </IfModule>

    SetEnv PP_CUSTOM_PHP_INI /var/www/vhosts/system/redmine.domaine.fr/etc/php.ini
    SetEnv PP_CUSTOM_PHP_CGI_INDEX fastcgi

    <IfModule mod_fcgid.c>
        FcgidInitialEnv PP_CUSTOM_PHP_INI /var/www/vhosts/system/redmine.domaine.fr/etc/php.ini
        FcgidInitialEnv PP_CUSTOM_PHP_CGI_INDEX fastcgi
        FcgidMaxRequestLen 134217728
    </IfModule>

    <Directory /var/www/vhosts/domaine.fr/redmine/public>

        <IfModule mod_perl.c>
            <Files ~ (\.pl$)>
                SetHandler perl-script
                PerlHandler ModPerl::Registry
                Options +ExecCGI
                allow from all
                PerlSendHeader On
            </Files>
        </IfModule>
        <IfModule mod_python.c>
            <Files ~ (\.py$)>
                SetHandler python-program
                PythonHandler mod_python.cgihandler
            </Files>
        </IfModule>
        <IfModule mod_fcgid.c>
            <Files ~ (\.fcgi$)>
                SetHandler fcgid-script
                Options +ExecCGI
            </Files>
        </IfModule>
        <IfModule mod_fcgid.c>
            <Files ~ (\.php$)>
                SetHandler fcgid-script
                FCGIWrapper /var/www/cgi-bin/cgi_wrapper/cgi_wrapper .php
                Options +ExecCGI
            </Files>
        </IfModule>

        Options -Includes +ExecCGI

    </Directory>

    <Directory /var/www/vhosts/domaine.fr/web_users>

        <IfModule mod_php4.c>
            php_admin_flag engine off
        </IfModule>

        <IfModule mod_php5.c>
            php_admin_flag engine off
        </IfModule>

    </Directory>

    <Directory /var/www/vhosts/redmine.domaine.fr>
        Options +FollowSymLinks
    </Directory>

    <Directory "/var/www/vhosts/system/redmine.domaine.fr/statistics">
        AuthType Basic
        AuthName "Statistiques du domaine"
        AuthUserFile "/var/www/vhosts/system/redmine.domaine.fr/pd/d..httpdocs@plesk-stat"
        require valid-user
    </Directory>

    Include "/var/www/vhosts/system/redmine.domaine.fr/conf/vhost.conf"

    <IfModule mod_security2.c>
    </IfModule>

</VirtualHost>

Hors ligne

Pied de page des forums