Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-12-2015 01:20:49

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Stretch 64 bits (en rade) +Jessie (en secours)
Noyau : Linux 4.2.0-1-amd64 + Linux 3.16.0-4-amd64
(G)UI : Gnome 3.18.2
Inscription : 07-01-2012

Grub disparu

Quand j'ai ouvert mon micro, il n'a pas affiché le grub, juste un écran noir  avec un tiret clignotant qui se balade un peu puis se fixe en haut de l'écran.
Je n'ai pas fait de changement hier et il m'affichait un grub avec une jessie et une stretch, et fonctionnait normalement.
J'ai essayé d'ouvrir une console, mais rien  ne se passe, si je fais un CTRL ALT SUP je reviens sur l'affichage du debut avec le nom de ma carte graphique puis je reviens a sur cet écran noir.

Mon micro n'est pas hors service, il s'ouvre et fonctionne sans histoire avec un CD live.

J'ai pensé refaire un install de Jessie, qui reconstituera un grub, mais il y a surement une autre solution pour reconstruire ou réparer le grub.
Guppy

Hors ligne

#2 20-12-2015 01:26:39

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Grub disparu

Bonsoir
la commande est "grub-install" il me semble.
mais attend l avis de personne plus expérimenté  et surtout savoir pourquoi tu a perdu ton grub.
le petit tiret qui se déplace il me semble que c est l uefi qui fait ça  et ensuite grub se charge et ensuite le noyau.

ps: tu est sur que ton bios pointe sur le bon disque (a vérifier les options de démarrage dans le bios)

Dernière modification par robert2a (20-12-2015 01:29:18)

Hors ligne

#3 20-12-2015 07:52:05

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : Grub disparu

Salut,

Il y a une page sur le wiki pour réparer grub2 : https://debian-facile.org/doc:systeme:grub2:reparer

Dernière modification par nono47 (20-12-2015 07:52:31)

Hors ligne

#4 28-12-2015 02:24:40

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Stretch 64 bits (en rade) +Jessie (en secours)
Noyau : Linux 4.2.0-1-amd64 + Linux 3.16.0-4-amd64
(G)UI : Gnome 3.18.2
Inscription : 07-01-2012

Re : Grub disparu

Merci pour vos répones, en fait j'ai réinstallé le grub avec le CD net install en mode rescue, cela commence comme pour une installation mais apès le passage de reconniassance de la carte ethernet et la configuration du lien internet , il y a une option pour reconstruire le grub et cela a fonctionné. J'ai de nouveau un grub au démarrage.
Mais je ne sais pas pourquoi le grub avait disparu.
Guppy88

Hors ligne

Pied de page des forums