Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-12-2015 14:20:23

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

paquets qui ne veulent pas se mettre à jour

Bonjour,

J'ai des paquets qui veulent pas se mettre à jour.

 apt upgrade



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  icedove icedove-l10n-fr iceowl-extension iceowl-l10n-fr
0 mis à jour, 0 nouvellement installés, 0 à enlever et 4 non mis à jour.
 



comment je fais pour savoir où ça bloque.

apt list --upgradable --all-versions



En train de lister... Fait
icedove/stable 38.4.0-1~deb8u1 amd64 [upgradable from: 31.8.0-1~deb8u1]
icedove/now 31.8.0-1~deb8u1 amd64 [installed,upgradable to: 38.4.0-1~deb8u1]
icedove/stable 31.7.0-1~deb8u1 amd64

icedove-l10n-fr/stable 1:38.0.1-1~deb8u1 all [upgradable from: 1:31.4.0-1]
icedove-l10n-fr/stable,now 1:31.4.0-1 all [installed,upgradable to: 1:38.0.1-1~deb8u1]

iceowl-extension/stable 38.4.0-1~deb8u1 amd64 [upgradable from: 31.8.0-1~deb8u1]
iceowl-extension/now 31.8.0-1~deb8u1 amd64 [installed,upgradable to: 38.4.0-1~deb8u1]
iceowl-extension/stable 31.7.0-1~deb8u1 amd64

iceowl-l10n-fr/stable 4.0.0.1-1~deb8u1 all [upgradable from: 3.3-1]
iceowl-l10n-fr/stable,now 3.3-1 all [installed,upgradable to: 4.0.0.1-1~deb8u1]

 

Hors ligne

#2 23-12-2015 14:34:07

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : paquets qui ne veulent pas se mettre à jour

Bonjour
ça viendrai pas de ceci : https://debian-facile.org/viewtopic.php?id=12810

tu a essayé avec synaptic  individuellement voir ce qu il te répond ?

Hors ligne

#3 23-12-2015 15:14:17

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : paquets qui ne veulent pas se mettre à jour

En principe, pour tout mettre à jour :

apt full-upgrade



Après, si tu as fait un hold sur un de ces paquets, ils seront peut-être ignorés…


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#4 23-12-2015 20:05:48

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : paquets qui ne veulent pas se mettre à jour

la question est surtout d'avoir quelque chose de plus bavard et savoir ou ça coince.

Hors ligne

#5 23-12-2015 20:51:25

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : paquets qui ne veulent pas se mettre à jour

J'ai eu le même souci tout à l'heure (sans iceowl), j'ai fais

apt-get dist-upgrade


no more problem ...


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#6 23-12-2015 21:36:24

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : paquets qui ne veulent pas se mettre à jour

ça reste pas normal d'etre obligé de faire un dist-ugrade tongue , pourquoi a moi ça n'arrive pas ?  => []
ps: avec synaptic tu a un onglet "propriétés" et des sous onglets avec pas mal d info en plus de se mettre en rouge  et de refuser la mise a jour .
a priori c'est pas un probleme de paquet cassé puisque dist-upgrade fonctionne , un soucis de version peut etre. (un fichier "préférence" , moi j en utilise pas ).

Hors ligne

#7 23-12-2015 21:54:30

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : paquets qui ne veulent pas se mettre à jour

le pb semble provenir du paquet xul-ext-compactheader
je l'ai désinstallé et les mises à jour sont passées.

apt install xul-ext-compactheader



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 xul-ext-compactheader : Dépend: icedove (>= 9.0) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
 



avec synaptic on obtient des infos supplémentaires mais pas possible de les copier. du coup si quelqu'un à une commande pour lister les paquets/dépendances cassées, ça m'intéresse.

@paskal: t'avais l'extension xul-ext-compactheader ou pas ?

Hors ligne

#8 23-12-2015 22:10:06

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : paquets qui ne veulent pas se mettre à jour

nIQnutn a écrit :

@paskal: t'avais l'extension xul-ext-compactheader ou pas ?

Non.


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#9 23-12-2015 22:13:27

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : paquets qui ne veulent pas se mettre à jour

nIQnutn a écrit :

avec synaptic on obtient des infos supplémentaires mais pas possible de les copier. du coup si quelqu'un à une commande pour lister les paquets/dépendances cassées, ça m'intéresse.



aptitude search ~i~b



ça te renvoie quelque chose ?
(https://www.debian.org/doc/manuals/apti … QuickGuide)


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#10 23-12-2015 22:19:25

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : paquets qui ne veulent pas se mettre à jour

du coup, difficile de savoir si c'est le même pb ou autre chose puisque tu as résolu le pb avec une méthode de sauvage.

Hors ligne

#11 23-12-2015 23:27:16

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : paquets qui ne veulent pas se mettre à jour

Ben, le full-upgrade indique bien le problème de dépendances… Tu peux toujours faire un

apt -s full-upgrade


quand tu veux voir ce qui coince smile


[Edit @paskal: tiens, je n'avais pas pressenti le pb en voyant le fichier de syntaxe de geshi, mais la coloration syntaxique est toute triste qd on met l'option avant l'action smile]


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#12 23-12-2015 23:35:47

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : paquets qui ne veulent pas se mettre à jour

merci Severian pour la commande et le lien.

@captnfab: j'avais pas penser à ça roll
par contre, je sais pas si apt gère correctement l'option -s ?


j'ai encore des choses à voir sur la gestion des paquets. Je suis en train de me faire une liste des commandes utiles.

Hors ligne

#13 23-12-2015 23:51:24

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : paquets qui ne veulent pas se mettre à jour

nIQnutn a écrit :

@captnfab: j'avais pas penser à ça roll
par contre, je sais pas si apt gère correctement l'option -s ?


Il la gère, j'ai testé… sous Stretch au moins. En fait, si tu regardes le man apt (sous stretch toujours…), tu vois qu'il renvoie au man apt-get pour un bon nombre de commandes. Donc a priori, il gère tous leurs paramètres aussi smile


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#14 24-12-2015 00:26:12

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : paquets qui ne veulent pas se mettre à jour

j'ai ça dans le man

DESCRIPTION
       apt (Advanced Package Tool) est un outil en ligne de commande pour gérer les paquets. Il fournit une interface en
       ligne de commande au système de gestion de paquets. Voir également apt-get(8) et apt-cache(8) pour davantage d'options
       en ligne de commande.


faut il en déduire que toutes les options de apt-get sont géré correctement par apt?
je ne sais pas si apt est désormais considéré comme stable.

autant sur ce qui est indiqué sur le man, il n'y a pas de doute, autant sur le reste je suis prudent. En cas de doute je reste généralement sur apt-get ou aptitude mais tu as peut être un avis plus éclairé sur la question.

Hors ligne

#15 24-12-2015 00:32:58

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : paquets qui ne veulent pas se mettre à jour

Ben, l'interface d'apt n'est pas figée. Dans Stretch on a déjà apt autoremove, apt clean… Mais pour ce qui est des options/actions, je pense que l'objectif est de coller au plus près des options déjà existantes dans apt-get et apt-cache.
Je préfère conseiller apt-get quand je ne sais pas sur quelle Debian les gens sont. Mais personnellement, j'utilise maintenant apt.
De toute façon, apt ne fait en général que réutiliser des fonctionnalités existantes, il ne les ré-implémente pas, c'est uniquement un « front-end », une interface.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#16 24-12-2015 01:03:22

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : paquets qui ne veulent pas se mettre à jour

merci.

j'utilise également apt dans le quotidien mais j'ai quand même quelques incertitudes.

UTILISATION DE SCRIPTS
       La ligne de commande de apt(8) est conçue comme un outil pour l'utilisateur et les sorties peuvent varier selon ses
       versions. Bien qu'il s'efforce de ne pas casser les compatibilités ascendantes, cela ne peut pas non plus être
       garanti. Toutes les fonctionnalités de apt(8) existent dans apt-cache(8) et apt-get(8) grâce aux options de APT. Il
       est conseillé d'utiliser ces commandes dans vos scripts.


je ne sais pas comment l'interpreter d'autant que kao a un message un peu plus alarmant http://kaocode.fr/apt-debut-de-simplification/ sur son utilisation dans les scripts.

je pense que se limiter à ce qui est indiqué dans le man est généralement plus prudent. De toute façon, on peut se retrouver à utiliser apt/apt-get/aptitude selon les cas.
L'essentiel est de savoir quoi utiliser. Pour les débutants, ça sera plus facile pour apprendre les commandes de base.

Hors ligne

#17 24-12-2015 01:12:45

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : paquets qui ne veulent pas se mettre à jour

Oui, dans les scripts, on a besoin de trucs figés, donc on évite apt, qui n'est de toute façon pas fait pour.

Dans le wiki, on continue pour l'instant à utiliser apt-get et apt-cache.

Ceci-dit, je pense qu'avec Stretch, on pourra discuter d'un passage à apt qui sera alors stabilisé et qui est plus ergonomique, donc plus sympa pour les débutants.
Là, ça me semble un peu trop tôt pour en faire l'outil par défaut dans le wiki, surtout que dans Jessie les fonctionnalités sont assez restreintes.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#18 24-12-2015 01:29:27

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : paquets qui ne veulent pas se mettre à jour

Milou connait le wiki par coeur, elle aurait vite fait de modifier tout ça big_smile

Pour le wiki, je pense également qu'il faut rester comme ça. Quand on verra apt arriver dans le wiki officiel Debian, on pourra changer.
Par contre je n'ai pas vu de page dans notre wiki traitant de apt ?
je pensais écrire un truc dessus de mon coté mais on pourrait rapatrier ici.

Hors ligne

#19 24-12-2015 10:04:51

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : paquets qui ne veulent pas se mettre à jour

captnfab a écrit :

[Edit @paskal: tiens, je n'avais pas pressenti le pb en voyant le fichier de syntaxe de geshi, mais la coloration syntaxique est toute triste qd on met l'option avant l'action smile]

Bon, vu l'heure "avancée", je vais faire comme Milou ==> marque page  big_smile


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#20 24-12-2015 10:35:00

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : paquets qui ne veulent pas se mettre à jour

Il me semblait que qqn voulait commencer une page au sujet d'apt. Peut-être dans une page perso ou au chantier? Je vais regarder ça.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#21 24-12-2015 14:27:30

milou
Modo ... e
Lieu : Sur une autre planète....
Distrib. : Jessie - Stretch/Sid
Noyau : 3.16.0-4-amd64
(G)UI : Lxde
Inscription : 12-02-2015
Site Web

Re : paquets qui ne veulent pas se mettre à jour

nIQnutn a écrit :

Milou connait le wiki par coeur, elle aurait vite fait de modifier tout ça

Je me ferai un plaisir de faire une nouvelle passe .... tongue lol


J’adorerais changer le monde, mais ils ne veulent pas me fournir le code source
Un vrai geek, c'est un mec qui croit que dans 1km, il y a 1024 mètres
Dans le doute, rebootes. Si tu te tâtes, formates.
1453651422.jpg

Hors ligne

#22 24-12-2015 14:45:32

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : paquets qui ne veulent pas se mettre à jour

milou a écrit :

nIQnutn a écrit :

Milou connait le wiki par coeur, elle aurait vite fait de modifier tout ça

Je me ferai un plaisir de faire une nouvelle passe .... tongue lol


c'est bien d'avoir des membres plein d'entrain big_smile

Hors ligne

#23 24-12-2015 14:47:03

milou
Modo ... e
Lieu : Sur une autre planète....
Distrib. : Jessie - Stretch/Sid
Noyau : 3.16.0-4-amd64
(G)UI : Lxde
Inscription : 12-02-2015
Site Web

Re : paquets qui ne veulent pas se mettre à jour

Un peu trop parfois ..... wink lol

J’adorerais changer le monde, mais ils ne veulent pas me fournir le code source
Un vrai geek, c'est un mec qui croit que dans 1km, il y a 1024 mètres
Dans le doute, rebootes. Si tu te tâtes, formates.
1453651422.jpg

Hors ligne

#24 24-12-2015 15:26:40

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : paquets qui ne veulent pas se mettre à jour

Hum, je crois qu'on fera plutôt ça via un script. Il y a 837 occurrences de « apt-get install », 432 de « apt-get update », 41 de dist/full/upgrade 86 d'apt-cache.
Ça prendra 1 minute via un bon script sed, et ça permettra à milou de souffler un peu smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#25 24-12-2015 15:29:43

milou
Modo ... e
Lieu : Sur une autre planète....
Distrib. : Jessie - Stretch/Sid
Noyau : 3.16.0-4-amd64
(G)UI : Lxde
Inscription : 12-02-2015
Site Web

Re : paquets qui ne veulent pas se mettre à jour

Merci Capitaine

et ça permettra à milou de souffler un peu

ça ne me dérange pas, ça m'occupe l'esprit .... wink


J’adorerais changer le monde, mais ils ne veulent pas me fournir le code source
Un vrai geek, c'est un mec qui croit que dans 1km, il y a 1024 mètres
Dans le doute, rebootes. Si tu te tâtes, formates.
1453651422.jpg

Hors ligne

Pied de page des forums