Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 24-04-2009 08:40:07

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Linux-libre disponible pour Lenny

Bonjour à tous,

Le projet Linux-libre est maintenant disponible pour Lenny, sur les architectures i386, amd64 et powerpc. Basé sur le noyau 2.6.26, ce projet vise à supprimer tout code non libre du noyau Linux, objectif qui n'a pas pu être atteint par les développeurs Debian pour la sortie de Lenny.

Si vous souhaitez utiliser ce nouveau noyau, rajoutez la ligne suivante à vote fichier /etc/apt/sources.list :

deb http://people.debian.org/~rmh/linux-libre lenny main


Puis installez la clé d'authentification et rechargez les dépôts :

wget http://people.debian.org/~rmh/linux-libre/archive-key.asc -O - | apt-key add -


apt-get update


Recherchez ensuite le noyau contenant la chaîne libre2 (pour moi : linux-image-2.6.26-libre2-1-amd64) ! smile

Source : http://lists.debian.org/debian-devel-an … 00010.html


« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#2 02-05-2009 23:46:55

dada
Membre
Lieu : Lorraine
Inscription : 21-09-2007
Site Web

Re : Linux-libre disponible pour Lenny

Génial !

J'vais tester ça tout de suite !

Hors ligne

#3 10-05-2009 16:50:40

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : Linux-libre disponible pour Lenny

Bonjour à toutes et tous,

J'ai installé le noyau linux-image-2.6.26-libre2-1-amd64, comme l'explique mani. Cependant, bien que j'aie fait la commande

wget http://people.debian.org/~rmh/linux-libre/archive-key.asc


lorsque je fais

apt-get update


j'obtiens un message d'erreur indiquant qu'une signature manque:

W: GPG error: http://people.debian.org lenny Release: Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY BB5ED5F25565FD7F
W: Vous pouvez lancer « apt-get update » pour corriger ces problèmes.


Il semble bien que la clé ne soit pas correctement installée. J'ai quand même pris le risque d'installer
le noyau linux-image-2.6.26-libre2-1-amd64 malgré la mise en garde indiquant qu'il n'est pas authentifié.

Résultat: pour le moment, avec ce noyau le serveur X ne marche pas, le wifi non plus. Je crains fort que ma clef USB 3G+ huawei ne marche pas non plus, je n'ai pas encore essayée avec ce noyau. Il va falloir que je refasse l'installation de ma carte graphique nvidia et de ma carte wifi broadcom. Comme je n'ai pas trop de temps en ce moment je suis revenu au noyau que j'utilisais avant. Mais j'ai bien l'intention de poursuivre le test de ce noyau, juste pour voir!

Cordialement,

C.-M. M.

Hors ligne

#4 10-05-2009 18:49:46

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : Linux-libre disponible pour Lenny

Rebonjour,

J'ai refait le pilote nvidia comme indiqué dans le wiki, en démarrant avec le nouveau noyau libre,  et maintenant le serveur X marche avec ce noyau linux-image-2.6.26-libre2-1-amd64. J'ai aussi essayé les logiciels que j'emploie le plus souvent et tous marchent comme avec le noyau précédent. J'ai aussi recréé
le pilote de ma carte wifi broadcom en utilisant la méthode indiquée ici:

http://www.paperblog.fr/1546601/install … -broadcom/

et le wifi fonctionne aussi avec ce nouveau noyau.

Il n'y a plus que le problème du message d'erreur que j'ai en faisant apt-get update qui n'est pas encore réglé.

Cordialement, C.-M. M.

Dernière modification par cmm1934@orange.fr (10-05-2009 22:14:25)

Hors ligne

#5 11-05-2009 08:46:59

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : Linux-libre disponible pour Lenny

Bonjour,

Si j'en crois ton message, tu as téléchargé la clé sans l'ajouter à apt. Le code est tronqué dans le premier message (trop long), si tu utilises l'ascenseur horizontal tu le verras en entier :

wget http://people.debian.org/~rmh/linux-lib … ve-key.asc -O - | apt-key add -

wink

« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#6 11-05-2009 13:36:04

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : Linux-libre disponible pour Lenny

Merci Mani, je me doutais bien que j'avais raté une étape, je ne savais pas très bien laquelle.

Par ailleurs j'ai peut-être encore fait des bêtises en parlant  dans ce fil de discussion de mes démêlés avec les pilotes nvidia et broadcom pour faire marcher carte graphique et wifi avec ce nouveau noyau, j'aurais mieux fait d'en parler dans d'autres parties du forum. J'essaierai d'être plus cohérent à l'avenir.

Cordialement,

C.-M. M.

Hors ligne

#7 11-05-2009 14:45:59

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : Linux-libre disponible pour Lenny

Pour cette fois on va dire que c'est un retour d'expérience qui va bien dans le fil alors ! wink

« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#8 16-05-2009 23:40:21

dada
Membre
Lieu : Lorraine
Inscription : 21-09-2007
Site Web

Re : Linux-libre disponible pour Lenny

Retour d'expérience ; ça ne marche pas du tout chez moi. Le noyaux ne boot même pas hmm

Hors ligne

Pied de page des forums