Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-01-2016 12:24:18

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Samba et dépendances non satisfaites [Résolu]

Bonjour,

j'ignore depuis quand mon problème existe, car je n'utilise plus samba depuis un moment. Je suis un cowboy solitaire, déconnecté de réseau local depuis plusieurs mois.  Mais voilà, je veux réactiver ces fonctions, car je ne suis plus sur une autre planète.

je fais donc

apt-get install samba



et j'obtiens ceci:

Les paquets suivants contiennent des dépendances non satisfaites :
 samba : Dépend: python-samba mais ne sera pas installé
         Dépend: samba-common-bin (= 2:4.1.17+dfsg-2+deb8u1) mais ne sera pas installé
 



blabla bla ... j'en arrive à

apt-get install libtdb1


qui m'assure que j'ai la version la plus récente
Or, il semble que python-samba et cie demandent une version plus ancienne!

Je n'ai pas envie de rétrograder, car libtdb1 est utilisée par une foule d'amis

Que me proposez-vous ?

Merci encore.

Dernière modification par Patriboom (09-01-2016 07:31:59)


Portez la paix
Patrick Allaire, ptre

Hors ligne

#2 07-01-2016 13:23:56

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Samba et dépendances non satisfaites [Résolu]

Il faut commencer par poster ton sources.list ici


nano /etc/apt/sources.list
 


et tu post le retour de cette commande.
a priori je dirai que tu a des problemes de versions , il faut savoir pourquoi smile

Hors ligne

#3 07-01-2016 15:30:14

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Samba et dépendances non satisfaites [Résolu]

Merci Robert, voici mon sources.list


# deb cdrom:[Debian GNU/Linux 7.1.0 _jessie_ - Official i386 NETINST Binary-1 20130615-21:53]/ jessie main
# deb cdrom:[Debian GNU/Linux 7.1.0 _jessie_ - Official i386 NETINST Binary-1 20130615-21:53]/ jessie main

deb http://ftp.ca.debian.org/debian/ jessie main contrib
deb-src http://ftp.ca.debian.org/debian/ jessie main contrib

#jessie security
deb http://security.debian.org/ jessie/updates main contrib
deb-src http://security.debian.org/ jessie/updates main contrib

# jessie-updates, previously known as 'volatile'
deb http://ftp.ca.debian.org/debian/ jessie-updates main contrib
deb-src http://ftp.ca.debian.org/debian/ jessie-updates main contrib

#A la suggestion de https://wiki.debian.org/fr/wl#Debian_7_.22 jessie
deb http://http.debian.net/debian/ jessie main contrib non-free
deb-src http://http.debian.net/debian/ jessie main contrib non-free

# jessie - rétroportages
# Paquets en provenance de la prochaine version mais adaptés pour s’intégrer sur votre système stable
deb http://ftp.debian.org/debian/ jessie-backports main contrib non-free

# Pour avoir la dernière version de firefox
deb http://mozilla.debian.net/ jessie-backports iceweasel-release
 



Peut-être le backports en trop ?


Portez la paix
Patrick Allaire, ptre

Hors ligne

#4 09-01-2016 07:29:22

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Samba et dépendances non satisfaites [Résolu]

Bonsoir à tous,

j'ai installé de manière forcée  le paquet de version antérieure  libtdb1_1.3.1-1

dpkg -i libtdb1_1.3.1-1 --force



et samba a pu être installé.


Portez la paix
Patrick Allaire, ptre

Hors ligne

#5 09-01-2016 10:18:17

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Samba et dépendances non satisfaites [Résolu]

Bonjour smile
@Patriboom
tu nous dit bonsoir mais nous le jour se lève tongue  ok => []   wink

Hors ligne

#6 09-01-2016 11:03:21

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Samba et dépendances non satisfaites [Résolu]

Ouch ! Très à l'ouest, alors ...  big_smile

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#7 09-01-2016 14:24:19

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Samba et dépendances non satisfaites [Résolu]

smile:):)  Et oui: Québec. 
Mon message affiche ici 00:29 et le vôtre 04:03 .... vous vous levez tôt, très tôt  yikes

Portez la paix
Patrick Allaire, ptre

Hors ligne

#8 09-01-2016 14:57:15

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Samba et dépendances non satisfaites [Résolu]

Ouaip, l'avenir nous appartient, il parait ...  wink

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#9 09-01-2016 15:32:35

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Samba et dépendances non satisfaites [Résolu]

J'ai toujours dit que je voulais vivre à 1 m. de la ligne de changement de date!

Portez la paix
Patrick Allaire, ptre

Hors ligne

#10 09-01-2016 16:10:33

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Samba et dépendances non satisfaites [Résolu]

Question d'en finir avec ces affaires de conflit de version, j'ai fait une petite tournée des résidus de sid. J'ai trouvé une bonne centaine - peut-être deux - de fichiers (surtout des lib... ) dont la version était « anticiipée ».  J'ai tout mis ça en « stable ».

Mon fichier /etc/apt/sources.list est désormais ceci  (avec choix de « stable » plutôt que « jessie »  ).
Merci à vous, encore une fois.

# deb cdrom:[Debian GNU/Linux 7.1.0 _stable_ - Official i386 NETINST Binary-1 20130615-21:53]/ stable main
# deb cdrom:[Debian GNU/Linux 7.1.0 _stable_ - Official i386 NETINST Binary-1 20130615-21:53]/ stable main

deb http://ftp.ca.debian.org/debian/ stable main contrib
deb-src http://ftp.ca.debian.org/debian/ stable main contrib

#stable security
deb http://security.debian.org/ stable/updates main contrib
deb-src http://security.debian.org/ stable/updates main contrib

# stable-updates, previously known as 'volatile'
deb http://ftp.ca.debian.org/debian/ stable-updates main contrib
deb-src http://ftp.ca.debian.org/debian/ stable-updates main contrib

#A la suggestion de https://wiki.debian.org/fr/wl#Debian_7_.22 stable
deb http://http.debian.net/debian/ stable main contrib non-free
deb-src http://http.debian.net/debian/ stable main contrib non-free

# Jessie - rétroportages
# Paquets en provenance de la prochaine version mais adaptés pour s’intégrer sur votre système stable
#deb http://ftp.debian.org/debian/ jessie-backports main contrib non-free

# Pour avoir la dernière version de firefox
deb http://mozilla.debian.net/ jessie-backports iceweasel-release

 




et ... puisque vous irez vous coucher plus tôt que moi ....

   bonne nuit.


Portez la paix
Patrick Allaire, ptre

Hors ligne

#11 09-01-2016 18:25:38

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Samba et dépendances non satisfaites [Résolu]

Il fait encore un peu jour !  big_smile

Tu as des doublons :

...
deb http://ftp.ca.debian.org/debian/ stable main contrib
...
deb http://http.debian.net/debian/ stable main contrib non-free


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

Pied de page des forums