Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 08-01-2016 14:47:06

TyZef
Membre
Lieu : 0°31'48.9"N 72°59'44.7"E
Distrib. : Debian8.2 (jessie)
Noyau : Noyaux Linux 3.16.0-4-amd64
(G)UI : MATE 1.8.1
Inscription : 09-05-2013

D-Link Wireless N 150 USB Adapter DWA-123

Salut!

Voila j'essaye d'installer cet adaptateur " D-Link Wireless N 150 USB Adapter DWA-123 " sans le succes !
Aussi j'ai tenté ceci https://wiki.debian.org/rt2800usb ainsi que http://forums.debian.net/viewtopic.php?f=17&t=94409 qui donne sur http://www.network-builders.com/getting … 09110.html mais rien...

tyzef@debian:~$ lsusb
Bus 002 Device 027: ID 0bb4:0003 HTC (High Tech Computer Corp.)
Bus 002 Device 028: ID 2001:3310 D-Link Corp.
Bus 002 Device 004: ID 413c:2111 Dell Computer Corp.
Bus 002 Device 003: ID 1915:0f01 Nordic Semiconductor ASA
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 


Ce qui est drole c'est que lorsque je connecte l'USB en question, mon CPU s'emballe...
Voila en gros comment je peux decrire le massala...

Merci d'avance pour ceux/celles qui porteront attention a ce massala!

Hors ligne

#2 08-01-2016 15:08:48

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : D-Link Wireless N 150 USB Adapter DWA-123

Bjr,
Je ne connais pas ce type de device, mais perso j'irai voir les résutats de

dmesg | grep firmware*

et aussi dans top ou htop le process qui emballe le cpu


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#3 08-01-2016 19:15:28

Atys
Membre
Distrib. : Debian GNU/Linux unstable (sid)
Noyau : Linux 4.8.0-2-686-pae
(G)UI : Fluxbox - Xfce
Inscription : 28-02-2015

Re : D-Link Wireless N 150 USB Adapter DWA-123

Bonjour

Connais rien au Wifi
Mais que donne :

usb-devices


Ce lien peu être
rtl819x

Me trompe certainement, pas assez d'infos, mais oui apparemment c'est une histoire de firmware !
HowToIdentifyADevice/USB

lsusb -v -d 2001:3310

Hors ligne

#4 09-01-2016 18:22:30

aurel-son
Membre
Lieu : Vietnam
Distrib. : Stable/Testing
Noyau : 3.2/3.18
(G)UI : Mate
Inscription : 23-03-2015
Site Web

Re : D-Link Wireless N 150 USB Adapter DWA-123

Salut,

Premiere chose a faire :
Installation des pilotes :

sudo aptitude install firmware-ralink wireless-tools



Si cela ne fonctionne pas, rajoute non-free dans les depots :

sudo nano /etc/apt/sources.list

deb http://ftp.fr.debian.org/debian jessie main contrib non-free



Puis tu fais lsusb pour trouver l'ID de ta wifi

lsusb



Puis la creation du module (modifie 07d1 3c0d par l'ID de ta carte wifi !!!!) :

echo 'install rt2870sta modprobe --ignore-install rt2870sta ; /bin/echo "07d1 3c0d" > /sys/bus/usb/drivers/rt2870/new_id' | sudo tee /etc/modprobe.d/rt2870sta.conf



Puis tu charges le module :

sudo modprobe rt2870sta



Tu verifies si ta carte est bien detecte, sinon fait un test avec une connection :

sudo iwconfig



Pour charger automatiquement le driver tu crees un rule :

sudo nano /etc/udev/rules.d/10-d_link.rules



Puis tu ajoutes ceci (idVendor et idProduct doivent avoir l'ID de ta cle !!!) :

# UDEV-Rule for D-LINK DWA-125N ID 07D1 :3C0D
SUBSYSTEM=="usb", SYSFS{idVendor}=="07d1", SYSFS{idProduct}=="3c0d", RUN+="/sbin/modprobe rt2870sta"
 



sudo nano /etc/udev/rules.d/10-d_link.rules



Puis reboot ton ordinateur et redis moi par la suite.

Dernière modification par aurel-son (09-01-2016 18:25:33)


Desktop : Debian Jessie Mate/Kali
Serveur/NAS/firewall : Debian stable,Centos,BSD

Hors ligne

#5 11-01-2016 19:04:17

TyZef
Membre
Lieu : 0°31'48.9"N 72°59'44.7"E
Distrib. : Debian8.2 (jessie)
Noyau : Noyaux Linux 3.16.0-4-amd64
(G)UI : MATE 1.8.1
Inscription : 09-05-2013

Re : D-Link Wireless N 150 USB Adapter DWA-123

Salut !
Merci beaucoup pour votre attention !
Désolé pour le temps de réponse tardive, je suis débordé en ce moment.

Donc je vais répondre dans l'ordre a vos sugjections.

@Phlinux
dmesg | grep firmware*
tyzef@debian:~$

root@debian:/home/tyzef#
root@debian:/home/tyzef#
Pour le top et htop, je ne sais pas faire mieux que cela donc n'hésites surtout pas a me reprendre !
On peut voir sur les courbes que l'USB était connecté puis je l'ai déconnecté puis l'ai reconnecté...
1452526073.png
1452526024.png

@Atys
usb-devices
root@debian:/home/tyzef#

root@debian:/home/tyzef#
lsusb -v -d 2001:3310
root@debian:/home/tyzef#

@Aurel-son
sudo aptitude install firmware-ralink wireless-tools

root@debian:/home/tyzef#
sudo
  GNU nano 2.2.6                                       Fichier : /etc/apt/sources.list                                                                                   

lsusb
root@debian:/home/tyzef#

root@debian:/home/tyzef#
echo 'install rt2870sta modprobe --ignore-install rt2870sta ; /bin/echo "07d1 3c0d" > /sys/bus/usb/drivers/rt2870/new_id' | sudo tee /etc/modprobe.d/rt2870sta.conf
root@debian:/home/tyzef#

modprobe rt2870sta
root@debian:/home/tyzef#

modprobe rt2870sta



modprobe: ERROR: ../libkmod/libkmod-module.c:816 kmod_module_insert_module() could not find module by name='rt2870sta'
modprobe: ERROR: could not insert 'rt2870sta': Function not implemented
sh: 1: cannot create /sys/bus/usb/drivers/rt2870/new_id: Directory nonexistent
modprobe: ERROR: ../libkmod/libkmod-module.c:960 command_do() Error running install command for rt2870sta
modprobe: ERROR: could not insert 'rt2870sta': Unknown symbol in module, or unknown parameter (see dmesg)
root@debian:/home/tyzef# echo 'install rt2870sta modprobe --ignore-install rt2870sta ; /bin/echo 2001:3310 > /sys/bus/usb/drivers/rt2870/new_id' | tee /etc/modprobe.d/rt2870sta.conf
install rt2870sta modprobe --ignore-install rt2870sta ; /bin/echo 2001:3310 > /sys/bus/usb/drivers/rt2870/new_id
root@debian:/home/tyzef# modprobe rt2870sta
modprobe: ERROR: ../libkmod/libkmod-module.c:816 kmod_module_insert_module() could not find module by name='rt2870sta'
modprobe: ERROR: could not insert 'rt2870sta': Function not implemented
sh: 1: cannot create /sys/bus/usb/drivers/rt2870/new_id: Directory nonexistent
modprobe: ERROR: ../libkmod/libkmod-module.c:960 command_do() Error running install command for rt2870sta
modprobe: ERROR: could not insert 'rt2870sta': Unknown symbol in module, or unknown parameter (see dmesg)


root@debian:/home/tyzef#

étant donne les messages "ERROR" je suppose que j'arrete ici en attendant de nouvelles instructions !
aussi je vous demandes pardon d'avance si je fais des erreurs de debutant!!!


su



Edit à toto :
Mise des commandes root sous les balises root et leur retour sous les balises Autre code. Séparation des indications qui ne sont ni une commande ni un retour. Hop ! smile

Dernière modification par TyZef (11-01-2016 19:13:40)

Hors ligne

#6 11-01-2016 20:45:19

aurel-son
Membre
Lieu : Vietnam
Distrib. : Stable/Testing
Noyau : 3.2/3.18
(G)UI : Mate
Inscription : 23-03-2015
Site Web

Re : D-Link Wireless N 150 USB Adapter DWA-123

Salut,
Hum etrange ....
Dans ce cas faire un purge :


sudo apt-get remove --purge firmware-ralink*
 



Puis telecharger le paquet :

http://ftp.de.debian.org/debian/pool/non-free/f/firmware-nonfree/firmware-ralink_0.43_all.deb



Puis installer le paquet dans le dossier Telechargements :

sudo dpkg -i firmware-ralink_0.43_all.deb



Puis refaire l'operation avec modprobe

Dernière modification par aurel-son (11-01-2016 20:45:37)


Desktop : Debian Jessie Mate/Kali
Serveur/NAS/firewall : Debian stable,Centos,BSD

Hors ligne

#7 12-01-2016 10:00:06

TyZef
Membre
Lieu : 0°31'48.9"N 72°59'44.7"E
Distrib. : Debian8.2 (jessie)
Noyau : Noyaux Linux 3.16.0-4-amd64
(G)UI : MATE 1.8.1
Inscription : 09-05-2013

Re : D-Link Wireless N 150 USB Adapter DWA-123

Salut!

Ce matin a voulu utiliser le desktop et tiiiliiin!!!!!!

1452584980.jpg

je ne comprend pas trop du coup...

y a t-il un rapport avec les commandes précédentes..?

Hors ligne

#8 12-01-2016 10:23:54

aurel-son
Membre
Lieu : Vietnam
Distrib. : Stable/Testing
Noyau : 3.2/3.18
(G)UI : Mate
Inscription : 23-03-2015
Site Web

Re : D-Link Wireless N 150 USB Adapter DWA-123

Oulalalala ...
De base non.
Il faut faire un

sudo chmod 1777 /tmp


Desktop : Debian Jessie Mate/Kali
Serveur/NAS/firewall : Debian stable,Centos,BSD

Hors ligne

#9 12-01-2016 15:38:34

TyZef
Membre
Lieu : 0°31'48.9"N 72°59'44.7"E
Distrib. : Debian8.2 (jessie)
Noyau : Noyaux Linux 3.16.0-4-amd64
(G)UI : MATE 1.8.1
Inscription : 09-05-2013

Re : D-Link Wireless N 150 USB Adapter DWA-123

Merci Aurel-son pour ton aide!

donc j'ai fais:

1452605559.jpg

mais ça renvoit au même problème...

Dernière modification par TyZef (12-01-2016 15:39:15)

Hors ligne

#10 12-01-2016 15:46:59

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : D-Link Wireless N 150 USB Adapter DWA-123

ça fait longtemps que tu démarres en rescue ? sinon depuis quelle étape ?

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#11 12-01-2016 16:05:36

TyZef
Membre
Lieu : 0°31'48.9"N 72°59'44.7"E
Distrib. : Debian8.2 (jessie)
Noyau : Noyaux Linux 3.16.0-4-amd64
(G)UI : MATE 1.8.1
Inscription : 09-05-2013

Re : D-Link Wireless N 150 USB Adapter DWA-123

je démarre en rescue pour pouvoir entrer les lignes de commande et ce que depuis ce matin...

à mon avis je suis dans ce problème de /tmp après l'étape:

root@debian:/home/tyzef#
echo 'install rt2870sta modprobe --ignore-install rt2870sta ; /bin/echo "07d1 3c0d" > /sys/bus/usb/drivers/rt2870/new_id' | sudo tee /etc/modprobe.d/rt2870sta.conf
(voir le message #5)

Dernière modification par TyZef (12-01-2016 16:06:44)

Hors ligne

#12 12-01-2016 16:18:44

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : D-Link Wireless N 150 USB Adapter DWA-123

Je ne suis pas un spécialiste, mais c'est aussi ce que je crois.
En général il faut simplement installer le firmware qui va bien et rebooter, voire faire un simple modprobe nom_du_module.

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#13 12-01-2016 16:32:01

TyZef
Membre
Lieu : 0°31'48.9"N 72°59'44.7"E
Distrib. : Debian8.2 (jessie)
Noyau : Noyaux Linux 3.16.0-4-amd64
(G)UI : MATE 1.8.1
Inscription : 09-05-2013

Re : D-Link Wireless N 150 USB Adapter DWA-123

ma carte mère est nouvelle... cela viendrait-il de là ?

Hors ligne

#14 12-01-2016 16:44:43

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : D-Link Wireless N 150 USB Adapter DWA-123

je l'ignore, mais si c'est seulement l'installation de l'adaptateur qui met le souk ?
Perso je reviendrais à un boot "normal" en virant les fichiers ajoutés, règle udev, etc....
Normalement firmware-ralink c'est bon, démarrage avec adaptateur connecté, vérif avec dmesg pour voir les erreurs (microcode non trouvé par exemple...)

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#15 12-01-2016 16:44:51

TyZef
Membre
Lieu : 0°31'48.9"N 72°59'44.7"E
Distrib. : Debian8.2 (jessie)
Noyau : Noyaux Linux 3.16.0-4-amd64
(G)UI : MATE 1.8.1
Inscription : 09-05-2013

Re : D-Link Wireless N 150 USB Adapter DWA-123

je vois que ma partition système est archi pleine... un rapport?

Hors ligne

#16 12-01-2016 16:48:46

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : D-Link Wireless N 150 USB Adapter DWA-123

Pour l'installation d'un paquet c'est sur. C'est peut être aussi pour ça que ton cpu s'emballe.
Il faut faire de la place (des paquets dans /var/cache/apt/archives ?)

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#17 12-01-2016 17:02:20

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : D-Link Wireless N 150 USB Adapter DWA-123


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#18 12-01-2016 18:21:25

TyZef
Membre
Lieu : 0°31'48.9"N 72°59'44.7"E
Distrib. : Debian8.2 (jessie)
Noyau : Noyaux Linux 3.16.0-4-amd64
(G)UI : MATE 1.8.1
Inscription : 09-05-2013

Re : D-Link Wireless N 150 USB Adapter DWA-123

j'ai fais le ménage(ma partition système ne fais que 10gio...) mais rien n'y fait toujours le même dilem...

clin d'oeuil à Smolski!

Hors ligne

#19 12-01-2016 19:20:19

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : D-Link Wireless N 150 USB Adapter DWA-123

Tu es donc revenu au point de départ de ton premier post ? càd sans les fichiers et les installations de modprobe et règle udev ?
La clé est reconnue > résultat de lsusb ou usb-devices
Le firmware-ralink est installé ?


Edit : j'ai regardé sur le net d'après ce que lsusb détecte pour ta clé : idVendor=2001, idProduct=3310
Il y a des pages intéressantes:
http://www.linux-hardware-guide.com/fr/ … sb-802-11g
https://wiki.debian.org/fr/rtl819x#r8188eu
https://wiki.debian.org/fr/rtl819x#supported-r8188eu

A vérifier mais il faudrait plutôt installer firmware-realtek

Dernière modification par phlinux (12-01-2016 20:13:05)


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#20 13-01-2016 06:57:21

TyZef
Membre
Lieu : 0°31'48.9"N 72°59'44.7"E
Distrib. : Debian8.2 (jessie)
Noyau : Noyaux Linux 3.16.0-4-amd64
(G)UI : MATE 1.8.1
Inscription : 09-05-2013

Re : D-Link Wireless N 150 USB Adapter DWA-123

Désolé @Phlinux, je me suis mal exprimé, quand je parlais de ménage je voulais dire que j'ai fais les "apt-get clean" et autres que @Smolski à proposé après toi!

Donc non pas de grande évolution dans tout ça...

mais merci quand même en tout cas!

Hors ligne

#21 13-01-2016 12:17:35

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : D-Link Wireless N 150 USB Adapter DWA-123

Je pense que la solution est dans mon avant-dernier message : prendre le bon firmware, qui ne semble pas être dans firmware-ralink

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#22 13-01-2016 19:09:09

TyZef
Membre
Lieu : 0°31'48.9"N 72°59'44.7"E
Distrib. : Debian8.2 (jessie)
Noyau : Noyaux Linux 3.16.0-4-amd64
(G)UI : MATE 1.8.1
Inscription : 09-05-2013

Re : D-Link Wireless N 150 USB Adapter DWA-123

Salut!

Du nouveau hehe !!!

Donc je suis allé chercher par ici http://www.linuxquestions.org/questions … ost3824168 il m'a donc fallu rajouter la commande "startx" après "apt-get clean" et j'ai enfin pu revoir mon bureau(avec une configuration d'origine) et ce beau petit message !
1452704678.jpg
par contre ce ne fut que temporaire pour accéder au bureau... même message d'erreur au redémarrage "Xsession: warning: unable to write to /tmp" sachant que je n'ai pas installé /tmpreaper vu que je vais refaire une installe avec plus de place pour le système Deb!
bon je reviens pour en finir avec cette clé wifi dès que j'ai réinstallé !

Merci et au plaisir !!!

Dernière modification par TyZef (15-01-2016 06:38:08)

Hors ligne

Pied de page des forums