Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-01-2016 12:56:52

groovyjona
Membre
Lieu : 77
Distrib. : Antix-MX-15
Noyau : Linux 4.2.0-0.bpo.1-amd64
(G)UI : Xfce
Inscription : 18-04-2015
Site Web

Préférences Alsamixer ne sont pas sauvegardées

Bonjour,
à chaque démarrage, je suis obligé de remonter les niveaux manuellement (la tranche "Headphone" jouant visiblement sur le niveau des haut-parleurs du macbook).
Je ne trouve pas de solutions qui fonctionnent...

Dernière modification par groovyjona (02-02-2016 15:59:16)


Voyager X8 - MacBook 2.1 fin 2007
"Tôt ou tard, nous devrons répondre à cet appel des ténèbres, aller voir ce qu'il y a derrière cette impérieuse mélancolie qui sort des saxophones." P. Morand

Hors ligne

#2 23-01-2016 13:35:10

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : Préférences Alsamixer ne sont pas sauvegardées

Salut,

Il y a la commande alsactl pour y remédier :

alsactl store

pour sauvegarder les réglages de alsa . smile

Dernière modification par nono47 (23-01-2016 13:38:36)

Hors ligne

#3 23-01-2016 13:45:36

groovyjona
Membre
Lieu : 77
Distrib. : Antix-MX-15
Noyau : Linux 4.2.0-0.bpo.1-amd64
(G)UI : Xfce
Inscription : 18-04-2015
Site Web

Re : Préférences Alsamixer ne sont pas sauvegardées

Merci Nono mais déjà fait et ça ne fonctionne pas. Je dois remonter le niveau de la tranche en question pour avoir un son correct.

Voyager X8 - MacBook 2.1 fin 2007
"Tôt ou tard, nous devrons répondre à cet appel des ténèbres, aller voir ce qu'il y a derrière cette impérieuse mélancolie qui sort des saxophones." P. Morand

Hors ligne

#4 23-01-2016 19:00:22

kawer
Adhérent(e)
Lieu : Académie de la Croix-Vraie
Distrib. : Debian stable / ArchLinux
Noyau : Current
(G)UI : xfwm4
Inscription : 08-10-2013
Site Web

Re : Préférences Alsamixer ne sont pas sauvegardées

Il faut penser à restorer les réglages sauvegarder par alsactl store avec

alsactl restore


Rendez à César ce qui est à César et à Dieu ce qui est à Dieu -Cit. J.C.
La persévérance, c'est ce qui rend l'impossible possible, le possible probable et le probable réalisé. -Cit. Robert Half.
Dans toutes les situations, le piège c'était avant, car tu ne voyais pas les murs -Cit. Crevette

Hors ligne

#5 23-01-2016 23:43:55

groovyjona
Membre
Lieu : 77
Distrib. : Antix-MX-15
Noyau : Linux 4.2.0-0.bpo.1-amd64
(G)UI : Xfce
Inscription : 18-04-2015
Site Web

Re : Préférences Alsamixer ne sont pas sauvegardées

kawer a écrit :

Il faut penser à restorer les réglages sauvegarder par alsactl store avec

alsactl restore


Par une commande lancée à chaque démarrage par exemple ?


Voyager X8 - MacBook 2.1 fin 2007
"Tôt ou tard, nous devrons répondre à cet appel des ténèbres, aller voir ce qu'il y a derrière cette impérieuse mélancolie qui sort des saxophones." P. Morand

Hors ligne

#6 24-01-2016 00:39:40

kawer
Adhérent(e)
Lieu : Académie de la Croix-Vraie
Distrib. : Debian stable / ArchLinux
Noyau : Current
(G)UI : xfwm4
Inscription : 08-10-2013
Site Web

Re : Préférences Alsamixer ne sont pas sauvegardées

oui exactement, smile

Rendez à César ce qui est à César et à Dieu ce qui est à Dieu -Cit. J.C.
La persévérance, c'est ce qui rend l'impossible possible, le possible probable et le probable réalisé. -Cit. Robert Half.
Dans toutes les situations, le piège c'était avant, car tu ne voyais pas les murs -Cit. Crevette

Hors ligne

#7 24-01-2016 07:38:56

groovyjona
Membre
Lieu : 77
Distrib. : Antix-MX-15
Noyau : Linux 4.2.0-0.bpo.1-amd64
(G)UI : Xfce
Inscription : 18-04-2015
Site Web

Re : Préférences Alsamixer ne sont pas sauvegardées

Bon, j'ai désinstallé... je garde cela sous le coude et j'essaye demain.

Voyager X8 - MacBook 2.1 fin 2007
"Tôt ou tard, nous devrons répondre à cet appel des ténèbres, aller voir ce qu'il y a derrière cette impérieuse mélancolie qui sort des saxophones." P. Morand

Hors ligne

#8 24-01-2016 18:47:44

groovyjona
Membre
Lieu : 77
Distrib. : Antix-MX-15
Noyau : Linux 4.2.0-0.bpo.1-amd64
(G)UI : Xfce
Inscription : 18-04-2015
Site Web

Re : Préférences Alsamixer ne sont pas sauvegardées

kawer a écrit :

oui exactement, smile


Je ne trouve pas comment je fais cela sous Debian Gnome 3 ?


Voyager X8 - MacBook 2.1 fin 2007
"Tôt ou tard, nous devrons répondre à cet appel des ténèbres, aller voir ce qu'il y a derrière cette impérieuse mélancolie qui sort des saxophones." P. Morand

Hors ligne

#9 25-01-2016 17:49:04

kawer
Adhérent(e)
Lieu : Académie de la Croix-Vraie
Distrib. : Debian stable / ArchLinux
Noyau : Current
(G)UI : xfwm4
Inscription : 08-10-2013
Site Web

Re : Préférences Alsamixer ne sont pas sauvegardées

Il te faut créer un script qui s'exécute au démarrage dans init.d par exemple roll

Rendez à César ce qui est à César et à Dieu ce qui est à Dieu -Cit. J.C.
La persévérance, c'est ce qui rend l'impossible possible, le possible probable et le probable réalisé. -Cit. Robert Half.
Dans toutes les situations, le piège c'était avant, car tu ne voyais pas les murs -Cit. Crevette

Hors ligne

#10 25-01-2016 18:11:59

groovyjona
Membre
Lieu : 77
Distrib. : Antix-MX-15
Noyau : Linux 4.2.0-0.bpo.1-amd64
(G)UI : Xfce
Inscription : 18-04-2015
Site Web

Re : Préférences Alsamixer ne sont pas sauvegardées

J'ai essayé sousdebian cinnamon et xfce d ajouter "alsa restore" au démarrage, mais le volume de la tranche "headphone" redevient muet à chaque démarrage. Il y a certainement une ligne dans le fichier de config de pulse audio qui commande cela, mais laquelle... ?

Dernière modification par groovyjona (25-01-2016 18:27:25)


Voyager X8 - MacBook 2.1 fin 2007
"Tôt ou tard, nous devrons répondre à cet appel des ténèbres, aller voir ce qu'il y a derrière cette impérieuse mélancolie qui sort des saxophones." P. Morand

Hors ligne

#11 26-01-2016 10:11:59

groovyjona
Membre
Lieu : 77
Distrib. : Antix-MX-15
Noyau : Linux 4.2.0-0.bpo.1-amd64
(G)UI : Xfce
Inscription : 18-04-2015
Site Web

Re : Préférences Alsamixer ne sont pas sauvegardées

Salut, j'avance dans ma galère !
J'ai trouvé http://superuser.com/questions/137805/s … l-accounts qui permet de définir les préférences de sorties audio utliisées, mais je n'arrive pas à l'adapter à ma configuration...
J'ai essayé d'éditer mon /etc/pulse/default.pa mais rien n'y fait...
Voici mon

pacmd list-cards



   

 1 card(s) available.
        index: 0
        name: <alsa_card.pci-0000_00_1b.0>
        driver: <module-alsa-card.c>
        owner module: 6
        properties:
            alsa.card = "0"
            alsa.card_name = "HDA Intel"
            alsa.long_card_name = "HDA Intel at 0xd0440000 irq 43"
            alsa.driver_name = "snd_hda_intel"
            device.bus_path = "pci-0000:00:1b.0"
            sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
            device.bus = "pci"
            device.vendor.id = "8086"
            device.vendor.name = "Intel Corporation"
            device.product.id = "27d8"
            device.product.name = "NM10/ICH7 Family High Definition Audio Controller (STAC9221 HD Audio Codec)"
            device.form_factor = "internal"
            device.string = "0"
            device.description = "Audio interne"
            module-udev-detect.discovered = "1"
            device.icon_name = "audio-card-pci"
        profiles:
            input:analog-stereo: Stéréo analogique Input (priority 60, available: unknown)
            input:iec958-stereo: Stéréo numérique (IEC958) Input (priority 55, available: unknown)
            output:analog-stereo: Stéréo analogique Output (priority 6000, available: unknown)
            output:analog-stereo+input:analog-stereo: Duplex stéréo analogique (priority 6060, available: unknown)
            output:analog-stereo+input:iec958-stereo: Stéréo analogique Output + Stéréo numérique (IEC958) Input (priority 6055, available: unknown)
            output:analog-surround-40: Surround analogique 4.0 Output (priority 700, available: unknown)
            output:analog-surround-40+input:analog-stereo: Surround analogique 4.0 Output + Stéréo analogique Input (priority 760, available: unknown)
            output:analog-surround-40+input:iec958-stereo: Surround analogique 4.0 Output + Stéréo numérique (IEC958) Input (priority 755, available: unknown)
            output:iec958-stereo: Stéréo numérique (IEC958) Output (priority 5500, available: unknown)
            output:iec958-stereo+input:analog-stereo: Stéréo numérique (IEC958) Output + Stéréo analogique Input (priority 5560, available: unknown)
            output:iec958-stereo+input:iec958-stereo: Duplex stéréo numérique (IEC958) (priority 5555, available: unknown)
            off: Éteint (priority 0, available: unknown)
        active profile: <output:analog-stereo+input:analog-stereo>
        sinks:
            alsa_output.pci-0000_00_1b.0.analog-stereo/#0: Audio interne Stéréo analogique
        sources:
            alsa_output.pci-0000_00_1b.0.analog-stereo.monitor/#0: Monitor of Audio interne Stéréo analogique
            alsa_input.pci-0000_00_1b.0.analog-stereo/#1: Audio interne Stéréo analogique
        ports:
            analog-input: Entrée analogique (priority 10000, latency offset 0 usec, available: unknown)
                properties:
                   
            analog-input-mic: Microphone (priority 8700, latency offset 0 usec, available: no)
                properties:
                    device.icon_name = "audio-input-microphone"
            analog-input-linein: Entrée-ligne (priority 8100, latency offset 0 usec, available: no)
                properties:
                   
            iec958-stereo-input: Digital Input (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
                properties:
                   
            analog-output: Sortie analogique (priority 9900, latency offset 0 usec, available: unknown)
                properties:
                   
            analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
                properties:
                    device.icon_name = "audio-speakers"
            analog-output-headphones: Casques analogiques (priority 9000, latency offset 0 usec, available: no)
                properties:
                    device.icon_name = "audio-headphones"
            iec958-stereo-output: Digital Output (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
                properties:



J'aimerais que la sortie analogique soit par défaut et que le volume des écouteurs ne soit pas muté (c'est bizarre mais c'est la seule solution pour que le son soit potable sans aucun casque ou enceinte branchés dessus).

Edit à toto :
Mise le retour de la commande user sous balise Autre code et non quote (citation).


Voyager X8 - MacBook 2.1 fin 2007
"Tôt ou tard, nous devrons répondre à cet appel des ténèbres, aller voir ce qu'il y a derrière cette impérieuse mélancolie qui sort des saxophones." P. Morand

Hors ligne

#12 02-02-2016 16:01:13

groovyjona
Membre
Lieu : 77
Distrib. : Antix-MX-15
Noyau : Linux 4.2.0-0.bpo.1-amd64
(G)UI : Xfce
Inscription : 18-04-2015
Site Web

Re : Préférences Alsamixer ne sont pas sauvegardées

Un petit message pour agiter un peu les bras pour vous dire que ce n'est toujours pas réglé... Je dois toujours faire un

sudo alsactl restore

dans un terminal à chaque fois que je redémarre l'ordinateur. C'est un peu fatigant...


Voyager X8 - MacBook 2.1 fin 2007
"Tôt ou tard, nous devrons répondre à cet appel des ténèbres, aller voir ce qu'il y a derrière cette impérieuse mélancolie qui sort des saxophones." P. Morand

Hors ligne

#13 02-02-2016 16:48:05

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Préférences Alsamixer ne sont pas sauvegardées

tu a bien les paquets audio de xfce installées comme xfce-pulseaudio-pluging , je suis sous mate , j'ai un mix d alasa et de pulseaudio dans les paquets installées.
de mémoire c est xfce qui a l option enregistrer la session en cour pour le prochain démarrage. (a tester)
c'est des idées en vrac , j'ai pas trop d idées sur le probleme  hmm
mais peut etre vérifier que les paquets nécessaires sont présent , avec mate pulseaudio fonctionne bien .

Hors ligne

#14 02-02-2016 20:06:10

avram
Membre
Distrib. : dual boot jessie/testing en 64 bits+xp virtualbox
Noyau : 3.16 et 4.3
(G)UI : xfce
Inscription : 28-01-2016

Re : Préférences Alsamixer ne sont pas sauvegardées

bonsoir à vous tous  big_smile

jessie s'installe avec pulseaudio par défaut; avez vous installé le paquet pavucontrol pour gérer vos entrées/sortie  audio?

Hors ligne

#15 02-02-2016 21:20:35

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Préférences Alsamixer ne sont pas sauvegardées

sur ma stretch ou je poste actuellement j'ai la totale , pavucontrol , pulseaudio et meme alsa et gstreamer.xxx-alsa etc ...
oui j'utilise pavucontrol sur mon bureau mate
@++

Hors ligne

#16 03-02-2016 10:38:22

groovyjona
Membre
Lieu : 77
Distrib. : Antix-MX-15
Noyau : Linux 4.2.0-0.bpo.1-amd64
(G)UI : Xfce
Inscription : 18-04-2015
Site Web

Re : Préférences Alsamixer ne sont pas sauvegardées

En fait oui, j'ai bien pavucontrol qui me permet de choisir les sorties mais à chaque redémarrage c'est le même cinéma.

J'ai installe hier une debian mate et effectivement le son est reconnu correctement sans aucun problème. Je pense switcher définitivement vers cette distribution car le problème reste irrésolu depuis plusieurs semaines.

Voyager X8 - MacBook 2.1 fin 2007
"Tôt ou tard, nous devrons répondre à cet appel des ténèbres, aller voir ce qu'il y a derrière cette impérieuse mélancolie qui sort des saxophones." P. Morand

Hors ligne

Pied de page des forums