Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-05-2009 11:22:39

Cody082
Membre
Distrib. : Wheezy
Noyau : 3.2.0-4-amd64
Inscription : 24-04-2009

[Résolu] Pb serveur graphique --> Second PC

Bonjour à tous,

J'ai passé un 2ème pc sur debian Lenny, et malheureusement, j'ai de nouveau un problème d'interface graphique... Je ne sais pas si c'est moi qui m'y prend mal, mais ça va faire 2 fois de suite ! :( (http://debian-facile.org/forum/viewtopic.php?id=1293)

J'ai réinstaller gnome comme me l'avait suggérer smolski dans un autre post, mais ça n'a rien changé... A noter également que la commande "dpkg-reconfigure xserver-xorg" n'a pas fonctionné non plus...

Je vous adresse quelques informations complémentaires qu'il m'avait été demandé par d'autres acteurs de la conversation :

* En faisant un "startx" :

[c]X.Org X Server 1.4.2
Release Date: 11 June 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux Debian (xorg-server 2:1.4.2-10.lenny1)
Current Operating System: Linux Poste4 2.6.26-2-686 #1 SMP Thu Mar 26 01:08:11 UTC 2009 i686
Build Date: 15 March 2009  03:18:10PM

    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun May  3 10:55:44 2009
(==) Using config file: "/etc/X11/xorg.conf"

(EE) Failed to load module "vesa" (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found


waiting for X server to begin accepting connections
giving up.

xinit:  Connection reset by peer (errno 104):  unable to connect to X server

xinit:  No such process (errno 3):  Server error.[/c]


* Un "lspci" :

[c]...
01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev b2)
...
[/c]

* Et voici le fichier "/etc/X11/xorg.conf" :

[c]# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "fr"
    Option        "XkbVariant"    "latin9"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
EndSection

Section "Device"
    Identifier    "Configured Video Device"
EndSection

Section "Monitor"
    Identifier    "Configured Monitor"
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Monitor        "Configured Monitor"
EndSection
[/c]

En analysant le fichier xorg, j'ai l'impression qu'il manque la ligne "driver" dans la section "Device" (vesa ou nv) ?

En vous remerciant pas avance

Cody082

Dernière modification par Cody082 (03-05-2009 12:32:11)

Hors ligne

#2 03-05-2009 12:07:16

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : [Résolu] Pb serveur graphique --> Second PC

Salut,

tu peux tester en rajoutant
Driver  "vesa" dans la section Device

xserver-xorg-video-vesa est bien installé ?

Hors ligne

#3 03-05-2009 12:42:29

Cody082
Membre
Distrib. : Wheezy
Noyau : 3.2.0-4-amd64
Inscription : 24-04-2009

Re : [Résolu] Pb serveur graphique --> Second PC

Salut neos,

Et bien un grand merci, c'était bien ça... J'ai du remettre 'Driver "vesa"' dans la section Device, puis j'ai réinstallé xerser-xorg-video-vesa.

En revanche, ce petit problème me force à me poser 2 questions, la 1ère pourquoi lors de la MAJ de Etch vers Lenny le driver précédement installé n'est upgradé de la même façon que les autres paquets ? Et la 2ème, lors de la réinstallation de gnome, pourquoi de driver n'est pas réinstallé en automatique ?

En tout les cas, merci beaucoup wink

PS : dernière question, lorsque j'ai installé xerser-xorg-video-vesa avec aptitude, le gestionnaire des paquets m'a marqué une phrase comme celle-ci : Des paquets non certifiées peuvent compromettre la sécurité du système, voulez-vous continuez ? J'ai dû taper en toute lettre : oui ! Y a-t-il un réel danger avec le driver libre ?

Cody082

Hors ligne

#4 03-05-2009 18:07:24

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : [Résolu] Pb serveur graphique --> Second PC

re,
non pas de souci à avoir

Hors ligne

#5 03-05-2009 19:34:24

Cody082
Membre
Distrib. : Wheezy
Noyau : 3.2.0-4-amd64
Inscription : 24-04-2009

Re : [Résolu] Pb serveur graphique --> Second PC

ok neos, merci de ton aide...

Hors ligne

#6 05-05-2009 00:21:49

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : [Résolu] Pb serveur graphique --> Second PC

Cody082 a écrit :

dernière question, lorsque j'ai installé xerser-xorg-video-vesa avec aptitude, le gestionnaire des paquets m'a marqué une phrase comme celle-ci : Des paquets non certifiées peuvent compromettre la sécurité du système, voulez-vous continuez ? J'ai dû taper en toute lettre : oui ! Y a-t-il un réel danger avec le driver libre ?


On dirait que tu as un problème de clé d'authentification : le paquet debian-archive-keyring est-il bien installé ou mis à jour ?


« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

Pied de page des forums