Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 27-01-2016 20:56:52

Maurice
Membre
Distrib. : jessie--Debian 8.2.0
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome
Inscription : 25-11-2015

[Résolu]Clavier numérique qui ne répond pas

Bonjour,
Je suis un débutant complet en Linux. J'ai installé sans problème Ubuntu seul sur un "vieux" Toshiba, c'est formidable! Je suis passé à l'étape suivante: je suis maintenant sur mon Dell Inspiron 15R 5537 avec en dualboot win 8.1 et Debian (Jessie) 8.2.0  UEFI  amd 64.

LE PROBLÈME: Lorsque je suis en Gnome, Gnome classique ou Gnome flashback mon clavier numérique ne répond rien; il semble ne pas être reconnu . J'ai essayé différentes manœuvres pour le réveiller sans succès ( ver num a été évidemment actionné). J'ai fini par essayer KDE (sous l’environnement Plasma ) et là... le clavier numérique est présent et répond normalement.
Y- aurait -il un logiciel  qui manquerait dans Gnome? J'ai pris l'image ISO par Torrent sur le site officiel.
Si vous trouvez une solution vous voudrez bien en donner,au débitant que je suis, le mode d'emploi en détail surtout s'il faut trouver , télécharger, et installer ce qui manque. A moins qu'il y ait une autre solution?KDE semble bien mais faut se faire à Konqueror, Kmail etc.

HS: Étant très ancien utilisateur de Windows, je suis surpris que nulle part dans la doc. que j'ai lu sur Linux , on ne parle ni de défragmentation, ni de nettoyage du navigateur (avec ccleaner par ex.). Pas besoin de ce genre d'accessoires avec Linux? A moins que je sois passer à coté lors de mes lectures!

Grand merci d'avance.
Maurice.

Dernière modification par Maurice (06-03-2016 19:01:01)

Hors ligne

#2 27-01-2016 21:00:13

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu]Clavier numérique qui ne répond pas

Bonsoir et bienvenue  smile

Pour ta dernière question, tu peux consulter https://debian-facile.org/doc:systeme:fragmentation  smile

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#3 27-01-2016 21:17:11

Maurice
Membre
Distrib. : jessie--Debian 8.2.0
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome
Inscription : 25-11-2015

Re : [Résolu]Clavier numérique qui ne répond pas

Merci paskal?
Vive Linux!
Et je vais me plonger dans toute la doc. de ce site!
Maurice

Hors ligne

#4 27-01-2016 21:43:28

milou
Modo ... e
Lieu : Sur une autre planète....
Distrib. : Jessie - Stretch/Sid
Noyau : 3.16.0-4-amd64
(G)UI : Lxde
Inscription : 12-02-2015
Site Web

Re : [Résolu]Clavier numérique qui ne répond pas

Bonjour Maurice, bienvenue sur DF smile

Tu peux consulter ça aussi https://debian-facile.org/doc:systeme:s … sous-linux?

ça va te changer de windows .... big_smile  wink

J’adorerais changer le monde, mais ils ne veulent pas me fournir le code source
Un vrai geek, c'est un mec qui croit que dans 1km, il y a 1024 mètres
Dans le doute, rebootes. Si tu te tâtes, formates.
1453651422.jpg

Hors ligne

#5 27-01-2016 23:58:24

Frosch
Adhérent(e)
Lieu : Sion (CH)
Distrib. : Chakra
Noyau : Linux 4.5.7
(G)UI : Plasma 5.8
Inscription : 09-12-2015
Site Web

Re : [Résolu]Clavier numérique qui ne répond pas

Maurice a écrit :

KDE semble bien mais faut se faire à Konqueror, Kmail etc.


Non non, tu peux très bien utiliser Firefox, Thunderbird, et tous les programmes que tu veux avec un bureau KDE wink


Schokolade ist keine Lüge.

Hors ligne

#6 28-01-2016 00:15:16

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [Résolu]Clavier numérique qui ne répond pas

Bonsoir,
Si Gnome, dans ses différentes versions, ne semble pas gérer ton clavier numérique, tu peux essayer d'installer et d'activer numlockx, un utilitaire (en ligne de commande) destiné à activer ou désactiver un pavé numérique.

Pour l'installer :
Sous GNU/Linux en général et Debian en particulier, on ne va pas chercher et télécharger ses logiciels sur le web, genre sur Télécharger01 ou autre Clubic. Les logiciels sont centralisés dans des dépôts officiels Debian et gérer de façon sécurisée par un logiciel spécifique (le gestionnaire de paquet) dont le rôle est d'assurer installation, suppression, coordination des logiciels.
Il existe un utilitaire graphique pour selon nommé synaptic ou tu peux, et ça peut être l'occasion de te familiariser avec ton système, utiliser la ligne de commande.
Tu ouvres un terminal, tu te connectes en utilisateur root comme suit :

su -


tu saisis le mot de passe de l'administrateur (par sécurité, tu vas devoir taper à l'aveugle, rien ne va s'afficher mais c'est normal) et tu procèdes à l'installation proprement dite :

apt-get install numlockx


Tu te déconnectes de l'utilisateur root avec Ctrl + d et te retrouves à nouveau en tant qu'utilisateur pour activer le logiciel installé:

numlockx


Si cela fonctionne et que ton pavé numérique devient alors opérationnel sous Gnome, nous verrons ensuite comment faire en sorte qu'il s'active automatiquement.


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#7 28-01-2016 14:42:05

Maurice
Membre
Distrib. : jessie--Debian 8.2.0
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome
Inscription : 25-11-2015

Re : [Résolu]Clavier numérique qui ne répond pas

Bonjour,
Merci pour ta réponse , hélas cela n'a pas marché.:

apt-get install numlockx


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
numlockx est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 62 non mis à jour.
root@dell:/home/m2588# exit
 


numlockx



Aurais tu une autre idée?
Maurice

Hors ligne

#8 28-01-2016 15:22:37

Maurice
Membre
Distrib. : jessie--Debian 8.2.0
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome
Inscription : 25-11-2015

Re : [Résolu]Clavier numérique qui ne répond pas

Frosch a écrit :

Maurice a écrit :

KDE semble bien mais faut se faire à Konqueror, Kmail etc.


Non non, tu peux très bien utiliser Firefox, Thunderbird, et tous les programmes que tu veux avec un bureau KDE wink



Merci Frosch,
Mais je crois que j'ai fait une c....rie! j'ai été chercher Thunderbird sur le web c'est tout un processus que je dois faire pour aller le lancer dans son répertoire décompressé il ne marche pas si je le retire de son répertoire pour le glisser-déplacer sur le bureau. Puis-je supprimer le répertoire et aller le chercher sur le dépôt Debian? Il porte quel nom sous Debian? Et Firefox porte quel nom? Iceweasel comme sur Gnome?
encore merci
Maurice.

Hors ligne

#9 28-01-2016 15:30:47

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : [Résolu]Clavier numérique qui ne répond pas

thunderbird -> icedove
firefox -> iceweasel

"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#10 28-01-2016 15:32:17

milou
Modo ... e
Lieu : Sur une autre planète....
Distrib. : Jessie - Stretch/Sid
Noyau : 3.16.0-4-amd64
(G)UI : Lxde
Inscription : 12-02-2015
Site Web

Re : [Résolu]Clavier numérique qui ne répond pas

Pour Firefox (Iceweasel sous Debian) tu peux regarder ici https://debian-facile.org/doc:reseau:iceweasel

Tu peux regarder ici aussi pour Icedove https://debian-facile.org/doc:reseau:icedove

J’adorerais changer le monde, mais ils ne veulent pas me fournir le code source
Un vrai geek, c'est un mec qui croit que dans 1km, il y a 1024 mètres
Dans le doute, rebootes. Si tu te tâtes, formates.
1453651422.jpg

Hors ligne

#11 28-01-2016 15:32:53

milou
Modo ... e
Lieu : Sur une autre planète....
Distrib. : Jessie - Stretch/Sid
Noyau : 3.16.0-4-amd64
(G)UI : Lxde
Inscription : 12-02-2015
Site Web

Re : [Résolu]Clavier numérique qui ne répond pas

lol Grillée par Severian, mais j'ai rajouté les liens .... tongue   lol

J’adorerais changer le monde, mais ils ne veulent pas me fournir le code source
Un vrai geek, c'est un mec qui croit que dans 1km, il y a 1024 mètres
Dans le doute, rebootes. Si tu te tâtes, formates.
1453651422.jpg

Hors ligne

#12 28-01-2016 15:33:59

Frosch
Adhérent(e)
Lieu : Sion (CH)
Distrib. : Chakra
Noyau : Linux 4.5.7
(G)UI : Plasma 5.8
Inscription : 09-12-2015
Site Web

Re : [Résolu]Clavier numérique qui ne répond pas

Oh, je suis bête, j'ai parlé de Firefox et Thunderbird, en oubliant que sur Debian ils sont nommés différemment (j'utilise plusieurs distributions).
Indépendemment du bureau que tu utilises, Firefox=Iceweasel et Thunderbird=Icedove wink
Et aussi, avec KDE, pour que les applications avec une interface GTK+ comme Firefox, Thunderbird, LibreOffice, etc. aient une apparence correcte, il faut installer les paquets gtk2-engines-oxygen et gtk3-engines-oxygen.

edit : doublement grillé lol

Dernière modification par Frosch (28-01-2016 15:34:32)


Schokolade ist keine Lüge.

Hors ligne

#13 28-01-2016 15:37:04

milou
Modo ... e
Lieu : Sur une autre planète....
Distrib. : Jessie - Stretch/Sid
Noyau : 3.16.0-4-amd64
(G)UI : Lxde
Inscription : 12-02-2015
Site Web

Re : [Résolu]Clavier numérique qui ne répond pas

lol lol lol

J’adorerais changer le monde, mais ils ne veulent pas me fournir le code source
Un vrai geek, c'est un mec qui croit que dans 1km, il y a 1024 mètres
Dans le doute, rebootes. Si tu te tâtes, formates.
1453651422.jpg

Hors ligne

#14 28-01-2016 15:37:30

Maurice
Membre
Distrib. : jessie--Debian 8.2.0
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome
Inscription : 25-11-2015

Re : [Résolu]Clavier numérique qui ne répond pas

milou a écrit :

Bonjour Maurice, bienvenue sur DF smile

Tu peux consulter ça aussi https://debian-facile.org/doc:systeme:s … sous-linux?

ça va te changer de windows .... big_smile  wink



Merci pour ton accueil Milou,
Je vais me plonger dans toute cette doc. Je crois aussi que Debian va me changer la vie une fois que je m'y serai fait.
Bien qu'ayant connu Windows 1, 3.3, XP, et bien d'autres je veux changer d'OS je trouve que Windows devient trop intrusif et ne m'amuse plus!
Revenir aux commandes sur un éditeur me rappelle mon jeune temps ou je programmais avec mes enfants en Basic!!
Merci encore.
Maurice

Hors ligne

#15 28-01-2016 15:38:40

milou
Modo ... e
Lieu : Sur une autre planète....
Distrib. : Jessie - Stretch/Sid
Noyau : 3.16.0-4-amd64
(G)UI : Lxde
Inscription : 12-02-2015
Site Web

Re : [Résolu]Clavier numérique qui ne répond pas

C'est avec plaisir smile

Et oui, Debian va te changer la vie .... wink

J’adorerais changer le monde, mais ils ne veulent pas me fournir le code source
Un vrai geek, c'est un mec qui croit que dans 1km, il y a 1024 mètres
Dans le doute, rebootes. Si tu te tâtes, formates.
1453651422.jpg

Hors ligne

#16 28-01-2016 15:42:17

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : [Résolu]Clavier numérique qui ne répond pas

Pour le clavier, la première chose est de vérifier qu'il soit bien configuré pour avoir un pavé numérique, quelque chose du genre "générique international 101, 102 ou 105 touches"... ou 106, 109... ah non ça c'est que pour les Japonais tongue

« Un optimiste, explique Raymond Aubrac, n’est pas un être satisfait, content de la situation actuelle. C’est quelqu’un qui pense qu’il peut faire quelque chose qui servira. »

Hors ligne

#17 28-01-2016 15:48:10

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : [Résolu]Clavier numérique qui ne répond pas

Haricophile a écrit :

Pour le clavier, la première chose est de vérifier qu'il soit bien configuré pour avoir un pavé numérique, quelque chose du genre "générique international 101, 102 ou 105 touches"... ou 106, 109... ah non ça c'est que pour les Japonais tongue



hummm la configuration du clavier ("générique international 101, 102 ou 105 touches") changerait entre gnome et kde ?

Maurice a écrit :

LE PROBLÈME: Lorsque je suis en Gnome, Gnome classique ou Gnome flashback mon clavier numérique ne répond rien; il semble ne pas être reconnu . J'ai essayé différentes manœuvres pour le réveiller sans succès ( ver num a été évidemment actionné). J'ai fini par essayer KDE (sous l’environnement Plasma ) et là... le clavier numérique est présent et répond normalement.



pas dans les préférences / configurations de clavier de gnome que ce situerait le soucis ? (je demande, je n'y connais rien à gnome)


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#18 28-01-2016 15:53:06

Maurice
Membre
Distrib. : jessie--Debian 8.2.0
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome
Inscription : 25-11-2015

Re : [Résolu]Clavier numérique qui ne répond pas

Bonjour,
comment fais tu pour connaître la config. du clavier? j'en ai essayé tellement que je ne sais plus ou j'en suis!Et je ne connais pas la commande pour y aller.

Merci

Hors ligne

#19 28-01-2016 15:55:37

Frosch
Adhérent(e)
Lieu : Sion (CH)
Distrib. : Chakra
Noyau : Linux 4.5.7
(G)UI : Plasma 5.8
Inscription : 09-12-2015
Site Web

Re : [Résolu]Clavier numérique qui ne répond pas

dpkg-reconfigure keyboard-configuration


Schokolade ist keine Lüge.

Hors ligne

#20 28-01-2016 15:56:48

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : [Résolu]Clavier numérique qui ne répond pas

 cat /var/log/Xorg.0.log | grep -i xkb


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#21 28-01-2016 16:21:36

Maurice
Membre
Distrib. : jessie--Debian 8.2.0
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome
Inscription : 25-11-2015

Re : [Résolu]Clavier numérique qui ne répond pas

Haricophile a écrit :

Pour le clavier, la première chose est de vérifier qu'il soit bien configuré pour avoir un pavé numérique, quelque chose du genre "générique international 101, 102 ou 105 touches"... ou 106, 109... ah non ça c'est que pour les Japonais tongue



il est en 104 touches ,j'ai essayé105,et 102 sans succès 101 n'est pas répertorié dans l'encart.

Hors ligne

#22 28-01-2016 16:28:30

Maurice
Membre
Distrib. : jessie--Debian 8.2.0
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome
Inscription : 25-11-2015

Re : [Résolu]Clavier numérique qui ne répond pas

Severian a écrit :

 cat /var/log/Xorg.0.log | grep -i xkb



m2588@dell:~$ 

cat /var/log/Xorg.0.log | grep -i xk



[    23.107] (**) Option "xkb_rules" "evdev"
[    23.107] (**) Option "xkb_model" "pc104"
[    23.107] (**) Option "xkb_layout" "fr"
[    23.107] (**) Option "xkb_variant" "oss_latin9"
[    23.208] (**) Option "xkb_rules" "evdev"
[    23.208] (**) Option "xkb_model" "pc104"
[    23.208] (**) Option "xkb_layout" "fr"
[    23.208] (**) Option "xkb_variant" "oss_latin9"
[    23.208] (**) Option "xkb_rules" "evdev"
[    23.208] (**) Option "xkb_model" "pc104"
[    23.208] (**) Option "xkb_layout" "fr"
[    23.208] (**) Option "xkb_variant" "oss_latin9"
[    23.211] (**) Option "xkb_rules" "evdev"
[    23.211] (**) Option "xkb_model" "pc104"
[    23.211] (**) Option "xkb_layout" "fr"
[    23.211] (**) Option "xkb_variant" "oss_latin9"
[    23.212] (**) Option "xkb_rules" "evdev"
[    23.212] (**) Option "xkb_model" "pc104"
[    23.212] (**) Option "xkb_layout" "fr"
[    23.212] (**) Option "xkb_variant" "oss_latin9"
[    23.313] (**) Option "xkb_rules" "evdev"
[    23.313] (**) Option "xkb_model" "pc104"
[    23.313] (**) Option "xkb_layout" "fr"
[    23.313] (**) Option "xkb_variant" "oss_latin9"
m2588@dell:~$
 



Edit à toto :
Séparation de la commande user de son retour

Hors ligne

#23 28-01-2016 17:51:03

greenmerlin
Membre
Lieu : 127.0.0.1
Distrib. : Archlinux/TinycoreLinux(CorePure 64-6.4.1)/Jessie
Noyau : 4.2.2-1 / 4.4
(G)UI : wmaker
Inscription : 23-01-2016

Re : [Résolu]Clavier numérique qui ne répond pas

Bonsoir,

Si ton clavier fonctionne avec Kde et pas avec gnome le problème ne vient pas de Xorg.
Lance

gnome-control-center region


et modifie ta sources d'entrée

@+


" La plus importante et la plus négligée de toutes les conversations, c'est l'entretien avec soi-même. "
Chancelier Oxenstiern.

536920766f7573206172726976657220c3a0206c69726520c3a7612c20632765737420717565206e6f757320706172746167656f6e73206c6573206dc3aa6d65732063656e747265732064e28099696e74c3a972c3aa74732e

Hors ligne

#24 28-01-2016 18:05:38

Maurice
Membre
Distrib. : jessie--Debian 8.2.0
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome
Inscription : 25-11-2015

Re : [Résolu]Clavier numérique qui ne répond pas

merci de ta réponse ,
mais je suis un ignare, que veut dire "modifie ta source d'entrée ?
Maurice

Hors ligne

#25 28-01-2016 18:07:54

greenmerlin
Membre
Lieu : 127.0.0.1
Distrib. : Archlinux/TinycoreLinux(CorePure 64-6.4.1)/Jessie
Noyau : 4.2.2-1 / 4.4
(G)UI : wmaker
Inscription : 23-01-2016

Re : [Résolu]Clavier numérique qui ne répond pas

Après avoir taper la commande tu verra un gros bouton "source d'entrée"...
en gros c'est l'agencement de ton clavier sous gnome

@+

" La plus importante et la plus négligée de toutes les conversations, c'est l'entretien avec soi-même. "
Chancelier Oxenstiern.

536920766f7573206172726976657220c3a0206c69726520c3a7612c20632765737420717565206e6f757320706172746167656f6e73206c6573206dc3aa6d65732063656e747265732064e28099696e74c3a972c3aa74732e

Hors ligne

Pied de page des forums