Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-02-2016 14:49:27

Tinley
Membre
Distrib. : Jessie 8.2
Noyau : Linux 3.16.0-4-686-pae
(G)UI : xfce4 + lightdm
Inscription : 02-02-2016

Problème Gstreamer

[Edit : discussion déplacée depuis la section Multimédia]

Bonjour à tous,

je suis un petit nouveau sur Debian, et en général Google est mon ami pour résoudre mes problèmes, mais là il vaut pas faire copain copain avec moi...

Je travaille dans un collège et j'ai installé Debian Jessie que j'ai intégré à un domaine Windows en réseau. Tout va bien, mes utilisateurs peuvent se connecter avec leur identifiant et mot de passe de l'AD Windows et j'ai limité les droits sur la machine. Le profil identique pour tout le monde est stocké dans /etc/skel. Il me reste cependant un souci de son.

Le son est désactivé de base et impossible de l'activer, j'ai ce message d'erreur : "Gstreamer n'a pas détecté de carte son. Certains paquets de Gstreamer peuvent être manquants. Il peut aussi s'agir d'un problème de permissions."

La commande "aslamixer" ne me propose en effet aucune carte son...

Si je me connecte en administrateur, je n'ai aucun problème : le son fonctionne bien et la commande "alsamixer" me propose de choisir ma carte son.

Bref, je sèche complètement, je suppose qu'il s'agit d'un problème de permissions, mais je n'arrive pas à trouver le fichier qui bloque.

Merci d'avance pour votre aide.
Tinley

Hors ligne

#2 02-02-2016 15:27:23

pili36
Membre
Lieu : Lille
Distrib. : Debian Jessie / Raspbian Jessie
Noyau : 3.16_amd64 / 3.16_armhf
(G)UI : Mate / Lxde
Inscription : 03-11-2009

Re : Problème Gstreamer

Bonjour,

Je pense que la première chose à faire est de vérifier que les utilisateurs ont bien été ajouté au groupe audio. Il ne semble pas que ce soit un problème matériel ou d'incompatibilité avec Linux puisque le son fonctionne sur le compte admin.

Pour ajouter un utilisateur à un groupe :

adduser nom_utilisateur audio

Dernière modification par pili36 (02-02-2016 15:31:43)


Debian Jessie Amd64, Mate, Lenovo G50, Amd Q4000 4*1,3Ghz, 4Go RAM, Amd Radeon R3
Debian Jessie Amd64, (pour Steam), Mate, Amd Athlon 860K 4*3.7Ghz, 8Go RAM, AMD Radeon R7 250 2Go
Raspbian Jessie Armhf, Lxde, Raspberry Pi model B

Hors ligne

#3 02-02-2016 17:19:56

Tinley
Membre
Distrib. : Jessie 8.2
Noyau : Linux 3.16.0-4-686-pae
(G)UI : xfce4 + lightdm
Inscription : 02-02-2016

Re : Problème Gstreamer

Bonjour pili36 et merci de ta réponse,

si j'ajoute un utilisateur à la main, effectivement ça marche... sauf que j'ai 1200 utilisateurs smile

Du coup je veux plutôt ajouter le groupe complet "utilisateurs du domaine", mais en éditant /etc/group à la main, j'ai essayé le gid du groupe (gid=10001) sans résultat. J'ai aussi tenté groupes / groups / users....

En tout cas ta réponse prouve bien que le problème vient de là, mais il me manque un élément.

Merci de votre aide.
Tinley

Hors ligne

Pied de page des forums