Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-02-2016 19:26:20

LauwCost
Membre
Distrib. : Debian 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome
Inscription : 02-02-2016

[Résolu] Comportement étrange connexion dd externe

Bonjour,

je suis sous dernière version de Debian sur un laptop ayant trois port USB dont 1 en 3.0.

Lorsque je branche le disque dur externe sur le port 3.0, le disque dur n'est pas reconnue automatiquement.
Lorsque je le branche en 2.0, il est reconnu mais le clavier sans fil s'arrête de fonctionner !!!

Je suis plutôt noob et reste très dubitatif devant un tel comportement.

Quelqu'un a une explication (et éventuellement une technique pour résoudre cela)  ?
Merci d'avance pour vos réponses.

LauwCost.

Dernière modification par LauwCost (30-04-2016 12:03:27)

Hors ligne

#2 02-02-2016 19:56:38

avram
Membre
Distrib. : dual boot jessie/testing en 64 bits+xp virtualbox
Noyau : 3.16 et 4.3
(G)UI : xfce
Inscription : 28-01-2016

Re : [Résolu] Comportement étrange connexion dd externe

en effet c'est curieux; je vais suivre ce post.
Dans votre fstab avez vous une entrée particulière pour les usb?

Dernière modification par avram (02-02-2016 19:57:20)

Hors ligne

#3 02-02-2016 19:57:09

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Comportement étrange connexion dd externe

LauwCost a écrit :

je suis sous dernière version de Debian


Alors là, debian a plusieurs branches avec plusieurs actualisation.
Lance cette commande dans un terminal user :

uname -a


et indique-nous le retour que tu en as.

À ce propos, tu peux remplir ton iinfodistri sur le forum dans ton Profil, ainsi nous pourrons te suivre tout au long sans te demander à chaque fois ouss' que t'es dans les branches debian.
Voir le tuto : Trop cool d'indiquer son installation dans son profil ! smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#4 02-02-2016 23:21:52

LauwCost
Membre
Distrib. : Debian 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome
Inscription : 02-02-2016

Re : [Résolu] Comportement étrange connexion dd externe

Bonsoir,

merci d'abord pour la considération de ma question.

Le résultat de la commande uname -a donne : 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt20-1+deb8u1 (2015-12-14) x86_64 GNU/Linux

En ce qui concerne fstab, l'installation étant très récente et n'ayant pas modifié le fichier, je présume que c'est le contenu par défaut.
Je peux copier-coller si besoin (voir en pied de message en fait).

Je pense qu'il ne faut pas écarter une config matérielle particulière non plus (je n'étais pas parvenu à l'époque à installer une Ubuntu via usb sur le port 3.0 / Toshiba portégé Z830 10F) mais bon, mon niveau technique ne me permet pas d'avancer sur des hypothèses concrètes.

Merci pour vos éclairages.

Cordialement,


# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/chenille--vg-root /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda1 during installation
UUID=de966acf-c067-490a-9f89-953de018f7d8 /boot           ext2    defaults        0       2
/dev/mapper/chenille--vg-home /home           ext4    defaults        0       2
/dev/mapper/chenille--vg-swap_1 none            swap    sw              0       0

Dernière modification par LauwCost (02-02-2016 23:23:04)

Hors ligne

#5 03-02-2016 00:14:52

avram
Membre
Distrib. : dual boot jessie/testing en 64 bits+xp virtualbox
Noyau : 3.16 et 4.3
(G)UI : xfce
Inscription : 28-01-2016

Re : [Résolu] Comportement étrange connexion dd externe

je ne comprends pas bien votre fstab, comment avez vous installé votre debian, en utilisant un cd, dvd ou clé usb?
Je ne comprends pas /dev/mapper ou alors je manque de connaissances plus approfondies.
Pourquoi /dev/sda1 est formaté en ext2 et pas en ext4?

Dernière modification par avram (03-02-2016 00:17:29)

Hors ligne

#6 03-02-2016 10:06:35

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Comportement étrange connexion dd externe

LauwCost a écrit :

Lorsque je branche le disque dur externe sur le port 3.0, le disque dur n'est pas reconnue automatiquement.


Faut-il comprendre qu'il est reconnu manuellement ? En faisant quoi ? Qu'entends-tu exactement par "reconnu" ?

LauwCost a écrit :

Lorsque je le branche en 2.0, il est reconnu mais le clavier sans fil s'arrête de fonctionner


La différence de la sortie de la commande dmesg avant et après le branchement pourrait contenir des informations intéressantes.

Cela se produit-il seulement avec ce disque USB ou avec tous ? Est-ce un disque USB 2 ou 3 ?

avram a écrit :

Je ne comprends pas /dev/mapper


/dev/mapper contient les volumes logiques gérés par le "device mapper". Cela inclut notamment les volumes logiques LVM et les volumes chiffrés LUKS/dm-crypt. Ici on voit trois volumes logiques LVM : root, home et swap_1.

avram a écrit :

Pourquoi /dev/sda1 est formaté en ext2 et pas en ext4?


C'est la configuration standard du partitionnement en mode assisté de l'installateur pour /boot lorsque la racine est un volume LVM ou chiffré. On n'a pas besoin d'un système de fichiers sophistiqué comme ext4 pour /boot qui ne contient pas grand-chose et est rarement écrit.

Rien que de très classique et aucun lien avec l'USB.

Dernière modification par raleur (03-02-2016 10:07:44)

Hors ligne

#7 03-02-2016 10:17:24

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Comportement étrange connexion dd externe


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#8 03-02-2016 11:16:05

LauwCost
Membre
Distrib. : Debian 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome
Inscription : 02-02-2016

Re : [Résolu] Comportement étrange connexion dd externe

Bonjour à tous,

merci pour vos retours.

Bisque, en essayant de répondre à vos questions et en testant à nouveau, je m'aperçois que ce n'est pas reproductible :
- ce matin, je branche le DD sur USB 3...et il est reconnu selon ma propre définition, c'est à dire qu'il se monte tout seul (il me propose d'ouvrir le répertoire)
- par contre, ça a encore bloqué le clavier.

Donc, après avoir éjecté le DD et enlevé le câble, j'ai été contraint de débranché l'émetteur pour le clavier. Un 1er rebranchement sur le même USB 2.0 n'a rien donné (toujours pas de clavier actif). Le débranchement et rebranchement sur le second USB 2 (interversion avec émetteur de la souris) a rendu à nouveau le clavier actif. 

La différence de la sortie de la commande dmesg avant et après le branchement pourrait contenir des informations intéressantes.


En branchant sur USB 3.0 pour pouvoir sortir le dmesg après, tout marche bien (accès direct au répertoire et clavier actif) !!!

Euh, les deux fichiers sont très longs, je rechigne à les copier ici dans leur intégralité.
Est-ce que le "diff" entre les deux fichiers peut suffire ?

1000,1017d999
< [ 4561.927144] usb 2-1: new SuperSpeed USB device number 3 using xhci_hcd
< [ 4561.949320] usb 2-1: New USB device found, idVendor=174c, idProduct=1153
< [ 4561.949329] usb 2-1: New USB device strings: Mfr=2, Product=3, SerialNumber=1
< [ 4561.949334] usb 2-1: Product: AS2115
< [ 4561.949338] usb 2-1: Manufacturer: ASMedia
< [ 4561.949342] usb 2-1: SerialNumber: 00000000000000000000
< [ 4561.950655] usb-storage 2-1:1.0: USB Mass Storage device detected
< [ 4561.951286] scsi7 : usb-storage 2-1:1.0
< [ 4562.951433] scsi 7:0:0:0: Direct-Access     ASMT     2115             0    PQ: 0 ANSI: 6
< [ 4562.952055] sd 7:0:0:0: Attached scsi generic sg1 type 0
< [ 4562.960614] sd 7:0:0:0: [sdb] 937703088 512-byte logical blocks: (480 GB/447 GiB)
< [ 4562.961376] sd 7:0:0:0: [sdb] Write Protect is off
< [ 4562.961384] sd 7:0:0:0: [sdb] Mode Sense: 43 00 00 00
< [ 4562.962110] sd 7:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
< [ 4562.967864]  sdb: sdb1 sdb2 sdb3
< [ 4562.969939] sd 7:0:0:0: [sdb] Attached SCSI disk
< [ 4563.227025] EXT4-fs (sdb1): mounted filesystem with ordered data mode. Opts: (null)
< [ 4563.263327] EXT4-fs (sdb3): mounted filesystem with ordered data mode. Opts: (null)




Cela se produit-il seulement avec ce disque USB ou avec tous ? Est-ce un disque USB 2 ou 3 ?



Pas d'autres disques durs sous la main pour l'instant. Je reviendrai ultérieurement.
A priori, c'est un USB 3 compatible (http://www.kingston.com/fr/ssd/v#sv300s3).
Par rapport au boîtier, j'aurais tendance à penser que la forme de la prise marquée ssusb (encoche au 2/3) confirme aussi un support 3.0

@avram : je confirme que j'ai installé via clé USB et que j'ai laissé faire l'installateur en optant pour la première fois pour moi pour du LVM

Bisque, quand ce n'est pas reproductible, c'est pas simple !

Merci pour vos retours.
Cordialement,

Hors ligne

#9 04-02-2016 17:28:28

LauwCost
Membre
Distrib. : Debian 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome
Inscription : 02-02-2016

Re : [Résolu] Comportement étrange connexion dd externe

Démarche chronologique entreprise avec 4 disques dur externes différents pour essayer de comprendre (mais le mystère s'épaissit) :

1°) branchement d'un disque dur externe "bluestork" cable micro-usb sur le port USB3
--> se monte automatiquement
--> le clavier sans fil est fonctionnel
Je démonte et je débranche

2°) branchement d'un disque dur externe "Fra" cable micro-usb (même câble) sur le port USB3
--> se monte automatiquement
--> le clavier sans fil se bloque
Je démonte (flèche eject) et je débranche

3°) branchement d'un disque dur externe msata sur port USB3
--> se monte automatiquement
--> le clavier sans fil est fonctionnel
Je démonte et je débranche

4°) branchement DD intial (celui testé au début du fil) sur USB3
--> se monte automatiquement
--> le clavier sans fil est fonctionnel
Je démonte et je débranche

5°) branchement DD intial (celui testé au début du fil) sur le 1er port USB2
--> ne se monte pas automatiquement
--> le clavier sans fil est fonctionnel
Je démonte et je débranche

6°) branchement DD intial (celui testé au début du fil) sur le 2er port USB2
--> ne se monte pas automatiquement
--> le clavier sans fil est fonctionnel
Je démonte et je débranche

7°) branchement du disque dur externe msata sur 2ème port USB2
--> ne se monte pas automatiquement
--> le clavier sans fil se bloque
Je démonte à l'aide de la souris (icône "éjecter") et je débranche

8°)  branchement d'un disque dur externe "Fra" cable micro-usb sur le 2ème port USB2
--> ne se monte pas automatiquement
--> le clavier sans fil se bloque
J'ai fini par devoir redémarrer car malgré le débranchement/rebranchement des émetteurs, je ne suis pas parvenu à faire refonctionner la souris externe et le clavier externe.
Le clavier du laptop et le touchpad, par contre, fonctionnaient tous les deux.

J'ai arrêté là même si de nombreuses autres combinaisons étaient sans doute possible. Le comportement semble erratique et c'est ça qui est compliqué !

Si vous avez des idées, je suis preneur.

Cordialement,

Hors ligne

#10 04-02-2016 18:54:23

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [Résolu] Comportement étrange connexion dd externe

Bonjour
peut etre prendre en considération l'energie que peu fournir les ports usb (usb1 , usb2 , usb3 et suivant)
je connais pas toutes les normes , mais au départ le courant max etait de 0.5A
il me semble que les ports usb fonctionnent par deux (partage du courant max a vérifier roll  )
un autre souci peut etre l utilisation de la bande passante de l usb (un scan lors d un branchement d un gros disque peu prendre beaucoup de ressources )
peut etre une piste  smile

ps: sur un blocage d une souri usb par exemple , de changer de port peu résoudre le probleme   (nouvelle détection du périphérique )

Hors ligne

#11 04-02-2016 23:49:27

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Comportement étrange connexion dd externe

Comme robert2a j'ai aussi pensé à un problème d'alimentation en lisant le résultat des tests.
Est-il possible d'alimenter le disque avec un source extérieure ou à travers un hub disposant de sa propre alimentation ?

Hors ligne

#12 05-02-2016 09:44:56

LauwCost
Membre
Distrib. : Debian 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome
Inscription : 02-02-2016

Re : [Résolu] Comportement étrange connexion dd externe

Merci pour vos retours,

à vous lire, ça renforce quand même une problématique qui serait plutôt liée à du hard qu'à du soft.
Je n'ai pas de hub alimenté sous le coude. Je vais essayer de faire des nouveaux tests.

Je ne peux pas mettre un résolu et ne sais pas s'il y en aura jamais un d'ailleurs mais je poursuis des tests et reviendrai ici si je trouve des choses probantes.

Merci pour votre aide.

Hors ligne

#13 30-04-2016 12:02:54

LauwCost
Membre
Distrib. : Debian 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome
Inscription : 02-02-2016

Re : [Résolu] Comportement étrange connexion dd externe

Bonjour à tous,

après quelques semaines d'usage, je ne rencontre plus de problème avec un hub alimenté...

Cordialement,

Hors ligne

Pied de page des forums