Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-02-2016 16:50:05

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

[Resolu] Autoriser nobody à utiliser ftp

Bonjour.

Sur ma piratebox j'ai un utilisateur nobody qui est propriétaire des répertoires qui sont mis en partage. C'est comme ça par défaut. Cet utilisateur n'a pas de /home et si j'essaie de me connecter en ssh avec ce compte il m'est répondu que


Could not chdir to home directory /nonexistent: No such file or directory
This account is currently not available.
Connection to 192.168.77.1 closed.
 



Pour des raisons pratiques et parce que les répertoires en partage lui appartiennent, j'aimerais pouvoir me connecter en ftp avec cet utilisateur.

J'ai installé proftpd.

Dans /etc/ftpusers j'ai commenté l'utilisateur nobody :


cat /etc/ftpusers
 



# /etc/ftpusers: list of users disallowed FTP access. See ftpusers(5).

root
daemon
bin
sys
sync
games
man
lp
mail
news
uucp
#nobody
 



J'ai redémarré la piratebox mais je n'arrive pas à me connecter en ftp avec cet utilisateur.

Est-ce qu'il y a un fichier de configuration qu'il faudrait modifier ?

A+

Dernière modification par laguespa (13-02-2016 15:23:52)


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#2 11-02-2016 17:55:35

avram
Membre
Distrib. : dual boot jessie/testing en 64 bits+xp virtualbox
Noyau : 3.16 et 4.3
(G)UI : xfce
Inscription : 28-01-2016

Re : [Resolu] Autoriser nobody à utiliser ftp

les utilisateurs ftp et ssh doivent être des utilisateurs  régulièrement enregistrés sur votre système,c'est à dire des utilisateurs avec login et passwd,l'utilisateur nobody ne fait pas partie  de cette catégorie donc il ne peut pas se connecter en ssh ou en ftp sur votre machine.Avec ftp les utilisateurs seront bien sûr chrootés dans le répertoire ftp que vous aurez vous même choisi.

Hors ligne

#3 11-02-2016 18:55:42

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] Autoriser nobody à utiliser ftp

Bonjour et merci de ton attention.

Pourtant, sur une version augmentée de la piratebox appelée bibliobox, il est possible de se connecter en ftp avec l'utilisateur nobody. Je ne sais pas exactement quelles modifications ont été apportées pour que ce soir rendu possible. D'autre part j'ai lu ici http://www.trustonme.net/didactels/58.html qu'il était possible d'utiliser l'utilisateur nobody mais je n'y arrive pas.

A+

"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#4 11-02-2016 21:01:20

leonlemouton
Adhérent(e)
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate 1.8.1
Inscription : 14-08-2012

Re : [Resolu] Autoriser nobody à utiliser ftp

Salut,
Dans le fichier /etc/proftpd/proftpd.conf, pour utiliser le fichier /etc/ftpusers, il faut ça :

<Global>
   UseFtpUsers on
</Global>


à vérifier...

Source : http://www.linuxtricks.fr/wiki/ftp-inst … ce-proftpd

Bon courage ! smile


Leonlemouton
°(")°

Hors ligne

#5 12-02-2016 13:17:08

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] Autoriser nobody à utiliser ftp

J'ai mis ça

cat /etc/proftpd/proftpd.conf



# Autoriser utilisateurs de /etc/ftpusers
<Global>
   UseFtpUsers on
</Global>
 



Et ça dans ftpusers :

cat /etc/ftpusers



# /etc/ftpusers: list of users disallowed FTP access. See ftpusers(5).

#root
#daemon
#bin
#sys
#sync
#games
#man
#lp
#mail
#news
#uucp
nobody
 



ce qui normalement devrait m'autoriser à me connecter avec l'utilisateur nobody mais ça ne fonctionne pas.
Du coup je pense que c'est lié à certaines particularités de l'utilisateur nobody.
Par précaution j'ai ajouté /bin/false dans /etc/shells mais ça ne change rien et de toute façon pour nobody dans /etc/passwd c'est nobody:x:65534:65534:nobody:/nonexistent:/usr/sbin/nologin

A+

Dernière modification par laguespa (12-02-2016 14:01:32)


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#6 12-02-2016 13:56:44

avram
Membre
Distrib. : dual boot jessie/testing en 64 bits+xp virtualbox
Noyau : 3.16 et 4.3
(G)UI : xfce
Inscription : 28-01-2016

Re : [Resolu] Autoriser nobody à utiliser ftp

mais votre "utilisateur" nobody n'est pas un utilisateur normalement enregistré sur votre système;il n'a pas de mot de passe.
Pour comprendre mieux cette notion essayez de vous connecter sur votre ftp avec l'utilisateur nobody en utilisant la commande:


 

ftp<adresse-ip-locale-de- votre-ftp>

Hors ligne

#7 12-02-2016 14:17:18

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] Autoriser nobody à utiliser ftp

Je me connecte de cette manière depuis le client :


$

ftp



ftp> open 192.168.77.1
Connected to 192.168.77.1.
220 ProFTPD 1.3.5 Server (RaspGeNUx) [::ffff:192.168.77.1]
Name (192.168.77.1:laguespa): nobody
331 Mot de passe requis pour nobody
Password:
530 Authentification incorrecte.
Login failed.
Remote system type is UNIX.
Using binary mode to transfer files.
 



Et ça veut dire quoi alors ?

Edit à toto :
Mis la commande user séparée de son retour et sans le $ pisque c'est marqué dans l'encart.


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#8 12-02-2016 14:48:04

avram
Membre
Distrib. : dual boot jessie/testing en 64 bits+xp virtualbox
Noyau : 3.16 et 4.3
(G)UI : xfce
Inscription : 28-01-2016

Re : [Resolu] Autoriser nobody à utiliser ftp

331 Mot de passe requis pour nobody
Password:
530 Authentification incorrecte.
Login failed.



et quel mot de passe pouvez vous renseigner pour l'utilisateur nobody? aucun car il n'est pas prévu qu'il en ait un.

Dernière modification par avram (12-02-2016 14:50:01)

Hors ligne

#9 12-02-2016 15:13:51

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] Autoriser nobody à utiliser ftp

Oui, c'est exact.
Je lui en ai donné un avec la commande :


passwd nobody
 


que j'ai utilisé mais ça ne change rien.

A quoi sert donc cet utilisateur nobody qui est propriétaire des répertoires mis en partage alors ?

Dernière modification par laguespa (12-02-2016 15:14:10)


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#10 12-02-2016 16:42:12

avram
Membre
Distrib. : dual boot jessie/testing en 64 bits+xp virtualbox
Noyau : 3.16 et 4.3
(G)UI : xfce
Inscription : 28-01-2016

Re : [Resolu] Autoriser nobody à utiliser ftp

A quoi sert donc cet utilisateur nobody qui est propriétaire des répertoires mis en partage alors ?



http://askubuntu.com/questions/426990/w … n-uucp-etc

Hors ligne

#11 12-02-2016 17:29:32

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] Autoriser nobody à utiliser ftp

Ok, merci pour ces informations et bonne journée.

"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#12 12-02-2016 19:40:10

avram
Membre
Distrib. : dual boot jessie/testing en 64 bits+xp virtualbox
Noyau : 3.16 et 4.3
(G)UI : xfce
Inscription : 28-01-2016

Re : [Resolu] Autoriser nobody à utiliser ftp

laguespa a écrit :

J'ai mis ça

cat /etc/proftpd/proftpd.conf



# Autoriser utilisateurs de /etc/ftpusers
<Global>
   UseFtpUsers on
</Global>
 



Et ça dans ftpusers :

cat /etc/ftpusers



# /etc/ftpusers: list of users disallowed FTP access. See ftpusers(5).

#root
#daemon
#bin
#sys
#sync
#games
#man
#lp
#mail
#news
#uucp
nobody
 



ce qui normalement devrait m'autoriser à me connecter avec l'utilisateur nobody mais ça ne fonctionne pas.
Du coup je pense que c'est lié à certaines particularités de l'utilisateur nobody.
Par précaution j'ai ajouté /bin/false dans /etc/shells mais ça ne change rien et de toute façon pour nobody dans /etc/passwd c'est nobody:x:65534:65534:nobody:/nonexistent:/usr/sbin/nologin

A+



Le fichier ftpusers donne la liste des utilisateurs qui sont interdits de connexion ftp et pas ceux qui sont autorisés à se connecter;attention parce que le nom de ce fichier est trompeur.Il ne faut pas modifier le contenu de ce fichier,tout au plus ajouter de nouveaux users mais pas en enlever et ceci pour des raisons de sécurité Si vous avez bien lu le lien que je vous ai donné vous avez compris que vous ne pouvez pas vous connecter en ssh ou ftp avec nobody.
Ne bricolez pas les fichiers sensibles pour la sécurité sous peine de compromettre votre machine.

Dernière modification par avram (12-02-2016 19:42:10)

Hors ligne

#13 12-02-2016 19:45:18

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] Autoriser nobody à utiliser ftp

Ok, merci, je l'ai remis dans son état initial.

A+

"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#14 12-02-2016 20:01:56

avram
Membre
Distrib. : dual boot jessie/testing en 64 bits+xp virtualbox
Noyau : 3.16 et 4.3
(G)UI : xfce
Inscription : 28-01-2016

Re : [Resolu] Autoriser nobody à utiliser ftp

vous créez un utilisateur ftp toto,vous mettez toto dans le groupe nogroup,vous donnez les droits775 sur /opt/piratbox/share,vous chrootez toto dans ce réprtoire share et vous pourrez uploader des fichiers dans share en utilisant ftp.
Au départ vous avez omis de donner les infos concernant le fichier share,d'où la longueur de ce post.

Hors ligne

#15 12-02-2016 20:02:20

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Resolu] Autoriser nobody à utiliser ftp

Ouch' !
Comment qu'y s'est fait taper sur les doigts le laguespa là ! big_smile

Dernière modification par smolski (12-02-2016 20:02:40)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#16 12-02-2016 20:05:23

avram
Membre
Distrib. : dual boot jessie/testing en 64 bits+xp virtualbox
Noyau : 3.16 et 4.3
(G)UI : xfce
Inscription : 28-01-2016

Re : [Resolu] Autoriser nobody à utiliser ftp

smolski a écrit :

Ouch' !
Comment qu'y s'est fait taper sur les doigts le laguespa là ! big_smile



mais non smolski,y'a pas de père fouettard sur ce forum  big_smile

Hors ligne

#17 12-02-2016 20:34:29

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] Autoriser nobody à utiliser ftp

Ok. Je crois que j'ai fait le tour de la question.

Mais ça veut dire quoi "chrooter toto dans le répertoire share" ?

A+

"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#18 12-02-2016 21:21:43

avram
Membre
Distrib. : dual boot jessie/testing en 64 bits+xp virtualbox
Noyau : 3.16 et 4.3
(G)UI : xfce
Inscription : 28-01-2016

Re : [Resolu] Autoriser nobody à utiliser ftp

Mais ça veut dire quoi "chrooter toto dans le répertoire share" ?



le répertoire de chroot des utilisateurs se définit dans /etc/proftpd/proftpd.conf à la ligne:


 

# Use this to jail all users in their homes
DefaultRoot            /opt/piratbox/share



et relancer proftpd en faisant


 

/etc/init.d/proftpd restart



pour que les changements dans proftpd.conf soient pris en charge.

Hors ligne

#19 12-02-2016 22:10:47

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] Autoriser nobody à utiliser ftp

avram a écrit :

vous créez un utilisateur ftp toto,vous mettez toto dans le groupe nogroup,vous donnez les droits775 sur /opt/piratbox/share,vous chrootez toto dans ce réprtoire share et vous pourrez uploader des fichiers dans share en utilisant ftp.
Au départ vous avez omis de donner les infos concernant le fichier share,d'où la longueur de ce post.



Il faut que je précise qu'un script de la piratebox remet les droits de share en 755 à chaque démarrage.


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#20 12-02-2016 22:15:58

avram
Membre
Distrib. : dual boot jessie/testing en 64 bits+xp virtualbox
Noyau : 3.16 et 4.3
(G)UI : xfce
Inscription : 28-01-2016

Re : [Resolu] Autoriser nobody à utiliser ftp

Il faut que je précise qu'un script de la piratebox remet les droits de share en 755 à chaque démarrage.



là je ne sais pas,je ne connais pas piratbox et ne l'ai jamais utilisé;faudrait lire la doc pour voir si il y a moyen de passer les droits de 755 à775 par défaut.

Hors ligne

#21 12-02-2016 22:50:47

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] Autoriser nobody à utiliser ftp

Je ne sais pas pour quelle raison mais quelque chose ne fonctionne plus.

J'ai un utilisateur agenux qui me permet de me connecter en ftp.
Dans /opt/piratebox/share/Shared j'ai créé un répertoire Musique dont agenux est le propriétaire


ls -l /opt/piratebox/share/Shared/
 



total 56
drwxr-xr-x 3 nobody nogroup 4096 janv. 30 16:53 Agenux
drwxr-xr-x 5 nobody nogroup 4096 févr.  3 05:51 Associations_presentes
drwxr-xr-x 2 nobody nogroup 4096 janv. 28 12:52 autre_chose
-rwxr-xr-x 1 nobody nogroup  815 janv. 25 18:23 HEADER.txt
drwxr-xr-x 2 nobody nogroup 4096 janv. 28 12:51 Image
drwxr-xr-x 2 nobody nogroup 4096 janv. 31 00:30 Intervenants
drwxr-xr-x 2 agenux agenux  4096 févr.  5 18:16 Musique
drwxr-xr-x 2 nobody nogroup 4096 janv. 23 14:27 PDF
drwxr-xr-x 2 nobody nogroup 4096 févr.  3 05:26 Programme
-rwxr-xr-x 1 nobody nogroup 1616 févr.  3 14:30 README.txt
drwxr-xr-x 2 nobody nogroup 4096 janv. 30 21:56 Ressource
drwxr-xr-x 2 nobody nogroup 4096 févr.  5 08:22 Restauration
drwxr-xr-x 2 nobody nogroup 4096 févr.  2 19:28 Video
drwxr-xr-x 5 nobody nogroup 4096 janv. 23 14:29 Vie privee
 



Quand je me connectais en ftp avec l'utilisateur agenux il m'était possible d'aller dans le répertoire /opt/piratebox/share/Shared/Musique et d'y faire des modifications. Bizarrement maintenant je ne peux plus.
L'utilisateur agenux est limité à son /home. Je crois me souvenir qu'il y a une option à modifier dans /etc/proftpd/proftpd.conf est-ce que vous savez laquelle ?

A+


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#22 12-02-2016 22:55:40

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] Autoriser nobody à utiliser ftp

Ayé, j'ai retrouvé. Dans /etc/proftpd/proftpd.conf il faut commenter


cat /etc/proftpd/proftpd.conf
 



#DefaultRoot                    ~
 

Dernière modification par laguespa (12-02-2016 22:56:03)


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#23 12-02-2016 23:00:34

avram
Membre
Distrib. : dual boot jessie/testing en 64 bits+xp virtualbox
Noyau : 3.16 et 4.3
(G)UI : xfce
Inscription : 28-01-2016

Re : [Resolu] Autoriser nobody à utiliser ftp

faites déjà voir votre fichier proftpd.conf,en fait la ligne qui permet de chrooter les utilisateurs.

Je viens de lire votre post juste avant; si vous diésez la ligne "defaulRoot" alors l'utilisateur pourra se ballader dans toute l'arborescence de votre système,mauvaise limonade pour la sécurité.Il faudrait que je comprenne exactement ce que vous voulez faire et dans quel répertoire.Vous voulez avoir le droit en écriture dans /opt/piratbox/share  ou dans  /opt/piratbox/share/shared ??  ou autre??

Dernière modification par avram (12-02-2016 23:09:23)

Hors ligne

#24 12-02-2016 23:58:45

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] Autoriser nobody à utiliser ftp

Je voudrais avoir les droits en lecture et écriture dans /opt/piratebox/share/Shared

Voici mon fichier :


cat /etc/proftpd/proftpd.conf
 



#
# /etc/proftpd/proftpd.conf -- This is a basic ProFTPD configuration file.
# To really apply changes, reload proftpd after modifications, if
# it runs in daemon mode. It is not required in inetd/xinetd mode.
#

# Includes DSO modules
Include /etc/proftpd/modules.conf

# Set off to disable IPv6 support which is annoying on IPv4 only boxes.
UseIPv6       on
# If set on you can experience a longer connection delay in many cases.
IdentLookups      off

ServerName      "RaspGeNUx"
ServerType      standalone
DeferWelcome      off

MultilineRFC2228    on
DefaultServer     on
ShowSymlinks      on

TimeoutNoTransfer   600
TimeoutStalled      600
TimeoutIdle     1200

DisplayLogin                    welcome.msg
DisplayChdir                .message true
ListOptions                 "-l"

DenyFilter      \*.*/

# Use this to jail all users in their homes
#DefaultRoot      ~
#DefaultRoot      /opt/piratebox/share/

# Users require a valid shell listed in /etc/shells to login.
# Use this directive to release that constrain.
# RequireValidShell   off

# Port 21 is the standard FTP port.
Port        21

# In some cases you have to specify passive ports range to by-pass
# firewall limitations. Ephemeral ports can be used for that, but
# feel free to use a more narrow range.
PassivePorts                  49152 65534

# If your host was NATted, this option is useful in order to
# allow passive tranfers to work. You have to use your public
# address and opening the passive ports used on your firewall as well.
# MasqueradeAddress   1.2.3.4

# This is useful for masquerading address with dynamic IPs:
# refresh any configured MasqueradeAddress directives every 8 hours
<IfModule mod_dynmasq.c>
# DynMasqRefresh 28800
</IfModule>

# To prevent DoS attacks, set the maximum number of child processes
# to 30.  If you need to allow more than 30 concurrent connections
# at once, simply increase this value.  Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
MaxInstances      30

# Set the user and group that the server normally runs at.
User        proftpd
Group       nogroup


# Autoriser utilisateurs de /etc/ftpusers
#<Global>
#   UseFtpUsers on
#</Global>



# Umask 022 is a good standard umask to prevent new files and dirs
# (second parm) from being group and world writable.
Umask       022  022
# Normally, we want files to be overwriteable.
AllowOverwrite      on

# Uncomment this if you are using NIS or LDAP via NSS to retrieve passwords:
# PersistentPasswd    off

# This is required to use both PAM-based authentication and local passwords
# AuthOrder     mod_auth_pam.c* mod_auth_unix.c

# Be warned: use of this directive impacts CPU average load!
# Uncomment this if you like to see progress and transfer rate with ftpwho
# in downloads. That is not needed for uploads rates.
#
# UseSendFile     off

TransferLog /var/log/proftpd/xferlog
SystemLog   /var/log/proftpd/proftpd.log

# Logging onto /var/log/lastlog is enabled but set to off by default
#UseLastlog on

# In order to keep log file dates consistent after chroot, use timezone info
# from /etc/localtime.  If this is not set, and proftpd is configured to
# chroot (e.g. DefaultRoot or <Anonymous>), it will use the non-daylight
# savings timezone regardless of whether DST is in effect.
#SetEnv TZ :/etc/localtime

<IfModule mod_quotatab.c>
QuotaEngine off
</IfModule>

<IfModule mod_ratio.c>
Ratios off
</IfModule>


# Delay engine reduces impact of the so-called Timing Attack described in
# http://www.securityfocus.com/bid/11430/discuss
# It is on by default.
<IfModule mod_delay.c>
DelayEngine on
</IfModule>

<IfModule mod_ctrls.c>
ControlsEngine        off
ControlsMaxClients    2
ControlsLog           /var/log/proftpd/controls.log
ControlsInterval      5
ControlsSocket        /var/run/proftpd/proftpd.sock
</IfModule>

<IfModule mod_ctrls_admin.c>
AdminControlsEngine off
</IfModule>

#
# Alternative authentication frameworks
#
#Include /etc/proftpd/ldap.conf
#Include /etc/proftpd/sql.conf

#
# This is used for FTPS connections
#
#Include /etc/proftpd/tls.conf

#
# Useful to keep VirtualHost/VirtualRoot directives separated
#
#Include /etc/proftpd/virtuals.conf

# A basic anonymous configuration, no upload directories.

# <Anonymous ~ftp>
#   User        ftp
#   Group       nogroup
#   # We want clients to be able to login with "anonymous" as well as "ftp"
#   UserAlias     anonymous ftp
#   # Cosmetic changes, all files belongs to ftp user
#   DirFakeUser on ftp
#   DirFakeGroup on ftp
#
#   RequireValidShell   off
#
#   # Limit the maximum number of anonymous logins
#   MaxClients      10
#
#   # We want 'welcome.msg' displayed at login, and '.message' displayed
#   # in each newly chdired directory.
#   DisplayLogin      welcome.msg
#   DisplayChdir    .message
#
#   # Limit WRITE everywhere in the anonymous chroot
#   <Directory *>
#     <Limit WRITE>
#       DenyAll
#     </Limit>
#   </Directory>
#
#   # Uncomment this if you're brave.
#   # <Directory incoming>
#   #   # Umask 022 is a good standard umask to prevent new files and dirs
#   #   # (second parm) from being group and world writable.
#   #   Umask       022  022
#   #            <Limit READ WRITE>
#   #            DenyAll
#   #            </Limit>
#   #            <Limit STOR>
#   #            AllowAll
#   #            </Limit>
#   # </Directory>
#
# </Anonymous>

# Include other custom configuration files
Include /etc/proftpd/conf.d/
 

Dernière modification par laguespa (13-02-2016 00:00:05)


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#25 13-02-2016 00:22:51

avram
Membre
Distrib. : dual boot jessie/testing en 64 bits+xp virtualbox
Noyau : 3.16 et 4.3
(G)UI : xfce
Inscription : 28-01-2016

Re : [Resolu] Autoriser nobody à utiliser ftp

# Use this to jail all users in their homes
#DefaultRoot      ~
#DefaultRoot      /opt/piratebox/share/



pas bon,deux répertoires de chroot;il n'en faut que un seul; et diésés tous les deux pour n'en avoir aucun au final.
Voici la bonne ligne:


 

# Use this to jail all users in their homes
DefaultRoot            /opt/piratebox/share



L'utilisateur agenux sera chrooté dans share.

Dernière modification par avram (13-02-2016 00:55:37)

Hors ligne

Pied de page des forums