Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-05-2009 06:52:57

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

[nVidia Geforce II MX/MX400] sur Amd K6 3DNow

Bonjour,

Cette carte graphique est une carte PCI. J'ai eu le plaisir de l'essayer sur ce K6, déjà comparé à la trident intégrée et même juste avec le driver libre nv, l'utilisation de la machine est beaucoup plus fluide (c'est une Debian Lenny, construite à partir d'une Lenny core).

Ensuite j'ai essayé d'installer le driver propriétaire mais je n'ai pas trouvé quelle version il fallait. J'ai d'abord suivi un tuto anglais qui m'a été présenté, (wiki) et ça m'a menée à avoir un driver 96xx, que j'ai compilé avec module assistant, car je n'avais pas vu la version pour kernel 486 dans la liste, puis j'ai tenté le wiki DF, bien que je ne voyais pas quelle version de driver était dessous, et là ça a été un 173, ce qui me semblait correct puisque pour cette carte ça semblait être une des trois propositions sur le site nvidia (après avoir mis les références de la carte dans leur moteur de recherches)

Entre deux essais, au moment de relancer gdm ça disait "module not found" ou "no screen found", truc comme ça.
Et dans la section des modules kernels (dans mon système) je n'ai trouvé qu'un nvidia-agp.ko, et dans la section drivers Xorg (dans mon système, sous /usr/lib-quelque chose-xorg), rien pour nvidia (juste trident et nv).

Après, j'aurais bien aimé tenter le 180.xx.xx, mais il n'est pas packagé si ? Et sinon quelqu'un aurait-il une info sur la version driver qui doit normalement être utilisée pour cette carte ?

Merci.

le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#2 10-05-2009 19:03:29

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [nVidia Geforce II MX/MX400] sur Amd K6 3DNow

Salut

En consultant cette page Debian Wiki, on peut trouver deux listes pour les drivers des cartes nVidia. Ta carte se retrouve sur cette liste : driver 1.0-8776

Avec ses infos, tu devrais arriver à tes fins.
Bonne chance
Martin

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#3 10-05-2009 19:08:37

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [nVidia Geforce II MX/MX400] sur Amd K6 3DNow

martin_mtl a écrit :

Salut

En consultant cette page Debian Wiki, on peut trouver deux listes pour les drivers des cartes nVidia. Ta carte se retrouve sur cette liste : driver 1.0-8776

Avec ses infos, tu devrais arriver à tes fins.


Non. Je sais déjà que cette carte est "GeForce2 MX/MX 400     0x0110"

Et j'ai déjà suivi le tuto dont tu donnes le lien. Cela mène au driver 96xx... dont je parlais ci-dessus. (Et qui produit le message "no screens found" etc... )

La question que je pose est une demande qui voudrait quasiment une connaissance plus poussée. smile

En attendant, merci.

PS: sur mon desktop habituel où j'ai une carte nvidia récente, sous /usr/lib/xorg/modules/drivers je peux voir:

$ pwd
/usr/lib/xorg/modules/drivers
ls
nv_drv.so  nvidia_drv.so
$

alors que dans l'autre machine, il n'y avait que nv_drv.so et trident_drv.so, après avoir installé deux fois le driver propriétaire (version xx96 et 173.xx.xx, donc)

Donc soit ce n'est pas la bonne version (les bonnes... ) soit les paquets n'ont pas tout ce qu'il faut dedans. Si ce n'est ni l'un ni l'autre, alors aucune idée :?:


le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#4 11-05-2009 02:23:02

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [nVidia Geforce II MX/MX400] sur Amd K6 3DNow

Salut

Ta question demande en effet des infos plus pointues. J'aurais dû m'en douter.  Une recherche une internet m'a permis de trouver un cas semblable au tien qui a été résolu : pilote nvidia. Le message date de 2007 mais on ne sait jamais.

Si j'ai bien compris, il semble qu'il faille le pilote disponible pour etch : nvidia-legacy

Sinon, il y a quelqu'un qui a exactement le même problème sur debian-fr.org Geforce MX400

Coïncidence pour le moins bizarre...

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#5 11-05-2009 09:08:09

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : [nVidia Geforce II MX/MX400] sur Amd K6 3DNow

Salut,

Quand on regarde la page du paquet nvidia-glx-legacy-96xx, on voit bien que tu utilises le bon pilote (ou du moins que tu as essayé de l'utiliser).

Du coup j'ai tenté une autre voie et j'ai trouvé un article intéressant dont j'ai tiré cet extrait :

The newer drivers don't support systems without SSE, but since only AGP and PCI systems don't have SSE, the 96xx driver should be sufficient since it covers all AGP cards. Only 8xxx (and newer) series cards would be a problem, but those are only PCI express, which is only found on systems which have SSE.


Le pilote 96xx supporte donc les vieilles cartes Nvidia AGP, mais aucune info sur leurs versions PCI. En fait je n'ai aucune preuve de ce que j'avance, mais je soupçonne le pilote legacy de ne plus supporter les cartes PCI.


« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

Pied de page des forums