Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-02-2016 14:45:30

nazmi
Membre
Lieu : Normandie
Distrib. : GNU/LINUX Debian Jessie
Noyau : Linux 4.3.0-0.bpo.1-amd64
(G)UI : KDE/XFCE
Inscription : 17-07-2015

[Résolu]Petit problème de mise à jour (python cffi manquant)

Salut,
ça fait un bout de temps que je suis pas passé (plus de setup multi moniteurs pour l'instant donc pas de place pour le flux atom de DF, pas eu trop de problèmes/questions, pas trop de temps et ce petit problème qui m'empêche de rester connecté sur le forum plus de 5minutes donc je vais me dépêcher d'écrire ce message hmm )

Alors récemment j'ai voulu mettre à jour mon système (comme d'hab quand l'utilitaire de mise à jour me le demande) et à la place du téléchargement des fichiers nécessaires et de la demande d'authentification, j'ai eu:
syutxt1kTl26RZQ6.png
ce qui est pour le moins inhabituel, est-ce que vous avez des pistes ? car ça doit faire une semaine que mon système n'est plus à jour neutral

Merci d'avance wink

(tout ça me fait penser qu'en réalité j'ai plein de questions et sujets de discussions, à ce soir)

Dernière modification par nazmi (24-03-2016 00:19:21)

Hors ligne

#2 29-02-2016 15:22:50

Firy
Membre
Distrib. : Debian Jessie 8.3
Noyau : 3.16.0
(G)UI : Openbox
Inscription : 22-01-2016

Re : [Résolu]Petit problème de mise à jour (python cffi manquant)

Tu as essayé de réinstaller le paquet python-cffi ?

Et un

apt-get update && apt-get upgrade


ça te donne quoi ?

Hors ligne

#3 29-02-2016 21:06:12

nazmi
Membre
Lieu : Normandie
Distrib. : GNU/LINUX Debian Jessie
Noyau : Linux 4.3.0-0.bpo.1-amd64
(G)UI : KDE/XFCE
Inscription : 17-07-2015

Re : [Résolu]Petit problème de mise à jour (python cffi manquant)

Merci de ta réponse, voila ce que j'ai fait:

apt-get install python-cffi


qui m'a donné

 Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libportmidi0 libsdl-ttf2.0-0 libsmpeg0 libtorrent-rasterbar7 linux-image-4.1.0-0.bpo.1-amd64
  linux-image-4.1.0-0.bpo.2-amd64 linux-image-4.2.0-0.bpo.1-amd64 python-characteristic python-libtorrent python-pam
  python-pyasn1 python-pyasn1-modules python-pygame python-serial python-twisted-bin python-zope.interface
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  python-cffi-backend
Les paquets suivants seront ENLEVÉS :
  deluge deluge-common deluge-gtk python-cryptography python-openssl python-service-identity python-twisted-core
  python-twisted-web
Les NOUVEAUX paquets suivants seront installés :
  python-cffi-backend
Les paquets suivants seront mis à jour :
  python-cffi
1 mis à jour, 1 nouvellement installés, 8 à enlever et 94 non mis à jour.
Il est nécessaire de prendre 127 ko dans les archives.
Après cette opération, 16,3 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
Réception de : 1 http://http.debian.net/debian/ jessie-backports/main python-cffi all 1.4.2-2~bpo8+1 [63,0 kB]
Réception de : 2 http://http.debian.net/debian/ jessie-backports/main python-cffi-backend amd64 1.4.2-2~bpo8+1 [63,6 kB]
127 ko réceptionnés en 0s (371 ko/s)          
Lecture des fichiers de modifications (« changelog »)... Terminé
(Lecture de la base de données... 271509 fichiers et répertoires déjà installés.)
Suppression de deluge (1.3.10-3) ...
Suppression de deluge-gtk (1.3.10-3) ...
Suppression de deluge-common (1.3.10-3) ...
Suppression de python-twisted-web (14.0.2-3) ...
Suppression de python-twisted-core (14.0.2-3) ...
Suppression de python-service-identity (1.0.0-3) ...
Suppression de python-openssl (0.14-1) ...
Suppression de python-cryptography (0.6.1-1) ...
Traitement des actions différées (« triggers ») pour menu (2.1.47) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.0.2-5) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.58) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.13-1) ...
(Lecture de la base de données... 269853 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../python-cffi_1.4.2-2~bpo8+1_all.deb ...
Dépaquetage de python-cffi (1.4.2-2~bpo8+1) sur (0.8.6-1) ...
Sélection du paquet python-cffi-backend précédemment désélectionné.
Préparation du dépaquetage de .../python-cffi-backend_1.4.2-2~bpo8+1_amd64.deb ...
Dépaquetage de python-cffi-backend (1.4.2-2~bpo8+1) ...
Paramétrage de python-cffi-backend (1.4.2-2~bpo8+1) ...
Paramétrage de python-cffi (1.4.2-2~bpo8+1) ...
 



elle m'a donc désinstallé Deluge neutral, ce qui n'est rien mais qui ne semble pas avoir grand chose à voir
aussi apper m'a mis une nouvelle notification avec plus de paquets à mettre à jour, j'ai cliqué et maintenant il me propose de virer GQRX, libgnuradio et autres:
m32ztbvu5RrirW6c.png
j'ai continué (ranafoutre de ces paquets, je peux les reinstaller quand j'en aurai de nouveau besoin.
Le téléchargement des mises à jour continue:
5TXOz9HG1PmmtgGr.png
On verra ce que ça donne au prochain démarrage hmm

Dernière modification par nazmi (29-02-2016 21:07:43)

Hors ligne

#4 29-02-2016 21:37:07

Firy
Membre
Distrib. : Debian Jessie 8.3
Noyau : 3.16.0
(G)UI : Openbox
Inscription : 22-01-2016

Re : [Résolu]Petit problème de mise à jour (python cffi manquant)

Deluge est développé en partie en python.

Le paquet est disponible sous stretch, un rétroportage aurait peut-être été mieux, d'autant plus que tu n'en a qu'un.

Possible quand même de faire un

cat /etc/apt/source.list


?

Dernière modification par Firy (29-02-2016 21:41:26)

Hors ligne

#5 01-03-2016 00:24:18

nazmi
Membre
Lieu : Normandie
Distrib. : GNU/LINUX Debian Jessie
Noyau : Linux 4.3.0-0.bpo.1-amd64
(G)UI : KDE/XFCE
Inscription : 17-07-2015

Re : [Résolu]Petit problème de mise à jour (python cffi manquant)

Alors, en effet mon source.list est pour le moins particulier, je vais essayer de décrire toutes les conneries que j'ai fait autour ce ça neutral :
J'ai entre autres voulu installer SimpleScreenRecorder, OBS-Studio entre autres mais vu qu'ils n'ont pas fait de paquet pour Debian, j'ai voulu utiliser les PPA Ubuntu en croyant que ça passerait  neutral et quand je fais un apt-get update, je vois encore les traces sans savoir tout nettoyer:
Jyd9aLhTEZYrD3Se.png

mon sources.list:

#

# deb cdrom:[Debian GNU/Linux 8.1.0 _Jessie_ - Official amd64 NETINST Binary-1 20150606-14:16]/ jessie main

# deb cdrom:[Debian GNU/Linux 8.1.0 _Jessie_ - Official amd64 NETINST Binary-1 20150606-14:16]/ jessie main

deb http://ftp.fr.debian.org/debian/ jessie main
deb-src http://ftp.fr.debian.org/debian/ jessie main

deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main

# jessie-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ jessie-updates main
deb-src http://ftp.fr.debian.org/debian/ jessie-updates main

#paquets backports
deb http://http.debian.net/debian jessie-backports main
deb-src http://http.debian.net/debian jessie-backports main

#dépots temporaires
#deb http://ftp.fr.debian.org/debian/ wheezy main
#deb-src http://ftp.fr.debian.org/debian/ wheezy main
#deb http://security.debian.org/ wheezy/updates main

#deb http://http.us.debian.org/debian/ wheezy main

#deb-src http://security.debian.org/ wheezy/updates main
#Trucs amiga
#deb http://morgoth.free.fr/ubuntu dapper-backports main



Je sais que ce n'est pas super propre mais l'installation des paquets et sources sous débian m'est encore un domaine incompris hmm
Au fait, j'ai voulu réinstaller Deluge et en effet, ce n'est pas passé du fait de la dépendance Deluge-gtk, comment corriger ça ?

Merci d'avance

PS: à quoi consiste un rétroportage ?

PS²: le

apt-get update && upgrade


a donné:

Ign http://ftp.fr.debian.org jessie InRelease
Ign http://ppa.launchpad.net jessie InRelease                                                                                                                                
Réception de : 1 http://ftp.fr.debian.org jessie-updates InRelease [136 kB]                                                                                                  
Ign http://ppa.launchpad.net jessie InRelease                                                                                                                                                  
Ign http://download.jitsi.org unstable/ InRelease                                                                                          
Ign http://ppa.launchpad.net jessie Release.gpg                                                                                          
Atteint http://download.jitsi.org unstable/ Release.gpg                                                                                                                    
Atteint http://security.debian.org jessie/updates InRelease                                                                                                                  
Atteint http://download.jitsi.org unstable/ Release                                                                                                                          
Ign http://ppa.launchpad.net jessie Release.gpg                                                                                                                              
Ign http://ppa.launchpad.net jessie Release                                                                                                                                                    
Atteint http://ftp.fr.debian.org jessie Release.gpg                                                                                                                                            
Ign http://ppa.launchpad.net jessie Release                                                                                                                                                    
Atteint http://ftp.fr.debian.org jessie Release                                                                                                                                                
Réception de : 2 http://ftp.fr.debian.org jessie-updates/main Sources [2 296 B]                                                                                                                
Réception de : 3 http://ftp.fr.debian.org jessie-updates/main amd64 Packages/DiffIndex [367 B]                                                                                                  
Réception de : 4 http://ftp.fr.debian.org jessie-updates/main Translation-en [2 506 B]                                                                                                          
Atteint http://security.debian.org jessie/updates/main Sources                                                                                                                                
Atteint http://download.jitsi.org unstable/ Packages                                                                                                                                          
Atteint http://security.debian.org jessie/updates/main amd64 Packages                                                                                                                          
Réception de : 5 http://http.debian.net jessie-backports InRelease [166 kB]                                                                                                                
Atteint http://security.debian.org jessie/updates/main Translation-en                                                                                                                          
Atteint http://ftp.fr.debian.org jessie/main Sources                                                                                                                                          
Atteint http://ftp.fr.debian.org jessie/main amd64 Packages                                                                                                                
Atteint http://ftp.fr.debian.org jessie/main Translation-fr                                                                                                                
Atteint http://ftp.fr.debian.org jessie/main Translation-en                                                                                                                    
Ign http://download.jitsi.org unstable/ Translation-fr_FR                                                                                                                      
Ign http://download.jitsi.org unstable/ Translation-fr                                                                    
Ign http://download.jitsi.org unstable/ Translation-en                                                                    
Réception de : 6 http://http.debian.net jessie-backports/main Translation-en/DiffIndex [24,3 kB]
Réception de : 7 http://http.debian.net jessie-backports/main Sources/DiffIndex [27,8 kB]                                      
Réception de : 8 http://http.debian.net jessie-backports/main amd64 Packages/DiffIndex [27,8 kB]
Err http://ppa.launchpad.net jessie/main amd64 Packages                                                                  
  404  Not Found
Ign http://ppa.launchpad.net jessie/main Translation-fr_FR                                                              
Réception de : 9 http://http.debian.net jessie-backports/main 2016-02-29-2049.12.pdiff [2 426 B]
Ign http://ppa.launchpad.net jessie/main Translation-fr                                                                  
Ign http://ppa.launchpad.net jessie/main Translation-en                                  
Réception de : 10 http://http.debian.net jessie-backports/main 2016-02-29-2049.12.pdiff [2 426 B]
Réception de : 11 http://http.debian.net jessie-backports/main amd64 2016-02-29-2049.12.pdiff [2 693 B]        
Réception de : 12 http://http.debian.net jessie-backports/main amd64 2016-02-29-2049.12.pdiff [2 693 B]              
Err http://ppa.launchpad.net jessie/main amd64 Packages                            
  404  Not Found
Ign http://ppa.launchpad.net jessie/main Translation-fr_FR                        
Ign http://ppa.launchpad.net jessie/main Translation-fr                        
Ign http://ppa.launchpad.net jessie/main Translation-en                          
392 ko réceptionnés en 2s (160 ko/s)                    
W: Impossible de récupérer http://ppa.launchpad.net/maarten-baert/simplescreenrecorder/ubuntu/dists/jessie/main/binary-amd64/Packages  404  Not Found

W: Impossible de récupérer http://ppa.launchpad.net/obsproject/obs-studio/ubuntu/dists/jessie/main/binary-amd64/Packages  404  Not Found

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

Dernière modification par nazmi (01-03-2016 00:27:42)

Hors ligne

#6 01-03-2016 13:53:41

Firy
Membre
Distrib. : Debian Jessie 8.3
Noyau : 3.16.0
(G)UI : Openbox
Inscription : 22-01-2016

Re : [Résolu]Petit problème de mise à jour (python cffi manquant)

Le rétroportage se fait avec

apt-get -t jessie-backports install python-cffi-backend


Je te renvoie au wiki pour la définition.

Je pense qu'il y a besoin que tu fasses le ménage aussi dans

/etc/apt/source.list.d

Hors ligne

#7 02-03-2016 01:29:49

nazmi
Membre
Lieu : Normandie
Distrib. : GNU/LINUX Debian Jessie
Noyau : Linux 4.3.0-0.bpo.1-amd64
(G)UI : KDE/XFCE
Inscription : 17-07-2015

Re : [Résolu]Petit problème de mise à jour (python cffi manquant)

j'ai fait le rétroportage, ça m'a donné:
nazmi@derpian:~$

sudo apt-get -t jessie-backports install python-cffi-backend



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
python-cffi-backend est déjà la plus récente version disponible.
python-cffi-backend passé en « installé manuellement ».
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  docutils-common docutils-doc gnuradio gr-fcdproplus gr-iqbal gr-osmosdr libairspy0 libbladerf0 libbladerf1 libboost-serialization1.55.0 libboost-test1.55.0 libcodec2-0.4 libcomedi0
  libegl1-mesa-drivers libgnuradio-analog3.7.5 libgnuradio-analog3.7.9 libgnuradio-atsc3.7.5 libgnuradio-atsc3.7.9 libgnuradio-audio3.7.5 libgnuradio-audio3.7.9 libgnuradio-blocks3.7.5
  libgnuradio-blocks3.7.9 libgnuradio-channels3.7.5 libgnuradio-channels3.7.9 libgnuradio-comedi3.7.5 libgnuradio-comedi3.7.9 libgnuradio-digital3.7.5 libgnuradio-digital3.7.9
  libgnuradio-dtv3.7.5 libgnuradio-dtv3.7.9 libgnuradio-fcd3.7.5 libgnuradio-fcd3.7.9 libgnuradio-fcdproplus0 libgnuradio-fec3.7.5 libgnuradio-fec3.7.9 libgnuradio-fft3.7.5
  libgnuradio-fft3.7.9 libgnuradio-filter3.7.5 libgnuradio-filter3.7.9 libgnuradio-iqbalance0 libgnuradio-noaa3.7.5 libgnuradio-noaa3.7.9 libgnuradio-osmosdr0.1.4 libgnuradio-pager3.7.5
  libgnuradio-pager3.7.9 libgnuradio-pmt3.7.5 libgnuradio-pmt3.7.9 libgnuradio-qtgui3.7.5 libgnuradio-qtgui3.7.9 libgnuradio-runtime3.7.5 libgnuradio-runtime3.7.9 libgnuradio-trellis3.7.5
  libgnuradio-trellis3.7.9 libgnuradio-uhd3.7.9 libgnuradio-video-sdl3.7.5 libgnuradio-video-sdl3.7.9 libgnuradio-vocoder3.7.5 libgnuradio-vocoder3.7.9 libgnuradio-wavelet3.7.5
  libgnuradio-wavelet3.7.9 libgnuradio-wxgui3.7.5 libgnuradio-wxgui3.7.9 libgnuradio-zeromq3.7.5 libgnuradio-zeromq3.7.9 libhackrf0 liblog4cpp5 libmirisdr0 libopenvg1-mesa libosmosdr0
  libpgm-5.1-0 libportmidi0 libqwt-dev libqwt5-qt4 libqwt6 libsdl-ttf2.0-0 libsmpeg0 libsodium13 libtorrent-rasterbar7 libuhd003 libvolk0.0.0 libvolk1-bin libvolk1.1 libwxbase2.8-0
  libwxgtk2.8-0 libzmq3 linux-image-4.1.0-0.bpo.1-amd64 linux-image-4.1.0-0.bpo.2-amd64 linux-image-4.2.0-0.bpo.1-amd64 python-characteristic python-cheetah python-dateutil python-decorator
  python-defusedxml python-docutils python-funcsigs python-libtorrent python-matplotlib python-matplotlib-data python-mock python-networkx python-opengl python-pam python-pbr python-pyasn1
  python-pyasn1-modules python-pygame python-pygments python-pygraphviz python-pyparsing python-qwt5-qt4 python-requests python-roman python-scipy python-serial python-soappy
  python-twisted-bin python-tz python-urllib3 python-wstools python-wxgtk2.8 python-yaml python-zmq python-zope.interface qthid-fcd-controller uhd-host
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 40 non mis à jour.
 


il n'y a donc pas eu de modification à ce que j'en ai compris.

J'ai entamé la lecture de la page Wiki sur les backports mais faudra que je finisse demain, enfin j'ai fait un nano sur source.list.d mais il me dit que c'est un répertoire et n'affiche donc rien dedans, je crois que j'ai pas fait la bonne commande neutral, quelle est la procédure ?

Merci beaucoup pour ton support, bonsoir

Edit à toto :
Séparation de la Commande user de son retour dans un code simple.

Hors ligne

#8 02-03-2016 06:28:51

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu]Petit problème de mise à jour (python cffi manquant)

nazmi a écrit :

j'ai fait un nano sur source.list.d


sources.list.d est un répertoire, nano crée des fichiers dans des répertoires, y faut donc ajouter à nano le nom d'un fichier que tu nommes à ta guise pour qu'il se situe dans le répertoire sources.list.d.

Et voilà... smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#9 04-03-2016 01:03:10

nazmi
Membre
Lieu : Normandie
Distrib. : GNU/LINUX Debian Jessie
Noyau : Linux 4.3.0-0.bpo.1-amd64
(G)UI : KDE/XFCE
Inscription : 17-07-2015

Re : [Résolu]Petit problème de mise à jour (python cffi manquant)

d'accord, c'est un dossier mais comment nettoyer mes sources alors ? un argument de apt ? vider le répertoire sources.list.d (je viens de comprendre, d=directory, non ?) ?
et pour les paquets que j'ai perdu (Deluge et GQRX), comment les réinstaller ? parce-que je suis un peu en manque de dessins animés là tongue .
sinon, pour les backports, merci

Merci d'avance, j'espère en apprendre beaucoup sur ce sujet que je maîtrise pas/peu hmm

Hors ligne

#10 04-03-2016 08:26:31

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : [Résolu]Petit problème de mise à jour (python cffi manquant)

Salut,

Pour nettoyer ( configurer ) les sources, il faut que tu te rendes dans le répertoire /etc/apt/sources.list.d et que tu regardes quels fichiers il y a dedans :

cd /etc/apt/sources.list.d


ls -l


Ce qui va t'indiquer le fichier.

nano <nom_du_fichier_trouvé>


Tu commentes ( ajouter un # en début de ligne ) les dépôts exotiques ( ubuntu ...)
Et tu rafraîchis le cache de apt :

apt-get update



Pour réinstaller deluge, comme il y a des problèmes de version dans les dépendances, tu peux essayer de le faire avec aptitude .
Aptitude contient un solveur de dépendances ! - A installer, il n'est pas livré par défaut à l'installation :

apt-get install aptitude


aptitude update


aptitude install deluge



Si la résolution de dépendances ne te satisfait pas, tu peux lui répondre non, et le solveur va chercher une autres façon de faire .
Explore quelles solutions il te propose !

Pour les paquets hors dépôts officiels, dis nous lesquels ?, pour voir comment les installer ( peut être en compilant les sources et en en faisant un paquet avec checkinstall )

smile

Edit à toto :
Séparation des commandes indiquées et précision sur la commande ls.

Réponse à toto : d'accord, j'y penserai à séparer les commandes ! big_smile

Dernière modification par nono47 (04-03-2016 09:11:42)

Hors ligne

#11 06-03-2016 02:31:38

nazmi
Membre
Lieu : Normandie
Distrib. : GNU/LINUX Debian Jessie
Noyau : Linux 4.3.0-0.bpo.1-amd64
(G)UI : KDE/XFCE
Inscription : 17-07-2015

Re : [Résolu]Petit problème de mise à jour (python cffi manquant)

J'ai viré les dépots inutiles (OBS Studio, SimpleScreenRecorder et Jitsi), fait un

 apt-get update


FYPW3WY5fj8UysYr.png

aptitude était apparemment installé car j'ai eu 0 nouvellement installés, après j'ai fait aptitude install deluge et...

l'utilitaire console le meilleur que j'ai jamais utilisé, il m'a proposé plusieurs solutions, j'ai fait:
root@machine:~#

aptitude install deluge



Les NOUVEAUX paquets suivants vont être installés :    
  deluge deluge-common{a} deluge-gtk{a} python-cryptography{a} python-idna{a} python-openssl{a} python-service-identity{a} python-twisted-core{a} python-twisted-web{a}
0 paquets mis à jour, 9 nouvellement installés, 0 à enlever et 28 non mis à jour.
Il est nécessaire de télécharger 35,2 ko/2 653 ko d'archives. Après dépaquetage, 16,9 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 python-cffi-backend : Casse: python-cryptography (< 0.8.2-4~) mais 0.6.1-1 doit être installé.
Les actions suivantes permettront de résoudre ces dépendances :

     Conserver les paquets suivants dans leur version actuelle :
1)     deluge [Non installé]                                    
2)     deluge-common [Non installé]                            
3)     deluge-gtk [Non installé]                                
4)     python-cryptography [Non installé]                      
5)     python-openssl [Non installé]                            
6)     python-service-identity [Non installé]                  
7)     python-twisted-core [Non installé]                      
8)     python-twisted-web [Non installé]                        



Accepter cette solution ? [Y/n/q/?] n
Les actions suivantes permettront de résoudre ces dépendances :

     Supprimer les paquets suivants :                                          
1)     python-cffi-backend                                                    

     Réinstaller à une version antérieure les paquets suivants :              
2)     python-cffi [1.4.2-2~bpo8+1 (jessie-backports, now) -> 0.8.6-1 (stable)]



Accepter cette solution ? [Y/n/q/?] y
Les paquets suivants vont être RÉINSTALLÉS à une VERSION ANTÉRIEURE :
  python-cffi
Les NOUVEAUX paquets suivants vont être installés :
  deluge deluge-common{a} deluge-gtk{a} python-cryptography{a} python-idna{a} python-openssl{a} python-service-identity{a} python-twisted-core{a} python-twisted-web{a}
Les paquets suivants seront ENLEVÉS :
  python-cffi-backend{a}
0 paquets mis à jour, 9 nouvellement installés, 1 remis à une version antérieure, 1 à enlever et 28 non mis à jour.
Il est nécessaire de télécharger 35,2 ko/2 721 ko d'archives. Après dépaquetage, 16,7 Mo seront utilisés.
Voulez-vous continuer ? [Y/n/?] y
Prendre :  1 http://http.debian.net/debian/ jessie-backports/main python-idna all 2.0-3~bpo8+1 [35,2 kB]
 35,2 ko téléchargés en 0s (40,1 ko/s)
dpkg: python-cffi-backend : problème de dépendance, mais suppression comme demandé :
 python-cffi dépend de python-cffi-backend (<< 1.4.2-2~bpo8+1+c).
 python-cffi dépend de python-cffi-backend (>= 1.4.2-2~bpo8+1).
 python-cffi dépend de python-cffi-backend (<< 1.4.2-2~bpo8+1+c).
 python-cffi dépend de python-cffi-backend (>= 1.4.2-2~bpo8+1).

(Lecture de la base de données... 277809 fichiers et répertoires déjà installés.)
Suppression de python-cffi-backend (1.4.2-2~bpo8+1) ...
dpkg : avertissement : dégradation (« downgrade ») de python-cffi depuis 1.4.2-2~bpo8+1 vers 0.8.6-1
(Lecture de la base de données... 277805 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../python-cffi_0.8.6-1_amd64.deb ...
Dépaquetage de python-cffi (0.8.6-1) sur (1.4.2-2~bpo8+1) ...
Sélection du paquet python-cryptography précédemment désélectionné.
Préparation du dépaquetage de .../python-cryptography_0.6.1-1_amd64.deb ...
Dépaquetage de python-cryptography (0.6.1-1) ...
Sélection du paquet python-openssl précédemment désélectionné.
Préparation du dépaquetage de .../python-openssl_0.14-1_all.deb ...
Dépaquetage de python-openssl (0.14-1) ...
Sélection du paquet python-service-identity précédemment désélectionné.
Préparation du dépaquetage de .../python-service-identity_1.0.0-3_all.deb ...
Dépaquetage de python-service-identity (1.0.0-3) ...
Sélection du paquet python-twisted-core précédemment désélectionné.
Préparation du dépaquetage de .../python-twisted-core_14.0.2-3_all.deb ...
Dépaquetage de python-twisted-core (14.0.2-3) ...
Sélection du paquet python-twisted-web précédemment désélectionné.
Préparation du dépaquetage de .../python-twisted-web_14.0.2-3_all.deb ...
Dépaquetage de python-twisted-web (14.0.2-3) ...
Sélection du paquet deluge-common précédemment désélectionné.
Préparation du dépaquetage de .../deluge-common_1.3.10-3_all.deb ...
Dépaquetage de deluge-common (1.3.10-3) ...
Sélection du paquet deluge-gtk précédemment désélectionné.
Préparation du dépaquetage de .../deluge-gtk_1.3.10-3_all.deb ...
Dépaquetage de deluge-gtk (1.3.10-3) ...
Sélection du paquet deluge précédemment désélectionné.
Préparation du dépaquetage de .../deluge_1.3.10-3_all.deb ...
Dépaquetage de deluge (1.3.10-3) ...
Sélection du paquet python-idna précédemment désélectionné.
Préparation du dépaquetage de .../python-idna_2.0-3~bpo8+1_all.deb ...
Dépaquetage de python-idna (2.0-3~bpo8+1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.0.2-5) ...
Traitement des actions différées (« triggers ») pour mime-support (3.58) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.13-1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1) ...
Traitement des actions différées (« triggers ») pour menu (2.1.47) ...
Paramétrage de python-cffi (0.8.6-1) ...
Paramétrage de python-cryptography (0.6.1-1) ...
Paramétrage de python-openssl (0.14-1) ...
Paramétrage de python-service-identity (1.0.0-3) ...
Paramétrage de python-twisted-core (14.0.2-3) ...
Paramétrage de python-twisted-web (14.0.2-3) ...
Paramétrage de deluge-common (1.3.10-3) ...
Paramétrage de deluge-gtk (1.3.10-3) ...
Paramétrage de deluge (1.3.10-3) ...
Paramétrage de python-idna (2.0-3~bpo8+1) ...
Traitement des actions différées (« triggers ») pour menu (2.1.47) ...
 



depuis j'ai récupéré Deluge mais je ne vois pas bien quelles lecons tirer de tout ça, surtout au niveau des backports, de la gestion des mises à jour, de la sécurité de tout ça neutral

parceque je suis souvent confronté a des logiciels un peu vieux dispos par apt-get, est-ce que je dois rester à ça (ça m'allait jusqu'à maintenant et je pense que ça continuera)
dois-je bidouiller les dépendances avec aptitude  et les backports ?
Quel est le bilan au niveau de la stabilité de mon système et de la sécurité de tout ça (paquets non à jour surtout hmm )

Enfin pour les paquets que j'aimerais installer, j'ai OBS studio (apparemment il faut compiler depuis les sources), il me faut aussi un moyen de capturer mon bureau (simplescreen recorder ou autre, car le Action ! de Mirilis sous windows et sa simplicité/son efficacité me manque) et enfin le pilote d'une de mes imprimantes (Pentax PocketJet 3+) qu'il faut aussi installer depuis les sources, je vous en reparle dès que j'ai la tête de nouveau la dedans car ces derniers jours c'est surtout la mécanique d'une imprimante 3D et ses caprices qui m'occupe l'esprit mad

Merci beaucoup pour l'aide jusqu'à maintenant et merci d'avance

Edit à toto :
Pour facilité la lecture aux débutants, mis uniquement la commande dans la balise Commande root.

Dernière modification par nazmi (06-03-2016 02:36:25)

Hors ligne

#12 06-03-2016 04:10:28

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : [Résolu]Petit problème de mise à jour (python cffi manquant)

Salut,

La leçon a tirer de tout cela : c'est que si tu ajoutes des dépôt tiers ( non officiel ), il faut s'attendre à des problèmes de version dans les dépendances ! ( et ça vaut pour deb-multimedia ! ) smile
( ppa-launchpad (ubuntu) et debian ça va pas ensemble ! )

Pour installer des logiciels hors dépôt, oui ça peut être bien de télécharger les sources et d'en lire le readme ou le install qui sont des fichiers généralement présent ! cool

Si tu compile, plutôt qu'un make install, tu peux te servir de checkinstall qui t'en fera un paquet facile à administer !
( genre le supprimer, si tu veux le remplacer par une mise à jour ! )

Sinon tu ouvres un sujet par logiciel, et des connaisseurs devraient t'aider ! smile

Dernière modification par nono47 (06-03-2016 04:11:54)

Hors ligne

#13 06-03-2016 13:06:18

nazmi
Membre
Lieu : Normandie
Distrib. : GNU/LINUX Debian Jessie
Noyau : Linux 4.3.0-0.bpo.1-amd64
(G)UI : KDE/XFCE
Inscription : 17-07-2015

Re : [Résolu]Petit problème de mise à jour (python cffi manquant)

Salut,
Maintenant les mises à jour passent bien big_smile

mais est-ce que le problème de python-cffi était du aux dépôts bizarres que j'avais ?
Maintenant qu'ils ne sont plus là, est-ce que tout va rentrer dans l'ordre ?
Ok pour les sources, j'ai déjà réussi a installer le parser pour mon imprimante Seiko SLP à l'époque, je vais voir de plus près pour les autres logiciels et si j'ai besoin, j'ouvrirai des topics/

Merci beaucoup pour toute cette aide smile

Hors ligne

Pied de page des forums