Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-05-2009 20:52:33

Al67
Membre
Inscription : 11-05-2009

Ati Radeon HD 4350 : Problème Fréquences non supportées (Résolu)

Bonjour,

-J'ai ce problème qui me donne une prise de tête maximale à chaque redémarrage depuis que je tente l'installation du pilote propriétaire, et histoire de m'énerver un peu plus avec, je parviens pourtant à le faire fonctionner sur une Ubuntu 9.04 !

J'avais ce problème dès ma 1ère installation de Debian, mais avec le pilote vesa ça marche en modifiant le xorg.conf

J'ai fait une "installation minimale" de Debian depuis un "CD minimal".
J'ai les dépôts des 3 branches et un fichier préférence Testing > Stable > Sid.
Les paquets recommandés ne sont pas installés automatiquement.
J'ai donc une une Debian squeeze/sid et un kernel 2.6.26-2-686
J'ai kdm comme gestionnaire d'affichage.

-J'ai installer les pilotes de cette façon :

apt-get install fglrx-control fglrx-driver module-assistant
m-a a-i fglrx
invoke-rc.d kdm stop
modprobe -r radeon drm
modprobe fglrx
echo fglrx >> /etc/modules


Donc en essayant de suivre la procédure trouver ici :
http://wiki.debian.org/ATIProprietary

Toujours le même problème après plusieurs modifications de xorg.conf ; Et encore après avoir essayer aticonfig --initial -f

-Voici mon xorg.conf :

Section "ServerLayout"
  Identifier     "Default Layout"
  Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "InputDevice"
  Identifier  "Generic Keyboard"
  Driver      "kbd"
  Option      "XkbRules" "xorg"
  Option      "XkbModel" "pc105"
  Option      "XkbLayout" "fr"
  Option      "XkbVariant" "latin9"
  Option      "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
  Identifier  "Configured Mouse"
  Driver      "mouse"
EndSection

Section "Monitor"
  Identifier   "aticonfig-Monitor[0]-0"
  Option      "VendorName" "ATI Proprietary Driver"
  Option      "ModelName" "Generic Autodetecting Monitor"
  Option      "DPMS" "true"
  HorizSync 30.0 - 82.0
  VertRefresh 50.0 - 75.0

EndSection

Section "Device"
  Identifier  "aticonfig-Device[0]-0"
  Driver      "fglrx"
  BusID       "PCI:1:0:0"
EndSection

Section "Screen"
  Identifier "aticonfig-Screen[0]-0"
  Device     "aticonfig-Device[0]-0"
  Monitor    "aticonfig-Monitor[0]-0"
  DefaultDepth     24
  SubSection "Display"
    Viewport   0 0
    Depth     24
  Modes "1280x1024" "1024x768" "800x600"
  EndSubSection
EndSection


-Voila ce que me donne cat /home/al67/Xorg.0.log | grep EE (Je suis sur Ubuntu 9.04 après avoir recopier le log de Debian) :

al67@ubuntu-desktop:~$ cat /home/al67/Xorg.0.log | grep EE
  (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
al67@ubuntu-desktop:~$


J'ai essayer de mettre le log au complet ici :
https://pastebin.via.ecp.fr/483

-Enfin, j'ai un écran Lcd 17 pouces Acer AL1714

Donc de me demander si l'accélération graphique avec cette carte est possible ou bien si je dois laisser tomber ?

Dernière modification par Al67 (16-09-2009 18:44:56)

Hors ligne

#2 12-05-2009 04:07:47

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Ati Radeon HD 4350 : Problème Fréquences non supportées (Résolu)

Salut

Je ne connais pas les cartes ATI, donc je ne peux pas vraiment t'aider. Par contre, en lisant ton message je me dis que tu devrais être en mesure d'avoir l'accélération graphique sur ta debian si tu réussit à l'avoir sur ta ubuntu. Il faut voir ce qui est différent sur les deux distrib. : version du noyau, version du serveur X (xserver-xorg-video-ati), version du pilote 3D et, surtout, comparer les deux fichiers xorg.conf.

Désole de ne pouvoir être plus utile.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#3 12-05-2009 15:25:03

Al67
Membre
Inscription : 11-05-2009

Re : Ati Radeon HD 4350 : Problème Fréquences non supportées (Résolu)

Salut,

Bah merci tout de même de m'avoir répondu, et effectivement ça m'a l'air dur de trouver de l'aide pour les cartes ati (En français du moins), peut être parce que sur Linux nvidia semble avoir la préférences des utilisateurs.

Et c'est vrai que la ou je l'ai mauvaise, c'est d'arriver à faire fonctionner cette Radeon HD 4350 sur Ubuntu 9.04, mais pas sur ma Debian...

-Sinon Ubuntu 9.04 a un noyau 2.6.28-11-generic (2.6.26-2-686 sur ma debian).

Xorg est en version 7.4 sur Ubuntu (7.3 pour Debian)

Mais je ne comprends pas la numérotation du pilote sur Ubuntu, Sur Debian c'est assez simple :
J'ai fglrx-driver en version 1:9-2-2 (testing)
Sur Ubuntu je lis xorg-driver-fglrx en version 2:8.600-0ubuntu2: amd64 i386
Or je pensais que les pilotes propriétaires Ati étaient numérotés façon année / mois ?

Quant au xorg.conf, j'avais pensé a essayer celui d'Ubuntu sur Debian, hélas sans succès.
Bon au cas ou, je laisse ici celui de Ubuntu 9.04 :

Section "Monitor"
  Identifier  "Monitor0"
  Option    "DPMS" "true"
  HorizSync 30.0 - 82.0
  VertRefresh 50.0 - 75.0

EndSection

Section "Screen"
  Identifier  "Screen0"
  Monitor   "Monitor0"
  Device    "Videocard0"
  DefaultDepth  24
  Subsection "Display"
    Depth       8
    Modes  "1280x1024" "1024x768" "800x600" "640x480"
  EndSubsection
  Subsection "Display"
    Depth       16
    Modes  "1280x1024" "1024x768" "800x600" "640x480"
  EndSubsection
  Subsection "Display"
    Depth       24
    Modes  "1280x1024" "1024x768" "800x600" "640x480"
  EndSubsection
  Subsection "Display"
    Depth       32
    Modes  "1280x1024" "1024x768" "800x600" "640x480"
  EndSubsection
EndSection

Section "Module"
  Load  "glx"
EndSection

Section "Device"
  Identifier  "Videocard0"
  Driver    "fglrx"
  BusID   "PCI:1:0:0"
EndSection

Section "ServerLayout"
  Identifier  "Layout0"
  Screen    "Screen0"
EndSection


En résumé, je comprends pas où est ce que ça coince avec cette carte !

Dernière modification par Al67 (16-09-2009 18:19:25)

Hors ligne

#4 12-05-2009 18:03:26

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : Ati Radeon HD 4350 : Problème Fréquences non supportées (Résolu)

Salut Al67

Al67 a écrit :

Sinon Ubuntu 9.04 a un noyau 2.6.28-11-generic (2.6.26-2-686 sur ma debian)


Effectivement tu devrais peut-être choisir de passer en sid pour avoir un noyau qui correspondrait le plus à celui d'ubuntu.

Al67 a écrit :

Xorg est en version 7.4 sur Ubuntu (7.3 pour Debian)


De même pour le xorg.
Ubuntu est créé à partir de la version unstable (SID) de debian. Ceci explique pourquoi sur Ubuntu ça fonctionne.
Du coup il va falloir te coltiner la modification du fichier preferences.
Bon courage wink
Sur ce sujet martin_mtl maîtrise mieux que moi.
Moi j'ai choisi la version stable Lenny (C'est peut-être aussi que j'ai une carte Nvidia)

A bientôt


logo_3dminfographie_signature.png

Hors ligne

#5 12-05-2009 18:20:46

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Ati Radeon HD 4350 : Problème Fréquences non supportées (Résolu)

Wouap !

Il y a un tuto pour installer les sources.list sid/unstable et tout le toutim des preferences dans le wiki DF là :
http://debian-facile.org/wiki/doku.php? … on:sources

Et yop !

Amitié, Joel

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#6 23-06-2009 11:15:18

tomtom47
Membre
Distrib. : Squeeze / Sid
(G)UI : Gnome
Inscription : 12-06-2009

Re : Ati Radeon HD 4350 : Problème Fréquences non supportées (Résolu)

Salut ^^
je pense pouvoir t'aider, j'ai eu un souci avec ma ATI HD4850 et gràce a ce forum j'ai réussi a faire marcher ma debian en reconfigurant mon xserver.

le principe est de faire utiliser a ton xorg le driver radeon dans sa version issu de sid.
Pour cela il faut désinstaller l'ancien radeon ( si il est installé ) et le fglrx.
Ensuite il faudra télécharger le nouveau radeon à partir du dépots sid auquel tu aura accés car tu auras, au préalable, éditer ton sources.list.

Bon beh on va faire quelques vérification.

0 : on commence pâr stopper gnome:

/etc/init.d/gdm stop

1 : montre moi ton :

lspci |grep VGA


2:  si tout va bien et que ton pci est bien le même que celui de ton xorg,

apt-get remove --purge xserver-xorg-video-radeon

apt-get remove --purger fglrx

apt-get autoclean


3: modifi ton xorg afin d'afficher "radeon" a la place de fglrx

nano /etc/X11/xorg.conf


4: modifie ton sources.list et ajoute :

##sid     
deb http://ftp.fr.debian.org/debian/ sid main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ sid main contrib non-free

##squeeze     
deb http://ftp.fr.debian.org/debian/ squeeze main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ squeeze main contrib non-free


puis aprés tu fais un

apt-get update


.

5 a : Tu tape :

apt-cache madison paquet xserver-xorg-video-radeon
apt-get install -t sid xserver-xorg-video-radeon


normalement il te diron que tu ne peux pas l'installer a cause de la dépendance xorg-core ( je sais plus trés bien si c'est cet ortographe ) qui n'est pas installé.

5 b : tu feras alors :

apt-get install -t sid xorg-core ( ou le nom exact du paquet )


il te dira que l'installation ne peut se faire a cause de la dépendance "xorg" ( ou ch'ais plus trop le nom ^^' )qui n'est pas installé.

5 c :Donc remanip :

apt-get install -t sid xorg ( ou le nom exact du paquet )


et là, au miracle l'installation se déroule.

À la fin de celle-ci tu tente une

apt-get install -t sid xorg-core ( ou le nom du fichier qui manqué pour arriver a installer ton driver radeon )


et normalement ça te mettra qu'il est déja installé.
par précaution tu fais un

apt-get install -t sid xserver-xorg-video-radeon


et làà encore, enfin chez moi ^^, il te mettra qu'il est installé.

Donc voili voilou tu nous fais un bon petit

startx

et normalement je dis bien normalement t'auras ta première image debiannaise tongue



ps: j'ai surement du oublier des trucs donc n'hésitez pas a me le dire histoire qu'il ne fasse pas toutes ses manip' si il manque une des 1eres xD

plop ^^

Dernière modification par tomtom47 (23-06-2009 23:27:29)

Hors ligne

#7 08-07-2009 15:52:13

Al67
Membre
Inscription : 11-05-2009

Re : Ati Radeon HD 4350 : Problème Fréquences non supportées (Résolu)

Salut,

Alors je ne l'ai effectivement pas explicitement mentionné dans mon 1er message, mais le but était de faire fonctionner l'accélération 3d avec les pilotes propriétaires sur cette carte.

Au passage, la carte fonctionne parfaitement avec les pilotes libres disponibles dans Testing, sachant que j'ai les dépôts des 3 branches avec un fichier préférence Testing > Stable > Sid.
Je ne sais plus en revanche avec quel pilote précisément, étant donné que j'avais aussi essayé avec un fichier xorg.conf en ne mentionnant pas de pilote dans la section "Device".
Donc je ne saurais pas dire s'il utilisait un pilote "vesa" ou bien "radeonhd" ou encore "radeon".

Pour les pilotes propriétaires, il me faudrait au moins pouvoir essayer avec un Xorg en version 7.4, et bien entendu les pilotes disponibles dans les dépôts Sid, voire avec un noyau plus récent.

Mais pour passer à Xorg 7.4 en Testing, c'est la croix et la bannière, apparemment c'est même "laisse tomber".
Et ça ne m'intéresse pas de tester en Sid, Testing est ma distribution principale, si ça marche en Sid et que je ne peux pas en profiter sur ma Testing, à part un peu plus d'amertume, ça ne m'aura pas apporté grand chose...

Du coup, en attendant de me toper une éventuelle nouvelle carte, je me suis rabattu sur une Nvidia Gforce 7200 GS que je gardais en réserve.

a+

Hors ligne

#8 16-09-2009 18:43:21

Al67
Membre
Inscription : 11-05-2009

Re : Ati Radeon HD 4350 : Problème Fréquences non supportées (Résolu)

Salut,

Cette fois ça y est, ma carte Ati Radeon HD 4350 fonctionne correctement avec les pilotes propriétaires Fglrx ! smile smile smile

Et ce grâce à la mise à jour de Xorg passé en version 7.4

Voici les changements intervenues sur ma Debian Testing depuis le 1er message :

kernel désormais en version 2.6.30-1-686
xserver-xorg en version 7.4
fglrx en version 9-9

La procédure d'installation que j'ai suivie :

invoke-rc.d kdm stop
apt-get install fglrx-control fglrx-driver fglrx-source module-assistant
m-a a-i fglrx
modprobe -r radeon drm
modprobe fglrx
echo fglrx >> /etc/modules
apt-get install fglr-glx


Il faut au minimum renseigner ceci dans son xorg.conf :

Section "Device"
    Identifier  "ATI"
    Driver      "fglrx"
EndSection

Section "Screen"
    Identifier "Default Screen"
    DefaultDepth     24
EndSection


Puis on relance son environnement de bureau, et ça marche cool

En passant, la carte ATI Radeon HD 4350 à une architecture RV710, soit la même architecture que la carte ATI Radeon HD 4550.

Seul problème maintenant que je ne suis pas encore arrivé à résoudre, les effets de bureau avec KWin.
Ils fonctionnent, mais je dois les activer systématiquement à chaque redémarrage.

J'en ferais peut être un sujet séparé à l'occasion wink

@+

P.S. : Pour l'installation des pilotes, je préfère quitter l'environnement de bureau dès le début de la manipulation, c'est l'objet de  invoke-rc.d kdm stop, autrement j'avais des erreurs à l'installation (J'ai modifié le post en conséquence).
En principe pour l'environnement de bureau Gnome, ça se passe évidemment avec invoke-rc.d gdm stop wink

Dernière modification par Al67 (17-09-2009 00:00:06)

Hors ligne

#9 18-09-2009 17:44:00

Al67
Membre
Inscription : 11-05-2009

Re : Ati Radeon HD 4350 : Problème Fréquences non supportées (Résolu)

Re,

Bon alors pour que les effets de bureau soient actifs dès le démarrage de la session, autrement donc je devais les activer manuellement via la configuration du système, j'ai ajouté ceci à la fin de mon fichier xorg.conf :

Section "Extensions"
        Option "Composite" "Enable"
EndSection


Et la plus de souci cool

Tout au plus, après avoir rentré mes identifiant, je prends peut être 2 secondes de plus pour arriver sur ma session, mais à part ça c'est parfait wink

Hors ligne

#10 18-09-2009 20:30:42

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Ati Radeon HD 4350 : Problème Fréquences non supportées (Résolu)

Merci du retour et de la solution Al67 !

Amitié, Joel

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

Pied de page des forums