Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-03-2016 11:20:02

T.Bayle
Membre
Distrib. : Debian Jessie 8.3
Noyau : Linux 3.16.0-4-amd64
(G)UI : GNOME
Inscription : 29-02-2016

Problème graphique avec GNOME après installation des "VBOXADDITIONS".

Bonjours à tous, ceci est mon premier sujet sur ce site et je tenais tout d’abord à vous remercier pour l'immense aide qui m'a déjà été apporté au travers des autres sujets.


Mon problème est le suivant : Dès que je me log(je rentre le MdP de mon user au démarrage) l'interface graphique s'affole. Concrètement la fenêtre va se mettre à "clignoter" (d'ailleurs je ne sais pas si il existe un mot  technique pour décrire ce phénomène?) dès que je bouge le curseur de la souris de telle manière qu'il est impossible de travailler sur cet environnement. Petite précision: si je persévère, que j'arrive à ouvrir un terminal, que je fasses un "su root"+mdp et que j'éxécute un "startx", alors après qqes freeze/écrans noirs, je reviens sur mon bureau sans avoir de problème graphique.


Je vais maintenant expliquer la démarche que j'ai suivit qui m'a conduit vers ce problème.

- Je travaille sur une machine qui boot avec Windows XP sur laquelle est installé "Oracle VM VirtualBox"(version 5.0.14)fin de pouvoir virtualiser une machine sous Debian(je ne sais pas si mes expressions sont les bonnes mais j'espère me faire comprendre).
- J'ai donc créé une machine virtuelle en suivant correctement le manuel fourni par Oracle.
- J'ai installé Debian 8.3 Jessie (avec un CD qui contenait la "net-install"), via l'interface graphique, installé GNOME(j'ai juste coché la petite SmartBox durant l'installation de Debian).

Me voilà enfin sur mon bureau, tout se passe bien et j'était bien content de moi d'avoir installer un OS en moins d'une matinée! tongue

Il ne me restait plus qu'à configurer le dossier de partage entre Windows et Debian. Pour ce faire, Oracle nous fournie une image .iso pour installer les "VBOXADDITIONS" nécessaire au bon fonctionnement du dossier de partage.
Je me met donc dans ma console en root, exécute les commandes demander, la machine mouline un peu, on me demande de redémarrer, j’exécute, et lors de mon retour sur le bureau, le voilà qui se met à clignoter comme jamais.



J'espère avoir été claire dans mon explication, si cela n'a pas été le cas,  n'hésitez pas à me demander de préciser certains points.

Merci du temps que vous avez consacré,


Cordialement,
Terence BAYLE

Dernière modification par T.Bayle (02-03-2016 11:22:41)

Hors ligne

#2 02-03-2016 18:11:21

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : Problème graphique avec GNOME après installation des "VBOXADDITIONS".

Salut,

Je n'y connais rien en virtualbox, mais gnome-shell a besoin de l'accélération graphique pour bien fonctionner .
Le pilote libre devrait suffire : dans le wiki facile : ati ou nvidia
( il faut sans doute activer les dépôts non-free et contrib )

Indique le modèle de ta carte graphique pour savoir quel pilote installer ? smile

T.Bayle a écrit :

que je fasses un "su root"+mdp et que j'éxécute un "startx"


L'interface graphique n'est pas souhaitable en root : d'un clic de souris, tu peux casser ton système ! big_smile

Dernière modification par nono47 (02-03-2016 18:14:30)

Hors ligne

#3 02-03-2016 19:24:32

H2L29
Membre
Distrib. : Debian GNU/Linux unstable (stretch/sid)
Noyau : Linux 4.4.0-1-amd64
(G)UI : openbox
Inscription : 02-03-2016
Site Web

Re : Problème graphique avec GNOME après installation des "VBOXADDITIONS".

salut, je pense que au début tu utilisai gnome3 en fallback et qu'après l'installation des additions (as tu bien installé les linux-headers nécéssaires?) tu est passé sur gnome-shell avec la composition et là ça demande l'accélération graphique

donc d'abord voir s'il y a les linux-headers pour qu'il puisse compiler le module kernel tu peut aussi installer virtualbox-guest-additions directement via le gestionnaire de paquets

GIF001.GIF

Hors ligne

Pied de page des forums