Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-03-2016 14:04:43

Orsam999
Membre
Distrib. : Debian GNU/Linux 7.9 (Jessi)
Noyau : Linux 3.2.0-4-486
Inscription : 16-01-2015

URGENT ! PHPMyAdmin erreur 403

Bonjour à tous,

Je sollicite une nouvelle fois votre aide, car je me retrouve avec un problème curieux.

En effet, j'utilisais ma base de données (uniquement en local, donc non publique) sans aucuns problèmes.

Mais depuis quelques jours, ça ne fonctionne plus. J'ai une erreur 403 qui s'affiche, et impossible d’accéder à phpmyadmin.

Suite à ça, j'ai suivi les conseils d'un forum qui préconisé de modifier le fichier /etc/phpmyadmin/apache.conf et y mettre les instructions suivantes :

<Directory /usr/share/phpmyadmin>
        Options Indexes FollowSymLinks MultiViews
        DirectoryIndex index.php
        AllowOverride all
 



Suite à ça, tout est reparti... (quoi que je ne sais pas si phpmyadmin est toujours utilisable uniquement en local) Enfin, au moins quelques dizaines de minutes (chose curieuse) après être entré dans phpmyadmin, après un rafraichissement, l'erreur 403 est revenue...

Et je n'y accède de nouveau plus.

Auriez-vous une solution ??? (durable !! big_smile) et ultra rapide !!

Merci par avance pour votre aide.

Orsam

Dernière modification par Orsam999 (04-03-2016 07:45:13)


Celui qui ne progresse pas chaque jour, recule chaque jour.
Confucius

Hors ligne

#2 03-03-2016 21:57:23

leonlemouton
Adhérent(e)
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate 1.8.1
Inscription : 14-08-2012

Re : URGENT ! PHPMyAdmin erreur 403

Salut,

Moi je ferai un truc comme ça :

AllowOverride all
Order Deny,Allow
Deny from all
Allow from 127.0.0.1
Allow from L'IPDETAMACHINE



Un peu d'explications:
AllowOverride : Lorsque cette directive est définie à All, toute directive valable dans le Contexte .htaccess sera autorisée dans les fichiers .htaccess. Inutile si pas de fichier .htaccess...

Order : La directive Order, associée aux directives Allow et Deny, implémente un système de contrôle d'accès en trois passes. Au cours de la première passe, ce sont soit toutes les directives Allow, soit toutes les directives Deny qui sont traitées, selon la définition de la directive Order. Le reste des directives (Deny ou Allow) est traité au cours de la seconde passe. La troisième passe s'applique à toutes les requêtes qui ne sont concernées par aucune des deux premières passes.

Deny : Définit quels hôtes ne sont pas autorisés à accéder au serveur

Allow : Spécifie quels hôtes peuvent accéder à une certaine zone du serveur

Source : https://httpd.apache.org/docs/2.4/fr/mo … tives.html

Quel forum as tu suivi ?

à confirmer par un expert...

Bon courage... smile

Dernière modification par leonlemouton (04-03-2016 23:51:15)


Leonlemouton
°(")°

Hors ligne

#3 03-03-2016 22:31:18

Orsam999
Membre
Distrib. : Debian GNU/Linux 7.9 (Jessi)
Noyau : Linux 3.2.0-4-486
Inscription : 16-01-2015

Re : URGENT ! PHPMyAdmin erreur 403

Bonjour leonlemouton,

Et merci tout fonctionne maintenant correctement. Au sujet du forum, je n'ai pas gardais l'adresse quand j'ai vu que ça fonctionné de nouveau. Mais hélas, ça a replanté après quelques minutes.

Un grand merci pour ton aide.  big_smile

Orsam

Celui qui ne progresse pas chaque jour, recule chaque jour.
Confucius

Hors ligne

#4 03-03-2016 22:50:25

leonlemouton
Adhérent(e)
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate 1.8.1
Inscription : 14-08-2012

Re : URGENT ! PHPMyAdmin erreur 403


Leonlemouton
°(")°

Hors ligne

#5 04-03-2016 07:51:17

Orsam999
Membre
Distrib. : Debian GNU/Linux 7.9 (Jessi)
Noyau : Linux 3.2.0-4-486
Inscription : 16-01-2015

Re : URGENT ! PHPMyAdmin erreur 403

Bonjour,

C'est reparti, j'ai de nouveau l'erreur 403 ! alors que tout fonctionné hier (avec les paramètres que tu m'avais donné). Après ces modifications, j'avais redémarré mon serveur et tout fonctionné bien.

Pour info, mon PC de travail, ainsi que mon serveur ne change jamais d'ip internes (192.168.1. etc...) leurs adresses MAC sont enregistrées sur mon routeur. Donc je ne vois pas d’où peut venir le problème.

Pour Info j'ai essayé ça :
Dans le fichier /etc/phpmyadmin/apache.conf j'ai mis "Deny from all" en commentaire !
et j'ai mis "Allow from all". J'ai ensuite redémarré mon serveur. Mais toujours rien !!!

Une autre idée ??

Merci encore pour ton aide.

Orsam

Dernière modification par Orsam999 (04-03-2016 08:06:52)


Celui qui ne progresse pas chaque jour, recule chaque jour.
Confucius

Hors ligne

#6 04-03-2016 21:19:58

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

Re : URGENT ! PHPMyAdmin erreur 403

Salut,

Dans ma config, je n'ai ni Allow, ni Deny.

Tu redémarres bien apache à chaque modif ?

Dernière modification par Papadakis (04-03-2016 21:20:28)


Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#7 04-03-2016 23:50:35

leonlemouton
Adhérent(e)
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate 1.8.1
Inscription : 14-08-2012

Re : URGENT ! PHPMyAdmin erreur 403

Il ne faut jamais vendre la peau de l'ours... Pas encore pour cette fois le point choco... sad

Quelle est ta version d'apache ?

apache2ctl -v


Quels modules sont activés ?

apache2ctl -M

Dernière modification par leonlemouton (04-03-2016 23:50:58)


Leonlemouton
°(")°

Hors ligne

#8 05-03-2016 07:57:11

Orsam999
Membre
Distrib. : Debian GNU/Linux 7.9 (Jessi)
Noyau : Linux 3.2.0-4-486
Inscription : 16-01-2015

Re : URGENT ! PHPMyAdmin erreur 403

salut Papadakis, Et merci pour ta réponse !

Oui j'ai même redémarré mon serveur plusieurs fois ! roll

leonlemouton,

Voici ma version d'apache :

Server version: Apache/2.2.22 (Debian)
Server built:   Aug 18 2015 10:17:37



Et voici les modules :

Loaded Modules:
 core_module (static)
 log_config_module (static)
 logio_module (static)
 version_module (static)
 mpm_prefork_module (static)
 http_module (static)
 so_module (static)
 alias_module (shared)
 auth_basic_module (shared)
 authn_file_module (shared)
 authz_default_module (shared)
 authz_groupfile_module (shared)
 authz_host_module (shared)
 authz_user_module (shared)
 autoindex_module (shared)
 cgi_module (shared)
 deflate_module (shared)
 dir_module (shared)
 env_module (shared)
 fcgid_module (shared)
 mime_module (shared)
 security2_module (shared)
 negotiation_module (shared)
 php5_module (shared)
 proxy_html_module (shared)
 reqtimeout_module (shared)
 rewrite_module (shared)
 setenvif_module (shared)
 status_module (shared)
 unique_id_module (shared)
Syntax OK
 



Ce qui est curieux, c'est que des fois, ça fonctionne très bien, et d'un seul coup, impossible de d'aceder à la page de connexion phpmyadmin à cause de l'erreur 403.

Merci pour votre aide à tous les deux.

Orsam


Celui qui ne progresse pas chaque jour, recule chaque jour.
Confucius

Hors ligne

#9 05-03-2016 15:58:00

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

Re : URGENT ! PHPMyAdmin erreur 403

Tu as quoi dans /etc/apache2/conf.d/phpmyadmin.conf ?

Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#10 08-03-2016 20:53:12

Orsam999
Membre
Distrib. : Debian GNU/Linux 7.9 (Jessi)
Noyau : Linux 3.2.0-4-486
Inscription : 16-01-2015

Re : URGENT ! PHPMyAdmin erreur 403

Bonsoir Papadakis,

Voici le contenu de mon fichier :


Alias /phpmyadmin /usr/share/phpmyadmin

<Directory /usr/share/phpmyadmin>
        Options FollowSymLinks
        DirectoryIndex index.php
        <IfModule mod_php5.c>
                AddType application/x-httpd-php .php
                php_flag magic_quotes_gpc Off
                php_flag track_vars On
                php_flag register_globals Off
                php_admin_flag allow_url_fopen Off
                php_value include_path .
                php_admin_value upload_tmp_dir /var/lib/phpmyadmin/tmp
                php_admin_value open_basedir /usr/share/phpmyadmin/:/etc/phpmyadmin/:/var/lib/phpmyadmin/
        </IfModule>

</Directory>

# Authorize for setup
<Directory /usr/share/phpmyadmin/setup>
    <IfModule mod_authn_file.c>
    AuthType Basic
    AuthName "phpMyAdmin Setup"
    AuthUserFile /etc/phpmyadmin/htpasswd.setup
    </IfModule>
    Require valid-user
</Directory>

# Disallow web access to directories that don't need it
<Directory /usr/share/phpmyadmin/libraries>
    Order Deny,Allow
    Deny from All
</Directory>
<Directory /usr/share/phpmyadmin/setup/lib>
    Order Deny,Allow
    Deny from All
</Directory>

 



Ca te parle ?? big_smile

Orsam


Celui qui ne progresse pas chaque jour, recule chaque jour.
Confucius

Hors ligne

Pied de page des forums