Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-03-2016 12:15:44

Zinzin
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : gnome
Inscription : 03-03-2016

[RESOLU] Point d'exclamation absent

Bonjour,
je débarque sur debian alors ma question à sûrement une réponse toute simple mais... je me suis lancé dans du traitement de texte ce matin et impossible de taper le point d'exclamation >< un logo genre stationnement interdit s'affiche sur mon écran lorsque je presse la fameuse touche hmm
mini_266912logonon.jpg

Si vous avez des idées je suis preneur smile

Dernière modification par Zinzin (05-03-2016 18:08:21)


Tout ce qui est .rar est share !

Hors ligne

#2 04-03-2016 12:33:05

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [RESOLU] Point d'exclamation absent

tu utilises quel éditeur ?

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 04-03-2016 12:39:30

Zinzin
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : gnome
Inscription : 03-03-2016

Re : [RESOLU] Point d'exclamation absent

Celui de base LibreOffice mais je viens de tester, je peux le faire nul part, terminal, navigateur, ...

Tout ce qui est .rar est share !

Hors ligne

#4 04-03-2016 12:54:55

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [RESOLU] Point d'exclamation absent

peux être que ton clavier est mal configuré ?

En ligne

#5 04-03-2016 12:57:22

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : [RESOLU] Point d'exclamation absent

Bonjour,
C'est très curieux, tu as peut-être un problème de définition du
clavier. Si tu utilises un clavier azerty (c'est à dire un clavier
français) tu peux essayer de faire dans un terminal :


setxkbmap fr
 


Ça permet de dire à Xorg que c'est un clavier français qui lui cause.

Il se peut que cela ne fonctionne pas si tu utilises gnome3 (en fait,
je n'en sais rien, mais il me semble qu'il y a une façon spécifique de
faire pour gnome3).

Ça ne réglera pas le problème de façon définitive, c'est juste pour
savoir si ça vient de là.


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#6 04-03-2016 13:03:04

Zinzin
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : gnome
Inscription : 03-03-2016

Re : [RESOLU] Point d'exclamation absent


setxkbmap fr
 



ne donne aucun retour et malheureusement ne change rien hmm

Pour ce qui est de ma config clavier je suis sur d'avoir choisi France -> Français
sauf s'il fallait prendre variante obsolète ??


Tout ce qui est .rar est share !

Hors ligne

#7 04-03-2016 13:05:34

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [RESOLU] Point d'exclamation absent

Salut smile

Je penserais à une histoire de clavier comme mes camarades du dessus wink

Une autre piste à suivre après celle d'enicar (il faut faire les chose avec méthode, commence par suivre sa piste wink ) : si tu utilises un portable, n'y aurait-il pas une touche Fn qui permet de modifier les touches du clavier (pour avoir un pavé numérique ou accéder aux touches interagissant avec le matériel) qui resterait active ?

Sinon, pour poursuivre dans la voie d'enicar, que donne

setxkbmap -print


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

En ligne

#8 04-03-2016 13:21:31

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : [RESOLU] Point d'exclamation absent

Zinzin a écrit :

ne donne aucun retour et malheureusement ne change rien hmm


Je ne te l'avais pas dit, mais de toute façon cette commande ne retourne rien. Par contre
si elle ne fait rien, c'est plus embêtant, et même pas normal.

Au fait quel environnement graphique utilises-tu ?

EDIT: Ah ! Pardon, en lisant ton profil de distribution, j'ai vu que tu utilises gnome wink
Et je ne sais pas comment on fait avec gnome, ça confirme aussi ce que je craignais…

Dernière modification par enicar (04-03-2016 13:25:08)


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#9 04-03-2016 13:53:28

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : [RESOLU] Point d'exclamation absent

Salut,

Peut être aussi un :

dpkg-reconfigure locales


pour reconfigurer les caractères disponibles .

Mais bon, si setxkbmap fr n'a pas fonctionné ! ... hmm

Dernière modification par nono47 (04-03-2016 13:55:46)

Hors ligne

#10 04-03-2016 14:04:53

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : [RESOLU] Point d'exclamation absent

nono47 a écrit :

Mais bon, si setxkbmap fr n'a pas fonctionné ! ... hmm


Ça ne veut rien dire… Ça peut aussi venir de locales mal définies.


@zinzin: Je viens de penser à autre chose pour déterminer si c'est la configuration du clavier qui est cause.
Tu peux nous transmettre le résultat de la commande :


cat /etc/default/keyboard
 



Par contre, je ne sais pas  quel est le paquet qui gère ce fichier… À moins qu'il soit créé à l'installation et
ne soit pas créé/géré par un paquet…


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#11 04-03-2016 14:20:16

Zinzin
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : gnome
Inscription : 03-03-2016

Re : [RESOLU] Point d'exclamation absent

@bendia
-> J'utilise effectivement un portable mais avec un clavier déporter donc je ne touche pas au clavier physique du pc

-> voici le retour de la commande :


xkb_keymap {
  xkb_keycodes  { include "evdev+aliases(azerty)" };
  xkb_types     { include "complete"  };
  xkb_compat    { include "complete"  };
  xkb_symbols   { include "pc+fr(latin9)+us:2+fr(oss):3+inet(evdev)"  };
  xkb_geometry  { include "pc(pc105)" };
};
 




@nono47
cela fonctionne mais je ne sais pas quoi cocher après hmm
mini_248163nono.jpg


@enicar
oui bien sur, voilà :


# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="fr"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"
 




J’espère que vous savez l'interpreter par ce que moi je suis perdu ><


Tout ce qui est .rar est share !

Hors ligne

#12 04-03-2016 14:55:30

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : [RESOLU] Point d'exclamation absent

zinzin a écrit :

… impossible de taper le point d'exclamation …

Essaye avec la commande xev (dans une fenêtre d'émulateur de terminal) pour savoir ce que retourne la touche censée te donner un caractère !

xev


Voici l'extrait concernant ce que retourne cette touche sur ma machine quand j'appuie dessus et que je la relâche :

KeyPress event, serial 34, synthetic NO, window 0x1c00001,
    root 0x284, subw 0x0, time 14896252, (-156,-475), root:(715,0),
    state 0x10, keycode 61 (keysym 0x21, exclam), same_screen YES,
    XLookupString gives 1 bytes: (21) "!"
    XmbLookupString gives 1 bytes: (21) "!"
    XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x1c00001,
    root 0x284, subw 0x0, time 14896316, (-156,-475), root:(715,0),
    state 0x10, keycode 61 (keysym 0x21, exclam), same_screen YES,
    XLookupString gives 1 bytes: (21) "!"
    XFilterEvent returns: False
 

Pour fermer la fenêtre qui s'affichera tu peux utiliser la souris ou Alt-F4

Dernière modification par MicP (04-03-2016 14:56:44)

Hors ligne

#13 04-03-2016 15:13:09

Zinzin
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : gnome
Inscription : 03-03-2016

Re : [RESOLU] Point d'exclamation absent

xev


il y a beaucoup de truc qui s'affiche avant même que je test le point d'exclamation, du coup je l'affiche en deux parties
avant :


Outer window is 0x1a00001, inner window is 0x1a00002

PropertyNotify event, serial 8, synthetic NO, window 0x1a00001,
    atom 0x27 (WM_NAME), time 21370096, state PropertyNewValue

PropertyNotify event, serial 9, synthetic NO, window 0x1a00001,
    atom 0x22 (WM_COMMAND), time 21370096, state PropertyNewValue

PropertyNotify event, serial 10, synthetic NO, window 0x1a00001,
    atom 0x28 (WM_NORMAL_HINTS), time 21370096, state PropertyNewValue

CreateNotify event, serial 11, synthetic NO, window 0x1a00001,
    parent 0x1a00001, window 0x1a00002, (10,10), width 50, height 50
border_width 4, override NO

PropertyNotify event, serial 14, synthetic NO, window 0x1a00001,
    atom 0x14c (WM_PROTOCOLS), time 21370097, state PropertyNewValue

MapNotify event, serial 15, synthetic NO, window 0x1a00001,
    event 0x1a00001, window 0x1a00002, override NO

ConfigureNotify event, serial 28, synthetic NO, window 0x1a00001,
    event 0x1a00001, window 0x1a00001, (0,0), width 178, height 178,
    border_width 0, above 0x1e005d0, override NO

PropertyNotify event, serial 28, synthetic NO, window 0x1a00001,
    atom 0x1d0 (_NET_WM_ALLOWED_ACTIONS), time 21370099, state PropertyNewValue

ReparentNotify event, serial 29, synthetic NO, window 0x1a00001,
    event 0x1a00001, window 0x1a00001, parent 0x1205432,
    (0,0), override NO

PropertyNotify event, serial 29, synthetic NO, window 0x1a00001,
    atom 0x151 (_NET_FRAME_EXTENTS), time 21370103, state PropertyNewValue

ConfigureNotify event, serial 29, synthetic NO, window 0x1a00001,
    event 0x1a00001, window 0x1a00001, (10,47), width 178, height 178,
    border_width 0, above 0x0, override NO

PropertyNotify event, serial 30, synthetic NO, window 0x1a00001,
    atom 0x154 (_NET_WM_DESKTOP), time 21370145, state PropertyNewValue

PropertyNotify event, serial 31, synthetic NO, window 0x1a00001,
    atom 0x1a2 (WM_STATE), time 21370146, state PropertyNewValue

PropertyNotify event, serial 31, synthetic NO, window 0x1a00001,
    atom 0x15a (_NET_WM_STATE), time 21370146, state PropertyNewValue

ConfigureNotify event, serial 33, synthetic YES, window 0x1a00001,
    event 0x1a00001, window 0x1a00001, (1247,131), width 178, height 178,
    border_width 2, above 0x0, override NO

PropertyNotify event, serial 33, synthetic NO, window 0x1a00001,
    atom 0x15a (_NET_WM_STATE), time 21370226, state PropertyNewValue

MapNotify event, serial 33, synthetic NO, window 0x1a00001,
    event 0x1a00001, window 0x1a00001, override NO

VisibilityNotify event, serial 33, synthetic NO, window 0x1a00001,
    state VisibilityUnobscured

Expose event, serial 33, synthetic NO, window 0x1a00001,
    (0,0), width 178, height 10, count 3

Expose event, serial 33, synthetic NO, window 0x1a00001,
    (0,10), width 10, height 58, count 2

Expose event, serial 33, synthetic NO, window 0x1a00001,
    (68,10), width 110, height 58, count 1

Expose event, serial 33, synthetic NO, window 0x1a00001,
    (0,68), width 178, height 110, count 0

FocusIn event, serial 33, synthetic NO, window 0x1a00001,
    mode NotifyNormal, detail NotifyNonlinear

KeymapNotify event, serial 33, synthetic NO, window 0x0,
    keys:  68  0   0   0   0   0   0   0   0   0   0   0   0   0   0   0  
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0  

PropertyNotify event, serial 33, synthetic NO, window 0x1a00001,
    atom 0x15a (_NET_WM_STATE), time 21370239, state PropertyNewValue

PropertyNotify event, serial 33, synthetic NO, window 0x1a00001,
    atom 0x15a (_NET_WM_STATE), time 21370239, state PropertyNewValue
 


après :

FocusOut event, serial 33, synthetic NO, window 0x1a00001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 33, synthetic NO, window 0x1a00001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 33, synthetic NO, window 0x0,
    keys:  0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0  
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0  

ClientMessage event, serial 33, synthetic YES, window 0x1a00001,
    message_type 0x14c (WM_PROTOCOLS), format 32, message 0x14a (WM_DELETE_WINDOW)

Dernière modification par Zinzin (04-03-2016 15:18:13)


Tout ce qui est .rar est share !

Hors ligne

#14 04-03-2016 15:58:57

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [RESOLU] Point d'exclamation absent

Zinzin a écrit :

Pour ce qui est de ma config clavier je suis sur d'avoir choisi France -> Français
sauf s'il fallait prendre variante obsolète ??


Normalement, l'agencement Français Français Variante convient à un clavier AZERTY classique tels que vendus en France (touche ² en haut à gauche sous Echap).

Pour activer cette variante tu peux essayer :

setxkbmap -option kpdl:kposs



Si rien de tout cela ne fonctionne mais que toutes les autres touches de ton clavier, à l'exception de " ! ", ont le comportement attendu, il faudrait voir si elle n'est pas endommagée physiquement.


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#15 04-03-2016 16:04:41

Zinzin
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : gnome
Inscription : 03-03-2016

Re : [RESOLU] Point d'exclamation absent

@sogal
aucun effet ><

J'ai testé deux claviers en plus du clavier physique du pc, le truc c'est que la touche fonctionne puisque je peut faire "¡" avec [alt gr] et "§" avec [shift] de plus le système réagi puisque lorsque je presse la touche ce logo apparaît en gros sur mon écran comme si la touche était interdite... hmm

Tout ce qui est .rar est share !

Hors ligne

#16 04-03-2016 16:07:26

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU] Point d'exclamation absent

Je n'y connais rien, mais ça ne pourrait pas être un raccourci clavier défini quelque part ?

Hors ligne

#17 04-03-2016 16:13:57

Zinzin
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : gnome
Inscription : 03-03-2016

Re : [RESOLU] Point d'exclamation absent

possible j'ai vus qu'on peut remapper ses touches clavier avec xkeycaps mais je n'ai pas trouver de tuto pour le faire...

EDIT : j'ai trouver comment utiliser xkeycaps en mod graphique, oui je sais je triche mais bon... du coup j'ai reset la touche et réassigné mais toujours ce logo de m**** qui s'affiche à la place du point d'exclamation sad

EDIT2 : bon j'ai trouvé une "solution" j'ai map mon "!" sur [shift]+[!] pas tip top mais comme je me sert pas de l'autre symbole... par contre si vous êtes ok pour finir d'explorer vos pistes avant de fermer le topic histoire de voir si on trouve une vraie solution c'est sympa smile

Dernière modification par Zinzin (04-03-2016 16:45:48)


Tout ce qui est .rar est share !

Hors ligne

#18 04-03-2016 17:17:45

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : [RESOLU] Point d'exclamation absent

pour dpkg-reconfigure locales, tu déroules la liste jusqu'à fr_FR.UTF-8 UTF-8
1457104526.png
(en principe, il devrait déjà être coché, mais ça ne mange pas de pain de vérifier )

Dernière modification par nono47 (04-03-2016 17:18:25)

Hors ligne

#19 04-03-2016 17:22:10

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [RESOLU] Point d'exclamation absent

Le logo en question sous gnome je crois qu'il correspond à la commande Play quand il n'y a pas de CD dans le lecteur.
Tu devrais regarder les raccourcis claviers définis par Gnome et voir si ! est défini quelque part dans les raccourcis.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#20 04-03-2016 19:28:15

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : [RESOLU] Point d'exclamation absent

Bizarre : Dans ton retour de la commande xev, je ne vois rien qui puisse concerner l’appui ou le relâchement d'une touche du clavier.

As-tu bien appuyé sur la touche qui te permet d'entrer un point d'exclamation après avoir lancé la commande xev ?
EDIT : Car effectivement, je ne l'avais pas clairement spécifié dans mon précédent message.

=======
Sinon, la ligne de commande qui suit limitera les retours aux seuls appuis et relâchements de touche.
Lance cette ligne de commandes, et une fois lancée, appuie sur la touche que tu utilise pour obtenir un point d'exclamation.

xev | sed -e '/./{H;$!d;}' -e 'x;/Key[PR]/!d;'

Merci.

Dernière modification par MicP (22-09-2016 23:21:05)

Hors ligne

#21 04-03-2016 20:24:27

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : [RESOLU] Point d'exclamation absent

@MicP chouette ta commande sed wink

La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#22 04-03-2016 22:23:42

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian Jessie 8.6
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome 3.14
Inscription : 29-04-2015

Re : [RESOLU] Point d'exclamation absent

Hello

Sous gnome j'ai eu un souci similaire ou le clavier "Français"par défaut de gnome ne correspond pas au standard des claviers de PC.

Essaye d'aller dans le menu "pays & langue" (appuie sur la touche de raccourci "logo" celle qui ressemble à une fenêtre puis tape "pays ")
Une fois dans le menu il faut que tu ajoutes en source d'entrée le "Français (variante)". Tu peux visualiser la disposition des touches avec le petit icône en forme de clavier. S'il correspond à celui de ton clavier tu peux supprimer la source "Français".

Hors ligne

#23 05-03-2016 05:42:55

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : [RESOLU] Point d'exclamation absent

@ enicar Merci pour l'appréciation.

Hors ligne

#24 05-03-2016 18:06:25

Zinzin
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : gnome
Inscription : 03-03-2016

Re : [RESOLU] Point d'exclamation absent

désolé pour l'absence j'étais en soirée hier smile

ok je le sens coup la réponse est toute simple hmm  captnfab à raison la touche "!" étais prévue par defaut dans les raccourcis multimédia pour faire pause >< je viens de virer le raccourcis et tout fonctionne parfaitement smile

merci à tous pour votre temps et votre aide !!!!!!!!! (t'as vu maintenant je peux en faire plein !!!!!!!!! ><)
encore merci smile

Tout ce qui est .rar est share !

Hors ligne

#25 05-03-2016 18:09:16

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [RESOLU] Point d'exclamation absent


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums