Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-05-2009 08:27:10

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

copie de mes documents sur le PC d'à coté (résolu)

Bonjour,
Je cherche à sauvegarder mes documents d'un PC "aspire" sous ubuntu 8.04 sur mon PC "jean" sous debian lenny :
Le PC dont les documents sont à sauvegarder fonctionne bien sur un autre PC client Ubuntu du partage NFS.

j'ai bien téléchargé le paquet "nfs-common" sur le client Lenny et créé un répertoire  /media/nfs

voici le script nfs.sh placé sur le bureau du client qui permet la copie :

#!/bin/bash
SOURCE_DIRS=/media/nfs/
TARGET_DIR=/home/jean/documents
# monter le repertoire nfs
mount /media/nfs

rsync -av --del --stats $SOURCE_DIRS "$TARGET_DIR"

umount /media/nfs

echo "Backup Terminé"


sur Ubuntu qui était l'ancien OS de ce PC je glissais le script dans le terminal gnome et appuyais sur entrée.

Mais sur Lenny ça ne marche pas.
Comment puis-je lancer ce script ? Le plus siomple : Je vais essayer d'installer "gnome-terminal"

Dernière modification par jrev (12-05-2009 20:03:55)


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#2 12-05-2009 13:45:58

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : copie de mes documents sur le PC d'à coté (résolu)

Le script se lance bien dans gnome-terminal mais voicila réponse :

jean@jean:~$ '/home/jean/Desktop/nfs.sh'
[mntent]: line 9 in /etc/fstab is bad
mount: can't find /media/nfs in /etc/fstab or /etc/mtab
sending incremental file list
./
rsync: failed to set times on "/home/jean/documents/.": Operation not permitted (1)

Number of files: 1
Number of files transferred: 0
Total file size: 0 bytes
Total transferred file size: 0 bytes
Literal data: 0 bytes
Matched data: 0 bytes
File list size: 17
File list generation time: 0.013 seconds
File list transfer time: 0.000 seconds
Total bytes sent: 29
Total bytes received: 15

sent 29 bytes  received 15 bytes  88.00 bytes/sec
total size is 0  speedup is 0.00
rsync error: some files could not be transferred (code 23) at main.c(1058) [sender=3.0.3]
umount: /media/nfs is not mounted (according to mtab)
Backup Terminé
jean@jean:~$


et voici fstab :

jean@jean:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda1       /               ext3    errors=remount-ro 0       1
/dev/hda6       /home           ext3    defaults        0       2
/dev/hda5       none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0
192.168.0.1:/home/jean/documents /media/nfs nfs ro,user,no auto 0       0


Debian plus dur qu'Ubuntu ?

Dernière modification par jrev (12-05-2009 13:55:26)


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#3 12-05-2009 18:16:55

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : copie de mes documents sur le PC d'à coté (résolu)

Re jrev

Je ne comprends pas ce qu'effectue la commande

'/home/jean/Desktop/nfs.sh'


Désolé je ne connais pas nfs.

Par contre dans le message qu'il t'envoie

[mntent]: line 9 in /etc/fstab is bad
mount: can't find /media/nfs in /etc/fstab or /etc/mtab


Il me semble qu'il n'arrive pas à trouver le répertoire nfs dans /media/
Execute la commande

ls /media/


Si tu ne vois pas le répertoire nfs alors positionne ton curseur sur /media/
Et créé le dossier avec la commande

mkdir nfs


Il doit peut-être falloir lui donner tous les droits à ce dossier :

chmod 777 nfs


Dans ton fichier /etc/fstab
La ligne correspondant à nfs est

192.168.0.1:/home/jean/documents /media/nfs nfs ro,user,no auto 0       0


Tiens nous au courant !

@+
damo


logo_3dminfographie_signature.png

Hors ligne

#4 12-05-2009 20:03:19

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : copie de mes documents sur le PC d'à coté (résolu)

Une petite erreur à la ligne 9 du fstab plus le dossier Documents qui se trouvait être en root et cela suffit pour tout enrayer...
Résolu, mes docs sont maintenant sauvegardés sur la Lenny !
ça progresse tongue

Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

Pied de page des forums