Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-03-2016 09:49:55

tuxdotnet
Membre
Inscription : 09-03-2016

Installation impossible sur debian 6.0.10 de php5

Bonjour

J'ai un serveur squeeze sur lequel je dois installer php5, mais impossible d'installer php5 :

/etc/apt/sources.list



deb http://ftp.fr.debian.org/debian/ squeeze-lts main contrib non-free
deb http://ftp.fr.debian.org/debian/squeeze-updates main contrib non-free
deb http://security.debian.org/squeeze/updates main contrib non-free



apt-get install php5



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 php5 : Dépend: libapache2-mod-php5 (>= 5.3.3.1-7+squeeze29) mais ne sera pas installé ou
                 libapache2-mod-php5filter (>= 5.3.3.1-7+squeeze29) mais ne sera pas installé ou
                 php5-cgi (>= 5.3.3.1-7+squeeze29) mais ne sera pas installé
E: Paquets défectueux





aptitude install php5



Les NOUVEAUX paquets suivants vont être installés :
  apache2-mpm-prefork{a} apache2-utils{ab} apache2.2-bin{ab} apache2.2-common{a} libapache2-mod-php5{ab} libapr1{a} php5 php5-cli{ab} php5-common{a}
0 paquets mis à jour, 9 nouvellement installés, 0 à enlever et 114 non mis à jour.
Il est nécessaire de télécharger 8 222 ko d'archives. Après dépaquetage, 22,3 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
  apache2-utils: Dépend: libaprutil1 (>= 1.2.7+dfsg) qui est un paquet virtuel
  apache2.2-bin: Dépend: libaprutil1 (>= 1.3.2+dfsg) qui est un paquet virtuel
                 Dépend: libaprutil1-dbd-sqlite3 qui est un paquet virtuel ou
                          libaprutil1-dbd-mysql qui est un paquet virtuel ou
                          libaprutil1-dbd-odbc qui est un paquet virtuel ou
                          libaprutil1-dbd-pgsql qui est un paquet virtuel ou
                          libaprutil1-dbd-freetds qui est un paquet virtuel
                 Dépend: libaprutil1-ldap qui est un paquet virtuel
  php5-cli: Dépend: libonig2 (>= 5.2.0) qui est un paquet virtuel
            Dépend: libqdbm14 (>= 1.8.74) qui est un paquet virtuel
  libapache2-mod-php5: Dépend: libonig2 (>= 5.2.0) qui est un paquet virtuel
                       Dépend: libqdbm14 (>= 1.8.74) qui est un paquet virtuel
Les actions suivantes permettront de résoudre ces dépendances :

    Conserver les paquets suivants dans leur version actuelle :
1)     apache2-mpm-prefork [Non installé]
2)     apache2-utils [Non installé]
3)     apache2.2-bin [Non installé]
4)     apache2.2-common [Non installé]
5)     libapache2-mod-php5 [Non installé]
6)     php5 [Non installé]
7)     php5-cli [Non installé]



Merci de votre aide

Edit Mamy Mise en conformité des balises code

Hors ligne

#2 09-03-2016 10:17:37

Rockmyu
Membre
Distrib. : Debian stretch/sid | Kali rolling
Noyau : 4.3.0-1-amd64 | 4.4.0-kali1-amd64
(G)UI : Gnome 3.18.2
Inscription : 17-02-2016

Re : Installation impossible sur debian 6.0.10 de php5

Bienvenue tuxdotnet smile

Pour obtenir une aide plus efficace, je te conseille vivement les liens ci-dessous :

- Voir le tuto : Le code, ça pique moins les yeux en couleur
- Voir le tuto : Trop cool d'indiquer son installation dans son profil !

Hors ligne

#3 09-03-2016 10:41:10

milou
Modo ... e
Lieu : Sur une autre planète....
Distrib. : Jessie - Stretch/Sid
Noyau : 3.16.0-4-amd64
(G)UI : Lxde
Inscription : 12-02-2015
Site Web

Re : Installation impossible sur debian 6.0.10 de php5

Bonjour tuxdotnet, bienvenue sur DF smile

Pour faire suite au message de Rockmyu, j'ai passé les commandes de ton premier message dans les blocs correspondants.

Tu peux éditer ton message pour voir comment procéder smile

J’adorerais changer le monde, mais ils ne veulent pas me fournir le code source
Un vrai geek, c'est un mec qui croit que dans 1km, il y a 1024 mètres
Dans le doute, rebootes. Si tu te tâtes, formates.
1453651422.jpg

Hors ligne

#4 09-03-2016 11:21:01

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Installation impossible sur debian 6.0.10 de php5

Bonjour,

As-tu tenté :

dpkg -i --force-all php5.deb

ou

dpkg -i --force-all php5_5.3.3-7+squeeze19_all.deb

?


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#5 09-03-2016 11:51:58

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : Installation impossible sur debian 6.0.10 de php5

Hmm, il semble que j’ai décidé d’embêter paskal aujourd’hui tongue

En tous cas 'dpkg' ne sera pas d’une grande aide ici, les problèmes de dépendances sont du domaine d’APT (que ce soit via 'apt', 'apt-get' ou 'aptitude').

Jouer sous Debian ? Facile !

Hors ligne

#6 09-03-2016 11:58:40

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Installation impossible sur debian 6.0.10 de php5

vv222 a écrit :

Hmm, il semble que j’ai décidé d’embêter paskal aujourd’hui tongue

et réciproquement !  tongue + tongue

E: Paquets défectueux


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#7 09-03-2016 12:21:26

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : Installation impossible sur debian 6.0.10 de php5

Bon, je viens de me monter une Squeeze dans un chroot, et la première chose que je remarque est que ton fichier sources.list actuel n’est pas correct.
Le remplacer par le suivant m’a suffi pour pouvoir installer php5 :

deb http://archive.debian.org/debian/ squeeze main
deb http://archive.debian.org/debian/ squeeze-lts main
deb http://security.debian.org/ squeeze/updates main

Dernière modification par vv222 (09-03-2016 12:26:38)


Jouer sous Debian ? Facile !

Hors ligne

#8 09-03-2016 12:26:48

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Installation impossible sur debian 6.0.10 de php5

Ah oui, squeeze-lts ...  wink

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#9 09-03-2016 12:33:06

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : Installation impossible sur debian 6.0.10 de php5

paskal a écrit :

Ah oui, squeeze-lts ...  wink


C’est bien le cœur du problème wink

Les dépôts de Squeeze ont migré assez récemment de http://ftp.debian.org/debian/ (et autres miroirs) vers http://archive.debian.org/debian/
Et surtout la "pseudo-branche" 'squeeze-lts' est très incomplète et ne sera pas utilisable correctement sans la plus complète 'squeeze' pour l’épauler.


Jouer sous Debian ? Facile !

Hors ligne

#10 09-03-2016 12:40:41

tuxdotnet
Membre
Inscription : 09-03-2016

Re : Installation impossible sur debian 6.0.10 de php5

Merci à tous ...

Alors résultat  :

 apt-get update



Réception de : 1 http://security.debian.org squeeze/updates Release.gpg [836 B]
Ign http://security.debian.org/ squeeze/updates/main Translation-en
Ign http://security.debian.org/ squeeze/updates/main Translation-fr
Atteint http://security.debian.org squeeze/updates Release
Atteint http://security.debian.org squeeze/updates/main i386 Packages
Atteint http://archive.debian.org squeeze Release.gpg
Ign http://archive.debian.org/debian/ squeeze/main Translation-en
Atteint http://archive.debian.org/debian/ squeeze/main Translation-fr
Ign http://archive.debian.org squeeze-lts Release.gpg
Ign http://archive.debian.org/debian/ squeeze-lts/main Translation-en
Ign http://archive.debian.org/debian/ squeeze-lts/main Translation-fr
Atteint http://archive.debian.org squeeze Release
Ign http://archive.debian.org squeeze-lts Release
Ign http://archive.debian.org squeeze-lts/main i386 Packages/DiffIndex
Atteint http://archive.debian.org squeeze/main i386 Packages
Ign http://archive.debian.org squeeze-lts/main i386 Packages
Err http://archive.debian.org squeeze-lts/main i386 Packages
  404  Not Found [IP : 206.12.19.126 80]
836 o réceptionnés en 1s (760 o/s)
W: Impossible de récupérer http://archive.debian.org/debian/dists/squeeze-lts/main/binary-i386/Packages.gz  404  Not Found [IP : 206.12.19.126 80]

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.
 



la branche squeeze-lts existe pas tel que donner dans votre sources.list ...
Par contre celui-ci existe : http://ftp.debian.org/debian/dists/squeeze-lts/main/ mais pas de trace de la sous arbo binary-i386

Ceci étant l'installation de php5 a fonctionné, merci (j'étais perdus avec les repo ... trop habitués à ceux de RHEL)

Merci

Dernière modification par tuxdotnet (09-03-2016 12:53:50)

Hors ligne

#11 09-03-2016 13:01:15

Rockmyu
Membre
Distrib. : Debian stretch/sid | Kali rolling
Noyau : 4.3.0-1-amd64 | 4.4.0-kali1-amd64
(G)UI : Gnome 3.18.2
Inscription : 17-02-2016

Re : Installation impossible sur debian 6.0.10 de php5

En outre, je vois ici que squeeze-lts ne reçoit plus les mises à jour de sécurité depuis fin février. Donc je ne sais pas si il reste utile hmm

Hors ligne

#12 09-03-2016 13:15:22

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : Installation impossible sur debian 6.0.10 de php5

tuxdotnet a écrit :

 apt-get update



(…)
W: Impossible de récupérer http://archive.debian.org/debian/dists/squeeze-lts/main/binary-i386/Packages.gz  404  Not Found [IP : 206.12.19.126 80]

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.
 



la branche squeeze-lts existe pas tel que donner dans votre sources.list ...
Par contre celui-ci existe : http://ftp.debian.org/debian/dists/squeeze-lts/main/ mais pas de trace de la sous arbo binary-i386


C’est dingue ça : l’entrée "deb http://archive.debian.org/debian/ squeeze-lts main" fonctionnait pour moi au moment de mon dernier message, et plus maintenant.
Je soupçonne que archive.debian.org redirige vers différents miroirs, pas forcément tous bien synchronisés.


Jouer sous Debian ? Facile !

Hors ligne

Pied de page des forums