Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-03-2016 09:39:13

Lancelot du Lac
Membre
Lieu : France
Distrib. : Jessie | Stretch
Noyau : Linux 3.16.0-4-amd64 | 4.5.0-1-amd64
(G)UI : ZSH / LXDE, Openbox | KDE
Inscription : 22-02-2016

[RESOLU] Impossible d'exécuter un programme

Bonjour à tous !

Je voudrais, sur ma Jessie, exécuter un programme qui affiche le dictionnaire Littré. Mais ça ne marche pas. J'ai pourtant fait le chmod, et d'ailleurs, dans les propriétés, il est bien marqué qu'il est exécutable. Voici ce que me renvoie le terminal :

philippe@palantir:~$ /home/philippe/Documents/Littre-linux-2.0/Littre
-bash: /home/philippe/Documents/Littre-linux-2.0/Littre: Aucun fichier ou dossier de ce type


Double-cliquer dessus ne donne rien non plus, en revanche, si je l'ouvre depuis une autre machine connectée en ssh avec Nemo, ça marche (mais pas avec Dolphin).

Merci d'avance !

Edit à toto :
Afin que ce soit bien plus lisible, dans la commande user (ou root) on ne met que la commande et son retour à part également.
Ainsi donc :
philippe@palantir:~$

/home/philippe/Documents/Littre-linux-2.0/Littre


-bash: /home/philippe/Documents/Littre-linux-2.0/Littre: Aucun fichier ou dossier de ce type

Dernière modification par Lancelot du Lac (10-03-2016 19:04:48)


Dell Inspiron 7500 series - Debian Stretch - KDE/openbox - ZSH
Samsung - Debian Jessie - LXDE/pas de graphique - ZSH

Hors ligne

#2 10-03-2016 10:10:37

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [RESOLU] Impossible d'exécuter un programme

Si c'est un programme, normalement il est installé dans le ./bin de ton /home/user et à lancer ainsi :

.bin/littre


Si l'utilisateur en a les droits, évidemment.


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 10-03-2016 11:59:33

Lancelot du Lac
Membre
Lieu : France
Distrib. : Jessie | Stretch
Noyau : Linux 3.16.0-4-amd64 | 4.5.0-1-amd64
(G)UI : ZSH / LXDE, Openbox | KDE
Inscription : 22-02-2016

Re : [RESOLU] Impossible d'exécuter un programme

smolski a écrit :

Si c'est un programme, normalement il est installé dans le ./bin de ton /home/user et à lancer ainsi :

.bin/littre


Si l'utilisateur en a les droits, évidemment.


En fait, il n'y a pas d'installation préalable : il faut juste extraire les fichiers d'une archive, autoriser l'exécution, et normalement, c'est bon. Sur Ubuntu/LinuxMint, pas de problème, mais ça ne fonctionne pas sur Debian (ni sur Fedora d'ailleurs).
Je viens de regarder : je n'ai pas de dossier .bin dans mon home... (même en affichant les fichiers cachés).


Dell Inspiron 7500 series - Debian Stretch - KDE/openbox - ZSH
Samsung - Debian Jessie - LXDE/pas de graphique - ZSH

Hors ligne

#4 10-03-2016 12:04:06

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [RESOLU] Impossible d'exécuter un programme

Salut,
Le message d'erreur semble indiquer qu'il y a une typo dans la commande utilisée.
Tu utilises bien l'auto-complétion pour obtenir le chemin d'exécution du programme ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#5 10-03-2016 12:09:03

Lancelot du Lac
Membre
Lieu : France
Distrib. : Jessie | Stretch
Noyau : Linux 3.16.0-4-amd64 | 4.5.0-1-amd64
(G)UI : ZSH / LXDE, Openbox | KDE
Inscription : 22-02-2016

Re : [RESOLU] Impossible d'exécuter un programme

captnfab a écrit :

Salut,
Le message d'erreur semble indiquer qu'il y a une typo dans la commande utilisée.
Tu utilises bien l'auto-complétion pour obtenir le chemin d'exécution du programme ?


Oui, absolument. Notez que c'est le même problème si je veux l'exécuter en graphique : on me dit que le fichier est introuvable.

Merci pour l'edit, je prends note ! :-)


Dell Inspiron 7500 series - Debian Stretch - KDE/openbox - ZSH
Samsung - Debian Jessie - LXDE/pas de graphique - ZSH

Hors ligne

#6 10-03-2016 12:15:39

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [RESOLU] Impossible d'exécuter un programme

Ok.

Que donnent les commandes suivantes ?
Savoir de quel type de fichier il s'agit :

file /home/philippe/Documents/Littre-linux-2.0/Littre


Obtenir des informations sur le fichier :

ls -lh /home/philippe/Documents/Littre-linux-2.0/Littre


Si c'est un exécutable, obtenir des informations sur ses dépendances :

ldd /home/philippe/Documents/Littre-linux-2.0/Littre


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#7 10-03-2016 12:42:17

Lancelot du Lac
Membre
Lieu : France
Distrib. : Jessie | Stretch
Noyau : Linux 3.16.0-4-amd64 | 4.5.0-1-amd64
(G)UI : ZSH / LXDE, Openbox | KDE
Inscription : 22-02-2016

Re : [RESOLU] Impossible d'exécuter un programme

file /home/philippe/Documents/Littre-linux-2.0/Littre



/home/philippe/Documents/Littre-linux-2.0/Littre: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux.so.2, for GNU/Linux 2.6.15, not stripped
 


ls -lh /home/philippe/Documents/Littre-linux-2.0/Littre


-rwxr-xr-x 1 philippe philippe 12M juil. 29  2009 /home/philippe/Documents/Littre-linux-2.0/Littre



ldd /home/philippe/Documents/Littre-linux-2.0/Littre



        n'est pas un exécutable dynamique
 



La réponse de ldd me laisse un peu perplexe... J'ai relancé, au cas où une erreur se serait glissée, mais même résultat.


Dell Inspiron 7500 series - Debian Stretch - KDE/openbox - ZSH
Samsung - Debian Jessie - LXDE/pas de graphique - ZSH

Hors ligne

#8 10-03-2016 15:00:39

dh
Membre
Lieu : Rhône
Distrib. : SID
Noyau : 4.2.0-1-amd64
(G)UI : Gnome3
Inscription : 23-03-2010

Re : [RESOLU] Impossible d'exécuter un programme

Tu as ajouté l'architecture 32 bits ?
et ça :


$ cd /home/philippe/Documents/Littre-linux-2.0/
$ ./Littre
 


ça donne quoi ?

Dernière modification par dh (10-03-2016 15:00:55)


Libertaire, libéral, libre.

Hors ligne

#9 10-03-2016 15:32:18

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [RESOLU] Impossible d'exécuter un programme

Donc, c'est un exécutable 32bits comme dit dh, et s'il ne passe pas c'est qu'il doit manquer de quoi le faire tourner, genre libc6-i386
Tu peux essayer après l'avoir installé ?

apt install libc6-i386


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#10 10-03-2016 15:50:26

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : [RESOLU] Impossible d'exécuter un programme

Le paquet que tu proposes captnfab ne sera à mon avis pas suffisant.
Il va falloir avant tout activer le multiarch sur la machine, et installer la version 32-bit de la libc6 :

dpkg --add-architecture i386
apt update
apt install libc6:i386


Ensuite la commande 'ldd' devrait nous donner le reste des dépendances de ce programme.


Jouer sous Debian ? Facile !

Hors ligne

#11 10-03-2016 16:06:51

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [RESOLU] Impossible d'exécuter un programme

Quel pessimisme crasse tongue
Je me posais la question justement. Je pense que ça suffirait si jamais il n'y avait pas de dépendances. Mais c'est vrai que j'en doute aussi…

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#12 10-03-2016 16:58:42

Lancelot du Lac
Membre
Lieu : France
Distrib. : Jessie | Stretch
Noyau : Linux 3.16.0-4-amd64 | 4.5.0-1-amd64
(G)UI : ZSH / LXDE, Openbox | KDE
Inscription : 22-02-2016

Re : [RESOLU] Impossible d'exécuter un programme

Merci pour vos réponses !
@dh : pas plus de résultat, malheureusement...

J'ai installé libc6-i386, mais ça n'a pas suffi. J'ai ensuite suivi les conseils de vv222, mais sans plus de résultat. Voici ce que répond le terminal lorsque je lance Littre :

Documents/Littre-linux-2.0/Littre: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory



et ldd :


        linux-gate.so.1 (0xf773b000)
        libpng12.so.0 => not found
        libfreetype.so.6 => not found
        libSM.so.6 => not found
        libICE.so.6 => not found
        libXrender.so.1 => not found
        libfontconfig.so.1 => not found
        libXext.so.6 => not found
        libX11.so.6 => not found
        libz.so.1 => not found
        libgthread-2.0.so.0 => not found
        librt.so.1 => /lib/i386-linux-gnu/i686/cmov/librt.so.1 (0xf7715000)
        libglib-2.0.so.0 => not found
        libdl.so.2 => /lib/i386-linux-gnu/i686/cmov/libdl.so.2 (0xf770f000)
        libpthread.so.0 => /lib/i386-linux-gnu/i686/cmov/libpthread.so.0 (0xf76f3000)
        libstdc++.so.6 => not found
        libm.so.6 => /lib/i386-linux-gnu/i686/cmov/libm.so.6 (0xf76ad000)
        libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xf7690000)
        libc.so.6 => /lib/i386-linux-gnu/i686/cmov/libc.so.6 (0xf74e2000)
        /lib/ld-linux.so.2 (0xf773e000)
 




Je suppose que c'est ce qu'il faut installer ?


Dell Inspiron 7500 series - Debian Stretch - KDE/openbox - ZSH
Samsung - Debian Jessie - LXDE/pas de graphique - ZSH

Hors ligne

#13 10-03-2016 17:21:00

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [RESOLU] Impossible d'exécuter un programme

A priori, il te faut installer toutes ces bibliothèques :

apt install libstdc++6:i386 libglib2.0-0:i386 libglib2.0-0:i386 zlib1g:i386 libx11-6:i386 libxext6:i386 libfontconfig1:i386 libxrender1:i386 libice6:i386 libsm6:i386 libfreetype6:i386 libpng12-0:i386



Si tu attends un moment, je te donne un moyen plus propre de faire tout ça smile


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#14 10-03-2016 17:51:24

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [RESOLU] Impossible d'exécuter un programme

Donc, la version « propre » consiste en la création d'un pseudo-paquet, qui n'installe rien mais qui a comme dépendances celles indiquées ci-dessus.

Pour ce faire, on utilise l'outil equivs, à installer

apt install equivs



On se place dans un dossier dédié, que l'on crée pour l'occasion

mkdir ~/littre-deps
cd ~/littre-deps



On génère un fichier modèle pour le pseudo-paquet :

equivs-control littre-deps



On édite le fichier ~/littre-deps/littre-deps avec son éditeur de texte favoris (par exemple gedit) de sorte à ce qu'il ressemble à ça :

Section: misc
Priority: optional
Standards-Version: 3.9.2

Package: littre-deps
Version: 1.0~alpha1
Depends: libstdc++6:i386,libglib2.0-0:i386,libglib2.0-0:i386,zlib1g:i386,libx11-6:i386,libxext6:i386,libfontconfig1:i386,libxrender1:i386,libice6:i386,libsm6:i386,libfreetype6:i386,libpng12-0:i386,libc6:i386,libgcc1:i386
Architecture: i386
Description: Dépendences du Littre 2.0
 Paquet equivs installant les dépendances requises pour Littre 2.0
 .
 Ce paquet n'installe aucun fichier particulier.



On génère le pseudo-paquet (l'option --arch i386 permet de générer un paquet pour architecture i386 alors que nous sommes sous architecture amd64) :

equivs-build --arch i386 littre-deps



Et pouf, magie, le .deb est généré.

On l'installe :

dpkg -i littre-deps_1.0~alpha1_i386.deb



Et on finalise l'installation des dépendances avec

apt install -f



L'avantage de cette version propre, c'est que si tu vires le paquet littre-deps, avec un « apt remove littre-deps » les dépendances qui ne sont plus nécessaires (si elles ne sont effectivement plus nécessaires) partiront également… smile
Tout ça pour ça ? Oui tongue


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#15 10-03-2016 17:54:06

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : [RESOLU] Impossible d'exécuter un programme

captnfab a écrit :

On l'installe :

dpkg -i littre-deps_1.0~alpha1_i386.deb



Et on finalise l'installation des dépendances avec

apt install -f


Sur une Stretch on peut effectuer ces deux opérations en une unique commande :

apt install littre-deps_1.0~alpha1_i386.deb


Jouer sous Debian ? Facile !

Hors ligne

#16 10-03-2016 17:55:24

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [RESOLU] Impossible d'exécuter un programme

@vv222: Oh ? Cool, j'aime smile Et ça ne fonctionne pas sous Jessie ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#17 10-03-2016 18:07:51

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : [RESOLU] Impossible d'exécuter un programme

captnfab a écrit :

Et ça ne fonctionne pas sous Jessie ?


Et non malheureusement, c’est une fonctionnalité qui est arrivée avec apt 1.1 :
http://metadata.ftp-master.debian.org/c … _changelog

apt (1.1~exp1) experimental; urgency=low
(…)
  * add support for "apt-get install foo_1.0_all.deb"
(…)

Dernière modification par vv222 (10-03-2016 18:09:21)


Jouer sous Debian ? Facile !

Hors ligne

#18 10-03-2016 18:10:58

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [RESOLU] Impossible d'exécuter un programme

Super smile dans quel tuto on mets ça ?

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#19 10-03-2016 18:55:03

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [RESOLU] Impossible d'exécuter un programme

+1  big_smile

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#20 10-03-2016 19:04:24

Lancelot du Lac
Membre
Lieu : France
Distrib. : Jessie | Stretch
Noyau : Linux 3.16.0-4-amd64 | 4.5.0-1-amd64
(G)UI : ZSH / LXDE, Openbox | KDE
Inscription : 22-02-2016

Re : [RESOLU] Impossible d'exécuter un programme

smile smile smile
Ça marche ! Merci à captnfab pour ses judicieux conseils, et notamment la méthode "propre". C'est facile à appliquer, moins à comprendre. Je vais essayer de me pencher là-dessus pour progresser. Merci à tous encore une fois !

Dell Inspiron 7500 series - Debian Stretch - KDE/openbox - ZSH
Samsung - Debian Jessie - LXDE/pas de graphique - ZSH

Hors ligne

Pied de page des forums