Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-03-2016 22:50:53

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

IW 24.xx contre IW 38.8 contre FF 45, 46, 47 esr ou release

Bsr,
Voilà les erreurs retournées avec les 2 versions. Essai fait sur une page youtube pour lecture d'une video; dans le cas de Firefox le lecteur mouline et finalement ne démarre pas la video. Avec Iceweasel le video démarre quasi instantanément.
Le but n'est pas de situer la différence entre les navigateurs mais entre les versions. De nombreux topics signalent le problème avec le streaming et les solutions rélèvent souvent du bidouillage. Étonnamment chez certains membres ça fonctionne sans problèmes: le hardware peut-il être ms en cause ? A toutes fins utiles j'essaierai la version FF esr.
En attendant, si quelques uns ont des idées merci de les partager ici

iceweasel


console.error:
  [CustomizableUI]
  Custom widget with id loop-button does not return a valid node
W/MPEG4Extractor(10212): Error -1004 parsing chuck at offset 1645 looking for first track
W/MPEG4Extractor(10212): Error -1004 parsing chuck at offset 1645 looking for first track
W/MPEG4Extractor(10212): Error -1004 parsing chuck at offset 60858 looking for first track
W/MPEG4Extractor(10212): Error -1004 parsing chuck at offset 60858 looking for first track
W/MPEG4Extractor(10212): Error -1004 parsing chuck at offset 60858 looking for first track
W/MPEG4Extractor(10212): Error -1004 parsing chuck at offset 136162 looking for first track
W/MPEG4Extractor(10212): Error -1004 parsing chuck at offset 139918 looking for first track

firefox


1457901094038 addons.productaddons  ERROR Request failed certificate checks: [Exception... "SSL is required
 and URI scheme is not https."  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  
location: "JS frame :: resource://gre/modules/CertUtils.jsm :: checkCert :: line 145"  data: no]

Dernière modification par phlinux (02-07-2016 16:05:49)


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#2 14-03-2016 09:22:36

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : IW 24.xx contre IW 38.8 contre FF 45, 46, 47 esr ou release

Bonjour smile
Est ce que tu peux donner un lien pour qu'on puisse tester chez nous ? Ou bien ça te fait ce probleme sur toutes les vidéos YouTube ?

Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#3 14-03-2016 13:33:50

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : IW 24.xx contre IW 38.8 contre FF 45, 46, 47 esr ou release

Bjr,

Apparemment ça le fait sur toutes. Mais essaies sur celle-ci https://www.youtube.com/watch?v=KymghYXtedE
A noter qu'aujourd'hui et à cette heure c'est encore pire, Firefox n'affiche même pas la page

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#4 14-03-2016 15:03:43

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : IW 24.xx contre IW 38.8 contre FF 45, 46, 47 esr ou release

J'ai l'impression que ton lien n'est pas une vidéo, image fixe mais bande son avec firefox 45
un clic droit indique que c'est le lecteur html5 qui joue
J'ai testé celle-ci et ça passe, toujours avec le lecteur html5
J'ai l'extension Youtube all html5
Si avec cette extension ça marche pour toi, c'est un problème (de plus) avec flash.
Edit : en fait ce n'est même pas cette extension, en la désactivant et redémarrant firefox45 c'est toujours le lecteur html5 qui joue et pas de souci.
On peut tester sur ce lien pour voir si la préférence est donné sur youtube au html5. Moi quand je clique sur le lien tout est coché OK. Et pour toi ?

Edit : je précise que j'ai le paquet flash browser-plugin-freshplayer-pepperflash des backports + pepeerflashplugin-nonfree

Dernière modification par chalu (14-03-2016 15:25:22)


Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#5 14-03-2016 15:34:45

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : IW 24.xx contre IW 38.8 contre FF 45, 46, 47 esr ou release

Ok la video en exemple c'était pour montrer que même avec un fichier simple ça déconne.
Perso avec IW 38.7 je n'ai ni flash, ni aucun plugin et Shockwave est désactivé.

Donc c'est bien FF qui ne fonctionne pas; rajouter des plugins fait partie des bidouillages dont je parle dans mon premier post.
Je ne peux pas faire un essai sur wheezy avec FF esr 45 car il désinstalle IW. Mais pour avoir auparavant fait l'essai avec IW 44 je sais que ça ne fonctionne pas non plus.

Par rapport à ceux chez qui ça marche sans plugin, ni flash (d'après ce qu'ils disent) je voudrais bien connaître les différences.
Reste que si à chaque nouvelle version c'est le même cirque....

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#6 14-03-2016 15:40:42

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : IW 24.xx contre IW 38.8 contre FF 45, 46, 47 esr ou release

Pour le lien que tu donnes avec FF 45 tout est Ok, mieux qu'avec IW 38.7 et pourtant pas de streaming video

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#7 14-03-2016 16:25:14

rodrigue7000
Membre
Lieu : beloeil
Distrib. : debian jessie (stable) v8.4
Noyau : Linux 4.5.0-0.bpo.2-amd64
(G)UI : kde et cinnamon Fixe pc + xfce et cinnamon laptop
Inscription : 01-03-2016

Re : IW 24.xx contre IW 38.8 contre FF 45, 46, 47 esr ou release

apt-get remove icewassel && apt-get -t backports jessie install firefox firefox-l10n-fr

je suis malentendant car une problème du Dyslexique en français smile merci vos respect
http://debian-art.org/CONTENT/content-pre1/80977-1.png
la groupe de debiannistes sur ce facebook : https://www.facebook.com/groups/1533439706960929/
le serveur irc de linuxfriends : irc.freemind.ovh #linuxfriends

Hors ligne

#8 14-03-2016 17:56:41

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : IW 24.xx contre IW 38.8 contre FF 45, 46, 47 esr ou release

@rodrigue7000 : merci mais c'est inutile iceweasel et firefox peuvent cohabiter

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#9 14-03-2016 19:37:34

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : IW 24.xx contre IW 38.8 contre FF 45, 46, 47 esr ou release

alors je viens de tout désinstaller firefox + flash
et j'ai réinstallé iceweasel 38.7 et firefox 45 sans flash et ça fonctionne pour les deux (l'un après l'autre, pas en même temps).
dans le lien donné plus haut, avec iceweasel, j'ai la première ligne (3 cases) cochée et le lecteur utilisé est le lecteur par défaut.
Dans firefox, j'ai les deux lignes (6 cases cochées) et lecteur html5 utilisé quand c'est possible (pas d'indication de lecteur par défaut).

1457901094038 addons.productaddons  ERROR Request failed certificate checks: [Exception... "SSL is required
and URI scheme is not https."  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)" 
location: "JS frame :: resource://gre/modules/CertUtils.jsm :: checkCert :: line 145"  data: no]


L'erreur que tu as donnée, j'ai eu la même en voulant lancer iceweasel et firefox en même temps.
Je ne pense pas que ce soit vraiment conseillé de garder les 2 d'ailleurs.

Dernière modification par chalu (14-03-2016 19:49:50)


Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#10 14-03-2016 21:00:38

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : IW 24.xx contre IW 38.8 contre FF 45, 46, 47 esr ou release

Iceweasel 44.0.2 tout fonctionne normalement le jazz, les mignons et tout est coché.

Aprés j'ai gstreamer0.10-ffmpeg et mozplugger qui sont installés cela arrange peut être bien les choses.

Hors ligne

#11 14-03-2016 21:30:55

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : IW 24.xx contre IW 38.8 contre FF 45, 46, 47 esr ou release

@chalu : merci pour ton retour. C'est vraiment sympa de ta part d'avoir poussé les essais jusqu'à ce point en te mettant dans les mêmes conditions. Il est possible que l'erreur en console soit effectivement due à l'installation parallèle de IW et FF (ça expliquerait d'ailleurs le conseil de rodrigue7000 au #7)
@deuchdeb : j'ai aussi gstreamer0.10-ffmpeg mais mozplugger c'est jessie ou sid. Comme j'ai le même problème sous sid et ma jessie à l'essai je vais l'installer pour voir.

Je continu les recherches et je vous tiens au parfum. Merci encore pour votre aide.

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#12 14-03-2016 21:43:10

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : IW 24.xx contre IW 38.8 contre FF 45, 46, 47 esr ou release

De mon côté sur une installation fraîche de jessie 8.3 , je n'ai pas gstreamer0.1 mais j'ai gstreamer1.0-libav et je crois l'avoir vu comme dépendance de Firefox dans Synaptic.
Mais là le PC est éteint pour que je vérifie wink

Dernière modification par chalu (14-03-2016 21:43:42)


Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#13 14-03-2016 22:42:09

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : IW 24.xx contre IW 38.8 contre FF 45, 46, 47 esr ou release

Je suis sur sid et j'ai aussi gstreamer1.0-libav installé.
J'ai fait quelques essais; en fait le message d'erreur et déclenché par la version, que ce soit iceweasel/firefox-esr 45 ou firefox 45 en installation "solitaire". Ce n'est donc pas quand ils sont installés en parallèle.
J'ai essayé quelques extensions, mais pas d'amélioration. Là je vais voir sur Jessie.

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#14 14-03-2016 23:00:47

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : IW 24.xx contre IW 38.8 contre FF 45, 46, 47 esr ou release

Bon me voilà sur Jessie avec IW 38.6.1. Pas d'extension, pas de plugin, aucun gstreamer et les video se lisent sans problème et sans trop trainer à s'ouvrir. Bref, j'essaie avec les backports

Edit: ben voilà génial: FF-esr 45.0 marche pas chez phlinux avec les video html5. Du coup repassé en IW 38.7

P... ça fait flipper pour la suite

Dernière modification par phlinux (14-03-2016 23:56:29)


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#15 15-03-2016 14:04:50

rodrigue7000
Membre
Lieu : beloeil
Distrib. : debian jessie (stable) v8.4
Noyau : Linux 4.5.0-0.bpo.2-amd64
(G)UI : kde et cinnamon Fixe pc + xfce et cinnamon laptop
Inscription : 01-03-2016

Re : IW 24.xx contre IW 38.8 contre FF 45, 46, 47 esr ou release

phlinux a écrit :

Bon me voilà sur Jessie avec IW 38.6.1. Pas d'extension, pas de plugin, aucun gstreamer et les video se lisent sans problème et sans trop trainer à s'ouvrir. Bref, j'essaie avec les backports

Edit: ben voilà génial: FF-esr 45.0 marche pas chez phlinux avec les video html5. Du coup repassé en IW 38.7

P... ça fait flipper pour la suite




j'ai déjà essaié esr mais y pas encore sortir mais y a dedans firefox-release 45.0 refaire toi

bien à toi
rodrigue7000


je suis malentendant car une problème du Dyslexique en français smile merci vos respect
http://debian-art.org/CONTENT/content-pre1/80977-1.png
la groupe de debiannistes sur ce facebook : https://www.facebook.com/groups/1533439706960929/
le serveur irc de linuxfriends : irc.freemind.ovh #linuxfriends

Hors ligne

#16 15-03-2016 14:14:01

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : IW 24.xx contre IW 38.8 contre FF 45, 46, 47 esr ou release

J'oubliais, j'ai aussi le module: YouTube ALL HTML5

https://addons.mozilla.org/fr/firefox/a … 5/?src=api

Hors ligne

#17 15-03-2016 15:41:53

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : IW 24.xx contre IW 38.8 contre FF 45, 46, 47 esr ou release

Oui je l'ai aussi. En fait si je le désactive, le lecteur vidéo sur youtube affiche "le plugin est désactivé" et la vidéo met du temps, mais elle se charge quand même. Donc sans aucun plugin ou extension pour IW 38.7 sous wheezy ça finit malgré tout par se lire.
Sous Jessie même IW 38.7 sans rien (voir post #14), ça fonctionne tout de suite.
Par contre il y a un saut "quantique" avec IW/Firefox 45.

Le problème de fond c'est que dès maintenant en IW 38.7 j'ai des icones/widjet qui ne s'affichent pas sur certaines pages; ça me met des "petits rectangles à la con" à la place. Et bien sur pas en version 45
Je vais peut être patienter un an et passer directement Wheezy > Stretch

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#18 15-03-2016 19:44:27

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : IW 24.xx contre IW 38.8 contre FF 45, 46, 47 esr ou release

Est-ce que les dépendances qui sont censées aller avec iceweasel vont bien avec Firefox?

Est-ce que tout le travail a déjà été fait de ce côté là?

Hors ligne

#19 15-03-2016 20:15:54

rodrigue7000
Membre
Lieu : beloeil
Distrib. : debian jessie (stable) v8.4
Noyau : Linux 4.5.0-0.bpo.2-amd64
(G)UI : kde et cinnamon Fixe pc + xfce et cinnamon laptop
Inscription : 01-03-2016

Re : IW 24.xx contre IW 38.8 contre FF 45, 46, 47 esr ou release

phlinux a écrit :

@chalu : merci pour ton retour. C'est vraiment sympa de ta part d'avoir poussé les essais jusqu'à ce point en te mettant dans les mêmes conditions. Il est possible que l'erreur en console soit effectivement due à l'installation parallèle de IW et FF (ça expliquerait d'ailleurs le conseil de rodrigue7000 au #7)
Je continu les recherches et je vous tiens au parfum. Merci encore pour votre aide.


de rien que je t'informe une encore des choes pour les importantes smile wink

deuchdeb a écrit :

Est-ce que les dépendances qui sont censées aller avec iceweasel vont bien avec Firefox?

Est-ce que tout le travail a déjà été fait de ce côté là?



pas egale :x

phlinux a écrit :

@rodrigue7000 : merci mais c'est inutile iceweasel et firefox peuvent cohabiter



ah pas vu désolé que j'ai trop vite lire tes messsage ;-)

Dernière modification par rodrigue7000 (15-03-2016 20:46:15)


je suis malentendant car une problème du Dyslexique en français smile merci vos respect
http://debian-art.org/CONTENT/content-pre1/80977-1.png
la groupe de debiannistes sur ce facebook : https://www.facebook.com/groups/1533439706960929/
le serveur irc de linuxfriends : irc.freemind.ovh #linuxfriends

Hors ligne

#20 15-03-2016 20:25:05

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : IW 24.xx contre IW 38.8 contre FF 45, 46, 47 esr ou release

Entre les versions 38 et 45, le lecteur html5 a évolué. Pourquoi ca ne marche pas chez toi, mystère quand même !

Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#21 15-03-2016 21:38:36

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : IW 24.xx contre IW 38.8 contre FF 45, 46, 47 esr ou release

@deuchdeb : ben je vois pas comment faire plus. Sur wheezy admettons qu'il puisse manquer des trucs comme mozplugger, mais sur Jessie ou Sid ...

Il y a beaucoup de post, articles, etc, sur le net qui parlent de ce problème, depuis la version 42 d'ailleurs. Et au final aucune bidouille ou astuce ne fonctionne pour tout le monde. Par exemple: modifier la détection du navigateur par le site youtube, empêcher certains scripts (il y a à ce propos une différence de temps de démarrage entre musictronic et youtube et ce pour la même vidéo), etc...

Bon on verra en allant. Je laisse le fil ouvert au cas où je trouverais une cause valable. Vos idées et conseils continuent à être les bienvenues naturellement.

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#22 15-03-2016 22:25:17

seb95deMLO
Invité

Re : IW 24.xx contre IW 38.8 contre FF 45, 46, 47 esr ou release

J'ai aucun soucis sur le binaire de mozilla par contre adblock est moins efficace qu'avant, j'ai plein de popup de cul qui se jettent sur moi...

#23 15-03-2016 22:27:31

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : IW 24.xx contre IW 38.8 contre FF 45, 46, 47 esr ou release

donc plus de cul c'est mieux qu'avant

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#24 10-05-2016 11:15:08

--gilles--
Membre
Distrib. : debian 7
Noyau : linux 3.2.0-4-powerpc-smp
(G)UI : gnome
Inscription : 15-02-2016

Re : IW 24.xx contre IW 38.8 contre FF 45, 46, 47 esr ou release

phlinux a écrit :

dans le cas de Firefox le lecteur mouline et finalement ne démarre pas la vidéo.

firefox


1457901094038 addons.productaddons  ERROR Request failed certificate checks: [Exception... "SSL is required
 and URI scheme is not https."  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  
location: "JS frame :: resource://gre/modules/CertUtils.jsm :: checkCert :: line 145"  data: no]



Il y a une piste qui n'a pas été exploitée, le message d'erreur : addons.productaddons  ERROR Request failed certificate checks : traduction
addons.productaddons ERREUR : La demande a échoué à vérifier les certificats.

Depuis Firefox 43 les addons doivent être signés et les addons non-signés doivent être supprimés et sont en principe supprimés automatiquement par le passage de Firefox 42 à Firefox 43.

https://support.mozilla.org/fr/kb/signa … es-firefox

Peux-tu nous dire l'état de tes addons et ensuite essayer la même vidéo sans addons et puis les rajouter un à un ?

Hors ligne

#25 10-05-2016 21:18:01

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : IW 24.xx contre IW 38.8 contre FF 45, 46, 47 esr ou release

Bsr,

Bon j'ai désactivé les 2 extensions, Video without Flash et Youtube machin html5;
- Firefox : une page youtube ne s'ouvre pas, et j'ai justement le message ci-dessus qui apparait lors de cette tentative
- Iceweasel : une page YT s'ouvre, à l'emplacement de la vidéo un message de plugin manquant, mais la video se lance quand même.
Bref, rien de nouveau sauf qu'en fait c'est la page YT qui génère le message d'erreur, même si aucun add-on n'est activé.
A la suite de quelques nombreuses recherches il apparait que la config de IW ou FF n'est pas la même pour tout le monde.

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

Pied de page des forums