Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-03-2016 00:11:57

nazmi
Membre
Lieu : Normandie
Distrib. : GNU/LINUX Debian Jessie
Noyau : Linux 4.3.0-0.bpo.1-amd64
(G)UI : KDE/XFCE
Inscription : 17-07-2015

[Résolu]Encore des problèmes de dépendances :tristesse:

Salut,
J'ai voulu installer livestreamer qui me permettrait de récupérer des directs utilisant un lecteur flash, sans avoir besoin de flash, et directement depuis VLC, ce qui me semble plutôt sympa (j'ai vu un tuto sur le wiki DF), j'ai essayé le paquet dans les dépots mais ça ne marche pas, sur l'assistance de gstreamer (sur Github je crois), ils recommandent d'installer python-pip puis de faire quelque chose comme (j'ai pas les instructions sous les yeux):

pip Livestreamer


mais avant ça il faut installer python-pip, j'ai donc essayé:

sudo apt-get install python-pip


mais:

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 python-pip : Dépend: python-setuptools (>= 0.6c1) mais ne sera pas installé
              Recommande: python-dev-all (>= 2.6) mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
 



avez vous une idée de solution, des explications sur le pourquoi (j'aimerais finir par arrèter de demander tout le temps pour installer des trucs et comprendre vraiment comment ça fonctionne roll ) et enfin ce qui cause tous ces problèmes de dépendances qui me rendent dingue yikes

Merci d'avance

Dernière modification par nazmi (23-03-2016 23:45:49)

Hors ligne

#2 19-03-2016 08:04:23

sinozis
Membre
Lieu : Moselle
Distrib. : Debian stable
Inscription : 12-03-2016

Re : [Résolu]Encore des problèmes de dépendances :tristesse:

Qu'est ce qu'il pose problème avec la version du dépôt debian ?

aptitude install livestreamer


Je résiste à tout sauf à la tentation.......

Hors ligne

#3 19-03-2016 08:49:52

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu]Encore des problèmes de dépendances :tristesse:

Ah oui, bonne idée !
La commande aptitude permet de faire un choix entre plusieurs propositions, n'exécute pas au hasard l'une d'elle mais recopie ici ces propositions. cool

Le mieux sera aussi d'utiliser l'option de simulation -s dans la commande ainsi :

aptitude -s install livestreamer


car même en validant une des propositions, elle ne s'exécutera que virtuellement et non réellement, ce qui permet ensuite d'affiner son choix ou de renvoyer les conséquences d'un des choix.

Voir le tuto de la commande aptitude. Clic ici. pour comprendre davantage son utilisation. smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#4 19-03-2016 14:37:37

nazmi
Membre
Lieu : Normandie
Distrib. : GNU/LINUX Debian Jessie
Noyau : Linux 4.3.0-0.bpo.1-amd64
(G)UI : KDE/XFCE
Inscription : 17-07-2015

Re : [Résolu]Encore des problèmes de dépendances :tristesse:

j'ai installé le paquet mais quand je voulais regarder une diffusion sur twitch pour tester, c'est vrai que je ne suis pas allé tester les autres hébergeurs, mais ça me donnait:

No stream found at this URL: http://twitch.tv/machinchose



j'ai donc cherché et sur github j'ai trouvé cette discussion:
https://github.com/chrippa/livestreamer/issues/835

où ils recommandent au final de faire:

sudo apt-get remove livestreamer
sudo apt-get autoremove


pour virer livestreamer 1.10

et pour installer la 1.11.1

sudo apt-get install python-pip
sudo pip install -U livestreamer
livestreamer -V



et je suis bloqué à python-pip pour l'instant neutral

Hors ligne

#5 21-03-2016 00:31:33

nazmi
Membre
Lieu : Normandie
Distrib. : GNU/LINUX Debian Jessie
Noyau : Linux 4.3.0-0.bpo.1-amd64
(G)UI : KDE/XFCE
Inscription : 17-07-2015

Re : [Résolu]Encore des problèmes de dépendances :tristesse:

j'ai réinstallé livestreamer des dépots, toujours le no stream found pour twitch.

j'ai testé la commande aptitude, elle me propose d'installer le paquet, je réponds oui et enfin elle me répond

Charger/installer/enlever des paquets.


et se termine

quelqu'un a des idées ?
Merci d'avance

Hors ligne

#6 21-03-2016 10:17:36

Dunatotatos
Membre
Lieu : Arabie Saoudite
Distrib. : Sid
Noyau : linux-image-amd64
(G)UI : tty
Inscription : 24-04-2012

Re : [Résolu]Encore des problèmes de dépendances :tristesse:

Ton erreur est étrange. Il manque des dépendances, et plutôt que de les installer, apt-get rale. Pourrais-tu nous donner la sortie complète de ta commande

apt-get install python-pip

Dernière modification par Dunatotatos (21-03-2016 10:17:52)


Never trust Windows output.

Hors ligne

#7 21-03-2016 17:41:14

nazmi
Membre
Lieu : Normandie
Distrib. : GNU/LINUX Debian Jessie
Noyau : Linux 4.3.0-0.bpo.1-amd64
(G)UI : KDE/XFCE
Inscription : 17-07-2015

Re : [Résolu]Encore des problèmes de dépendances :tristesse:

je m'en occupe dès que je rentre chez moi

Hors ligne

#8 22-03-2016 02:36:01

nazmi
Membre
Lieu : Normandie
Distrib. : GNU/LINUX Debian Jessie
Noyau : Linux 4.3.0-0.bpo.1-amd64
(G)UI : KDE/XFCE
Inscription : 17-07-2015

Re : [Résolu]Encore des problèmes de dépendances :tristesse:

voila (mais je l'avais déja mise dans le premier post):

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 python-pip : Dépend: python-setuptools (>= 0.6c1) mais ne sera pas installé
              Recommande: python-dev-all (>= 2.6) mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».



voila tout, j'ai essayé d'installer "python-setuptools" mais on me répond:

nazmi@derpian:~$ sudo apt-get install python-setuptools
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 python-setuptools : Dépend: python-pkg-resources (= 5.5.1-1) mais 18.8-1~bpo8+1 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
 



c'est très étrange comme situation mais j'ai l'impression d'avoir déja vu ce genre de problèmes et les avoir contrournés auparavant

Hors ligne

#9 22-03-2016 03:46:09

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu]Encore des problèmes de dépendances :tristesse:

Salut

Les paquets suivants contiennent des dépendances non satisfaites :
python-setuptools : Dépend: python-pkg-resources (= 5.5.1-1) mais 18.8-1~bpo8+1 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».



Il semble bien que tu donnes priorité au dépôt jessie-backports. Là apt tiens absolument à installé la version des backports pour le paquet python-pkg-resources. As-tu un fichier /etc/apt/preferences particulier ?

Il y a un truc de bizarre aussi mais comme je n'ai pas jessie je ne peux pas tester cela. Sur la page du paquet python-pip pour jessie, on peut lire :

dep: python-setuptools (>= 0.6c1)

alors que pour jessie on a python-setuptools (5.5.1-1). Alors pour ceux qui ont jessie, vous pouvez ou non installer python-pip (même juste en simulation)?


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#10 22-03-2016 09:28:17

Dunatotatos
Membre
Lieu : Arabie Saoudite
Distrib. : Sid
Noyau : linux-image-amd64
(G)UI : tty
Inscription : 24-04-2012

Re : [Résolu]Encore des problèmes de dépendances :tristesse:

nazmi : En effet, désolé. Vu la fin du message, j'avais l'impression qu'une partie manquait.

Et pour info, oui, python-pip est installable sur Jessie :

apt-get install -s python-pip


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
  python-cffi python-chardet python-colorama python-cryptography
  python-distlib python-html5lib python-ndg-httpsclient python-openssl
  python-ply python-pyasn1 python-pycparser python-requests python-six
  python-urllib3 python-wheel
Paquets suggérés :
  python-cryptography-doc python-cryptography-vectors python-genshi
  python-openssl-doc python-openssl-dbg python-ply-doc doc-base
Paquets recommandés :
  python-dev-all
Les NOUVEAUX paquets suivants seront installés :
  python-cffi python-chardet python-colorama python-cryptography
  python-distlib python-html5lib python-ndg-httpsclient python-openssl
  python-pip python-ply python-pyasn1 python-pycparser python-requests
  python-six python-urllib3 python-wheel
0 mis à jour, 16 nouvellement installés, 0 à enlever et 0 non mis à jour.


Never trust Windows output.

Hors ligne

#11 22-03-2016 23:48:29

nazmi
Membre
Lieu : Normandie
Distrib. : GNU/LINUX Debian Jessie
Noyau : Linux 4.3.0-0.bpo.1-amd64
(G)UI : KDE/XFCE
Inscription : 17-07-2015

Re : [Résolu]Encore des problèmes de dépendances :tristesse:

alors j'ai commenté les dépots backports dans mon sources.list (ils étaient à la fin), j'ai fait un

apt-get update



puis j'ai réessayé d'installer python pip, mais il continue à me parler de ces dépendances

 python-pip : Dépend: python-setuptools (>= 0.6c1) mais ne sera pas installé
              Recommande: python-dev-all (>= 2.6) mais il n'est pas installable



avez vous d'autres pistes

ps pour Martinux_qc: j'ai essayé d'éditer /etc/apt/preferences avec nano ou d'aller dedans avec cd mais j'ai soit un fichier vide soit un dossier qui n'existe pas, est-ce que ça veut dire qu'il n'y a pas de problème de ce côté

j'ai aussi joué avec les backports, je ne sais plus pourquoi mais je m'en rappelle, aussi j'ai dû faire des conneries il y a un bout de temps quand je débutais, conneries qui se répercutent maintenant, à savoir quoi, aucune idée car j'ai tellement bidouillé au début... sad

Dernière modification par nazmi (22-03-2016 23:49:16)

Hors ligne

#12 23-03-2016 02:42:18

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu]Encore des problèmes de dépendances :tristesse:

Dunatotatos a écrit :

nazmi : En effet, désolé. Vu la fin du message, j'avais l'impression qu'une partie manquait.

Et pour info, oui, python-pip est installable sur Jessie :

apt-get install -s python-pip



Merci pour l'info. Par contre, je ne vois rien pour le paquet python-setuptools. Il était déjà installé ou quoi.

@ nazmi. Si tu n'as rien dans ton fichier preferences il n'y a pas de problèmes de ce côté.

Comme je n'ai pas jessie installé je ne peux donc pas tester et là vraiment je n'arrive pas à mettre le doigt sur ce foutu problème. La version en sid a aussi beaucoup de dépendances aussi.

Dernière modification par martinux_qc (23-03-2016 02:45:30)


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#13 23-03-2016 09:36:11

Dunatotatos
Membre
Lieu : Arabie Saoudite
Distrib. : Sid
Noyau : linux-image-amd64
(G)UI : tty
Inscription : 24-04-2012

Re : [Résolu]Encore des problèmes de dépendances :tristesse:

martinux_qc a écrit :

Merci pour l'info. Par contre, je ne vois rien pour le paquet python-setuptools. Il était déjà installé ou quoi.


Oui, il était installé en tant que dépendance suggéré de python-virtualenv. La même chose en supprimant python-setuptools avant :
#

apt-get install -s python-pip


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
  python-cffi python-chardet python-colorama python-cryptography
  python-distlib python-html5lib python-ndg-httpsclient python-openssl
  python-ply python-pyasn1 python-pycparser python-requests python-setuptools
  python-six python-urllib3 python-wheel
Paquets suggérés :
  python-cryptography-doc python-cryptography-vectors python-genshi
  python-openssl-doc python-openssl-dbg python-ply-doc doc-base
Paquets recommandés :
  python-dev-all
Les NOUVEAUX paquets suivants seront installés :
  python-cffi python-chardet python-colorama python-cryptography
  python-distlib python-html5lib python-ndg-httpsclient python-openssl
  python-pip python-ply python-pyasn1 python-pycparser python-requests
  python-setuptools python-six python-urllib3 python-wheel
0 mis à jour, 17 nouvellement installés, 0 à enlever et 0 non mis à jour.



@ nazmi : Attention ! preferences est un fichier. Tant mieux s'il est vide. Par contre, le dossier /etc/apt/preferences.d n'est peut-être pas vide.
Peux-tu nous donner la sortie de

apt-cache policy


apt-cache policy python-pip


apt-cache policy python-setuptools


Never trust Windows output.

Hors ligne

#14 23-03-2016 11:24:49

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu]Encore des problèmes de dépendances :tristesse:

Merci Dunatotatos encore de confirmer que l'installation sur jessie se fait normalement chez toi

@ nazmi : Attention ! preferences est un fichier. Tant mieux s'il est vide. Par contre, le dossier /etc/apt/preferences.d n'est peut-être pas vide.



En effet, hier soir, je suis passé un peu rapidement sur le sujet, il est bon de vérifier le contenu de ce dossier. En espérant qu'on finisse par trouver ce qui cloche smile.


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#15 23-03-2016 12:57:49

nazmi
Membre
Lieu : Normandie
Distrib. : GNU/LINUX Debian Jessie
Noyau : Linux 4.3.0-0.bpo.1-amd64
(G)UI : KDE/XFCE
Inscription : 17-07-2015

Re : [Résolu]Encore des problèmes de dépendances :tristesse:

Salut, merci pour vos réponses, voila les apt-cache policy (edit: j'ai testé en root aussi, mêmes sorties)


apt-cache policy


Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
 500 http://ftp.fr.debian.org/debian/ jessie-updates/main Translation-en
 500 http://ftp.fr.debian.org/debian/ jessie-updates/main amd64 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=main
     origin ftp.fr.debian.org
 500 http://security.debian.org/ jessie/updates/main Translation-en
 500 http://security.debian.org/ jessie/updates/main amd64 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=main
     origin security.debian.org
 500 http://ftp.fr.debian.org/debian/ jessie/main Translation-fr
 500 http://ftp.fr.debian.org/debian/ jessie/main Translation-en
 500 http://ftp.fr.debian.org/debian/ jessie/main amd64 Packages
     release v=8.3,o=Debian,a=stable,n=jessie,l=Debian,c=main
     origin ftp.fr.debian.org
Paquets épinglés :



apt-cache policy python-pip


python-pip:
  Installé : (aucun)
  Candidat : 1.5.6-5
 Table de version :
     1.5.6-5 0
        500 http://ftp.fr.debian.org/debian/ jessie/main amd64 Packages
 



apt-cache policy python-setuptools


python-setuptools:
  Installé : (aucun)
  Candidat : 5.5.1-1
 Table de version :
     5.5.1-1 0
        500 http://ftp.fr.debian.org/debian/ jessie/main amd64 Packages



le dossier  /etc/apt/preferences.d est bien vide smile j'ai fait un cd et un ls pour voir

Dernière modification par nazmi (23-03-2016 12:59:08)

Hors ligne

#16 23-03-2016 15:25:38

Dunatotatos
Membre
Lieu : Arabie Saoudite
Distrib. : Sid
Noyau : linux-image-amd64
(G)UI : tty
Inscription : 24-04-2012

Re : [Résolu]Encore des problèmes de dépendances :tristesse:

J'ai oublié de te demander les informations sur le principal fautif :

apt-cache policy python-pkg-resources


Never trust Windows output.

Hors ligne

#17 23-03-2016 17:51:40

nazmi
Membre
Lieu : Normandie
Distrib. : GNU/LINUX Debian Jessie
Noyau : Linux 4.3.0-0.bpo.1-amd64
(G)UI : KDE/XFCE
Inscription : 17-07-2015

Re : [Résolu]Encore des problèmes de dépendances :tristesse:

Salut, le problème s'étend:

Kdenlive a disparu de mon système (bizarre) donc j'ai voulu le réinstaller, ça n'a pas marché comme prévu et j'ai perdu ffmpeg, sinon je me rappelle pourquoi j'ai utilisé les backports, c'était pour installer le ffmpeg de ce dépot (plus à jour que sur le dépot jessie).

voila la réponse de

apt-get install kdenlive



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
  libav-tools
Les paquets suivants seront ENLEVÉS :
  ffmpeg
Les NOUVEAUX paquets suivants seront installés :
  kdenlive libav-tools
0 mis à jour, 2 nouvellement installés, 1 à enlever et 2 non mis à jour.
Il est nécessaire de prendre 0 o/1 776 ko dans les archives.
Après cette opération, 5 522 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
dpkg: ffmpeg : problème de dépendance, mais suppression comme demandé :
 winff-gtk2 dépend de libav-tools | ffmpeg ; cependant :
  Le paquet libav-tools n'est pas installé.
  Le paquet ffmpeg doit être supprimé.

(Lecture de la base de données... 275053 fichiers et répertoires déjà installés.)
Suppression de ffmpeg (7:2.8.6-1~bpo8+1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.0.2-5) ...
Sélection du paquet libav-tools précédemment désélectionné.
(Lecture de la base de données... 275021 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libav-tools_6%3a11.6-1~deb8u1_amd64.deb ...
Dépaquetage de libav-tools (6:11.6-1~deb8u1) ...
Sélection du paquet kdenlive précédemment désélectionné.
Préparation du dépaquetage de .../kdenlive_0.9.10-2_amd64.deb ...
Dépaquetage de kdenlive (0.9.10-2) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.0.2-5) ...
Traitement des actions différées (« triggers ») pour menu (2.1.47) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.58) ...
Paramétrage de libav-tools (6:11.6-1~deb8u1) ...
Paramétrage de kdenlive (0.9.10-2) ...
Traitement des actions différées (« triggers ») pour menu (2.1.47) ...
 



pour

apt-cache policy python-pkg-resources


python-pkg-resources:
  Installé : 18.8-1~bpo8+1
  Candidat : 18.8-1~bpo8+1
 Table de version :
 *** 18.8-1~bpo8+1 0
        100 /var/lib/dpkg/status
     5.5.1-1 0
        500 http://ftp.fr.debian.org/debian/ jessie/main amd64 Packages



Merci d'avance

Edit: enfin au moins kdenlive est de retour tongue

Dernière modification par nazmi (23-03-2016 17:52:39)

Hors ligne

#18 23-03-2016 20:54:02

Dunatotatos
Membre
Lieu : Arabie Saoudite
Distrib. : Sid
Noyau : linux-image-amd64
(G)UI : tty
Inscription : 24-04-2012

Re : [Résolu]Encore des problèmes de dépendances :tristesse:

Ok, le souci vient du fait que la version 18.8-& de python-pkg-resources est installé, et apt-get refuse de downgrader pour installer la version 5.5.1-1 nécessaire à python-setuptools.

Un simple

apt-get remove python-pkg-resources


suffira. Ensuite, installe python-pip comme prévu initialement. Fais attention tout de même à ne pas supprimer des choses importantes avec python-pkg-resources. Regarde bien ce que apt-get te propose de virer.


Never trust Windows output.

Hors ligne

#19 23-03-2016 23:39:13

nazmi
Membre
Lieu : Normandie
Distrib. : GNU/LINUX Debian Jessie
Noyau : Linux 4.3.0-0.bpo.1-amd64
(G)UI : KDE/XFCE
Inscription : 17-07-2015

Re : [Résolu]Encore des problèmes de dépendances :tristesse:

J'ai entré la commande, il veut me supprimer un paquet de trucs dont Deluge sad

[sudo] password for nazmi:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  python-concurrent.futures python-crypto python-idna python-singledispatch rtmpdump
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  deluge deluge-common deluge-gtk python-chardet python-cryptography python-debian python-livestreamer python-matplotlib
  python-nose python-openssl python-pkg-resources python-reportbug python-requests python-service-identity
  python-twisted-core python-twisted-web python-zope.interface reportbug uhd-host
0 mis à jour, 0 nouvellement installés, 19 à enlever et 2 non mis à jour.
Après cette opération, 52,9 Mo d'espace disque seront libérés.



J'ai donc répondu oui puis j'ai pu installer python-pip (but original), réinstaller deluge (qui a gardé tous les paramètres, et les torrents en cours, chapeau).

puis j'ai appliqué la procédure sus-citée présente sur: https://github.com/chrippa/livestreamer/issues/835

sudo apt-get remove livestreamer
sudo apt-get autoremove
sudo apt-get install python-pip
sudo pip install -U livestreamer
livestreamer -V




Petite question, tous ces paramètres utilisateurs ne sont pas supprimés quand je supprime un programme alors ils sont stockés ailleurs, il y a t-il un moyen donc de transposer ma configuration vers une autre machine pour mes programmes principaux, surtout ceux que j'ai installé (et d'en faire la liste) ?

En tout cas, merci beaucoup pour votre aide, je m'en vais de ce pas mettre le sujet en résolu et en ouvrir un autre pour une autre question que j'ai wink

Dernière modification par nazmi (23-03-2016 23:40:35)

Hors ligne

#20 24-03-2016 00:00:36

Dunatotatos
Membre
Lieu : Arabie Saoudite
Distrib. : Sid
Noyau : linux-image-amd64
(G)UI : tty
Inscription : 24-04-2012

Re : [Résolu]Encore des problèmes de dépendances :tristesse:

Si tu veux quelques explications sur ce qu'il s'est passé :
À une époque, tes dépôts backports étaient prioritaires sur les dépôts de Jessie. Ou tu as volontairement installé cette version de python-pkg-resources. Ou une autre action a entraîné l'installation de la version 18.8.1 de python-pkg-resources. Sauf que pour installer python-pip, tu as besoin de la version 5.5.1. Tu avais certainement compris tout ça. Le problème qui s'est posé est que apt-get refuse de downgrader un paquet installé sur ta machine. La version des backports (et donc celle installée) étant plus récente, c'était coincé !

En ce qui concerne tes fichiers personnels de configuration, ils sont dans des dossiers cachés au sein de ton $HOME. Tu trouveras certainement un dossier nommé .deluge dans ton dossier personnel. Il suffit effectivement de copier ton dossier home en totalité sur un autre ordinateur pour transférer la configuration personnelle de la plupart des logiciels. Attention par contre aux configurations qui se font dans d'autres dossiers, généralement à la main, dans /etc.

Never trust Windows output.

Hors ligne

#21 24-03-2016 00:25:30

nazmi
Membre
Lieu : Normandie
Distrib. : GNU/LINUX Debian Jessie
Noyau : Linux 4.3.0-0.bpo.1-amd64
(G)UI : KDE/XFCE
Inscription : 17-07-2015

Re : [Résolu]Encore des problèmes de dépendances :tristesse:

Ok, merci pour les explications, c'est censé de la part d'apt et en plus c'était de ma faute (j'avais installé python-cffi (qui devait avoir ça comme dépendance) pour résoudre un problème de mises à jour qui foiraient car j'avais un peu joué avec les ppa et cie au début que j'avais installé Débian (il y a presque 1an)

j'ai regardé dans mon /home, pas de .deluge mais de toute façon je regarderai ça en temps voulus smile

Merci pour tout

Hors ligne

Pied de page des forums