Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 27-03-2016 06:02:17

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu - mais il y a place mieux] Messagerie locale Win Linux

Note:  http://www.exim.org/exim-html-current/d … faces.html  pourrait peut-être nous aider dans la récupération des messages d'un usager.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#27 27-03-2016 17:03:57

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu - mais il y a place mieux] Messagerie locale Win Linux

Selon http://www.spencerstirling.com/computergeek/email.html 
il semble falloir utiliser le format mailbox pour être en mesure de récupérer le courriel depuis un ordinateur du réseau, extérieur au serveur.

Je reconfigure Exim4 et vous reviendrai.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#28 28-03-2016 01:01:01

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu - mais il y a place mieux] Messagerie locale Win Linux

Comme promis, retour sur l'installation exim4 sur un réseau local et isolé de l'internet.

La récupération des messages par ClawsMail affiche les états suivants:

* Compte 'Tout IP' : Connexion au serveur POP3 : 192.168.2.13:110..
[16:30:10] POP3< 220 patriboom.net ESMTP Exim 4.84_2 Sun, 27 Mar 2016 16:30:10 -0400
*** Une erreur est survenue pendant le traitement du message.


Portez la paix
Patrick Allaire, ptre

Hors ligne

#29 28-03-2016 02:11:46

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [Résolu - mais il y a place mieux] Messagerie locale Win Linux

Je n'ai pas trop lu la doc du site exim , il doit y avoir des infos comment stocker  les messages .
un dossier ou une base de donnée , d'aprés ce que j'ai lu tu arrive a joindre le serveur , tu doit avoir des logs dans /var/log/exim4/
peut etre regarder leur contenu
le client exim stocke les messages qui n'ont pu etre livré , ce qui permet de retenter un envois
pour le serveur je sais pas

Hors ligne

#30 28-03-2016 03:22:44

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu - mais il y a place mieux] Messagerie locale Win Linux

Ce que je trouve d'intéressant dans mes registres est ceci:

2016-03-27 16:33:59 1akHNn-0004mn-18 <= patrick@patriboom.net H=patriboom.local (patriboom.net) [192.168.2.13] P=esmtp S=721 id=60327163358.2e81a9d7@patriboom.net
2016-03-27 16:33:59 1akHNn-0004mn-18 => patrick <patrick@patriboom.net> R=local_user T=maildir_home
2016-03-27 16:33:59 1akHNn-0004mn-18 Completed
2016-03-27 16:41:05 SMTP protocol synchronization error (input sent without waiting for greeting): rejected connection from H=patriboom.local [192.168.2.13] input="\026\003"
 



C'est un problème de synchronisation, de non-respect du protocole.

J'ai résolu d'installer courier-pop3 pour tenter de régler cette question de protocole  (courier-imap existe aussi).


Portez la paix
Patrick Allaire, ptre

Hors ligne

#31 28-03-2016 03:45:32

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu - mais il y a place mieux] Messagerie locale Win Linux

Merci de tous ces retours. J'espère que ta persévérance va finir par porter fruit.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#32 28-03-2016 04:01:16

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu - mais il y a place mieux] Messagerie locale Win Linux

Je crois que ça fonctionne.
Du moins, ça fonctionne sur ma machine qui sert à la fois de client et de serveur.
Je testerai sur la machine client de ma soeur.

Il semble que ce soit la configuration de /etc/courier/pop3d qui réglât la question.

À suivre.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#33 28-03-2016 04:36:52

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu - mais il y a place mieux] Messagerie locale Win Linux

Confirmation: ça fonctionne!
Le test ne sera complet qu'avec des machines Windows dans le réseau, mais en théorie, il n'y a pas de raison de croire que ça bloque, car les configurations des clients de courriel sont des plus habituelles.

je vous passe en bloque ce que j'ai fait:
- m'assurer qu'exim4 est complètement installé (exim4-light), c'est-à dire que les fichiers suivants sont présents dans /etc/exim4:
-- exim4.conf.template
-- update-exim4.conf.conf
- Aussi longtemps que je n'ai pas eu cela, rien ne débloquait.  Il me fallut faire apt-get purge exim4, supprimer le répertoire /etc/exim4, puis créer de nouveau ce répertoire, installer exim4

La configuration actuelle - changez ce qui vous concerne - d'exim4 est:


dc_eximconfig_configtype='local'
dc_other_hostnames=''
dc_local_interfaces='127.0.0.1 ; 192.168.2.13.26 ; ::1'
dc_readhost=''
dc_relay_domains=''
dc_minimaldns='false'
dc_relay_nets=''
dc_smarthost=''
CFILEMODE='644'
dc_use_split_config='false'
dc_hide_mailname=''
dc_mailname_in_oh='true'
dc_localdelivery='maildir_home'
 



- Ensuite installer les paquets courier (et ses dépendances) et courier-pop3
- Les configurations importantes de /etc/courier/courier-pop3d sont


PORT=192.168.2.13.110
ADDRESS=192.168.2.10,192.168.2.11,192.168.2.12,192.168.2.13,192.168.2.14,192.168.2.15,192.168.2.16,192.168.2.17,192.168.2.18
 


J'ignore si j'aurais pu abréger les adresses acceptées par la graphie standard

ADDRESS=192.168.2.10/20



Après redémarrage de ces services


/etc/init.d/exim4 restart
/etc/init.d/courier-pop restart
 



Il faut que la commande

netstat -antp


Vous permette de voir que les ports suivants sont écoutés par les serveurs suivants:


192.168.2.13:110        0.0.0.0:*               LISTEN      5393/couriertcpd
127.0.0.1:25            0.0.0.0:*               LISTEN      5241/exim4
192.168.2.13:26         0.0.0.0:*               LISTEN      5241/exim4
::1:25                  :::*                    LISTEN      5241/exim4
 



Alors, on peut configurer nos logiciel de lecture de courriel (graphiques).
Ici j'ai testé avec deux ClawsMail


Adresse courriel:  usager@serveur.net
Protocole: pop3
Serveur de réception: 192.168.2.13
Serveur d'envoi: 192.168.2.13
Nom d'utilisateur:  usager  (sans le nom de domaine, car c'est ici l'usager inscrit dans le système linux du serveur)
Mot de passe: le mot de passe de cet usager sur le système linux (du serveur)

Envoyer: authentification SMTP (automatique)
Nom d'utilisateur: usager
Mot de passe: le mot de passe de cet usager

SSL: ne pas utiliser SSL en pop3 ni en SMTP   (si vous voulez le faire, il vous faudra installer d'autres paquets pour courier, dont celui courier-pop-ssl)

Port SMTP: 26
Port POP3: 110
 



Mes deux machines s'envoient désormais des courriels sans passer par l'internet.

N'oubliez pas, pour cela, de définir les usagers sur le serveur et d'aménager les répertoires correspondant dans /home avec les droits appropriés.  Ainsi, dans mon cas, j'aurai sur mon serveur linux:

/home/patrick/Maildir/new
/home/diane/Maildir/new
/home/ginette/Maildir/new
/home/mario/Maildir/new
/home/martin/Maildir/new



Je crois, robert, que nous avons ici de quoi compléter ton tuto.

J'ai tenté ici de faire le plus minimaliste possible, avec les paquets installés par défaut (exim4).  J'ai dû faire appel à courier-pop pour compléter, mais rien de très gros encore.

Au plaisir.

Dernière modification par Patriboom (28-03-2016 04:39:44)


Portez la paix
Patrick Allaire, ptre

Hors ligne

#34 28-03-2016 13:02:32

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [Résolu - mais il y a place mieux] Messagerie locale Win Linux

ce qui me derrange c'est les users sur le serveur et en plus dans le /home
normalement il y a un dossier systeme pour exim4  (et courier pop3 )
sur le serveur tu n a pas a créer les comptes des utilisateurs ,  exim4 filtrera par les ip que tu a autorisé et il a les droits pour enregistrer les messages localement et les redistribuer en fonction du destinataire
sinon bravo tu a bien avancé
si tu n a pas le livre , regarde sur internet les cahier de l admin debian , le paragraphe sur postfix et la mise en place des boites mails sur le serveur.
pour exim cela doit etre a peu pres le meme fonctionnement
pour l ipv6 je le désactive du genre  "127.0.0.1 , 192.168.0.0/24"  (ip autorisé a envoyer et recevoir )

Dernière modification par robert2a (28-03-2016 13:05:17)

Hors ligne

#35 28-03-2016 13:30:09

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu - mais il y a place mieux] Messagerie locale Win Linux

Cette histoire du home me déplaît aussi.  Il ma fallut un long temps pour trouver mes messages qui s'enregistraient là.  J'ignore pourquoi il vont à home plutôt que dans /var/mail.

Quant à l' IPv6, je crois que c'est une habitude à développer que de les traiter car un jour ou l'autre il faudra bien se mettre à l'IP6.  Aussi bien apprendre à jouer avec cela pendant que ça n'a pas de conséquence.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#36 28-03-2016 21:28:34

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu - mais il y a place mieux] Messagerie locale Win Linux

Retour d'expérience,

la configuration a été remise au courriel local non-pop  /var/mail

dc_eximconfig_configtype='local'
dc_other_hostnames='patriboom.net'
dc_local_interfaces='127.0.0.1 ; 192.168.2.13.26 ; ::1'
dc_readhost='192.168.2.10/20'
dc_relay_domains=''
dc_minimaldns='false'
dc_relay_nets=''
dc_smarthost=''
CFILEMODE='644'
dc_use_split_config='false'
dc_hide_mailname=''
dc_mailname_in_oh='true'
dc_localdelivery='mail_spool'
 



Je puis récupérer le courriel depuis le serveur sur la machine A (patrick récupère courriel - utilisant machine A - depuis le serveur - lui aussi sur machine A) via une connexion 192.168.2.13:110
Je n'arrive pas à en faire autant sur la machine B  (192.168.2.10)

J'ai cherché une réponse dans /etc/courier/pop3d et je ne trouve rien qui explique cela

Voici les seules modifications que j'apportasse à /etc/courer/pop3d


PORT=192.168.2.13.110
ADDRESS=192.168.2.10/20
MAILDIRPATH=Maildir
#MAILDIRPATH=/var/mail
 



Vous voyez que j'ai tenté de changer le MAILDIRPATH, mais ça n'a rien donné qui valût.


Portez la paix
Patrick Allaire, ptre

Hors ligne

#37 29-03-2016 00:52:16

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu - mais il y a place mieux] Messagerie locale Win Linux

Je cherche encore à faire en sorte que mes messages arrivent (ça fonctionne) et soient récupérés dans le répertoire /var/mail.

Après POP3 qui ne semble pas collaborer, j'ai tenté le IMAP: sans plus de succès.
D'ailleurs, on peut lire ceci dans /etc/courier/imapd :

##NAME: IMAP_MAILBOX_SANITY_CHECK:0
# Sanity check -- make sure home directory and maildir's ownership matches the IMAP server's effective uid and gid
I



Il est donc inutile d'investiguer davantage du côté IMAP

Bref, je suis revenu au POP3 dans les sous-répertoire usagers de home.
Je suis ouvert aux suggestions.

Dernière modification par Patriboom (29-03-2016 01:06:38)


Portez la paix
Patrick Allaire, ptre

Hors ligne

#38 29-03-2016 01:29:52

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [Résolu - mais il y a place mieux] Messagerie locale Win Linux

j'ai passé mon deuxieme serveur en serveur de messagerie.
j'utilise le hostname
en local du serveur j'arrive a livrer un mail en "/home/user/maildir/new" ou en "/var/mail/mailuser"
je n'utilise que exim4

Dernière modification par robert2a (29-03-2016 01:32:15)

Hors ligne

#39 29-03-2016 02:20:42

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu - mais il y a place mieux] Messagerie locale Win Linux

Oui,

moi aussi j'arrive à faire cela en local (ordinateur A, usager et serveur en un)
Dès que j'ouvre l'ordinateur de ma soeur, sur le même réseau local, je n'y arrive plus à partir de cet ordinateur B.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#40 29-03-2016 02:56:33

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [Résolu - mais il y a place mieux] Messagerie locale Win Linux

exim4 utilise un fichier /etc/aliases et /etc/email-addresses et génère un fichier qui est utilisé par les clients qui le demande.

je pense que sur mon réseau local ça ne fonctionnera pas , il faut un petit réseau de 3 ordinateurs .
j ai icedove ou evolution comme client le second a une config déja pour le smarthost (ça fonctionne pas )
ou alors il faut que je casse ma configuration existante
ce qui m inquiette un peu c est la methode pour ouvrir les messages , (comment différencier les messages de pierre , paul etc .... )
enfin pour moi je n ai qu un utilisateur sur le réseau , bien qu il soit possible d avoir une adresse mail par machines différente (du genre machine1@exemple )

il y a ce petit nota sur le wiki et l utilisation des fichiers aliases et email-addresses
Nota: Exim4 renseigne un petit fichier /etc/mailname qui contient le nom du serveur de mail

ce que tu peu faire c'est récupérer les messages systemes de tes machines sur ton serveur local a l'aide justement de ces 3 fichiers
il faut créer un compte de messagerie "admin@" par exemple sur le serveur (c'est surement la que je bloque , au niveau du FAI ça pose pas de probleme , mais au niveau d un serveur local j'ai pas compris la méthode hmm  )

ps: j ai récupéré la doc exim-html qui est bien détaillé mais en anglais , hmm

peut etre regarder sur debian-fr et faire une recherche sur exim4 , j y est pas pensé , il y a des barbus wink

Dernière modification par robert2a (29-03-2016 03:21:13)

Hors ligne

#41 29-03-2016 04:39:56

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu - mais il y a place mieux] Messagerie locale Win Linux

Merci robert, mais je ne suis pas sùr qu'exim4 soit en cause.
Je crois être en mesure d'orienter les message vers /var/mail qu'ils soient envoyés par un usager extérieur ou par mutt interne (je commence à être mêlé dans mes tests! hmm )

J'essaie maintenant de trouver un serveur POP3 qui ait accès à /var/mail.
solid-pop3d est super-petit et offre cette promesse.  Il prendrait lieu et fonction de courier et courier-pop.
Le problème que j'ai pour l'instant avec solid-pop3 c'est de voir s'il fonctionne ou pas.
Il semble que non, puisque  netstat -antp  ne me donne aucun signe de sa présence.
Je cherche donc à le démarrer.
/etc/init.d/solid-pop3 start me fait un simple retour à la ligne
de même pour stop et restart.
À suivre.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#42 29-03-2016 11:35:20

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu - mais il y a place mieux] Messagerie locale Win Linux

Bonjour,

je crois que nous y sommes.

La commande 
dpkg-reconfigure solid-pop3d permet de choisir le mode « daemon » pour le serveur pop3
Quand je fais /etc/init.d/solid-pop3d restart  oui, le petit OK vert apparaît

Il faut ensuite s'assurer que  dpkg-reconfigure exim4-config a bien été remis au format « mbox » /var/mail
Et ça semble fonctionner à notre goût.

L'essai n'a été tenté que sur l'ordinateur A  (à la fois client et serveur) par manque de temps en matinée hâtive.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#43 30-03-2016 03:39:50

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu - mais il y a place mieux] Messagerie locale Win Linux

Bonsoir,

un premier but est atteint: tout en /var/mail
grâce à exim4 et solid-pop3

J'aimerais maintenant être ne mesure de créer des usagers mail qui ne sont pas obligatoirement usager du serveur.
Pour cela, j'ai fait appel aux fichiers de /etc/exim4/conf.d/auth  plusieurs options sont offertes, j'y suis allé au plus simple:  plaintext
- Modification du fichier /etc/exim4/conf.d/auth/30_exim4-config_examples
--y dé-commantant les paragraphes de
--plain-server et de
--login_server

-Création d'un fichier /etc/exim4/passwd
Modification des droits
    chown root /etc/exim4/passwd
    chgrp Debian-exim /etc/exim4/passwd
    chmod 640 /etc/exim4/passwd

/usr/share/doc/exim4-base/examples/exim-adduser

pour créer les usagers

- modification de solid-pop3  ( /etc/spop3d.conf )

<VirtualHost 192.168.2.13>
  UserOverride  false
  UnreadExpire  never
  APOPServerName  "patriboom.net"
  MailDropName  "/var/mail/%s"
  MailDropType  "mailbox"
  AutoLogoutTime  5s
  UserOverride  yes
  AllowAPOP   yes
</VirtualHost>
 



J'aimerais y ajouter

       UserMapFile     "/etc/exim4/passwd"
 


ou

       UserMapFile     "/etc/exim4/passwd.spop3d"
 


mais ça ne fonctionne pas.

Oups!  je crois que je viens de trouver mon problème pour la suite  :  « UserOverride  » devrait-il être à true  ?

UserOverride boolean
                     Allow  users  specify their maildrops (path and type) and
                     APOP secrets.  It's enabled by default.




Au bout du compte, j'aimerais que exim4 et solid-pop3 partagent le même fichier de configuration des usagers
Voici à quoi ressemble le fichier  /etc/exim4/passwd

Batard:$1$cVqS$rk62wLeahIjHen2MIUj611:Batard
Patrick:MotPasseMD5:MotPasse
banane:$1$sNLs$4oBXvuv/Qv17Wgbw0v0gJ0:tomate
nathalie:MotPasse2MD5:MotPasse2
yolland:$1$iEqr$6dcvea/3dLCJYUXB8Oa6G1:passepasse



J'ai tenté de créé son semblable pour solid-pop3, qui s'appelle /etc/exim4/passwd.spop3d

Batard:Batard
Patrick:MotPasse
banane:tomate
nathalie:MotPasse2
yolland:passepasse



J'ai trouvé ceci:  https://sourcecodebrowser.com/solid-pop … ource.html, mais je ne sais pas quoi en faire, comment l'installer, comment l'exploiter, si même ce m'est utile de quelque façon

00001 static const char rcsid[] = "$Id: mapping.c,v 1.2 2000/04/17 19:38:04 jurekb Exp $";
00002 /*
00003  *  Solid POP3 - a POP3 server
00004  *  Copyright (C) 1999  Jerzy Balamut <jurekb@dione.ids.pl>
00005  *
00006  *  This program is free software; you can redistribute it and/or modify
00007  *  it under the terms of the GNU General Public License as published by
00008  *  the Free Software Foundation; either version 2 of the License, or
00009  *  (at your option) any later version.
00010  *
00011  *  This program is distributed in the hope that it will be useful,
00012  *  but WITHOUT ANY WARRANTY; without even the implied warranty of
00013  *  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00014  *  GNU General Public License for more details.
00015  *
00016  *  You should have received a copy of the GNU General Public License
00017  *  along with this program; if not, write to the Free Software
00018  *  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00019  */
00020
00021 #include "includes.h"
00022 #include "mapping.h"
00023 #include "fdfgets.h"
00024 #include "log.h"
00025 #include <fcntl.h>
00026 #include <pwd.h>
00027 #ifdef HAVE_GRP_H
00028 #include <grp.h>
00029 #endif
00030
00031 /* result should be a (MAXARGLN+1)-byte buffer */
00032 int map_finduser(char *mapfile, char *username, char *result) {
00033        int fd, linenr = 1, tmp2, tmp3;
00034        ssize_t lcount;
00035        char linebuf[MAXARGLN + 1 + MAXARGLN + 1];
00036               /* username:maptouser\n */
00037        char *tmp;
00038       
00039        if ((fd = open(mapfile, O_RDONLY)) < 0) {
00040               pop_log(pop_priority, "map: can't open file: %.1024s", mapfile);
00041               pop_error("map: open");
00042               return -1;
00043        };
00044        fd_initfgets();
00045        while ((lcount = fd_fgets(linebuf, sizeof(linebuf), fd)) > 0) {
00046               if ((linebuf[lcount - 1] != '\n') && (lcount == sizeof(linebuf))) { /* line too long */
00047                      pop_log(pop_priority, "map: line %d in %.1024s is too long", linenr, mapfile);
00048                      lcount = -1;
00049                      break;
00050               };
00051               if (linebuf[lcount - 1] == '\n')
00052                      linebuf[lcount - 1] = 0;
00053               else
00054                      linebuf[lcount] = 0; /* lcount < sizeof(linebuf) */
00055               tmp3 = 0;
00056               for (tmp2 = 0; tmp2 < lcount; tmp2++)
00057                      if (linebuf[tmp2] == ':')
00058                             tmp3++;
00059               if (tmp3 != 1) {
00060                      pop_log(pop_priority, "map: syntax error in line nr %d in file %.1024s", linenr, mapfile);
00061                      lcount = -1;
00062                      break;
00063               };
00064               *(tmp = strchr(linebuf, ':')) = 0;
00065               if (strlen(linebuf) > MAXARGLN) {
00066                      pop_log(pop_priority, "map: user name too long in line %d in %.1024s", linenr, mapfile);
00067                      lcount = -1;
00068                      break;
00069               };
00070               if (strcmp(linebuf, username) == 0) { /* parse line */
00071                      if (strlen(++tmp) > MAXARGLN) {
00072                             pop_log(pop_priority, "map: wrong mapped user name entry in line %d in %.1024s", linenr, mapfile);
00073                             lcount = -1;
00074                             break;
00075                      };
00076                      strcpy(result, tmp);
00077                      break;
00078               };
00079               linenr++;
00080        };
00081        close(fd);
00082        memset(linebuf, 0, sizeof(linebuf));
00083        return (lcount <= 0) ? -1 : 0;
00084 };



Voyez, ça progresse  cool


Portez la paix
Patrick Allaire, ptre

Hors ligne

#44 30-03-2016 11:31:38

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [Résolu - mais il y a place mieux] Messagerie locale Win Linux

Bravo pour ce retour, je suis avec intérêt même si je ne peux pas te venir en aide. smile

En ligne

#45 03-04-2016 22:51:58

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu - mais il y a place mieux] Messagerie locale Win Linux

Bonjour à tous,

je creuse, je creuse, mais je suis encore bloqué sur une chose pourtant simple.

Au point où j'en suis, voici ce qui fonctionne:
- émission de message depuis n'importe quel ordinateur vers n'importe quel autre ordinateur du réseau
- réception des messages sur n'importe quel ordinateur du réseau depuis le serveur  exim4 / spop3d
Contraintes:
- les usagers doivent avoir un compte ouvert sur le serveur, un répertoire ~/Mail et un répertoire ~/Maildir

Ce que je cherche à faire:
- offrir le courriel aux non-membres du système
- limiter l'accès au courriel aux seuls ordinateurs connectés au réseau local ( ça fonctionne )
- ne plus être obligé d'ouvrir des comptes usagers ni créer de fichiers dans /home
- utiliser un seul fichier d'indentifiants / mots de passe pour exim4 et spop3d

Là où j'achoppe actuellement c'est sur la configuration d'exim4 afin de lui faire lire mon fichier de mots de passe et les comparer à ceux soumis par un envoi SMTP.

Voici le fichier de configuration personnel que je monte afin d'éviter d'intervenir dans les configurations standards d'exim4

#Répertoire de configuration
CONFDIR = /etc/exim4

MAIN_LOCAL_DOMAINS = localhost:patriboom.net
MESSAGE_SIZE_LIMIT = 50MB

#Vérification des courriels
#MAIN_ACL_CHECK_MAIL = /etc/exim4/passwrd
MAIN_ACL_CHECK_MAIL = /etc/exim4/VerifSMTP

#Les messages reçus depuis les IP suivants sont automatiquement retransmis, sans filtrage, sans discrimination
MAIN_RELAY_NETS = 192.168.2.10/20

#ETC_MAILNAME = patriboom.net

#Définition de la méthode d'enregistrement
##mail_spool est la méthode classique de Debian
##my_mailboxes triera les messages par nom de domaine dans /var/mail
LOCAL_DELIVERY = mail_spool

#Définition du répertoire de travail par défaut
CURRENT_DIR = /var/mail

#Permet d'ajouter automatiquement le nom de domaine à une adresse qui en serait dépourvue
MAIN_QUALIFY_DOMAIN = patriboom.net
RCP_QUALIFY = patriboom.net

#Permission de se connecter sans sécurité TLS
AUTH_CLIENT_ALLOW_NOTLS_PASSWORDS = true
AUTH_SERVER_ALLOW_NOTLS_PASSWORDS = patriboom.net
MAIN_TLS_ENABLE = false
MAIN_TLS_TRY_VERIFY_HOSTS =


#Le répertoire par défaut où sont envoyés les messages
MAILDIR_HOME_MAILDIR_LOCATION = /var/mail

#Le fichier où sont enregistrés les mots de passe non-encodés MD5
MOTSPASSE = /etc/exim4/passwd.spop3d

#Mettre en remarque la ligne suivante si vous souhaitez utiliser les alias système, autrement seuls les mots de passe du fichier désigné ci-haut seront utilisés
SYSTEM_ALIASES_UTILISER = false

 



Ceci fait en sorte que
- Les messages ne sont pas obligatoirement passés à la moulinette du TLS
- Les messages sont enregistrés dans un fichier (par usager) dans le répertoire /var/mail/nomDeDomain, en l'occurrence /var/mail/patriboom.net les distinguant donc par nom de domaine et des fichiers générés par root
- Les messages qui seraient adressés à des destinataires qui n'ont pas de compte sont simplement perdus  ( gestion facile des usagers, il suffit de créer un fichier vide du nom souhaité)
- les messages peuvent être envoyés à une personne sans nom de domaine, celui-ci étant complété automatiquement et gardé dans le bon fichier. vg:  un message adressé à patrick sera ré-adressé à patrick@patriboom.net et conservé dans le fichier /etc/mail/patriboom.net/patrick
- la configuration des logiciels de courriel est standard, sauf quant au port de destination, ici utilisé le port 26 afin de ne pas entrer en conflit avec les messages de root ou de gestion interne adressés au port 25  ( serveur POP )

Bref, je vise le plus simple possible autant pour l'usager que pour la mise en place.
Ici, j'utilise la configuration en un seul fichier, mais je suggérerai la configuration éclatée d'exim4 qui - dans ce cas - s'avère plus facile à gérer.

Votre aide serait appréciée afin de passer cette étape: lire et interpréter adéquatement le fichier d'usagers/mots de passe par exim4
Actuellement, j'obtiens ce message d'erreur de la part de ClawsMail :

* Compte 'Tout IP' : Connexion au serveur SMTP : 192.168.2.13:26..
[16:50:59] SMTP< 220 patriboom.net ESMTP Exim 4.84_2 Sun, 03 Apr 2016 16:50:59 -0400
[16:50:59] ESMTP> EHLO patriboom.net
[16:50:59] ESMTP< 250-patriboom.net Hello patriboom.local [192.168.2.13]
[16:50:59] ESMTP< 250-SIZE 52428800
[16:50:59] ESMTP< 250-8BITMIME
[16:50:59] ESMTP< 250-PIPELINING
[16:50:59] ESMTP< 250 HELP
** Aucune méthode SMTP AUTH disponible
[16:50:59] ESMTP> MAIL FROM:<nathalie@patriboom.net> SIZE=397
[16:50:59] SMTP< 550 Administrative prohibition
** Erreur pendant la session SMTP
*** Une erreur est survenue pendant l'envoi du message :
550 Administrative prohibition



Merci


Portez la paix
Patrick Allaire, ptre

Hors ligne

#46 04-04-2016 00:30:59

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu - mais il y a place mieux] Messagerie locale Win Linux

J'ai peut-être ici une réponse:  pas de login ni plain sans TLS selon:

2.3. SMTP-AUTH

Exim can do SMTP AUTH both as a client and as a server.

AUTH PLAIN and AUTH LOGIN are disabled for connections which are not protected by SSL/TLS per default. These authentication methods use cleartext passwords, and allowing the transmission of cleartext passwords on unencrypted connections is a security risk. Therefore, the default configuration configures Exim not to use and/or allow AUTH PLAIN and AUTH LOGIN over unencrypted connections.

It is thus recommended to set up Exim to use TLS to encrypt the connections. Please refer to Section 2.2, “Using TLS” for documentation about this. Note that most Microsoft clients need special handling for TLS.



-- tiré de http://pkg-exim4.alioth.debian.org/READ … tml#macros


Portez la paix
Patrick Allaire, ptre

Hors ligne

#47 04-04-2016 01:03:31

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [Résolu - mais il y a place mieux] Messagerie locale Win Linux

je suis admiratif devant ton boulot tongue
et ta persévérance wink

Hors ligne

#48 05-04-2016 04:01:52

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu - mais il y a place mieux] Messagerie locale Win Linux

Bonsoir,

on arrive à nos fins et à la fin du travail.
J'ai tout remis à zéro et j'ai recommencé: plus simple.
J'ai aussi balancé bon nombre de fichiers de /etc/exim4/conf.d
Oui, je fonctionne en configuration mutli-fichiers, c'est plus clair et facile.

Dans tout cela, j'ai perdu deux options en chemin: auto-complétion du nom de domaine et limite des IP acceptables.

Cependant, j'ai gagné:
    - libération des destinataires du registre des usagers linux  ( on peut avoir un compte mail sans être usager inscrit au système ni même avoir un répertoire dans le /home )
    - si le fichier n'existe pas, on ne peut pas écrire à cette personne.

J'ai conservé:
- les messages sont enregistrés dans /var/mail/NomDeDomaine
- simplicité de configurer les logiciels d'usagers
- modifications mineures dans les fichiers source.

Ceci était pour exim4

C'est bien beau tout cela, mais il faut maintenant récupérer les messages envoyés.
Là je bloque avec solidpop3

Voici le résultat:

* Compte 'Tout IP' : Connexion au serveur POP3 : 192.168.2.13:110..
[21:48:30] POP3< +OK Solid POP3 server ready
[21:48:30] POP3> USER yolland
[21:48:30] POP3< +OK username accepted
[21:48:30] POP3> PASS ********
[21:48:31] POP3< -ERR authentication failed
*** Erreur lors de l'autorisation
*** L'authentification a échoué.



d'une configuration de /etc/spop3d.conf telle que:

/* Configuration file for Solid POP3 */
<Global>
  LogPriority    daemon.info
  MailDropName   Maildir
  MailDropType   maildir
  /* UserBullFile   .spop3d-blurp It's just an example */
  ReadExpire     0
  UnreadExpire   2w
</Global>

<VirtualHost 192.168.2.13>
  UserOverride  true
  UnreadExpire  never
  UserMapFile /etc/exim4/passwd.spop3d
  DoMapping true
  MailDropName  /var/mail/patriboom.net/%s  
  MailDropType  mailbox
  AutoLogoutTime  5s
  AllowUser yes
  AllowAPOP   false
</VirtualHost>
 



Voici enfin le fichier des mots de passe (en clair)  /etc/exim4/passwrd.spop3d

baboom tomate;
nathalie Claude;
Batard Batard;
Patrick Bonjour;
yolland passepasse;
 



Je soupçonne que ce soit simple question de balisage entre usagers et mot de passe.
Le code solid-pop3 semble utiliser  map.h pour mapper les fichiers; ça vous donne peut-être une piste pour m'aider.

--------------

En gros, les modifications apportées sont

### transport/30_exim4-config_mail_spool

# This transport is used for local delivery to user mailboxes in traditional
# BSD mailbox format.
#
mail_spool:
  debug_print = "T: appendfile for $local_part@$domain"
  driver = appendfile
  #Condition de sécurité ajoutée par Patrick
  file_must_exist = true
  #Ligne originale
  #file = /var/mail/$local_part
  #Modification par Patrick
  file = MAILDIR_HOME_MAILDIR_LOCATION/$domain/$local_part
  delivery_date_add
  envelope_to_add
  return_path_add
  group = mail
  mode = 0660
  mode_fail_narrower = false
 




### router/900_exim4-config_local_user
#################################

# This router matches local user mailboxes. If the router fails, the error
# message is "Unknown user".

local_user:
  debug_print = "R: local_user for $local_part@$domain"
  driver = accept
  domains = +local_domains
  #En mettant en remarque, le destinataire n'a plus l'obligation d'être usager du système
#  check_local_user
  local_parts = ! root
  transport = LOCAL_DELIVERY
  cannot_route_message = Unknown user
 



##### Fichier de configuration personnalisée  dans /etc/exim4/conf.d/main/00_exim4-config_listmacrosdefs #########
#Répertoire de configuration
CONFDIR = /etc/exim4

#Définition de la méthode d'enregistrement
##mail_spool est la méthode classique de Debian
##my_mailboxes triera les messages par nom de domaine dans /var/mail
LOCAL_DELIVERY = mail_spool

#Définition du répertoire de travail par défaut
CURRENT_DIR = /var/mail

#Permet d'ajouter automatiquement le nom de domaine à une adresse qui en serait dépourvue
##C'est bien ce que je croyais, mais ça ne fonctionne plus depuis la mise en place de la configuration à fichiers éclatés.
MAIN_LOCAL_DOMAINS = localhost:patriboom.net
ETC_MAILNAME = patriboom.net
#MAIN_QUALIFY_DOMAIN == patriboom.net
RCP_QUALIFY = patriboom.net

#Le répertoire par défaut où sont envoyés les messages
MAILDIR_HOME_MAILDIR_LOCATION = /var/mail

#Mettre en remarque la ligne suivante si vous souhaitez utiliser les alias système, autrement seuls les mots de passe du fichier désigné ci-haut seront utilisés
SYSTEM_ALIASES_UTILISER = false
 


Portez la paix
Patrick Allaire, ptre

Hors ligne

#49 07-04-2016 03:31:17

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu - mais il y a place mieux] Messagerie locale Win Linux

Bonjour à tous,

après des dizaines d'heures de recherche, j'arrive aux conclusions suivantes:

- il est possible d'utiliser exim4 hors des usagers définis par le système, mais ça demande quelques bricolages
- il est impossible de configurer le serveur solid-pop3 pour en faire autant. Il est prisonnier des usagers du système ou il demande des paquets supplémentaires.

L'objectif étant de rester au plus simple, au plus léger et aux moins de bicolages possibles, il vaut mieux se tourner vers une autre solution que la combinaison exim4 / spop3d même si cela semble léger.

https://books.google.ca/books?id=yUUnCg … le&f=false m'amène à penser que qmail peut être plus léger et plus facile à configurer.  qmail utilise spop3.  Le tableau de la page  8 prétend ceci
gestionnaire MTA complet           version              taille          version actuelle
sendmail                                   8.11.3               303212       8.14
postfix                                      20010228-pl02   240370       2.11
exim                                         3.02                 302236       4.84
courier                                      0.33.0               668945       0.66
qmail                                         1.03                  80025       1.06

J'ai ajouté ci-haut les numéros des versions actuelles, car - de toute évidence - l'article date un peu.
Quoi qu'il en soit, synaptic commente ainsi le paquet qmail: « qmail is meant as a replacement for the entire sendmail-binmail system on typical Internet-connected UNIX hosts. »  Est-ce le commentaire de l'auteur ou est celui des éditeurs debian ?

Je me lance dans qmail et voici la déception:  il y a toute une liste de paquets à installer.  Oui, qmail est léger, mais il exige les ressources des autres. Est-ce vraiment une plus léger ?  Je pense que non.
Je me rabattrai donc sur le duo exim4 / courier qui me semblait prometteur au début et ce vers quoi je me tourne désormais.

Dernière modification par Patriboom (07-04-2016 12:36:41)


Portez la paix
Patrick Allaire, ptre

Hors ligne

Pied de page des forums