Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 27-03-2016 19:31:15

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

systemd et autologin : problème [Résolu bêtement]

Bjr,
J'ai une config avec Sid sur laquelle j'ai besoin d'un autologin. Y'a pas si longtemps ça fonctionnait très bien avec l'ancienne méthode, réactualisée en modifiant /lib/systemd/system/getty@.service :

...
ExecStart=-/sbin/agetty -n -l /usr/sbin/autologin %I $TERM
...

...etc, etc...
Depuis une mise à jour, qui semble avoir réactualisé ce fichier, et où j'ai donc perdu l'autologin, j'ai tenté la méthode donnée par ArchLinux (création des fichiers dans /etc/systemd/system etc.....)
Arrive alors le sujet du problème: presque évidemment l'autologin ne fonctionne pas et cela semble dû à un "vague à l'âme" de systemd-logind. Voici l'erreur (après m'être logué en manuel bien sûr)

systemd-logind failed to start unit user@1000.service unknown unit


Des idées, des expériences ?

Dernière modification par phlinux (29-03-2016 22:33:28)


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#2 28-03-2016 18:12:39

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : systemd et autologin : problème [Résolu bêtement]

ExecStart=-/sbin/agetty -n -l /usr/sbin/autologin %I $TERM

Si ce n'est pas une erreur de frappe lors de la retranscription, il y a un tiret en trop,
juste entre "=" et "/sbin…"

Hors ligne

#3 28-03-2016 22:28:55

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : systemd et autologin : problème [Résolu bêtement]

Je viens de vérifier sur 2 config, que je n'ai pas modifiées, et  c'est bien comme inscrit dans mon post.
De toute façon j'ai le même message d'erreur avec les autres manip décrites.

Je vais faire d'autres essais, mais le problème semble bien venir de la reconnaissance de l'unit

Edit: après essais sur une Jessie, le problème n'existe que sur l'ordi en Sid dont je fais mention au post#1.
J'en profite pour donner le lien vers une excellente méthode, simple, pour se faire un autologin avec systemd. C'est là >> https://memo-linux.com/debian-8-systemd … y-manager/

Dernière modification par phlinux (28-03-2016 22:55:11)


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#4 29-03-2016 18:37:01

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : systemd et autologin : problème [Résolu bêtement]

Ok, j'ai trouvé à quoi servait ce tiret :

"man systemd.service" a écrit :

… If the absolute filename is prefixed with "-", an exit code of the command normally considered a failure (i.e. non-zero exit status or abnormal exit due to signal) is ignored and considered success.…

Dernière modification par MicP (29-03-2016 19:57:32)

Hors ligne

#5 29-03-2016 22:32:34

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : systemd et autologin : problème [Résolu bêtement]

Et surtout il ne faut pas mettre d'espace après ça bloque carrément le boot.

Quant à mon problème d'autologin c'était tout con; avec toutes les manip j'avais oublié d'installer systemd-sysv. Donc pas de problème...à part chez le mec qui pilote

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

Pied de page des forums