Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 21-05-2009 16:41:46

Al67
Membre
Inscription : 11-05-2009

Problème d'affichage avec Nvidia et KDE 4 (Résolu)

Bonjour,

Ce problème d'affichage, je pensais d'abord qu'il se limitait au style de menu Kickoff, mais en réalité ça me le fait un peu partout, par exemple lors de la notification de nouveaux périphériques :

notificationdenouveaupr.th.png

Ainsi que lors de l'ajout de nouveaux plasmoides :

ajouterdesplasmoides.th.png

Et donc également lorsque je navigue dans le menu Kickoff.

Je pense que c'est du aux pilotes nvidia, parce qu'a l'installation avec les pilotes libres, je n'avais pas ce problème.

Ça se passe sur une Debian squezze/sid (Noyau 2.6.26-2-686) avec une carte Nvidia Geforce 7200 GS.
J'ai les pilotes propriétaires en version 173.14.09

Je les ai installés comme indiqué dans le chapitre Installation du pilote propriétaire avec les dépôts Debian

Est ce quelqu'un d'autre à déjà eu a faire à ça ?

Dernière modification par Al67 (26-05-2009 16:17:48)

Hors ligne

#2 26-05-2009 16:17:12

Al67
Membre
Inscription : 11-05-2009

Re : Problème d'affichage avec Nvidia et KDE 4 (Résolu)

Le problème est résolu : Il faut pour cela installer les pilotes propriétaires en version 180.44-2

Hors ligne

#3 26-05-2009 16:27:25

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Problème d'affichage avec Nvidia et KDE 4 (Résolu)

Tchop ! Merci du retour... wink

Amicalement, Joel

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#4 31-05-2009 18:57:12

Tophe
Membre
Lieu : Ardeche
Distrib. : Stable
(G)UI : Kde
Inscription : 11-10-2008

Re : Problème d'affichage avec Nvidia et KDE 4 (Résolu)

Bonjour

Je suis dans le même cas : Debian squezze (Noyau 2.6.26-2-686) mais avec une carte Nvidia Geforce 6200 et j'ai les pilotes propriétaires en version 173.14.09

tu les prends où ces pilotes 180 ??? sur le site nvidia ou dans les dépôts ???
Je ne les trouve pas dans les dépôts.

Quand je fais :
$ apt-cache policy nvidia-kernel-2.6.26-2-686
nvidia-kernel-2.6.26-2-686:
  Installé : 173.14.09-5+2.6.26-15
  Candidat : 173.14.09-5+2.6.26-15
Table de version :
*** 173.14.09-5+2.6.26-15 0
        100 /var/lib/dpkg/status
     173.14.09+3+lenny1 0
        980 http://ftp.fr.debian.org testing/non-free Packages
         90 http://ftp.fr.debian.org unstable/non-free Packages

En fait les problèmes que tu décrits je les ai ainsi que la barre des tâches qui freese avec Icedove et Open-Office mais uniquement lorsque j'active les effets de bureux ou Compizfusion.

Dernière modification par Tophe (31-05-2009 18:59:10)


* AMD Athlon 64 3500+ / ASUS A8N-SLI / nVidia GeForce 6200 / RAM 1Go / Debian Stable / KDE
* Eee PC X101CH / RAM 1Go / Debian Stable / KDE
Xtophe - Ardèche

Hors ligne

#5 31-05-2009 20:10:07

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Problème d'affichage avec Nvidia et KDE 4 (Résolu)

Salut

tu les prends où ces pilotes 180 ??? sur le site nvidia ou dans les dépôts ???
Je ne les trouve pas dans les dépôts.


Pour les avoir, tu devras aller piocher dans les dépôts sid.


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#6 09-06-2009 20:21:55

Tophe
Membre
Lieu : Ardeche
Distrib. : Stable
(G)UI : Kde
Inscription : 11-10-2008

Re : Problème d'affichage avec Nvidia et KDE 4 (Résolu)

Retour d'expérience
donc, sous testing, je désirais installer les pilotes nvidia 180 de sid et j'avais le souci qu'avec la commande "apt-cache policy" citée dans mon post précédent, les pilotes 180 n'apparaissaient pas malgrè un sources-list apparemment bien configuré.
Puis en essayant de temps à autres ils sont apparus.

J'ai donc installé  : apt-get install -t unstable nvidia-kernel-source nvidia-kernel-common
puis
    m-a prepare
    m-a update
    m-a a-i nvidia
et puis si tout c'était bien passé j'aurais fini par : apt-get install -t unstable nvidia-glx nvidia-settings

mais non ça a coincé à la compilation avec module-assistant
J'ai testé directement avec module-assistant sans passer par les 3 lignes ci-dessus : idem

Pourtant tout paraissaient ok notamment :
christophe@debian:~/Documents$ apt-cache policy nvidia-kernel-source
nvidia-kernel-source: Installé : 180.44-2

J'ai fait une série de apt-get install -t unstable "tout ce qui concerne nvidia" mais que dalle.

et j'ai trouvé sur le tuto des astuces debian-fr qui dit :
" Et puis si après tout ça ... Cela ne fonctionne toujours pas ! et bien il y a peut être un conflit avec une installation antérieure comme nous l'a démontré Shenga. Donc voila une suite de commande à faire dans un terminal :"

$ su
# rm -rf /usr/src/modules/nvidia-kernel/
# cd /usr/src
# tar xjvf nvidia-kernel.tar.bz2
# cd modules/nvidia-kernel/debian
# cp control.template control
# m-a a-i -i nvidia-kernel-source
# apt-get install nvidia-glx

là ça fonctionnait. J'ai juste du modifier la dernière ligne en : apt-get install -t unstable nvidia-glx
et c'est désormais ok. J'ai récupéré la fluidité avec le bureau 3D.

* AMD Athlon 64 3500+ / ASUS A8N-SLI / nVidia GeForce 6200 / RAM 1Go / Debian Stable / KDE
* Eee PC X101CH / RAM 1Go / Debian Stable / KDE
Xtophe - Ardèche

Hors ligne

#7 09-06-2009 20:57:32

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Problème d'affichage avec Nvidia et KDE 4 (Résolu)

Plus c'est bête... plus c'est chouette de trouver la solution...

Merci du retour Tophe !

Tchibâââ ! lol

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

Pied de page des forums