Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-04-2016 18:39:43

Choupex 22
Membre
Distrib. : Debian stable : Jessie 8.4
Noyau : 3.16.0-4-amd64
(G)UI : cinnamon 2.2.16
Inscription : 25-03-2016

(RÉSOLU !)Wifi non détecté sur Dell Latitude E6400

Bonjour,
j'installe le Dell pour une camarade en debian jessie, voici sa carte de visite :

Debian 8.4, version Cinnamon, noyau Linux : 3.16.0-4-amd64
intel core 2Duo CPU  P8700@2.53GHz x 2
Carte graphique : intel corporation Mobile 4 Series Chipset Integrated Graphics Controller


Auparavant la wifi était intermittente, depuis l'installation, rien !

plongée dans la lecture du forum, j'ai suivi le tutoriel debian.
La commande lspci -nn donne le nom de la carte : Broadcom Corporation BCM4312 802.11b/g LP-PHY[14e4;4315]

Ensuite module noyau : subsystem: Dell Wireless 1397 Wlan Mini-card Kernel Driver in use : b43-pci-bridge.

par l'intermédiaire de Synaptic  j'ai contacté après l'ajout de dépôts, la présence de paquet non-free de "b43-fwccutter" et de "firmware-b43-installer".

Alors que lorsque je tape en commande dans le terminal administrateur, la phrase :
apt-get install firmware-b43-lppy-installer, voici la réponse :

apt-get install firmware-b43-lpphy-installer
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Package firmware-b43-lpphy-installer is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  firmware-b43-installer
E: Package 'firmware-b43-lpphy-installer' has no installation candidate


j'ai compris, malgré ma mauvaise pratique de la langue anglaise, que le paquet est obsolète et qu'il était remplacé par firmware-b43-installer qui est bien installé.

Mais cela ne fonctionne pas.

je suis le tutoriel ...

et tape la commande :

lsusb
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 002: ID 13ee:0001 MosArt
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 0a5c:5800 Broadcom Corp. BCM5880 Secure Applications Processor
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

revoilà le fameux Broadcom Corp. mais en BCM5880, là je m'égare un peu !!!!

je continue le tuto et tape :

/sbin/ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:26:b9:cd:73:17 
          inet adr:192.168.1.41  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: fe80::226:b9ff:fecd:7317/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3254 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2808 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:2839423 (2.7 MiB)  TX bytes:340100 (332.1 KiB)
          Interruption:22 Mémoire:f6ae0000-f6b00000

lo        Link encap:Boucle locale 
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:54 errors:0 dropped:0 overruns:0 frame:0
          TX packets:54 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:17754 (17.3 KiB)  TX bytes:17754 (17.3 KiB)

pas de wlan0 qui pointe son nez, donc si j'ai bien compris c'est que le firmware manque ... et pourtant il me semble qu'il y est .... Vu avec Synaptic !


Là je coince complètement.

je veux bien un coup de main;

Salut à tous et merci.

Dernière modification par Choupex 22 (10-04-2016 22:09:38)

Hors ligne

#2 09-04-2016 18:49:23

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : (RÉSOLU !)Wifi non détecté sur Dell Latitude E6400

On va commencer par les questions stupides :

Tu as fais

apt-get update

avant ? Il n'y a pas d'erreur ?


« La religion et l'art sont les luxes des lâches, qui permettent de fuir la réalité quand elle devient trop difficile à affronter. La différence c'est que la religion transforme tout mensonge en vérité alors que l'art transforme toute vérité en mensonge. »

Hors ligne

#3 10-04-2016 15:41:39

Choupex 22
Membre
Distrib. : Debian stable : Jessie 8.4
Noyau : 3.16.0-4-amd64
(G)UI : cinnamon 2.2.16
Inscription : 25-03-2016

Re : (RÉSOLU !)Wifi non détecté sur Dell Latitude E6400

oui, c'est du reste de cette façon que j'ai chargé firmware b43 installer.
merci tout de même,

Hors ligne

#4 10-04-2016 15:59:27

raleur
Membre
Inscription : 03-10-2014

Re : (RÉSOLU !)Wifi non détecté sur Dell Latitude E6400

Choupex 22 a écrit :

plongée dans la lecture du forum, j'ai suivi le tutoriel debian.


Quel tutoriel exactement ?

Choupex 22 a écrit :

Mais cela ne fonctionne pas.


Mais encore ? Que se passe-t-il quand tu utilises firmware-b43-installer ?

Choupex 22 a écrit :

lsusb
(...)
là je m'égare un peu


Je confirme. Aucun rapport avec le contrôleur wifi qui est sur le bus PCI/PCIe.

Choupex 22 a écrit :

donc si j'ai bien compris c'est que le firmware manque


Qu'est-ce qui te fait dire cela ?
Tu as vu dans les logs du noyau qu'un pilote s'était chargé pour ce contrôleur mais avait recherché un firmware manquant ?

Choupex 22 a écrit :

pourtant il me semble qu'il y est .... Vu avec Synaptic !


Non. firmware-b43-installer ne contient pas de firmware mais un programme ayant pour but de télécharger et 'installer des firmwares.

Hors ligne

#5 10-04-2016 16:10:46

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : (RÉSOLU !)Wifi non détecté sur Dell Latitude E6400

Salut Choupex 22 smile

Voici quelques petites infos pour te permettre de donner des informations qui pourront nous aider à te dépanner et éviter à raleur de poser trop de questions wink : Voir le tuto : Manuel du chocolat DF : « Ça marche pas ! »

Pour résumer, l'idéal est de taper la commande que tu essayes et de mettre le retour ici avec les balises code comme indiqué là Voir le tuto : Le code, ça pique moins les yeux en couleur.

Ainsi, on sera en mesure de mieux comprendre ton problème smile

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

En ligne

#6 10-04-2016 17:55:11

Choupex 22
Membre
Distrib. : Debian stable : Jessie 8.4
Noyau : 3.16.0-4-amd64
(G)UI : cinnamon 2.2.16
Inscription : 25-03-2016

Re : (RÉSOLU !)Wifi non détecté sur Dell Latitude E6400

J'ai compris problème de langage adéquat. le tuto en question est : "Pas à pas : faire que sa carte wifi soit détectée".

Je reprends :

je cherche à identifier la carte réseau :




 lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub [8086:2a40] (rev 07)
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
00:02.1 Display controller [0380]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a43] (rev 07)
00:19.0 Ethernet controller [0200]: Intel Corporation 82567LM Gigabit Network Connection [8086:10f5] (rev 03)
00:1a.0 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 [8086:2937] (rev 03)
00:1a.1 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 [8086:2938] (rev 03)
00:1a.2 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 [8086:2939] (rev 03)
00:1a.7 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 [8086:293c] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 03)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 [8086:2940] (rev 03)
00:1c.1 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 [8086:2942] (rev 03)
00:1c.2 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 [8086:2944] (rev 03)
00:1d.0 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 [8086:2934] (rev 03)
00:1d.1 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 [8086:2935] (rev 03)
00:1d.2 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 [8086:2936] (rev 03)
00:1d.7 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 [8086:293a] (rev 03)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev 93)
00:1f.0 ISA bridge [0601]: Intel Corporation ICH9M-E LPC Interface Controller [8086:2917] (rev 03)
00:1f.2 RAID bus controller [0104]: Intel Corporation 82801 Mobile SATA Controller [RAID mode] [8086:282a] (rev 03)
00:1f.3 SMBus [0c05]: Intel Corporation 82801I (ICH9 Family) SMBus Controller [8086:2930] (rev 03)
03:01.0 CardBus bridge [0607]: Ricoh Co Ltd RL5c476 II [1180:0476] (rev ba)
03:01.1 FireWire (IEEE 1394) [0c00]: Ricoh Co Ltd R5C832 IEEE 1394 Controller [1180:0832] (rev 04)
03:01.2 SD Host controller [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter [1180:0822] (rev 21)
0c:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
 





Je repère le nom de la carte (et à ce qu'il parait pénible à installer !) :  Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315]
Module de noyau, y es-tu ?



 lspci -k
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
  Subsystem: Dell Device 0233
  Kernel driver in use: agpgart-intel
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
  Subsystem: Dell Device 0233
  Kernel driver in use: i915
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
  Subsystem: Dell Device 0233
00:19.0 Ethernet controller: Intel Corporation 82567LM Gigabit Network Connection (rev 03)
  Subsystem: Dell Device 0233
  Kernel driver in use: e1000e
00:1a.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
  Subsystem: Dell Device 0233
  Kernel driver in use: uhci_hcd
00:1a.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
  Subsystem: Dell Device 0233
  Kernel driver in use: uhci_hcd
00:1a.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
  Subsystem: Dell Device 0233
  Kernel driver in use: uhci_hcd
00:1a.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
  Subsystem: Dell Device 0233
  Kernel driver in use: ehci-pci
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
  Subsystem: Dell Device 0233
  Kernel driver in use: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
  Kernel driver in use: pcieport
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
  Kernel driver in use: pcieport
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
  Kernel driver in use: pcieport
00:1d.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
  Subsystem: Dell Device 0233
  Kernel driver in use: uhci_hcd
00:1d.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
  Subsystem: Dell Device 0233
  Kernel driver in use: uhci_hcd
00:1d.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
  Subsystem: Dell Device 0233
  Kernel driver in use: uhci_hcd
00:1d.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
  Subsystem: Dell Device 0233
  Kernel driver in use: ehci-pci
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
  Subsystem: Dell Device 0233
  Kernel driver in use: lpc_ich
00:1f.2 RAID bus controller: Intel Corporation 82801 Mobile SATA Controller [RAID mode] (rev 03)
  Subsystem: Dell Device 0233
  Kernel driver in use: ahci
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
  Subsystem: Dell Device 0233
  Kernel driver in use: i801_smbus
03:01.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ba)
  Subsystem: Dell Device 0233
  Kernel driver in use: yenta_cardbus
03:01.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 04)
  Subsystem: Dell Device 0233
  Kernel driver in use: firewire_ohci
03:01.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 21)
  Subsystem: Dell Device 0233
  Kernel driver in use: sdhci-pci
0c:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
  Subsystem: Dell Wireless 1397 WLAN Mini-Card
  Kernel driver in use: b43-pci-bridge





le module noyau est là : b43-pci-bridge
et le firmware est-il là ?


 /sbin/ifconfig
eth0      Link encap:Ethernet  HWaddr 00:26:b9:cd:73:17  
          inet adr:192.168.1.41  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: fe80::226:b9ff:fecd:7317/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4099 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3961 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:3054274 (2.9 MiB)  TX bytes:918297 (896.7 KiB)
          Interruption:22 Mémoire:f6ae0000-f6b00000

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:54 errors:0 dropped:0 overruns:0 frame:0
          TX packets:54 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:17754 (17.3 KiB)  TX bytes:17754 (17.3 KiB)




Pas de wlan0, donc pas de firmware !


 apt-get install firmware-b43-installer
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
firmware-b43-installer est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.




je fais une tentative toute personnelle et peut-être un peu sauvage ...


 apt-get firmware-b43-lppy-installer
E: L'opération firmware-b43-lppy-installer n'est pas valable
root@FO:/home/gwen# apt-get firmware-b43-lp-phy-installer
E: L'opération firmware-b43-lp-phy-installer n'est pas valable




C'est là que je sèche.
suis-je plus claire de cette façon-là ?

Salut et merci aux gourmands en chocolat et de plus râleur !

Hors ligne

#7 10-04-2016 19:12:10

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : (RÉSOLU !)Wifi non détecté sur Dell Latitude E6400

Salut,

Je ne suis pas spécialiste du matériel, mais il y a cette page dans la documentation officielle : https://wiki.debian.org/fr/wl
où il y a le pas à pas pour installer ta carte ( Périphériques Broadcom BCM4311, BCM4312, BCM4313, BCM4321, BCM4322, BCM43224, BCM43225, BCM43227,
BCM43228, BCM43142, BCM4331, BCM4352, BCM4360 (wl) )

ou cette page pour le pilote libre b3 :https://wiki.debian.org/fr/bcm43xx
avec une rubrique dépannage .

Je ne sais pas lequel des deux pilotes est le plus performant .

en complément, la page de présentation du wifi sous debian : https://wiki.debian.org/fr/WiFi

Dernière modification par nono47 (10-04-2016 19:17:12)

Hors ligne

#8 10-04-2016 22:03:39

Choupex 22
Membre
Distrib. : Debian stable : Jessie 8.4
Noyau : 3.16.0-4-amd64
(G)UI : cinnamon 2.2.16
Inscription : 25-03-2016

Re : (RÉSOLU !)Wifi non détecté sur Dell Latitude E6400

Merci Nono47,

J'ai suivi ton conseil et je suis allée dans la documentation officielle : https://wiki.debian.org/fr/wl.
J'avais installée la source non-free, mais je m'arrêtait au firmware !

Voilà la commande qui a tout débloqué :



# apt-get install linux-image-$(uname -r|sed 's,[^-]*-[^-]*-,,') linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') broadcom-sta-dkms




Et BANZAÏ la wifi fut !!!

Que le grand distributeur de chocolats linusiens et de surcroît debianesques, soit large envers vous qui m'avez répondue et guidée dans la patouille !

Fraternité

Hors ligne

#9 10-04-2016 22:08:21

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : (RÉSOLU !)Wifi non détecté sur Dell Latitude E6400


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

En ligne

Pied de page des forums