Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-04-2016 13:32:58

Antic Bomber
Adhérent(e)
Lieu : O.P-O.66
Distrib. : jessie 8.6 & backports
Noyau : Linux 3.16.0.4 amd64
(G)UI : xfce
Inscription : 10-08-2014

(Résolu) hic avec carte SD système

Salut les Dfs,

je voudrai créer une carte SD système Linux Raspbian pour ma Raspberry Pi 3, j'ai téléchargé et décompressé les fichiers.

Le fichier .img (4 Go) que j'essaie d'installer avec le Terminal.

Je m'embourbe avec les manips et je tourne en rond.

Merci de vos conseils et de votre aide !

lahurlette@debian:~$ su


Mot de passe :
root@debian:/home/lahurlette$ dd if=2016-03-18-raspbian-jessie.img of=/dev/mmcbk0p2 bs=2M
 



dd: erreur d'écriture de « /dev/mmcbk0p2 »: Aucun espace disponible sur le périphérique

1+0 enregistrements lus
0+0 enregistrements écrits
0 octet (0 B) copié, 0,00183028 s, 0,0 kB/s
root@debian:/home/lahurlette$
 



Ma SD avec gparted :

68SU8F6SOagt.png

Merci !  smile

Dernière modification par Antic Bomber (11-04-2016 09:59:12)


Si le problème a une solution, il ne sert à rien de s’inquiéter. Mais s'il n'en a pas, alors s'inquiéter ne change rien. (Proverbe Tibétain)

La connaissance s'acquiert par l'expérience, tout le reste n'est que de l'information.  Albert Einstein

Hors ligne

#2 10-04-2016 14:05:39

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : (Résolu) hic avec carte SD système

Salut smile

Il me semble en lisant la doc officielle de Raspbian qu'il faut écrire sur la carte en entier, et non juste sur une partition.

Ta commande devrait donc être

dd if=2016-03-18-raspbian-jessie.img of=/dev/mmcbk0p bs=2M

sans le numéro de partition. Attention, ça efface ce qui est sur la première partition:/

Il faut également avoir démonter les 2 partitions avant de commencer avec

umount /dev/mmcbk0p1
umount /dev/mmcbk0p2


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

En ligne

#3 10-04-2016 14:16:59

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : (Résolu) hic avec carte SD système

sans le chiffre, ni le p => /dev/mmcbk0

Hors ligne

#4 10-04-2016 17:46:36

Antic Bomber
Adhérent(e)
Lieu : O.P-O.66
Distrib. : jessie 8.6 & backports
Noyau : Linux 3.16.0.4 amd64
(G)UI : xfce
Inscription : 10-08-2014

Re : (Résolu) hic avec carte SD système

merci pour vos interventions, j'ai ramé un bon moment et je vous ai induit en erreur,

  j'ai fais une faute de frappe : /dev/mmcbk0p bs=2M pour /dev/mmcblk0 bs=2M

et ça change Tooooooouuuuuut !

su



Mot de passe :
root@debian:/home/lahurlette$ fdisk -l


Disque /dev/mmcblk0 : 15 GiB, 16088301568 octets, 31422464 secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : dos
Identifiant de disque : 0x000ce63c

Device         Boot Start    End Sectors  Size Id Type
/dev/mmcblk0p1       2048 499711  497664  243M  c W95 FAT32 (LBA)
 


su


Mot de passe :
root@debian:/home/lahurlette$ dd if=2016-03-18-raspbian-jessie.img of=/dev/mmcblk0 bs=2M
1923+1 enregistrements lus
1923+1 enregistrements écrits
4033871872 octets (4,0 GB) copiés, 318,762 s, 12,7 MB/s
 


CyIANe2pZ19P.png

me reste toujours un problème !  sad
4WQ1FLWslPqF.png


Si le problème a une solution, il ne sert à rien de s’inquiéter. Mais s'il n'en a pas, alors s'inquiéter ne change rien. (Proverbe Tibétain)

La connaissance s'acquiert par l'expérience, tout le reste n'est que de l'information.  Albert Einstein

Hors ligne

#5 11-04-2016 06:08:35

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : (Résolu) hic avec carte SD système

me reste toujours un problème !  sad

Désolé, je n'arrive pas à comprendre de quel problème il s'agit.

Hors ligne

#6 11-04-2016 09:57:12

Antic Bomber
Adhérent(e)
Lieu : O.P-O.66
Distrib. : jessie 8.6 & backports
Noyau : Linux 3.16.0.4 amd64
(G)UI : xfce
Inscription : 10-08-2014

Re : (Résolu) hic avec carte SD système

Salut les Dfs

la nuit porte conseil, c'est bon, j'avais une erreur dans le démontage de ma SD, donc j'ai reformater

correctement et réinstallé. Tout baigne, je suis en train de configurer ma Rpi 3, et dans la foulée je

vais créer une SD avec OSMC pour un média center. Et vive la musique ! lol

Je passe en résolu.

Merci pour vos conseils et directions a appliquer, qui m'ont permis de me sortir de ce bourbier.  wink

À bientôt de vous lire.

Alà.

Si le problème a une solution, il ne sert à rien de s’inquiéter. Mais s'il n'en a pas, alors s'inquiéter ne change rien. (Proverbe Tibétain)

La connaissance s'acquiert par l'expérience, tout le reste n'est que de l'information.  Albert Einstein

Hors ligne

Pied de page des forums