Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 16-04-2016 19:31:48

enicnath
Membre
Inscription : 28-04-2012

Erreur Synaptic sur Python

Bonjour,

Lorsque j'utilise Synaptic, j'ai depuis quelques temps et invariablement le message d'erreur suivant :


E: /var/cache/apt/archives/python-libxml2_2.9.1+dfsg1-5+deb8u1_amd64.deb:
  le sous-processus nouveau script pre-removal a retourné une erreur de sortie d'état 1

E: /var/cache/apt/archives/python-pygments_2.0.1+dfsg-1.1+deb8u1_all.deb:
  le sous-processus nouveau script pre-removal a retourné une erreur de sortie d'état 1
 

Ces deux erreurs sont liées à Python.

Quelqu'un saurait-il comment corriger cette erreur ?

Hors ligne

#2 16-04-2016 20:08:56

Firy
Membre
Distrib. : Debian Jessie 8.3
Noyau : 3.16.0
(G)UI : Openbox
Inscription : 22-01-2016

Re : Erreur Synaptic sur Python

Essayes un

apt-get -f install

Hors ligne

#3 16-04-2016 22:35:50

enicnath
Membre
Inscription : 28-04-2012

Re : Erreur Synaptic sur Python

Oui, il me renvoie ceci :

E: Impossible d'obtenir le verrou /var/lib/dpkg/lock - open (11: Ressource temporairement non disponible)
E: Impossible de verrouiller le répertoire d'administration (/var/lib/dpkg/). Il est possible qu'un autre processus l'utilise.
 

Hors ligne

#4 16-04-2016 23:31:56

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : Erreur Synaptic sur Python

Salut smile

Il faut fermer Synaptic.

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#5 17-04-2016 18:26:45

enicnath
Membre
Inscription : 28-04-2012

Re : Erreur Synaptic sur Python

bendia a écrit :

Il faut fermer Synaptic.


Ca ne suffit pas. On a toujours des erreurs

Traceback (most recent call last):
  File "/usr/bin/apt-listchanges", line 29, in <module>
    import anydbm
ImportError: No module named 'anydbm'
(Lecture de la base de données... 168199 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../python-libxml2_2.9.1+dfsg1-5+deb8u1_amd64.deb ...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg : avertissement : le sous-processus ancien script pre-removal a retourné une erreur de sortie d'état 1
dpkg: tentative d'exécution du script du nouveau paquet à la place...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/python-libxml2_2.9.1+dfsg1-5+deb8u1_amd64.deb (--unpack) :
 le sous-processus nouveau script pre-removal a retourné une erreur de sortie d'état 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg : erreur lors du nettoyage :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Préparation du dépaquetage de .../python-pygments_2.0.1+dfsg-1.1+deb8u1_all.deb ...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg : avertissement : le sous-processus ancien script pre-removal a retourné une erreur de sortie d'état 1
dpkg: tentative d'exécution du script du nouveau paquet à la place...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/python-pygments_2.0.1+dfsg-1.1+deb8u1_all.deb (--unpack) :
 le sous-processus nouveau script pre-removal a retourné une erreur de sortie d'état 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg : erreur lors du nettoyage :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/python-libxml2_2.9.1+dfsg1-5+deb8u1_amd64.deb
 /var/cache/apt/archives/python-pygments_2.0.1+dfsg-1.1+deb8u1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
 



Au final, les deux erreurs du début sont toujours là.
Et puis, je ne sais pas pourquoi le fait de rajouter -f permettrait de ne plus les avoirs ?

Hors ligne

#6 17-04-2016 18:40:46

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Erreur Synaptic sur Python

peut etre nettoyer ton cache


apt-get clean
 


le recharger


apt-get update
 


et voir si ton sources.list est correct (un probleme avec une source exterieure a debian ou un melange  stable et sid par exemple)

ps: l'option -f  force l'installation , fortement déconseillé , sauf si on sait ce que l'on fait ce qui a priori n'est pas ton cas
tu risque de casser ta debian  hmm

Dernière modification par robert2a (17-04-2016 18:42:50)

Hors ligne

#7 17-04-2016 23:22:24

enicnath
Membre
Inscription : 28-04-2012

Re : Erreur Synaptic sur Python

robert2a a écrit :

peut etre nettoyer ton cache

 apt-get clean


le recharger

 apt-get update


et voir si ton sources.list est correct (un probleme avec une source exterieure a debian ou un melange  stable et sid par exemple)

Bonjour,
Je viens de lancer ces deux commandes apt-get clean et apt-get update.
Puis derrière, j'ai refait un apt-get -f install
Le résultat est toujours le même, les deux erreurs déjà signalées plus haut.
Quant à mon sources.list. Il me semble ordinaire et sans risques particuliers :

deb http://ftp.fr.debian.org/debian/ jessie main
deb-src http://ftp.fr.debian.org/debian/ jessie main

deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main

deb http://ftp.fr.debian.org/debian/ jessie-updates main
deb-src http://ftp.fr.debian.org/debian/ jessie-updates main

Hors ligne

#8 18-04-2016 02:01:49

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Erreur Synaptic sur Python

utiliser apt-get -f install ne correspond a rien

lui demander plutot :


apt-get -s upgrade
 


et nous donner le retour
et


apt-get -s autoremove --purge
 


idem donner le retour

je suis pas assez barbu pour expliquer les retours des erreurs que tu donne

il y a des commandes qui donnent plus de détails sur le probleme (et les solutions ) , avec Aptitude . je laisse faire les experts neutral

ps: un conseil ne lance plus cette commande "apt-get -f install"
le blocage est sur une mise a jour de jessie par synaptic je suppose ?

Hors ligne

#9 18-04-2016 20:33:15

Firy
Membre
Distrib. : Debian Jessie 8.3
Noyau : 3.16.0
(G)UI : Openbox
Inscription : 22-01-2016

Re : Erreur Synaptic sur Python

Ca permet au moins de voir s'il manquerai pas des dépendances, c'est en aucun cas une abomination.

Hors ligne

#10 22-04-2016 21:44:03

enicnath
Membre
Inscription : 28-04-2012

Re : Erreur Synaptic sur Python

robert2a a écrit :

lui demander plutot :

 apt-get -s upgrade

et nous donner le retour
et

 apt-get -s autoremove --purge

idem donner le retour



bon voici les retours (accrochez-vous) :

sudo apt-get -s upgrade


[sudo] password for enicnath:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libasn1-8-heimdal libgssapi3-heimdal libhcrypto4-heimdal libheimbase1-heimdal libheimntlm0-heimdal libhx509-5-heimdal libkrb5-26-heimdal
  libroken18-heimdal libwind0-heimdal
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Fait
Les paquets suivants seront mis à jour :
  apt apt-utils base-files bind9-host calendar-google-provider dnsutils exim4 exim4-base exim4-config exim4-daemon-light
  gnome-shell-extension-weather gnupg gpgv gtk2-engines-pixbuf host icedove iceowl-extension iceweasel iceweasel-l10n-fr imagemagick
  imagemagick-6.q16 imagemagick-common initramfs-tools libapt-inst1.5 libapt-pkg4.12 libavcodec56 libavformat56 libavresample2 libavutil54
  libbind9-90 libc-bin libcairo-gobject2 libcairo2 libdns-export100 libdns100 libgail-common libgail18 libgif4 libglib2.0-0 libglib2.0-bin
  libgraphite2-3 libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libgudev-1.0-0 libhogweed2 libimage-magick-perl libimage-magick-q16-perl
  libimlib2 libirs-export91 libisc-export95 libisc95 libisccc90 libisccfg-export90 libisccfg90 libjasper1 libldb1 liblwres90
  libmagick++-6.q16-5 libmagickcore-6.q16-2 libmagickcore-6.q16-2-extra libmagickwand-6.q16-2 libnettle4 libpam-modules libpam-modules-bin
  libpam-systemd libpam0g libperl5.20 librsvg2-2 librsvg2-common libsane libsane-common libservlet2.5-java libsmbclient libsndfile1
  libsrtp0 libssl1.0.0 libswscale3 libsystemd0 libtalloc2 libtdb1 libtevent0 libudev1 libwbclient0 linux-image-3.16.0-4-amd64
  linux-libc-dev locales multiarch-support openssh-client openssl perl perl-base perl-modules perlmagick python-imaging python-libxml2
  python-pil python-pygments python-talloc samba-libs sane-utils systemd systemd-sysv tzdata tzdata-java udev
106 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
7 partiellement installés ou enlevés.
Inst libcairo2 [1.14.0-2.1] (1.14.0-2.1+deb8u1 Debian:8.4/stable [amd64])
Inst libglib2.0-bin [2.42.1-1] (2.42.1-1+b1 Debian:8.4/stable [amd64]) []
Inst libglib2.0-0 [2.42.1-1] (2.42.1-1+b1 Debian:8.4/stable [amd64])
Inst python-libxml2 [2.9.1+dfsg1-5] (2.9.1+dfsg1-5+deb8u1 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Inst python-pygments [2.0.1+dfsg-1.1] (2.0.1+dfsg-1.1+deb8u1 Debian:8.4/stable, Debian-Security:8/stable [all])
Inst base-files [8+deb8u3] (8+deb8u4 Debian:8.4/stable [amd64])
Conf base-files (8+deb8u4 Debian:8.4/stable [amd64])
Inst libperl5.20 [5.20.2-3+deb8u3] (5.20.2-3+deb8u4 Debian:8.4/stable, Debian-Security:8/stable [amd64]) []
Inst perl [5.20.2-3+deb8u3] (5.20.2-3+deb8u4 Debian:8.4/stable, Debian-Security:8/stable [amd64]) []
Inst perl-base [5.20.2-3+deb8u3] (5.20.2-3+deb8u4 Debian:8.4/stable, Debian-Security:8/stable [amd64]) []
Conf perl-base (5.20.2-3+deb8u4 Debian:8.4/stable, Debian-Security:8/stable [amd64]) []
Inst perl-modules [5.20.2-3+deb8u3] (5.20.2-3+deb8u4 Debian:8.4/stable, Debian-Security:8/stable [all])
Inst libapt-pkg4.12 [1.0.9.8.2] (1.0.9.8.3 Debian:8.4/stable [amd64])
Conf libapt-pkg4.12 (1.0.9.8.3 Debian:8.4/stable [amd64])
Inst gpgv [1.4.18-7] (1.4.18-7+deb8u1 Debian:8.4/stable [amd64])
Conf gpgv (1.4.18-7+deb8u1 Debian:8.4/stable [amd64])
Inst gnupg [1.4.18-7] (1.4.18-7+deb8u1 Debian:8.4/stable [amd64])
Conf gnupg (1.4.18-7+deb8u1 Debian:8.4/stable [amd64])
Inst apt [1.0.9.8.2] (1.0.9.8.3 Debian:8.4/stable [amd64])
Conf apt (1.0.9.8.3 Debian:8.4/stable [amd64])
Inst libc-bin [2.19-18+deb8u3] (2.19-18+deb8u4 Debian:8.4/stable [amd64])
Conf libc-bin (2.19-18+deb8u4 Debian:8.4/stable [amd64])
Inst libudev1 [215-17+deb8u3] (215-17+deb8u4 Debian:8.4/stable [amd64]) [udev:amd64 ]
Conf libudev1 (215-17+deb8u4 Debian:8.4/stable [amd64]) [udev:amd64 ]
Inst udev [215-17+deb8u3] (215-17+deb8u4 Debian:8.4/stable [amd64])
Conf udev (215-17+deb8u4 Debian:8.4/stable [amd64])
Inst linux-image-3.16.0-4-amd64 [3.16.7-ckt20-1+deb8u3] (3.16.7-ckt25-2 Debian:stable-updates [amd64])
Inst initramfs-tools [0.120] (0.120+deb8u1 Debian:8.4/stable [all])
Inst libsystemd0 [215-17+deb8u3] (215-17+deb8u4 Debian:8.4/stable [amd64]) [systemd:amd64 ]
Conf libsystemd0 (215-17+deb8u4 Debian:8.4/stable [amd64]) [systemd:amd64 ]
Inst systemd [215-17+deb8u3] (215-17+deb8u4 Debian:8.4/stable [amd64]) [libpam-systemd:amd64 systemd-sysv:amd64 ]
Conf systemd (215-17+deb8u4 Debian:8.4/stable [amd64]) [libpam-systemd:amd64 systemd-sysv:amd64 ]
Inst systemd-sysv [215-17+deb8u3] (215-17+deb8u4 Debian:8.4/stable [amd64]) [libpam-systemd:amd64 ]
Conf systemd-sysv (215-17+deb8u4 Debian:8.4/stable [amd64]) [libpam-systemd:amd64 ]
Inst libpam-systemd [215-17+deb8u3] (215-17+deb8u4 Debian:8.4/stable [amd64])
Inst libpam0g [1.1.8-3.1+deb8u1] (1.1.8-3.1+deb8u1+b1 Debian:8.4/stable [amd64])
Conf libpam0g (1.1.8-3.1+deb8u1+b1 Debian:8.4/stable [amd64])
Inst libpam-modules-bin [1.1.8-3.1+deb8u1] (1.1.8-3.1+deb8u1+b1 Debian:8.4/stable [amd64]) [libpam-modules:amd64 on libpam-modules-bin:amd64] [libpam-modules:amd64 ]
Conf libpam-modules-bin (1.1.8-3.1+deb8u1+b1 Debian:8.4/stable [amd64]) [libpam-modules:amd64 ]
Inst libpam-modules [1.1.8-3.1+deb8u1] (1.1.8-3.1+deb8u1+b1 Debian:8.4/stable [amd64])
Conf libpam-modules (1.1.8-3.1+deb8u1+b1 Debian:8.4/stable [amd64])
Inst libapt-inst1.5 [1.0.9.8.2] (1.0.9.8.3 Debian:8.4/stable [amd64])
Inst libssl1.0.0 [1.0.1k-3+deb8u2] (1.0.1k-3+deb8u4 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Inst libmagickwand-6.q16-2 [8:6.8.9.9-5] (8:6.8.9.9-5+deb8u1 Debian:8.4/stable [amd64]) []
Inst libmagickcore-6.q16-2 [8:6.8.9.9-5] (8:6.8.9.9-5+deb8u1 Debian:8.4/stable [amd64]) []
Inst imagemagick-common [8:6.8.9.9-5] (8:6.8.9.9-5+deb8u1 Debian:8.4/stable [all])
Inst libavutil54 [6:11.4-1~deb8u1] (6:11.6-1~deb8u1 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Inst libavresample2 [6:11.4-1~deb8u1] (6:11.6-1~deb8u1 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Inst libavcodec56 [6:11.4-1~deb8u1] (6:11.6-1~deb8u1 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Inst libavformat56 [6:11.4-1~deb8u1] (6:11.6-1~deb8u1 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Inst libcairo-gobject2 [1.14.0-2.1] (1.14.0-2.1+deb8u1 Debian:8.4/stable [amd64])
Inst libisc-export95 [1:9.9.5.dfsg-9+deb8u5] (1:9.9.5.dfsg-9+deb8u6 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Inst libdns-export100 [1:9.9.5.dfsg-9+deb8u5] (1:9.9.5.dfsg-9+deb8u6 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Inst libgail-common [2.24.25-3] (2.24.25-3+deb8u1 Debian:8.4/stable [amd64]) []
Inst libgtk2.0-common [2.24.25-3] (2.24.25-3+deb8u1 Debian:8.4/stable [all]) []
Inst gtk2-engines-pixbuf [2.24.25-3] (2.24.25-3+deb8u1 Debian:8.4/stable [amd64]) []
Inst librsvg2-common [2.40.5-1] (2.40.5-1+deb8u1 Debian:8.4/stable [amd64]) []
Inst librsvg2-2 [2.40.5-1] (2.40.5-1+deb8u1 Debian:8.4/stable [amd64]) []
Inst libgtk2.0-bin [2.24.25-3] (2.24.25-3+deb8u1 Debian:8.4/stable [amd64]) []
Inst libgail18 [2.24.25-3] (2.24.25-3+deb8u1 Debian:8.4/stable [amd64]) []
Inst libgtk2.0-0 [2.24.25-3] (2.24.25-3+deb8u1 Debian:8.4/stable [amd64])
Inst libgif4 [4.1.6-11] (4.1.6-11+deb8u1 Debian:8.4/stable [amd64])
Inst libgraphite2-3 [1.3.5-1~deb8u1] (1.3.6-1~deb8u1 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Inst libgudev-1.0-0 [215-17+deb8u3] (215-17+deb8u4 Debian:8.4/stable [amd64])
Inst libhogweed2 [2.7.1-5] (2.7.1-5+deb8u1 Debian:8.4/stable [amd64]) []
Inst libnettle4 [2.7.1-5] (2.7.1-5+deb8u1 Debian:8.4/stable [amd64])
Inst libisccfg-export90 [1:9.9.5.dfsg-9+deb8u5] (1:9.9.5.dfsg-9+deb8u6 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Inst libirs-export91 [1:9.9.5.dfsg-9+deb8u5] (1:9.9.5.dfsg-9+deb8u6 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Inst libjasper1 [1.900.1-debian1-2.4] (1.900.1-debian1-2.4+deb8u1 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Inst libwbclient0 [2:4.1.17+dfsg-2+deb8u1] (2:4.2.10+dfsg-0+deb8u2 Debian-Security:8/stable [amd64])
Inst libtalloc2 [2.1.1-2] (2.1.2-0+deb8u1 Debian-Security:8/stable [amd64])
Inst libsmbclient [2:4.1.17+dfsg-2+deb8u1] (2:4.2.10+dfsg-0+deb8u2 Debian-Security:8/stable [amd64]) []
Inst libtdb1 [1.3.1-1] (1.3.6-0+deb8u1 Debian-Security:8/stable [amd64]) []
Inst libtevent0 [0.9.21-1] (0.9.25-0+deb8u1 Debian-Security:8/stable [amd64]) []
Inst python-talloc [2.1.1-2] (2.1.2-0+deb8u1 Debian-Security:8/stable [amd64]) []
Inst samba-libs [2:4.1.17+dfsg-2+deb8u1] (2:4.2.10+dfsg-0+deb8u2 Debian-Security:8/stable [amd64]) []
Inst libldb1 [2:1.1.17-2+deb8u1] (2:1.1.20-0+deb8u1 Debian-Security:8/stable [amd64])
Inst libmagick++-6.q16-5 [8:6.8.9.9-5] (8:6.8.9.9-5+deb8u1 Debian:8.4/stable [amd64])
Inst libsane [1.0.24-8] (1.0.24-8+deb8u1 Debian:8.4/stable [amd64]) []
Inst libsane-common [1.0.24-8] (1.0.24-8+deb8u1 Debian:8.4/stable [all])
Inst libsndfile1 [1.0.25-9.1] (1.0.25-9.1+deb8u1 Debian:8.4/stable [amd64])
Inst libswscale3 [6:11.4-1~deb8u1] (6:11.6-1~deb8u1 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Inst multiarch-support [2.19-18+deb8u3] (2.19-18+deb8u4 Debian:8.4/stable [amd64])
Conf multiarch-support (2.19-18+deb8u4 Debian:8.4/stable [amd64])
Inst tzdata-java [2015g-0+deb8u1] (2016c-0+deb8u1 Debian:8.4/stable, Debian:stable-updates [all]) []
Inst tzdata [2015g-0+deb8u1] (2016c-0+deb8u1 Debian:8.4/stable, Debian:stable-updates [all])
Conf tzdata (2016c-0+deb8u1 Debian:8.4/stable, Debian:stable-updates [all])
Inst apt-utils [1.0.9.8.2] (1.0.9.8.3 Debian:8.4/stable [amd64])
Inst dnsutils [1:9.9.5.dfsg-9+deb8u5] (1:9.9.5.dfsg-9+deb8u6 Debian:8.4/stable, Debian-Security:8/stable [amd64]) []
Inst bind9-host [1:9.9.5.dfsg-9+deb8u5] (1:9.9.5.dfsg-9+deb8u6 Debian:8.4/stable, Debian-Security:8/stable [amd64]) []
Inst libisc95 [1:9.9.5.dfsg-9+deb8u5] (1:9.9.5.dfsg-9+deb8u6 Debian:8.4/stable, Debian-Security:8/stable [amd64]) []
Inst libdns100 [1:9.9.5.dfsg-9+deb8u5] (1:9.9.5.dfsg-9+deb8u6 Debian:8.4/stable, Debian-Security:8/stable [amd64]) []
Inst libisccc90 [1:9.9.5.dfsg-9+deb8u5] (1:9.9.5.dfsg-9+deb8u6 Debian:8.4/stable, Debian-Security:8/stable [amd64]) []
Inst libisccfg90 [1:9.9.5.dfsg-9+deb8u5] (1:9.9.5.dfsg-9+deb8u6 Debian:8.4/stable, Debian-Security:8/stable [amd64]) []
Inst liblwres90 [1:9.9.5.dfsg-9+deb8u5] (1:9.9.5.dfsg-9+deb8u6 Debian:8.4/stable, Debian-Security:8/stable [amd64]) []
Inst host [1:9.9.5.dfsg-9+deb8u5] (1:9.9.5.dfsg-9+deb8u6 Debian:8.4/stable, Debian-Security:8/stable [all]) []
Inst libbind9-90 [1:9.9.5.dfsg-9+deb8u5] (1:9.9.5.dfsg-9+deb8u6 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Inst exim4 [4.84-8+deb8u2] (4.84.2-1 Debian:8.4/stable, Debian-Security:8/stable [all]) []
Inst exim4-daemon-light [4.84-8+deb8u2] (4.84.2-1 Debian:8.4/stable, Debian-Security:8/stable [amd64]) []
Inst exim4-base [4.84-8+deb8u2] (4.84.2-1 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Inst exim4-config [4.84-8+deb8u2] (4.84.2-1 Debian:8.4/stable, Debian-Security:8/stable [all])
Inst locales [2.19-18+deb8u3] (2.19-18+deb8u4 Debian:8.4/stable [all])
Inst openssh-client [1:6.7p1-5+deb8u1] (1:6.7p1-5+deb8u2 Debian-Security:8/stable [amd64])
Inst calendar-google-provider [38.6.0-1~deb8u1] (38.7.0-1~deb8u1 Debian-Security:8/stable [all])
Inst iceowl-extension [38.6.0-1~deb8u1] (38.7.0-1~deb8u1 Debian-Security:8/stable [amd64]) []
Inst icedove [38.6.0-1~deb8u1] (38.7.0-1~deb8u1 Debian-Security:8/stable [amd64])
Inst iceweasel-l10n-fr [1:38.6.1esr-1~deb8u1] (1:38.7.1esr-1~deb8u1 Debian:8.4/stable, Debian-Security:8/stable [all]) []
Inst iceweasel [38.6.1esr-1~deb8u1] (38.7.1esr-1~deb8u1 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Inst imagemagick [8:6.8.9.9-5] (8:6.8.9.9-5+deb8u1 Debian:8.4/stable [amd64]) []
Inst imagemagick-6.q16 [8:6.8.9.9-5] (8:6.8.9.9-5+deb8u1 Debian:8.4/stable [amd64])
Inst libimage-magick-q16-perl [8:6.8.9.9-5] (8:6.8.9.9-5+deb8u1 Debian:8.4/stable [amd64])
Inst libimage-magick-perl [8:6.8.9.9-5] (8:6.8.9.9-5+deb8u1 Debian:8.4/stable [all])
Inst libimlib2 [1.4.6-2+b3] (1.4.6-2+deb8u1 Debian-Security:8/stable [amd64])
Inst libmagickcore-6.q16-2-extra [8:6.8.9.9-5] (8:6.8.9.9-5+deb8u1 Debian:8.4/stable [amd64])
Inst libservlet2.5-java [6.0.41-3] (6.0.45+dfsg-1~deb8u1 Debian-Security:8/stable [all])
Inst libsrtp0 [1.4.5~20130609~dfsg-1.1] (1.4.5~20130609~dfsg-1.1+deb8u1 Debian-Security:8/stable [amd64])
Inst linux-libc-dev [3.16.7-ckt25-1] (3.16.7-ckt25-2 Debian:stable-updates [amd64])
Inst openssl [1.0.1k-3+deb8u2] (1.0.1k-3+deb8u4 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Inst perlmagick [8:6.8.9.9-5] (8:6.8.9.9-5+deb8u1 Debian:8.4/stable [all])
Inst python-pil [2.6.1-2] (2.6.1-2+deb8u2 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Inst python-imaging [2.6.1-2] (2.6.1-2+deb8u2 Debian:8.4/stable, Debian-Security:8/stable [all])
Inst sane-utils [1.0.24-8] (1.0.24-8+deb8u1 Debian:8.4/stable [amd64])
Inst gnome-shell-extension-weather [0~20140924.git7e28508-1+deb8u1] (0~20151125.gitccaa1eb-1~deb8u1 Debian:8.4/stable [all])
Conf libcairo2 (1.14.0-2.1+deb8u1 Debian:8.4/stable [amd64])
Conf libgda-5.0-common (5.2.2-2 Debian:8.4/stable [all])
Conf libglib2.0-0 (2.42.1-1+b1 Debian:8.4/stable [amd64])
Conf libglib2.0-bin (2.42.1-1+b1 Debian:8.4/stable [amd64])
Conf libgda-5.0-4 (5.2.2-2 Debian:8.4/stable [amd64])
Conf gnome-mplayer (1.0.9-3 Debian:8.4/stable [amd64])
Conf python-libxml2 (2.9.1+dfsg1-5+deb8u1 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf python-pygments (2.0.1+dfsg-1.1+deb8u1 Debian:8.4/stable, Debian-Security:8/stable [all])
Conf python-wxversion (3.0.1.1+dfsg-2 Debian:8.4/stable [all])
Conf python-wxgtk3.0 (3.0.1.1+dfsg-2 Debian:8.4/stable [amd64])
Conf libperl5.20 (5.20.2-3+deb8u4 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf perl-modules (5.20.2-3+deb8u4 Debian:8.4/stable, Debian-Security:8/stable [all])
Conf perl (5.20.2-3+deb8u4 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf initramfs-tools (0.120+deb8u1 Debian:8.4/stable [all])
Conf linux-image-3.16.0-4-amd64 (3.16.7-ckt25-2 Debian:stable-updates [amd64])
Conf libpam-systemd (215-17+deb8u4 Debian:8.4/stable [amd64])
Conf libapt-inst1.5 (1.0.9.8.3 Debian:8.4/stable [amd64])
Conf libssl1.0.0 (1.0.1k-3+deb8u4 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf imagemagick-common (8:6.8.9.9-5+deb8u1 Debian:8.4/stable [all])
Conf libmagickcore-6.q16-2 (8:6.8.9.9-5+deb8u1 Debian:8.4/stable [amd64])
Conf libmagickwand-6.q16-2 (8:6.8.9.9-5+deb8u1 Debian:8.4/stable [amd64])
Conf libavutil54 (6:11.6-1~deb8u1 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf libavresample2 (6:11.6-1~deb8u1 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf libavcodec56 (6:11.6-1~deb8u1 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf libavformat56 (6:11.6-1~deb8u1 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf libcairo-gobject2 (1.14.0-2.1+deb8u1 Debian:8.4/stable [amd64])
Conf libisc-export95 (1:9.9.5.dfsg-9+deb8u6 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf libdns-export100 (1:9.9.5.dfsg-9+deb8u6 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf libgtk2.0-common (2.24.25-3+deb8u1 Debian:8.4/stable [all])
Conf libgtk2.0-0 (2.24.25-3+deb8u1 Debian:8.4/stable [amd64])
Conf libgail18 (2.24.25-3+deb8u1 Debian:8.4/stable [amd64])
Conf libgail-common (2.24.25-3+deb8u1 Debian:8.4/stable [amd64])
Conf gtk2-engines-pixbuf (2.24.25-3+deb8u1 Debian:8.4/stable [amd64])
Conf librsvg2-2 (2.40.5-1+deb8u1 Debian:8.4/stable [amd64])
Conf librsvg2-common (2.40.5-1+deb8u1 Debian:8.4/stable [amd64])
Conf libgtk2.0-bin (2.24.25-3+deb8u1 Debian:8.4/stable [amd64])
Conf libgif4 (4.1.6-11+deb8u1 Debian:8.4/stable [amd64])
Conf libgraphite2-3 (1.3.6-1~deb8u1 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf libgudev-1.0-0 (215-17+deb8u4 Debian:8.4/stable [amd64])
Conf libnettle4 (2.7.1-5+deb8u1 Debian:8.4/stable [amd64])
Conf libhogweed2 (2.7.1-5+deb8u1 Debian:8.4/stable [amd64])
Conf libisccfg-export90 (1:9.9.5.dfsg-9+deb8u6 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf libirs-export91 (1:9.9.5.dfsg-9+deb8u6 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf libjasper1 (1.900.1-debian1-2.4+deb8u1 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf libwbclient0 (2:4.2.10+dfsg-0+deb8u2 Debian-Security:8/stable [amd64])
Conf libtalloc2 (2.1.2-0+deb8u1 Debian-Security:8/stable [amd64])
Conf libtdb1 (1.3.6-0+deb8u1 Debian-Security:8/stable [amd64])
Conf libtevent0 (0.9.25-0+deb8u1 Debian-Security:8/stable [amd64])
Conf libldb1 (2:1.1.20-0+deb8u1 Debian-Security:8/stable [amd64])
Conf python-talloc (2.1.2-0+deb8u1 Debian-Security:8/stable [amd64])
Conf samba-libs (2:4.2.10+dfsg-0+deb8u2 Debian-Security:8/stable [amd64])
Conf libsmbclient (2:4.2.10+dfsg-0+deb8u2 Debian-Security:8/stable [amd64])
Conf libmagick++-6.q16-5 (8:6.8.9.9-5+deb8u1 Debian:8.4/stable [amd64])
Conf libsane-common (1.0.24-8+deb8u1 Debian:8.4/stable [all])
Conf libsane (1.0.24-8+deb8u1 Debian:8.4/stable [amd64])
Conf libsndfile1 (1.0.25-9.1+deb8u1 Debian:8.4/stable [amd64])
Conf libswscale3 (6:11.6-1~deb8u1 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf tzdata-java (2016c-0+deb8u1 Debian:8.4/stable, Debian:stable-updates [all])
Conf apt-utils (1.0.9.8.3 Debian:8.4/stable [amd64])
Conf libisc95 (1:9.9.5.dfsg-9+deb8u6 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf libdns100 (1:9.9.5.dfsg-9+deb8u6 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf libisccc90 (1:9.9.5.dfsg-9+deb8u6 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf libisccfg90 (1:9.9.5.dfsg-9+deb8u6 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf libbind9-90 (1:9.9.5.dfsg-9+deb8u6 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf liblwres90 (1:9.9.5.dfsg-9+deb8u6 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf bind9-host (1:9.9.5.dfsg-9+deb8u6 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf host (1:9.9.5.dfsg-9+deb8u6 Debian:8.4/stable, Debian-Security:8/stable [all])
Conf dnsutils (1:9.9.5.dfsg-9+deb8u6 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf exim4-config (4.84.2-1 Debian:8.4/stable, Debian-Security:8/stable [all])
Conf exim4-base (4.84.2-1 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf exim4-daemon-light (4.84.2-1 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf exim4 (4.84.2-1 Debian:8.4/stable, Debian-Security:8/stable [all])
Conf locales (2.19-18+deb8u4 Debian:8.4/stable [all])
Conf openssh-client (1:6.7p1-5+deb8u2 Debian-Security:8/stable [amd64])
Conf calendar-google-provider (38.7.0-1~deb8u1 Debian-Security:8/stable [all])
Conf icedove (38.7.0-1~deb8u1 Debian-Security:8/stable [amd64])
Conf iceowl-extension (38.7.0-1~deb8u1 Debian-Security:8/stable [amd64])
Conf iceweasel (38.7.1esr-1~deb8u1 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf iceweasel-l10n-fr (1:38.7.1esr-1~deb8u1 Debian:8.4/stable, Debian-Security:8/stable [all])
Conf imagemagick-6.q16 (8:6.8.9.9-5+deb8u1 Debian:8.4/stable [amd64])
Conf imagemagick (8:6.8.9.9-5+deb8u1 Debian:8.4/stable [amd64])
Conf libimage-magick-q16-perl (8:6.8.9.9-5+deb8u1 Debian:8.4/stable [amd64])
Conf libimage-magick-perl (8:6.8.9.9-5+deb8u1 Debian:8.4/stable [all])
Conf libimlib2 (1.4.6-2+deb8u1 Debian-Security:8/stable [amd64])
Conf libmagickcore-6.q16-2-extra (8:6.8.9.9-5+deb8u1 Debian:8.4/stable [amd64])
Conf libservlet2.5-java (6.0.45+dfsg-1~deb8u1 Debian-Security:8/stable [all])
Conf libsrtp0 (1.4.5~20130609~dfsg-1.1+deb8u1 Debian-Security:8/stable [amd64])
Conf linux-libc-dev (3.16.7-ckt25-2 Debian:stable-updates [amd64])
Conf openssl (1.0.1k-3+deb8u4 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf perlmagick (8:6.8.9.9-5+deb8u1 Debian:8.4/stable [all])
Conf python-pil (2.6.1-2+deb8u2 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf python-imaging (2.6.1-2+deb8u2 Debian:8.4/stable, Debian-Security:8/stable [all])
Conf sane-utils (1.0.24-8+deb8u1 Debian:8.4/stable [amd64])
Conf gnome-shell-extension-weather (0~20151125.gitccaa1eb-1~deb8u1 Debian:8.4/stable [all])
enicnath@OrdiLinux:~$
 



sudo apt-get -s autoremove --purge


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
  python-libxml2 python-pygments
Paquets suggérés :
  ttf-bitstream-vera
Les paquets suivants seront mis à jour :
  python-libxml2 python-pygments
2 mis à jour, 0 nouvellement installés, 0 à enlever et 104 non mis à jour.
7 partiellement installés ou enlevés.
Inst python-libxml2 [2.9.1+dfsg1-5] (2.9.1+dfsg1-5+deb8u1 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Inst python-pygments [2.0.1+dfsg-1.1] (2.0.1+dfsg-1.1+deb8u1 Debian:8.4/stable, Debian-Security:8/stable [all])
Conf libgda-5.0-common (5.2.2-2 Debian:8.4/stable [all])
Conf libgda-5.0-4 (5.2.2-2 Debian:8.4/stable [amd64])
Conf gnome-mplayer (1.0.9-3 Debian:8.4/stable [amd64])
Conf python-libxml2 (2.9.1+dfsg1-5+deb8u1 Debian:8.4/stable, Debian-Security:8/stable [amd64])
Conf python-pygments (2.0.1+dfsg-1.1+deb8u1 Debian:8.4/stable, Debian-Security:8/stable [all])
Conf python-wxversion (3.0.1.1+dfsg-2 Debian:8.4/stable [all])
Conf python-wxgtk3.0 (3.0.1.1+dfsg-2 Debian:8.4/stable [amd64])
enicnath@OrdiLinux:~$



Est-ce que ce charabia vous permet de voir quelque chose ?

Hors ligne

#11 23-04-2016 10:09:38

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Erreur Synaptic sur Python

Bonjour
pour moi tout est bon , mais parfois apt-get passe en simulation et nous fait des miseres en mode normal.

tu a 106 paquets a mettre a jour et pas de probleme  a priori
il te faudra faire un autoremove --purge a la fin de la mise a jour


Calcul de la mise à jour... Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libasn1-8-heimdal libgssapi3-heimdal libhcrypto4-heimdal libheimbase1-heimdal libheimntlm0-heimdal libhx509-5-heimdal libkrb5-26-heimdal
  libroken18-heimdal libwind0-heimdal
Veuillez utiliser « apt-get autoremove » pour les supprimer.
 



quand tu a simulé un autoremove (2 eme partie sans upgrade )


Les paquets supplémentaires suivants seront installés :
  python-libxml2 python-pygments
Paquets suggérés :
  ttf-bitstream-vera
Les paquets suivants seront mis à jour :
  python-libxml2 python-pygments
2 mis à jour, 0 nouvellement installés, 0 à enlever et 104 non mis à jour.
7 partiellement installés ou enlevés.
 


si ta debian etait ok , il ne devrait rien avoir
la tu vois qu il y a des choses non terminées .

on retrouve les 2 paquets qui posent probleme => "python-libxml2" " python-pygments"
peut etre donner le type de bureau que tu utilise

si tu utilise synaptic de gnome par exemple , tu peut mettre a jour paquet par paquet ( il prendra automatiquement les dépendances nécessaires )

autre truc bizzare , si tu fais un "apt-get upgrade" il te propose d'enlever des paquets , et si tu fais "apt-get autoremove" non , juste 2 paquets a mettre a jour
et pourtant il dit :


7 partiellement installés ou enlevés.
 

Dernière modification par robert2a (23-04-2016 10:40:51)

Hors ligne

#12 23-04-2016 11:39:07

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : Erreur Synaptic sur Python

Pour les 7 partiellement installés ou enlevés, tu peux faire un :

dpkg --configure -a


pour que apt termine les opérations à faire sur ces paquets :

man dpkg a écrit :

dpkg --configure paquet ... | -a | --pending Reconfiguration d'un paquet dépaqueté. Si l'on donne l'option -a ou --pending au lieu de paquet, tous les paquets dépaquetés mais non configurés sont configurés.
La configuration comporte les étapes suivantes :
1. Dépaquetage des fichiers de configuration, et dans le même temps sauvegarde des anciens fichiers de configuration, de manière à pouvoir les restaurer si quelque chose se passe mal.
2. Exécution du script postinst, s'il est fourni par le paquet.

Hors ligne

#13 23-04-2016 18:39:09

enicnath
Membre
Inscription : 28-04-2012

Re : Erreur Synaptic sur Python

robert2a a écrit :

il te faudra faire un autoremove --purge a la fin de la mise a jour
peut etre donner le type de bureau que tu utilise


Bonjour,
Tu à mis le doigt sur quelque chose !
En effet, cela fait plusieurs mois que je n'utilise plus gnome, parce que ça plante au lancement.
Du coup je suis passé sur Xfce.

Je viens d'exécuter, comme le conseille nono47

dpkg --configure -a

. Voici le résultat

enicnath@OrdiLinux:~$ sudo dpkg --configure -a
[sudo] password for enicnath:
Paramétrage de python-wxversion (3.0.1.1+dfsg-2) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: erreur de traitement du paquet python-wxversion (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de python-wxgtk3.0 :
 python-wxgtk3.0 dépend de python-wxversion ; cependant :
 Le paquet python-wxversion n'est pas encore configuré.

dpkg: erreur de traitement du paquet python-wxgtk3.0 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: erreur de traitement du paquet python-pygments (--configure) :
 le paquet est dans un état vraiment incohérent; vous devriez
 le réinstaller avant de tenter de le configurer.
dpkg: erreur de traitement du paquet python-libxml2 (--configure) :
 le paquet est dans un état vraiment incohérent; vous devriez
 le réinstaller avant de tenter de le configurer.
Paramétrage de libgda-5.0-common (5.2.2-2) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: erreur de traitement du paquet libgda-5.0-common (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de libgda-5.0-4 :
 libgda-5.0-4 dépend de libgda-5.0-common (>= 5.2.2-2) ; cependant :
 Le paquet libgda-5.0-common n'est pas encore configuré.

dpkg: erreur de traitement du paquet libgda-5.0-4 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de gnome-mplayer :
 gnome-mplayer dépend de libgda-5.0-4 (>= 5.0.2) ; cependant :
 Le paquet libgda-5.0-4 n'est pas encore configuré.

dpkg: erreur de traitement du paquet gnome-mplayer (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 python-wxversion
 python-wxgtk3.0
 python-pygments
 python-libxml2
 libgda-5.0-common
 libgda-5.0-4
 gnome-mplayer
enicnath@OrdiLinux:~$
 



On voit qu'outre les erreurs python déjà signalées, j'ai une erreur gnome-player.

Hors ligne

#14 23-04-2016 18:57:22

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Erreur Synaptic sur Python

tu peut désinstaller les paquets listés et tenter un upgrade

puis tenter de réparer gnome et le player
tu a  7 paquets qui posent problemes (comme indiqué au dessus )


 python-wxversion
 python-wxgtk3.0
 python-pygments
 python-libxml2
 libgda-5.0-common
 libgda-5.0-4
 gnome-mplayer
 

Dernière modification par robert2a (23-04-2016 19:02:57)

Hors ligne

#15 23-04-2016 20:43:17

enicnath
Membre
Inscription : 28-04-2012

Re : Erreur Synaptic sur Python

robert2a a écrit :

tu peut désinstaller les paquets listés et tenter un upgrade puis tenter de réparer gnome et le player
tu a  7 paquets qui posent problemes (comme indiqué au dessus )

 python-wxversion
 python-wxgtk3.0
 python-pygments
 python-libxml2
 libgda-5.0-common
 libgda-5.0-4
 gnome-mplayer
 


Ok, penses-tu que je puisse désinstaller sous synpatic, ou vaut-il mieux le faire par apt-get ?

Hors ligne

#16 24-04-2016 07:47:52

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Erreur Synaptic sur Python

synaptic est trés puissant , juste faire attention sur ce qu il te dit.

commencer par gnome-player (desinstaller complettement )
vérifier les paquets cassés , dans "état" voir ce qu il te propose d'enlever (paquet inutile )
tu peut aussi demander a ne mettre qu un paquet a jour ( un qui ne pose pas probleme )

dans tous les cas tu peut suivre l opération (log en direct pendant qu il travaille )

moi je commencerai par purger ces 7 paquets en surveillant ce que cela risque de casser , puis mettre a jour (104 paquets quand meme wink  )
si tout se passe bien voir se que te dit synaptic sur l etat de ta debian

sinon par la console (tu ne peut ouvrir les 2 en meme temps , il faut fermer synaptic)


apt-get remove --purge gnome-mplayer
 



si il te propose un autoremove , vérifier de quoi il s'agit ( la liste des paquets devenu inutile )

si tu est pas sur de toi la commande -s te donnera le detail sans rien faire


apt-get -s remove --purge gnome-mplayer
 


tu fais ça pour les 7 paquets
quand tu aura purgé les 7 paquets , l upgrade devrait fonctionner

ps: sur stretch quand je recherche gnome-mplayer il me propose le paquet "smtube"  tongue  roll
=> https://packages.debian.org/sid/video/gnome-mplayer (voila le pourquoi  wink  )
et => https://packages.qa.debian.org/g/gnome-mplayer.html

Dernière modification par robert2a (24-04-2016 08:18:46)

Hors ligne

#17 24-04-2016 10:18:59

enicnath
Membre
Inscription : 28-04-2012

Re : Erreur Synaptic sur Python

robert2a a écrit :

... tu fais ça pour les 7 paquets
quand tu aura purgé les 7 paquets , l upgrade devrait fonctionner

Bonjour,
Et merci de tes conseils.
Les tentatives sur chacun de mes paquets renvoient des erreurs, qui me semblent liées à la bibliothèque python-libxml2.
J'ai quand même tenté un upgrade. Il me renvoie aussi des erreurs, notamment celle-ci, toujours liées à python-libxml2 :


Préparation du dépaquetage de .../python-libxml2_2.9.1+dfsg1-5+deb8u1_amd64.deb ...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:



Je commence quand même à fatiguer ...

Hors ligne

#18 24-04-2016 10:56:56

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : Erreur Synaptic sur Python

Salut,

Souvent aptitude est plus souple pour la gestion des dépendances ( il peut ajuster les versions ), essaie de réinstaller
les paquets en commençant par ceux que apt te conseille de réinstaller :

apt a écrit :

dpkg: erreur de traitement du paquet python-pygments (--configure) :
le paquet est dans un état vraiment incohérent; vous devriez
le réinstaller avant de tenter de le configurer.


aptitude reinstall python-pygments



Il faut débloquer ces paquets pour que apt fonctionne bien .

édition : et aussi pour python-libxml2 si tu penses qu'il est fautif .

Dernière modification par nono47 (24-04-2016 10:58:51)

Hors ligne

#19 24-04-2016 12:27:41

enicnath
Membre
Inscription : 28-04-2012

Re : Erreur Synaptic sur Python

nono47 a écrit :

... vous devriez le réinstaller avant de tenter de le configurer...

Alors voilà, pour python-pygments :

sudo aptitude reinstall python-pygments


Les résultats donnent :

enicnath@OrdiLinux:~$ sudo aptitude reinstall python-pygments
[sudo] password for enicnath:
Les paquets suivants seront RÉINSTALLÉS :              
  python-pygments
Les paquets partiellement installés suivants seront configurés :
  base-files libgda-5.0-common python-wxversion system-config-printer
0 paquets mis à jour, 0 nouvellement installés, 1installés, 0 à enlever et 104 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.
E: Impossible de trouver une source de téléchargement de la version « 2.9.1+dfsg1-5 » de « python-libxml2:amd64 »
E: Impossible de trouver une source de téléchargement de la version « 2.9.1+dfsg1-5 » de « python-libxml2:amd64 »
E: Erreur interne : impossible de créer la liste des paquets à télécharger
enicnath@OrdiLinux:~$



Et pour python-libxml2 :

enicnath@OrdiLinux:~$ sudo aptitude reinstall python-libxml2


Ici aussi on a des erreurs

Les paquets suivants seront RÉINSTALLÉS :              
  python-libxml2
Les paquets partiellement installés suivants seront configurés :
  base-files libgda-5.0-common python-wxversion system-config-printer
0 paquets mis à jour, 0 nouvellement installés, 1installés, 0 à enlever et 104 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.
E: Impossible de trouver une source de téléchargement de la version « 2.9.1+dfsg1-5 » de « python-libxml2:amd64 »
E: Impossible de trouver une source de téléchargement de la version « 2.9.1+dfsg1-5 » de « python-libxml2:amd64 »
E: Erreur interne : impossible de créer la liste des paquets à télécharger
enicnath@OrdiLinux:~$

Hors ligne

#20 24-04-2016 12:54:33

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Erreur Synaptic sur Python

il y a une commande dpkg , qui doit pouvoir résoudre ce souci , mais je vais laisser la place aux barbu's  hmm
ça dépasse mes compétences

Hors ligne

#21 24-04-2016 13:13:35

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : Erreur Synaptic sur Python

aptitude update


se déroule normalement, il arrive à joindre les dépôts ?

Je le vois bien dans le dépôt stable ( jessie ) :

apt-cache policy python-libxml2


python-libxml2
python-libxml2:
  Installé : 2.9.3+dfsg1-1
  Candidat : 2.9.3+dfsg1-1
 Table de version :
 *** 2.9.3+dfsg1-1 500
        500 [url]http://ftp.fr.debian.org/debian[/url] unstable/main amd64 Packages
        500 [url]http://ftp.fr.debian.org/debian[/url] testing/main amd64 Packages
        100 /var/lib/dpkg/status
     2.9.1+dfsg1-5+deb8u1 500
        500 [url]http://ftp.fr.debian.org/debian[/url] stable/main amd64 Packages
        500 [url]http://security.debian.org[/url] stable/updates/main amd64 Packages

Dernière modification par nono47 (24-04-2016 13:16:38)

Hors ligne

#22 24-04-2016 13:22:08

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Erreur Synaptic sur Python

d'aprés son post en #7 , l update est correct et son sources.list aussi

Hors ligne

#23 24-04-2016 14:19:34

enicnath
Membre
Inscription : 28-04-2012

Re : Erreur Synaptic sur Python

nono47 a écrit :

aptitude update

se déroule normalement, il arrive à joindre les dépôts ?


Oui,
Voici le résultat :

enicnath@OrdiLinux:~$ sudo aptitude update
[sudo] password for enicnath:
Ignoré http://ftp.fr.debian.org jessie InRelease
Prendre :  1 http://security.debian.org jessie/updates InRelease [63,1 kB]
Prendre :  2 http://ftp.fr.debian.org jessie-updates InRelease [142 kB]          
Prendre :  3 http://security.debian.org jessie/updates/main Sources [128 kB]
Atteint http://ftp.fr.debian.org jessie Release.gpg                              
Prendre :  4 http://ftp.fr.debian.org jessie-updates/main Sources [14,1 kB]
Prendre :  5 http://security.debian.org jessie/updates/main amd64 Packages [234 kB]  
Prendre :  6 http://ftp.fr.debian.org jessie-updates/main amd64 Packages/DiffIndex [2 980 B]
Prendre :  7 http://ftp.fr.debian.org jessie-updates/main Translation-en/DiffIndex [1 720 B]
Atteint http://ftp.fr.debian.org jessie Release                          
Prendre :  8 http://security.debian.org jessie/updates/main Translation-en [128 kB]                      
Prendre :  9 http://ftp.fr.debian.org jessie-updates/main amd64 2016-04-19-2053.08.pdiff [2 111 B]
Prendre :  10 http://ftp.fr.debian.org jessie-updates/main amd64 2016-04-23-1455.20.pdiff [378 B]
Prendre :  11 http://ftp.fr.debian.org jessie-updates/main amd64 2016-04-23-1455.20.pdiff [378 B]
Prendre :  12 http://ftp.fr.debian.org jessie-updates/main 2016-04-19-2053.08.pdiff [2 245 B]
Prendre :  13 http://ftp.fr.debian.org jessie-updates/main 2016-04-19-2053.08.pdiff [2 245 B]
Atteint http://ftp.fr.debian.org jessie/main Sources                        
Atteint http://ftp.fr.debian.org jessie/main amd64 Packages
Atteint http://ftp.fr.debian.org jessie/main Translation-fr
Atteint http://ftp.fr.debian.org jessie/main Translation-en
 719 ko téléchargés en 3s (231 ko/s)
                                   
État actuel : 108 mises à jour restantes [+3].
enicnath@OrdiLinux:~$



Et pour apt-cache policy python-libxml2, voici le résultat :

enicnath@OrdiLinux:~$ sudo apt-cache policy python-libxml2
python-libxml2:
  Installé : 2.9.1+dfsg1-5
  Candidat : 2.9.1+dfsg1-5+deb8u1
 Table de version :
     2.9.1+dfsg1-5+deb8u1 0
        500 http://ftp.fr.debian.org/debian/ jessie/main amd64 Packages
        500 http://security.debian.org/ jessie/updates/main amd64 Packages
 *** 2.9.1+dfsg1-5 0
        100 /var/lib/dpkg/status
enicnath@OrdiLinux:~$

Hors ligne

#24 28-04-2016 22:01:04

enicnath
Membre
Inscription : 28-04-2012

Re : Erreur Synaptic sur Python

ouh ouh !

Y-a quelqu'un ?
Personne n'a d'idée ?
Vais-je devoir rester planté là ?

Hors ligne

Pied de page des forums