Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 17-04-2016 15:37:22

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

[resolu]perdu la carte réseau filaire

Bonjour

sur une machine j'ai perdu le réseau , a priori le service networking est absent (la carte intégré reste éteinte )
j'ai ajouté une carte PCIe meme souci
j'ai plus d'idée et surtout plus de réseau

j étais sur la désactivation d ipv6 , je pense que j'ai fait une bétise
je vois eth0 avec ifconfig -a , le mac adresse et son interruption
je ping la boucle locale , mais pas d ip affecté a la carte

on dirait que le driver n est  pas chargé au démarrage (ou le module réseau )
le voyant de la carte s allume au démarrage puis s eteint au chargement de debian (sur la carte PCIe le voyant reste allumé mais en 100 sans signal tx/rx)
commande

]
ip a
 


retour


1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 00:1d:60:59:71:28 brd ff:ff:ff:ff:ff:ff
 


commande


ifconfig -a
 


retour


eth0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 00:1d:60:59:71:28  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 17  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Boucle locale)
        RX packets 12  bytes 1248 (1.2 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 12  bytes 1248 (1.2 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
 

Dernière modification par robert2a (17-04-2016 16:44:35)

Hors ligne

#2 17-04-2016 16:06:49

raleur
Membre
Inscription : 03-10-2014

Re : [resolu]perdu la carte réseau filaire

robert2a a écrit :

je vois eth0 avec ifconfig -a


Pas nous.

robert2a a écrit :


on dirait que le driver n est  pas chargé au démarrage (ou le module réseau )


S'il ne l'était pas, tu ne verrais pas l'interface avec ifconfig.

Par quel moyen le réseau était-il géré ? /etc/network/interfaces, NetworkManager, Wicd, systemd ?

Hors ligne

#3 17-04-2016 16:11:22

raleur
Membre
Inscription : 03-10-2014

Re : [resolu]perdu la carte réseau filaire

Ah, les infos arrivent.

PS : évite d'ajouter des informations à un message existant car les lecteurs qui l'ont déjà lu ne verront pas de nouveau message.

Bon, l'interface n'est pas activée. Note que tu peux le faire à la main. ifconfig et ip ne servent pas qu'en consultation.

Hors ligne

#4 17-04-2016 16:19:05

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [resolu]perdu la carte réseau filaire

j'ai testé avec l ancien kernel meme soucis (4.3 ) , la je suis en mode rescue , je regarde les options.
ps: je n ai pas les outils ifdown et ifup (paquet non installé )
j ai un fichier interfaces basic ( en dhcp et auto ) , changé le cable rj45 quand meme

Hors ligne

#5 17-04-2016 16:23:05

raleur
Membre
Inscription : 03-10-2014

Re : [resolu]perdu la carte réseau filaire

Sans paquet ifupdown, le fichier interfaces ne va pas servir à grand-chose.

Hors ligne

#6 17-04-2016 16:44:10

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [resolu]perdu la carte réseau filaire

commande


ifup eth0
 


retour


Internet Systems Consortium DHCP Client 4.3.3
Copyright 2004-2015 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/eth0/00:1d:60:59:71:28
Sending on   LPF/eth0/00:1d:60:59:71:28
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 11
DHCPREQUEST of 192.168.10.23 on eth0 to 255.255.255.255 port 67
DHCPOFFER of 192.168.10.23 from 192.168.10.1
DHCPACK of 192.168.10.23 from 192.168.10.1
bound to 192.168.10.23 -- renewal in 3243 seconds.
 



je suis sur la machine en panne
j'ai recupéré le .deb et installé le paquet ifupdown de stretch
a priori et de mémoire j utilisais un autre paquet que j ai du retirer par erreur (aujourd'hui ), parce que ifupdown ça fait un moment qu il est absent (depuis le bug ) et j ai oublié de le remettre
entre temps j ai fonctionné aussi avec network manager. (sans fichier interfaces)
enfin c'est réparé
merci pour le coup de main  smile

Hors ligne

#7 17-04-2016 18:03:47

raleur
Membre
Inscription : 03-10-2014

Re : [resolu]perdu la carte réseau filaire

Tu peux retrouver la liste des paquets supprimés aujourd'hui dans les logs d'apt ou dpkg.

Hors ligne

#8 17-04-2016 18:31:30

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [resolu]perdu la carte réseau filaire

le paquet que j'ai retiré c'est "netscript"
a la fin du log c'est l installation de ifupdown que j aurai du remettre depuis fort longtemps (un oublie) suite a bug de ce fichier sur stretch


2016-04-17 12:37:46 status installed netscript-2.4:all 5.4.11
2016-04-17 12:37:54 remove netscript-2.4:all 5.4.11 <aucune>
2016-04-17 12:37:54 status half-configured netscript-2.4:all 5.4.11
2016-04-17 12:37:54 status half-installed netscript-2.4:all 5.4.11
2016-04-17 12:37:54 status triggers-pending man-db:amd64 2.7.5-1
2016-04-17 12:37:55 status config-files netscript-2.4:all 5.4.11
2016-04-17 12:37:55 purge netscript-2.4:all 5.4.11 <aucune>
2016-04-17 12:37:55 status config-files netscript-2.4:all 5.4.11
2016-04-17 12:37:55 status config-files netscript-2.4:all 5.4.11
2016-04-17 12:37:55 status config-files netscript-2.4:all 5.4.11
2016-04-17 12:37:56 status config-files netscript-2.4:all 5.4.11
2016-04-17 12:37:56 status config-files netscript-2.4:all 5.4.11
2016-04-17 12:37:56 status not-installed netscript-2.4:all <aucune>
2016-04-17 12:37:56 trigproc man-db:amd64 2.7.5-1 <aucune>
2016-04-17 12:37:56 status half-configured man-db:amd64 2.7.5-1
2016-04-17 12:37:58 status installed man-db:amd64 2.7.5-1
2016-04-17 12:37:58 startup packages configure
2016-04-17 12:38:42 startup packages purge
2016-04-17 12:38:42 status installed bridge-utils:amd64 1.5-9
2016-04-17 12:38:42 remove bridge-utils:amd64 1.5-9 <aucune>
2016-04-17 12:38:42 status half-configured bridge-utils:amd64 1.5-9
2016-04-17 12:38:42 status half-installed bridge-utils:amd64 1.5-9
2016-04-17 12:38:42 status triggers-pending man-db:amd64 2.7.5-1
2016-04-17 12:38:43 status config-files bridge-utils:amd64 1.5-9
2016-04-17 12:38:43 purge bridge-utils:amd64 1.5-9 <aucune>
2016-04-17 12:38:43 status config-files bridge-utils:amd64 1.5-9
2016-04-17 12:38:43 status config-files bridge-utils:amd64 1.5-9
2016-04-17 12:38:43 status config-files bridge-utils:amd64 1.5-9netscript
2016-04-17 12:38:43 status config-files bridge-utils:amd64 1.5-9
2016-04-17 12:38:43 status config-files bridge-utils:amd64 1.5-9
2016-04-17 12:38:43 status not-installed bridge-utils:amd64 <aucune>
2016-04-17 12:38:43 trigproc man-db:amd64 2.7.5-1 <aucune>
2016-04-17 12:38:43 status half-configured man-db:amd64 2.7.5-1
2016-04-17 12:38:43 status installed man-db:amd64 2.7.5-1
2016-04-17 12:38:44 startup packages configure
2016-04-17 16:32:37 startup archives install
2016-04-17 16:32:45 install ifupdown:amd64 <aucune> 0.8.10
2016-04-17 16:32:45 status half-installed ifupdown:amd64 0.8.10
2016-04-17 16:32:45 status triggers-pending man-db:amd64 2.7.5-1
2016-04-17 16:32:45 status triggers-pending systemd:amd64 229-4
2016-04-17 16:32:46 status unpacked ifupdown:amd64 0.8.10
2016-04-17 16:32:46 status unpacked ifupdown:amd64 0.8.10
2016-04-17 16:32:46 configure ifupdown:amd64 0.8.10 0.8.10
2016-04-17 16:32:46 status unpacked ifupdown:amd64 0.8.10
2016-04-17 16:32:46 status unpacked ifupdown:amd64 0.8.10
2016-04-17 16:32:46 status unpacked ifupdown:amd64 0.8.10
2016-04-17 16:32:46 status unpacked ifupdown:amd64 0.8.10
2016-04-17 16:32:46 status unpacked ifupdown:amd64 0.8.10
2016-04-17 16:32:46 status unpacked ifupdown:amd64 0.8.10
2016-04-17 16:32:46 status unpacked ifupdown:amd64 0.8.10
2016-04-17 16:32:46 status unpacked ifupdown:amd64 0.8.10
2016-04-17 16:32:46 status unpacked ifupdown:amd64 0.8.10
2016-04-17 16:32:46 status half-configured ifupdown:amd64 0.8.10
2016-04-17 16:32:47 status installed ifupdown:amd64 0.8.10netscript
2016-04-17 16:32:47 trigproc man-db:amd64 2.7.5-1 <aucune>
2016-04-17 16:32:47 status half-configured man-db:amd64 2.7.5-1
2016-04-17 16:32:49 status installed man-db:amd64 2.7.5-1
2016-04-17 16:32:49 trigproc systemd:amd64 229-4 <aucune>
2016-04-17 16:32:49 status half-configured systemd:amd64 229-4
2016-04-17 16:32:49 status installed systemd:amd64 229-4
 


ce que me dit apt "history.log"


Start-Date: 2016-04-17  12:37:46
Commandline: /usr/sbin/synaptic
Requested-By: robert (1000)
Purge: netscript-2.4:amd64 (5.4.11)
End-Date: 2016-04-17  12:37:58

Start-Date: 2016-04-17  12:38:42
Commandline: /usr/sbin/synaptic
Requested-By: robert (1000)
Purge: bridge-utils:amd64 (1.5-9)
End-Date: 2016-04-17  12:38:44
 

Dernière modification par robert2a (17-04-2016 19:06:39)

Hors ligne

Pied de page des forums