Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-04-2016 08:30:24

kawer
Adhérent(e)
Lieu : Académie de la Croix-Vraie
Distrib. : Debian stable / ArchLinux
Noyau : Current
(G)UI : xfwm4
Inscription : 08-10-2013
Site Web

[Résolu] Squid3, le daemon démarre mais squid ne fait pas le boulo

Bonjour,

J'utilisais merveilleusement bien squi3 jusqu'a présent, depuis le reboot du serveur où est squid3 j'ai le droit à un "La connexion a été refusée par le serveur proxy".

Rien dans acces.log, pas de fichier error.log, rien dans syslog, le retour du démarrage du daemon par systemd indique qu'il est démarrer mais j'en trouve pas de trace avec netstat.

Coté client j'ai capturé les paquets et lorsque je vais sur une page, le client envoie un paquet et le serveur proxy retourne un TCP RST sans rien d'autre sad

Une idée ?

Dernière modification par kawer (12-05-2016 19:29:08)


Rendez à César ce qui est à César et à Dieu ce qui est à Dieu -Cit. J.C.
La persévérance, c'est ce qui rend l'impossible possible, le possible probable et le probable réalisé. -Cit. Robert Half.
Dans toutes les situations, le piège c'était avant, car tu ne voyais pas les murs -Cit. Crevette

Hors ligne

#2 29-04-2016 11:42:56

Kusajika
Membre
Inscription : 08-04-2015

Re : [Résolu] Squid3, le daemon démarre mais squid ne fait pas le boulo

Bonjour , tu as installé squidguard aussi ? si oui es-tu allé voir le squidguard.log ?
Peux tu nous transmettre le contenu de ton squid.conf stp ?

Hors ligne

#3 29-04-2016 11:48:40

kawer
Adhérent(e)
Lieu : Académie de la Croix-Vraie
Distrib. : Debian stable / ArchLinux
Noyau : Current
(G)UI : xfwm4
Inscription : 08-10-2013
Site Web

Re : [Résolu] Squid3, le daemon démarre mais squid ne fait pas le boulo

Je n'ai pas encore installé squidguard, voici les compléments :

Mes règles iptables :

iptables -t filter -P INPUT DROP
iptables -t filter -P FORWARD DROP
iptables -t filter -P OUTPUT ACCEPT

# Vider les tables actuelles
iptables -t filter -F
iptables -t filter -X

# Ne pas casser les connexions etablies
iptables -A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT
iptables -A OUTPUT -m state --state RELATED,ESTABLISHED -j ACCEPT

# loopback
iptables -t filter -A INPUT -i lo -j ACCEPT
iptables -t filter -A OUTPUT -o lo -j ACCEPT

# squid
iptables -t filter -A INPUT -p tcp --dport 4486 -j ACCEPT



Mon squid.conf :


acl SSL_ports port 443
acl Safe_ports port 80          # http
acl Safe_ports port 21          # ftp
acl Safe_ports port 443         # https
acl Safe_ports port 70          # gopher
acl Safe_ports port 210         # wais
acl Safe_ports port 1025-65535  # unregistered ports
acl Safe_ports port 280         # http-mgmt
acl Safe_ports port 488         # gss-http
acl Safe_ports port 591         # filemaker
acl Safe_ports port 777         # multiling http
acl CONNECT method CONNECT
acl kawer src 88.xxx.xxx.xxx
http_access allow kawer
http_access allow localhost
http_access deny !Safe_ports
http_access deny CONNECT !SSL_portshttp_access allow localhost manager
http_access deny manager
http_port 4486
forwarded_for off
 



Squid fonctionne :

ps aux |  grep squid


root      1116  0.0  0.2  79616  5308 ?        Ss   08:07   0:00 /usr/sbin/squid3 -YC -f /etc/squid3/squid.conf
proxy     1121  0.0  1.1 120320 23872 ?        S    08:07   0:00 (squid-1) -YC -f /etc/squid3/squid.conf
proxy     1128  0.0  0.0  33624  1872 ?        S    08:07   0:00 (logfile-daemon) /var/log/squid3/access.log
kawer     1422  0.0  0.0  12684  1624 pts/0    S+   11:44   0:00 grep squid
 



Squid n'est à l'écoute sur aucun ports.

netstat -atup | grep LISTEN



tcp        0      0 *:ssh                   *:*                     LISTEN      286/sshd        
tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      286/sshd
 

Dernière modification par kawer (29-04-2016 11:53:03)


Rendez à César ce qui est à César et à Dieu ce qui est à Dieu -Cit. J.C.
La persévérance, c'est ce qui rend l'impossible possible, le possible probable et le probable réalisé. -Cit. Robert Half.
Dans toutes les situations, le piège c'était avant, car tu ne voyais pas les murs -Cit. Crevette

Hors ligne

#4 29-04-2016 14:48:54

Kusajika
Membre
Inscription : 08-04-2015

Re : [Résolu] Squid3, le daemon démarre mais squid ne fait pas le boulo

Ton fichier config semble tout à fait correct.
En revanche

netstat -atup | grep LISTEN


tcp        0      0 *:3128                  *:*                     LISTEN      10457/(squid)


Mon squid config est config en :

http_port 3128 transparent



Peux tu me donner une information dans l'utilisation de ton squid stp ? car ta ligne :

acl kawer src 88.xxx.xxx.xxx

me trouble un peu, ta src est distante?

Hors ligne

#5 29-04-2016 19:22:46

kawer
Adhérent(e)
Lieu : Académie de la Croix-Vraie
Distrib. : Debian stable / ArchLinux
Noyau : Current
(G)UI : xfwm4
Inscription : 08-10-2013
Site Web

Re : [Résolu] Squid3, le daemon démarre mais squid ne fait pas le boulo

Oui la source est distante. Je come connecte sur un serveur ovh.

Rendez à César ce qui est à César et à Dieu ce qui est à Dieu -Cit. J.C.
La persévérance, c'est ce qui rend l'impossible possible, le possible probable et le probable réalisé. -Cit. Robert Half.
Dans toutes les situations, le piège c'était avant, car tu ne voyais pas les murs -Cit. Crevette

Hors ligne

#6 29-04-2016 21:52:05

kawer
Adhérent(e)
Lieu : Académie de la Croix-Vraie
Distrib. : Debian stable / ArchLinux
Noyau : Current
(G)UI : xfwm4
Inscription : 08-10-2013
Site Web

Re : [Résolu] Squid3, le daemon démarre mais squid ne fait pas le boulo

Bon d'après le bug tracker, je ne suis pas le seul. Le problème à l'air récurant avec jessie, je test avec wheezy.

Rendez à César ce qui est à César et à Dieu ce qui est à Dieu -Cit. J.C.
La persévérance, c'est ce qui rend l'impossible possible, le possible probable et le probable réalisé. -Cit. Robert Half.
Dans toutes les situations, le piège c'était avant, car tu ne voyais pas les murs -Cit. Crevette

Hors ligne

#7 30-04-2016 09:28:25

Kusajika
Membre
Inscription : 08-04-2015

Re : [Résolu] Squid3, le daemon démarre mais squid ne fait pas le boulo

La config sur lequel se trouve mon squid est Wheezy.

Hors ligne

#8 30-04-2016 13:13:49

kawer
Adhérent(e)
Lieu : Académie de la Croix-Vraie
Distrib. : Debian stable / ArchLinux
Noyau : Current
(G)UI : xfwm4
Inscription : 08-10-2013
Site Web

Re : [Résolu] Squid3, le daemon démarre mais squid ne fait pas le boulo

Bon pour le moment sa roule sous wheezy, si dans une semaine tout vas bien je pousserais la configuration et passerais le sujet en résolu. Merci Kusajika cool.

Rendez à César ce qui est à César et à Dieu ce qui est à Dieu -Cit. J.C.
La persévérance, c'est ce qui rend l'impossible possible, le possible probable et le probable réalisé. -Cit. Robert Half.
Dans toutes les situations, le piège c'était avant, car tu ne voyais pas les murs -Cit. Crevette

Hors ligne

#9 01-05-2016 19:51:34

Kusajika
Membre
Inscription : 08-04-2015

Re : [Résolu] Squid3, le daemon démarre mais squid ne fait pas le boulo

De rien , mais j'espère que le bug avec Jessie va vite être résolu car ce serveur où se trouve le squid je voudrait le passer en Jessie dans 2-3 mois big_smile

Hors ligne

#10 12-05-2016 19:28:46

kawer
Adhérent(e)
Lieu : Académie de la Croix-Vraie
Distrib. : Debian stable / ArchLinux
Noyau : Current
(G)UI : xfwm4
Inscription : 08-10-2013
Site Web

Re : [Résolu] Squid3, le daemon démarre mais squid ne fait pas le boulo

J'adore, squid3 détecte même les malwares :

1463074026.png

cool cool cool

Rendez à César ce qui est à César et à Dieu ce qui est à Dieu -Cit. J.C.
La persévérance, c'est ce qui rend l'impossible possible, le possible probable et le probable réalisé. -Cit. Robert Half.
Dans toutes les situations, le piège c'était avant, car tu ne voyais pas les murs -Cit. Crevette

Hors ligne

Pied de page des forums