Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-05-2016 15:59:14

autrekrikri
Membre
Distrib. : Debian 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : wmii
Inscription : 26-01-2016

pas de screensaver installé, mais écran qui se met en veille

Bonjour,
j'ai fait une installation minimale, sans wm. Puis j'ai installé wmii, et avec l'aide de certains d'entre vous, tout va bien ou tout allait bien ...
Je n'ai pas de screensaver installé, mais au bout de 5~10 minutes, il se met en veille, ou plus précisément, il m'indique qu'il ne reçoit plus d'information par le câble.
Après recherche, je crois connaitre le coupable, mais je n'ose y toucher : xdg-screensaver.
Vous pouvez m’aider à le configurer ?

Hors ligne

#2 11-05-2016 16:22:07

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : pas de screensaver installé, mais écran qui se met en veille

il m'indique qu'il ne reçoit plus d'information par le câble.



c'est qui "il" ?

que donne la commande

xset -q


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#3 11-05-2016 20:14:03

autrekrikri
Membre
Distrib. : Debian 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : wmii
Inscription : 26-01-2016

Re : pas de screensaver installé, mais écran qui se met en veille

Severian a écrit :

il m'indique qu'il ne reçoit plus d'information par le câble.



c'est qui "il" ?

que donne la commande

xset -q


Bonsoir,
en effet, après relecture, il me manque des "bouts" ... wink
Il est l'écran, c'est un comportement habituel de mon écran, lorsque je suis sur "HDMI1" ou "HDMI2" et que la source n'est pas allumée, lorsqu'elle n'envoie pas de signal, c'est ce que l'écran indique.
Voici la sortie de la commande :

Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000002
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    on     02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  660    repeat rate:  25
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  600    cycle:  600
Colors:
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/X11/misc,/usr/share/fonts/X11/100dpi/:unscaled,/usr/share/fonts/X11/75dpi/:unscaled,/usr/share/fonts/X11/Type1,/usr/share/fonts/X11/100dpi,/usr/share/fonts/X11/75dpi,built-ins
DPMS (Energy Star):
  Standby: 600    Suspend: 600    Off: 600
  DPMS is Enabled
  Monitor is On
 

Hors ligne

#4 11-05-2016 20:36:58

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : pas de screensaver installé, mais écran qui se met en veille

bon le "coupable" est xset...

Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  600    cycle:  600



écran noir au bout de 600 secondes

DPMS (Energy Star):
  Standby: 600    Suspend: 600    Off: 600
  DPMS is Enabled
  Monitor is On



économie d'énergie dpms (Display Power Management Signaling)
standby / suspendre / éteindre au bout de 600 secondes

si tu veux désactiver

xset s off -dpms



pour configurer le mieux c'est que tu lise le résultat de

xset

-


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#5 13-05-2016 14:27:43

autrekrikri
Membre
Distrib. : Debian 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : wmii
Inscription : 26-01-2016

Re : pas de screensaver installé, mais écran qui se met en veille

Bon, alors pour désactiver, maintenant, je sais comment faire, mais si un jour je souhaite réactiver ?

Hors ligne

#6 13-05-2016 14:40:59

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : pas de screensaver installé, mais écran qui se met en veille

et donc c'était bien ça qui posait soucis ?? smile

sinon

xset s on +dpms


pour règler les timers ecran de veille

xset s 600 600


600 600 sont des exemple, c'est le temps donné par défaut en secondes, tu peux le modifier
pareil pour dpms

xset dpms 600 1200 1800


600 1200 1800 sont aussi des exemple, toujours en secondes

Dernière modification par Severian (13-05-2016 14:41:50)


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

Pied de page des forums