Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 16-05-2016 17:12:50

jibel
Membre
Lieu : bruxelles
Distrib. : voyager X8 debian
Noyau : Linux 3.16.0-44-generic
Inscription : 09-03-2014

rePB avec la debian 8.2

Bonjour,
Voila de nouveau un PB lors des MàJs et d'installations de logiciels ... tout a été faux aux résultats...pour quoi?
parce que kodi est bien présent, masi que lors des MàJs les commandes ont repondus  ceci dessous.
J'ai eu beau aller voir dans la sources.list tout serait correct... Mais lors de ces MàJs refus de celle-ci a cause  des commandes
faitent avec gksu pour passer en root ..... 

jib@debian:~$ apt-get update
E: Impossible d'ouvrir le fichier verrou /var/lib/apt/lists/lock - open (13: Permission non accordée)
E: Impossible de verrouiller le répertoire /var/lib/apt/lists/
E: Impossible d'ouvrir le fichier verrou /var/lib/dpkg/lock - open (13: Permission non accordée)
E: Impossible de verrouiller le répertoire d'administration (/var/lib/dpkg/). Avez-vous les privilèges du superutilisateur ?
jib@debian:~$ sudo su
[sudo] password for jib:
root@debian:/home/jib# apt-get update
E: Le pilote pour la méthode /usr/lib/apt/methods/https n'a pu être trouvé.
N: Is the package apt-transport-https installed?
root@debian:/home/jib# apt-get install kodi
Lecture des listes de paquets... Erreur !
E: Problème de renommage du fichier /var/cache/apt/srcpkgcache.bin.G9FxIz en /var/cache/apt/srcpkgcache.bin - rename (2: Aucun fichier ou dossier de ce type)
E: Problème de renommage du fichier /var/cache/apt/pkgcache.bin.a3iZXd en /var/cache/apt/pkgcache.bin - rename (2: Aucun fichier ou dossier de ce type)
E: Les listes de paquets ou le fichier « status » ne peuvent être analysés ou lus.
root@debian:/home/jib# gksu apt-get update
No protocol specified


et ceci

gksu:2080): Gtk-WARNING **: cannot open display: :0
root@debian:/home/jib# apt-get update
E: Le pilote pour la méthode /usr/lib/apt/methods/https n'a pu être trouvé.
N: Is the package apt-transport-https installed?
root@debian:/home/jib#



J'ai regardé dans la sources.list ou ailleurs(fichiers) pour trouver "apt-transport-https" qui n'existe pas  ? ? ?
donc impossible de faire une mise a jour.....
Voila les résultats qui gênent... Est-ce que je devrais refaire cette installe ou essayer de trouver le pourquoi de ces échecs  avec "apper" le gestionnaire de MàJ.....  je peux mentionner d'autres ennuis si c'est nécessaire  @+ etc, etc  merci pour les avis a discuter smile

Dernière modification par jibel (16-05-2016 17:17:45)


Plus grande est la face , plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur.Elles peuvent être reproduites et même corrigées sans l'accord préalable du susdit.  8-) Avec kubuntu 14.04 Voyager14.04 et 13.04, Linux mint 17, hybryde fusion et voyager X8 debian

Hors ligne

#2 17-05-2016 23:31:39

mimi
Membre
Distrib. : Poutoux 0.2
Noyau : Linux 3.16.0-4-amd64
(G)UI : openbox
Inscription : 13-05-2016
Site Web

Re : rePB avec la debian 8.2

Salut, peut tu poster ton fichier source.list ?
Je ne sais pas trop d'où viens exactement ton problème mais en regardants https://packages.debian.org/fr/sid/apt-transport-https je pense comprendre que dans ton sources.list les dépôts sont en https. Je pense que si tu les passe en http et que tu installe le paquet apt-transport-https tu pourra repasser tes source en https et tout devrai rentrer dan l'ordre ...  big_smile

@++

Dernière modification par mimi (17-05-2016 23:35:55)

Hors ligne

#3 18-05-2016 05:59:50

jibel
Membre
Lieu : bruxelles
Distrib. : voyager X8 debian
Noyau : Linux 3.16.0-44-generic
Inscription : 09-03-2014

Re : rePB avec la debian 8.2

mimi a écrit :

Salut, peut tu poster ton fichier source.list ?
Je ne sais pas trop d'où viens exactement ton problème mais en regardants https://packages.debian.org/fr/sid/apt-transport-https je pense comprendre que dans ton sources.list les dépôts sont en https. Je pense que si tu les passe en http et que tu installe le paquet apt-transport-https tu pourra repasser tes source en https et tout devrai rentrer dan l'ordre ...  big_smile

@++



Merci mimi,
voila la sources.list :

 


 # Debian Jessie, dépôt principal + paquets non libres
deb http://httpredir.debian.org/debian/ jessie main contrib non-free
 # Debian Jessie, mises-à-jour de sécurité + paquets non libres
deb http://security.debian.org/ jessie/updates main contrib non-free
 # Debian Jessie, mises-à-jour "volatiles" + paquets non libres
deb http://httpredir.debian.org/debian/ jessie-updates main contrib non-free
 # Debian Jessie, dépôt de rétroportages ("backports")
deb http://httpredir.debian.org/debian jessie-backports main contrib non-free
# XBMC repos
deb https://people.debian.org/~rbalint/ppa/xbmc-ffmpeg xbmc-ffmpeg-unstable/
deb http://http.debian.net/debian unstable main
deb http://www.deb-multimedia.org2 jessie main non-free

 



J'ai regardé ce https-etc et je crois qu'il faut installer  la commande  des paquets en jessie ou en sid qui apparaissent ?
de toutes façons ce apt-transport-https ne figure pas dans  cette liste ... Je tente ces telechargement de ces paquets , j'verrais bien si ça sera
ok pour certaines commandes et le root direct..... Qui n'a pas été fait dans les procedures  lors de l'installe de la debian, c'est a dire  :
mot de passe root ===>(2fois) nom de user===> mot de passe user( 2 fois) qui devient accès en root apres l'installe ... C'est tout .....


Plus grande est la face , plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur.Elles peuvent être reproduites et même corrigées sans l'accord préalable du susdit.  8-) Avec kubuntu 14.04 Voyager14.04 et 13.04, Linux mint 17, hybryde fusion et voyager X8 debian

Hors ligne

#4 18-05-2016 08:33:44

jibel
Membre
Lieu : bruxelles
Distrib. : voyager X8 debian
Noyau : Linux 3.16.0-44-generic
Inscription : 09-03-2014

Re : rePB avec la debian 8.2

http://pix.toile-libre.org/?img=1463552733.png

Bon ben voila le PB encore cet agacement de pouvoir installer ce paquet de "apt-transport-https" en suivant ce qui doit être fait .... c'est tout
qu'est-ce qui doit être ajouté dans la sources.list , qu'est-ce qui doit être supprimé aussi dans cette sources.list........ lol mad  gros mystère
que ça soit avec "synaptic" ou "apper" gestionnaires d'installe... rien a faire pour corriger cet ennuis , mince cool

Plus grande est la face , plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur.Elles peuvent être reproduites et même corrigées sans l'accord préalable du susdit.  8-) Avec kubuntu 14.04 Voyager14.04 et 13.04, Linux mint 17, hybryde fusion et voyager X8 debian

Hors ligne

#5 18-05-2016 10:19:22

mimi
Membre
Distrib. : Poutoux 0.2
Noyau : Linux 3.16.0-4-amd64
(G)UI : openbox
Inscription : 13-05-2016
Site Web

Re : rePB avec la debian 8.2

Salut, alors il te faut éditer le fichier sources.list et commenter la ligne en https comme ça:

 # Debian Jessie, dépôt principal + paquets non libres
deb http://httpredir.debian.org/debian/ jessie main contrib non-free
 # Debian Jessie, mises-à-jour de sécurité + paquets non libres
deb http://security.debian.org/ jessie/updates main contrib non-free
 # Debian Jessie, mises-à-jour "volatiles" + paquets non libres
deb http://httpredir.debian.org/debian/ jessie-updates main contrib non-free
 # Debian Jessie, dépôt de rétroportages ("backports")
deb http://httpredir.debian.org/debian jessie-backports main contrib non-free
# XBMC repos
# deb https://people.debian.org/~rbalint/ppa/xbmc-ffmpeg xbmc-ffmpeg-unstable/
deb http://http.debian.net/debian unstable main
deb http://www.deb-multimedia.org2 jessie main non-free
 



Ensuite on installe le paquet apt-transport-https dans une console admin (root):

apt-get update
apt-get install apt-transport-https



voila maintenant tu peut repasser ton sources.list comme avant, le https devrait être pris en charge.:D

@++

Hors ligne

#6 18-05-2016 13:41:20

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : rePB avec la debian 8.2

Salut,

il y a un problème de version avec la dépendance libapt-pkg4.12 ( sur ta capture d'écran ) - c'est le pourquoi, l'installation de apt-transport-https échoue .

aptitude possède un " solveur " de dépendances qui lui permet d'ajuster les versions ( /!\ si le cache des paquet n'a pas été effacé ( avec apt-get clean ou autoclean ),
il peut même rétrograder des paquets ! smile )

essaie :

aptitude install apt-transport-https


Tu peux répondre non, pour qu'il te cherche d'autres solutions, quelque fois, ça suffit à corriger le système .

Dernière modification par nono47 (18-05-2016 13:48:02)

Hors ligne

#7 18-05-2016 13:56:26

raleur
Membre
Inscription : 03-10-2014

Re : rePB avec la debian 8.2

nono47 a écrit :

si le cache des paquet n'a pas été effacé ( avec apt-get clean ou autoclean ), il peut même rétrograder des paquets !


M'étonnerait. Le cache de paquets n'a rien à voir avec les dépendances.
Par contre il se peut que apt-get clean n'efface pas que le cache de paquets.

Dernière modification par raleur (18-05-2016 13:58:50)

Hors ligne

#8 18-05-2016 15:00:17

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : rePB avec la debian 8.2

@ raleur : oui ok, mais je ne connais pas assez les mots techniques pour expliquer !

le manuel n'est pas plus clair :

man apt-get a écrit :

clean
La commande clean nettoie le référentiel local des paquets récupérés. Elle supprime tout, excepté le fichier de verrou situé dans /var/cache/apt/archives/ et /var/cache/apt/archives/partial/.

autoclean (and the auto-clean alias since 1.1)
Tout comme clean, autoclean nettoie le référentiel local des paquets récupérés. La différence est qu'il supprime uniquement les paquets qui ne peuvent plus être téléchargés et qui sont inutiles.
On peut ainsi contrôler la taille de ce cache sur une longue période. Tant qu'elle n'est pas activée, l'option de configuration APT::Clean-Installed empêche la suppression de paquets installés.



Je le précisais, parce qu'il arrive que je vois des utilisateurs faire un clean non justifié alors qu'il vaudrait mieux garder le " référentiel " .

smile

Dernière modification par nono47 (18-05-2016 15:03:54)

Hors ligne

#9 18-05-2016 15:56:52

jibel
Membre
Lieu : bruxelles
Distrib. : voyager X8 debian
Noyau : Linux 3.16.0-44-generic
Inscription : 09-03-2014

Re : rePB avec la debian 8.2

@tous,
Je viens de faire ce qui a été recommandé.... tout a été correct  wink wink wink mad  apt-get install apt-transport-https..... parfait OUF.....
Mais il y a eu une bourde de ma part? Ce que j'ai suivi ont étés faites dans la debian 8.2 deuxieme installe et non dans le premier debian-test KDE ...... lol lol lol il faut que je redémarre cette version installation et tenter de refaire les conseils donnés des apt-get etc en root.... Ce que j'ai eu avec succès dans la seconde installe de debian 8.2....J'y retourne des maintenant, dans la premiere, avec les modifs que j'ai faites dans la debian 8.2 avec les PBs qui sont arrivés .... @+ et merci

Dernière modification par jibel (18-05-2016 16:06:26)


Plus grande est la face , plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur.Elles peuvent être reproduites et même corrigées sans l'accord préalable du susdit.  8-) Avec kubuntu 14.04 Voyager14.04 et 13.04, Linux mint 17, hybryde fusion et voyager X8 debian

Hors ligne

#10 18-05-2016 17:44:23

jibel
Membre
Lieu : bruxelles
Distrib. : voyager X8 debian
Noyau : Linux 3.16.0-44-generic
Inscription : 09-03-2014

Re : rePB avec la debian 8.2

@moi,
Je me reponds ...grosse erreur avec la sources.list  plus bas :
listes des  commandes passées dans le terminal.......

 jib@debian:~$ apt-get update
E: Ligne 16 mal formée dans la liste de sources /etc/apt/sources.list (distribution)
E: La liste des sources ne peut être lue.
jib@debian:~$ apt-get upgrade
E: Impossible d'ouvrir le fichier verrou /var/lib/dpkg/lock - open (13: Permission non accordée)
E: Impossible de verrouiller le répertoire d'administration (/var/lib/dpkg/). Avez-vous les privilèges du superutilisateur ?
jib@debian:~$ sudo su
[sudo] password for jib:
root@debian:/home/jib# apt-get upgrade
Lecture des listes de paquets... Erreur !
E: Ligne 16 mal formée dans la liste de sources /etc/apt/sources.list (distribution)
E: La liste des sources ne peut être lue.
E: Les listes de paquets ou le fichier « status » ne peuvent être analysés ou lus.
root@debian:/home/jib#


Deuxieme point, pour avoir dolphin je suis obligé de  taper cette commande en user, avec le Mot de Passe pour que j'ai dolphin ouvert

 root@debian:/home/jib# exit
exit
jib@debian:~$ gksu dolphin
 


Une fois que dolphin en "root" j'ouvre  la sources.list que j'ai modifié,  la voila :

 deb http://ftp.be.debian.org/debian/ jessie main
deb-src http://ftp.be.debian.org/debian/ jessie main
#deb de http://download.jitsi.org/deb instable  
deb http://www.deb-multimedia.org jessie main non-free



 # Debian Jessie, dépôt principal + paquets non libres

 # Debian Jessie, mises-à-jour de sécurité + paquets non libres
deb http://security.debian.org/ jessie/updates main contrib non-free
 # Debian Jessie, mises-à-jour "volatiles" + paquets non libres
deb http://www.deb-multimedia.org jessie main non-free
 

deb http://www.deb-multimedia.org# Debian Jessie, dépôt principal + paquets non libres
deb http://httpredir.debian.org/debian/ jessie main contrib non-free
 # Debian Jessie, mises-à-jour de sécurité + paquets non libres
deb http://security.debian.org/ jessie/updates main contrib non-free
 # Debian Jessie, mises-à-jour "volatiles" + paquets non libres
deb http://httpredir.debian.org/debian/ jessie-updates main contrib non-free
 # Debian Jessie, dépôt de rétroportages ("backports")
deb http://httpredir.debian.org/debian jessie-backports main contrib non-free
 



Donc, lors d'une apt-get update ou apt-get upgrade rien n'est OK dans cette sources.list (ligne 16) qui provoque la non possibilité de faire ces commandes root.... Qu'est ce qui est anormal dans cette ligne 16 ? ? ? (doublon ou pas ?) C'est moi qui débloque ou pas ? merci pour les modifs a effectuer dans cette sources.list de cet OS Deb. 8.2 KDE test..... comme l'autre OS debian 8.2  KDE aussi...Mais qui fonctionne très bien..... Alors la je coince en m’agaçant moi-même..... Merci pour les infos les meilleures.... est-ce que je peux refaire une installe en virant celle qui me gêne, gardant les partoches ?.....
Mais, il y a un mais, pas des moindres...Lors de l'installe j'ai du ne pas mettre le MdeP root a cause de mon clavier, je n'ai que le MdeP user ce qui me sers lors des commandes , installes des logiciels, outils par exemple ou autres....! MàJ, apt-get update et apt-get upgrade etc etc  .  @+  jibel  smile cool


Plus grande est la face , plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur.Elles peuvent être reproduites et même corrigées sans l'accord préalable du susdit.  8-) Avec kubuntu 14.04 Voyager14.04 et 13.04, Linux mint 17, hybryde fusion et voyager X8 debian

Hors ligne

#11 18-05-2016 19:40:09

mimi
Membre
Distrib. : Poutoux 0.2
Noyau : Linux 3.16.0-4-amd64
(G)UI : openbox
Inscription : 13-05-2016
Site Web

Re : rePB avec la debian 8.2

Remplace la ligne 16 par cette ligne:

deb http://www.deb-multimedia.org jessie main non-free



Sinon je ne comprends pas trop ton soucis de mot de passe root.

@++

Dernière modification par mimi (18-05-2016 19:42:32)

Hors ligne

#12 18-05-2016 20:25:18

jibel
Membre
Lieu : bruxelles
Distrib. : voyager X8 debian
Noyau : Linux 3.16.0-44-generic
Inscription : 09-03-2014

Re : rePB avec la debian 8.2

mimi a écrit :

Remplace la ligne 16 par cette ligne:

deb http://www.deb-multimedia.org jessie main non-free



Sinon je ne comprends pas trop ton soucis de mot de passe root.

@++



Ça n'est pas un vrai soucis, sauf lors de l'installe j'ai fais le 1er MdeP root avec mon MdeP habituel. Ce qui a été découvert lors de la fin de l'installe, rouverture de l'installe neuve. Ce qui a provoqué le PB c'est l'achat du clavier logitech K520 soi-disant spécial pour la Belgique. Quand je tapais le MdeP root il y avait une belle erreur c'était tapé en qwerty pas en azerty dans mon debian a la maison...Pour le second debian 8.2 je suis aller a mon assos a Bruxelles pour faire une autre installe avec un clavier "dell" tout c'est passé très bien, c'est ce qui s'y passe toujours bien dans cette installe.... Donc cette histoire clavier a été remis au top.......+/- sauf pour certaines installes de logiciels etc etc dans cette installe...
J'ai du faire un "sudo dpkg-reconfigure keyboard-configuration" pour ce clavier, mais il y a un big probleme ce clavier K520 ne se trouve pas dans les logitech qui s'affichent, aie , j'ai du changer des trucs pour que je ne sois pas embêté  avec les MdeP root ou user...Installer Ibus pour le choix du FR/BE et tout est en ordre sauf quand je fais une belle erreur... comme celles dont j'ai parlé....Si c'est ça qui continu? ben, je refais une installe de la debian, chez moi,  sans erreur tout en sachant ce que je dois mettre comme lettre de mon mot de passe root et user
La plupart de temps, ici, c'est un PB avec debian et son procédé d'installe.........Enfin lors de mes installes d'OSs différents mais avec le procédé de debian sad
de toute façon je remodifie cette ligne 16 et hop c'est good @+
Ce qui va faire que toute la sources.list sera OK


Plus grande est la face , plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur.Elles peuvent être reproduites et même corrigées sans l'accord préalable du susdit.  8-) Avec kubuntu 14.04 Voyager14.04 et 13.04, Linux mint 17, hybryde fusion et voyager X8 debian

Hors ligne

#13 18-05-2016 23:47:00

jibel
Membre
Lieu : bruxelles
Distrib. : voyager X8 debian
Noyau : Linux 3.16.0-44-generic
Inscription : 09-03-2014

Re : rePB avec la debian 8.2

@moi même,
J'ai fais tout ce qui est conseillés, changer/modifier  la sources.list.... A chaque modif, ça réponds que telle ligne n'est pas bonne, donc a virer ou modifier?
Je crois que je vais encore essayer d'avoir les "basiques " sources.list de debian. lol Et ras le bol... alors que tout fonctionne,  iceweasel, icedove,le son, le network void de renommée mondiale,  les forums quels qu'ils soient...Un paquet entre autre !... C'est normal, parce que j'ai une bonne dizaine d'OSs installés testés dans mes 4 DDs internes et externe...Qui fonctionnent farpaitement tous..... Donc que me reste-t-il ? Rien il faut que je recommence cette installe...Ça c'est bête... Mais je m'en fiche.... C'est du boulot point barre @+ et merci a tous  cool

Plus grande est la face , plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur.Elles peuvent être reproduites et même corrigées sans l'accord préalable du susdit.  8-) Avec kubuntu 14.04 Voyager14.04 et 13.04, Linux mint 17, hybryde fusion et voyager X8 debian

Hors ligne

#14 19-05-2016 09:23:55

jibel
Membre
Lieu : bruxelles
Distrib. : voyager X8 debian
Noyau : Linux 3.16.0-44-generic
Inscription : 09-03-2014

Re : rePB avec la debian 8.2

Pour moi-même,
Ce matin , apres les modifs de la sources.list ? je crois que tout est en ordre dans la debian 8.2. J'ai tapé

"root@debian:/home/jib# sudo apt-get upgrade"


tout a été fait... apparemment en ordre , même pour  une installe de vokoscreen OK .... Je crois que je vais placer mon post en "résolu" dans quelques jours de sécurité par rapport a ce qui a été fini.....
J'aurais du faire ce lancement, seulement avec le DD branché dans lequel sont les trois debians ... De toutes façons , merci pour les aides et avis a faire @+

Dernière modification par jibel (19-05-2016 12:49:29)


Plus grande est la face , plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur.Elles peuvent être reproduites et même corrigées sans l'accord préalable du susdit.  8-) Avec kubuntu 14.04 Voyager14.04 et 13.04, Linux mint 17, hybryde fusion et voyager X8 debian

Hors ligne

Pied de page des forums