Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 31-05-2009 17:18:16

vanpatr
Membre
Lieu : Beauvechain - Belgique
Distrib. : Lenny
Noyau : Laptop Debian 2.6.30-bpo.1-686 #1
(G)UI : Gnome 2.22.3
Inscription : 15-02-2009

[RESOLU par Re-Installa.]"Impossible d'éjecter le volume" intempestif

Bonjour,

Depuis un moment, une boîte de dialogue s'affiche de manière intempestive sur mon écran.

captureimpossibledeject.th.png

Bien évidemment, j'en cherche la raison et ne la trouve pas, sûrement une mauvaise manipulation avec la commande "mount" ou configuration du fichier fstab.
Je joinds ci-dessous le résultat de quelques commandes et du du contenu du fichier après avoir tapé en console la commande suivante $ gedit /etc/fstab"fstab".
Je n'arrive pas à détecter ou se trouve le problème ...

$ uname -a
Linux debian 2.6.26-2-486 #1 Mon May 11 18:33:01 UTC 2009 i686 GNU/Linux


$ mount
/dev/hda6 on / type ext3 (rw,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
procbususb on /proc/bus/usb type usbfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
/dev/hda8 on /home type ext3 (rw)
/dev/sda1 on /media/Elements_ type vfat (rw,nosuid,nodev,uhelper=hal,shortname=lower,uid=1000)


$  dmesg | tail
[16788.388113] hdd: drive not ready for command
[16788.388141] hdd: status error: status=0x58 { DriveReady SeekComplete DataRequest }
[16788.388145] ide: failed opcode was: unknown
[16788.388147] hdd: drive not ready for command
[16788.388173] hdd: status error: status=0x58 { DriveReady SeekComplete DataRequest }
[16788.388176] ide: failed opcode was: unknown
[16788.388178] hdd: drive not ready for command
[16788.388227] hdd: status error: status=0x58 { DriveReady SeekComplete DataRequest }
[16788.388230] ide: failed opcode was: unknown
[16788.388234] hdd: drive not ready for command


# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda6       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda8       /home           ext3    defaults        0       2
/dev/hda2       none            swap    sw              0       0
/dev/hda7       none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/hdd        /media/cdrom1   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
/dev/sdb1       /media/usb0     auto    rw,user,noauto  0       0


...je suis donc fort ennuyé!
Est-ce qu'un "linuxien" de ce forum aurait une idée pour m'orienter, et trouver la solution à ce problème?
D'avance, je remercie déjà ce membre qui deviendra providentiel ainsi que la communanté.
J'espère que la résolution de ce problème permettra à d'autre d'améliorer leur compétance sur linux et debian en particulier.
@+

Dernière modification par vanpatr (15-11-2009 12:14:21)


C'est par ici qu'on va par là!

Hors ligne

#2 31-05-2009 19:49:04

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [RESOLU par Re-Installa.]"Impossible d'éjecter le volume" intempestif

Bonjour,

ll faudrait isoler le problème. Je te conseille de débrancher les deux périphériques amovibles, hdd et hdc, puis d'utiliser ta machine, puis de rebrancher l'un, le débrancher à nouveau et rebrancher l'autre, pour voir si ça viendrait d'une mauvaise communication entre le système et l'un d'entre eux.

(commentes-les dans le fstab, aussi, en rapport avec tes manips)

le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#3 01-06-2009 12:28:07

vanpatr
Membre
Lieu : Beauvechain - Belgique
Distrib. : Lenny
Noyau : Laptop Debian 2.6.30-bpo.1-686 #1
(G)UI : Gnome 2.22.3
Inscription : 15-02-2009

Re : [RESOLU par Re-Installa.]"Impossible d'éjecter le volume" intempestif

Bonjour Melodie,
Merci pour ton intervention.
Je pense que les lignes ci-dessous ...
/dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/hdd        /media/cdrom1   udf,iso9660 user,noauto     0       0
...n'y sont pour rien dans mon problème, en effet ces deux périphériques sont pas nouveaux sur mon PC, je ne comprends pas pourquoi ils seraient la cause de mes soucis!
Je comprends ton idée de procéder par élimination, veux -tu me donner ton avis?
Par contre, les informations suivantes pourraient aider à trouver le problème, qu'en pense-tu?

$ ls -la /media
total 28
drwxr-xr-x  7 root root 4096 jun  1 00:24 .
drwxr-xr-x 22 root root 4096 mai  2 07:35 ..
lrwxrwxrwx  1 root root    6 déc 24 16:44 cdrom -> cdrom0
drwxr-xr-x  2 root root 4096 déc 24 16:44 cdrom0
drwxr-xr-x  2 root root 4096 déc 24 16:44 cdrom1
drwxr-xr-x  2 root root 4096 mar  7 07:33 Elements
lrwxrwxrwx  1 root root    7 déc 24 16:44 floppy -> floppy0
drwxr-xr-x  2 root root 4096 déc 24 16:44 floppy0
-rw-r--r--  1 root root    0 jun  1 00:23 .hal-mtab
-rw-------  1 root root    0 jun  1 00:24 .hal-mtab-lock
lrwxrwxrwx  1 root root    4 déc 24 16:44 usb -> usb0
drwxr-xr-x  2 root root 4096 déc 24 16:44 usb0


Plusieurs lignes sont dans la liste et je ne les comprends pas, soit les lignes 3, 7, ainsi que les 4 dernières!

lrwxrwxrwx  1 root root    6 déc 24 16:44 cdrom -> cdrom0
lrwxrwxrwx  1 root root    7 déc 24 16:44 floppy -> floppy0-rw-r--r--  1 root root    0 jun  1 00:23 .hal-mtab
-rw-------  1 root root    0 jun  1 00:24 .hal-mtab-lock
lrwxrwxrwx  1 root root    4 déc 24 16:44 usb -> usb0
drwxr-xr-x  2 root root 4096 déc 24 16:44 usb0


Que peux-tu m'en dire?
Merci pour ton aide.
@+

Dernière modification par vanpatr (01-06-2009 12:29:02)


C'est par ici qu'on va par là!

Hors ligne

#4 01-06-2009 18:11:18

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [RESOLU par Re-Installa.]"Impossible d'éjecter le volume" intempestif

Non, je parlais de problème lié au matériel. Si tu débranches les deux périphériques, plus de message, tu es d'accord ? Rebranches en un et regarde si le message revient, etc...

Pour que ça (le fait de débrancher les deux lecteurs ou lecteurs graveurs) ne cause pas de perturbation dans le système, commentes les lignes relatives à ces devices dans fstab ! (avec un # devant la ligne pour désactiver leur détection par le fstab)

le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

Pied de page des forums