Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-06-2016 10:58:15

Xunil
Membre
Distrib. : Debian GNU/Linux 7.6 - Wheezy
Noyau : 3.10.23
Inscription : 19-03-2016

[Résolu] Je suis root mais je ne peux pas lancer une commande

Bonjour,

J'ai voulu lancer une commande qui permet de voir si le fichier de configuration d'Apache est correct. J'ai eu cette réponse :

/etc/apache2/apache2.conf -S

-bash: /etc/apache2/apache2.conf: Permission non accordée


Ce qui m'a assez surpris.
Je trouve cette commande plutôt pratique, savez vous ce que je peux faire pour pouvoir l'excuter ?

Merci

Dernière modification par Xunil (09-06-2016 11:47:03)

Hors ligne

#2 09-06-2016 11:03:11

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu] Je suis root mais je ne peux pas lancer une commande

Salut smile

Tu la tires d'où cette commande ? Parce que la syntaxe ne me semble absolument pas logique, le fichier /etc/apache2/apache2.conf étant un simple fichier texte, et en aucun cas un fichier exécutable hmm

ls -l /etc/apache2/apache2.conf

-rw-r--r-- 1 root root 7115 oct.  24  2015 /etc/apache2/apache2.conf


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#3 09-06-2016 11:28:26

Kusajika
Membre
Inscription : 08-04-2015

Re : [Résolu] Je suis root mais je ne peux pas lancer une commande

Bonjour , la seule que je connaisse par rapport à apache c'est:

apachectl configtest


Syntax OK

En ligne

#4 09-06-2016 11:39:46

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu] Je suis root mais je ne peux pas lancer une commande

En fait, l'erreur doit venir du fait que tu essayes d’exécuter un fichier sans les droites d'exucution.

Exemple :


cd /tmp
echo "echo Execution du fichier testexec.conf" > testexec.conf
./testexec.conf


bash: ./testexec.conf: Permission non accordée


chmod a+x testexec.conf
./testexec.conf


Execution du fichier testexec.conf


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#5 09-06-2016 11:46:47

Xunil
Membre
Distrib. : Debian GNU/Linux 7.6 - Wheezy
Noyau : 3.10.23
Inscription : 19-03-2016

Re : [Résolu] Je suis root mais je ne peux pas lancer une commande

@Kusajika : Ah merci, ça fonctionne smile

@bendia : Merci pour tes précisions.
J'aivais trouvé ça ici : http://www.champagne.fr/manual/fr/vhosts/index.html et j'essayais tant bien que mal de l'adapter... et comme j'avais enfin une réponse (Permission non accordée) j'ai cru être sur la bonne voie...
Merci smile

Hors ligne

#6 09-06-2016 11:53:57

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu] Je suis root mais je ne peux pas lancer une commande

Xunil a écrit :

J'aivais trouvé ça ici : http://www.champagne.fr/manual/fr/vhosts/index.html et j'essayais tant bien que mal de l'adapter... et comme j'avais enfin une réponse (Permission non accordée) j'ai cru être sur la bonne voie...

C'était nettement plus simple que ce que tu cherchais

apache2 -S



Je t'invite à jetter un œil au wiki sur le PATH pour comprendre l'histoire smile


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#7 09-06-2016 14:47:26

Xunil
Membre
Distrib. : Debian GNU/Linux 7.6 - Wheezy
Noyau : 3.10.23
Inscription : 19-03-2016

Re : [Résolu] Je suis root mais je ne peux pas lancer une commande

A oui en effet :s

Par contre j'ai cette erreur :

apache2 -S

apache2: bad user name ${APACHE_RUN_USER}


mais si je fais

apache2ctl -S

ou

apachectl -S

J'ai bien le listing de mes vhost et un "Syntax ok" à la fin

VirtualHost configuration:
wildcard NameVirtualHosts and _default_ servers:
*:80                   is a NameVirtualHost
         default server ... (/etc/apache2/sites-enabled/000-default:1)
         port 80 namevhost ... (/etc/apache2/sites-enabled/000-default:1)
         port 80 namevhost www. ... .fr (/etc/apache2/sites-enabled/ ... .fr:1)
         port 80 namevhost www. ... .fr (/etc/apache2/sites-enabled/ ... .fr:1)
         port 80 namevhost www. ... .com (/etc/apache2/sites-enabled/ ... .com:1)
 ...
Syntax OK




ps : Merci pour le lien vers la page wiki

Dernière modification par Xunil (09-06-2016 14:48:05)

Hors ligne

#8 09-06-2016 15:27:55

Xunil
Membre
Distrib. : Debian GNU/Linux 7.6 - Wheezy
Noyau : 3.10.23
Inscription : 19-03-2016

Re : [Résolu] Je suis root mais je ne peux pas lancer une commande

Je viens de trouver que :

apachectl -t

Syntax OK

Permet juste de dire si la syntaxe est bonne ou pas

Hors ligne

Pied de page des forums