Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-06-2009 13:01:21

NuDub
Membre
Lieu : OISE
Distrib. : Debian Testing
Noyau : 3.16 amd64
(G)UI : LXDE-GNOME-KDE
Inscription : 31-05-2009

Install amsn, veut supprimer flash plugin, où est le rapport?

Bonjours à tous,

Je vous remercie pour les conseils et les informations que vous pourrez m'apportez.

Voici mon doutes/problème:

Aujourd'hui j'ai décidé d'installer amsn, donc j'ai avant tous fais deux commandes, je signal que je suis sous Debian Lenny (stable), avec uniquement Fluxbox, et que pour les paquet je fais mes manip en console avec aptitude et idem pour la gestion/recherche de paquet.

Lors de l'install de debian j'utilisai directement le "aptitude install nom_du_paquet", mais après j'ai découvert le gestionnaire en mode console.

#aptitude update
#aptitude safe-upgrade


Ensuite je lance mon gestionnaire en mode console et cherche amsn

#aptitude


Donc je sélectionne amsn et il prend également amsn-data.

Ensuite il me donne un aperçu de se qui va se passer et ainsi je peux décocher des chose ou pas, jusque-là sa va.

Mais dans cette aperçus dans la section "à enlever", il me mets Flash-plugin(le non-free).

Donc là est mon incompréhension.

Pourquoi enlever le flash plugin et aussi des ttf(fonts).
Donc moi j'ai marquer ces paquet en "à garder"

Mais au final n'étant pas sur j'ai pas osé installer amsn car pour cette raison et deuxièmement, car le amsn-data qui vas avec est noter en conflit.

Puis j'avais donc quitter puis là je veux rouvrir et du coup il a enregistré mon action de "à garder en faisant (":").

Donc comme je suis débutant ces choses ne sont pas clair du tous, et surtout du coup j'ai pas installez amsn en plus.

Quelqu'un serais m'expliqué le pourquoi de c'est suppression qui pour moi ne semble pas justifié et qui me font me dire, mais si j'avais fais directement:

#aptitude install amsn


Sa aurais donc supprimé ce plugin flash, puis même avec d'autre install, sa me semble donc "bordélique" et "aléatoire" comme comportement.

Et de plus je trouve pas d'infos sur le pourquoi?, et du coup je pensai avoir mieux compris mais là d'un coup sa me met dans le flou quand au fonctionnement d'une install, car comme je le disais je vois pas de rapport, et comment savoir si c'est une suppression car après il y auras une mise à jours.

Car dans aptitude il y a deux colonne après le nom du paquet et les numéro de version(je crois que ça correspond à ça) sont les même.
D'ailleurs a quoi corresponde c'est deux colonne dont souvent la première est écrit "<aucun>"
car je n'ai pas trouvé de réponse a ça aussi.

Et sinon je me demandai si on pouvais au cas ou annuler le fais d'avoir mis ces paquet a garder?

Voilà, en fait je souhaiterai mieux comprendre ces petites choses et savoir si je peux installer ce amsn.

PS: maintenant je crois comprendre pourquoi lors d'une install de je sais plus quoi, je me suis retrouver avec Konqueror d'installer alors que je le voulais pas.

Merci beaucoup pour l'aide que vous pourrez m'apporter.

Donc pour le moment j'ai pas installez amsn, et les ttf(fonts) et flashplugin que j'ai mis avec ":" en "à garder" sont plus dans les éléments à supprimer, mais comme je suis débutant j'aimerais pouvoir comprendre ce comportement si bien sur il y une explication.


VM Debian Testing sur Win7

Hors ligne

#2 06-06-2009 14:09:32

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Install amsn, veut supprimer flash plugin, où est le rapport?

Bjr,
Je viens de faire l'install de amsn et flashplugin-nonfree avec aptitude (sous sid) Apparemment ils cohabitent sans problème.
N'aurais-tu pas anciennement installé flashplugin-nonfree avec apt-get ou synaptic ? Si c'est la cas tu pourras toujours le réinstaller avec aptitude

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#3 06-06-2009 14:31:16

NuDub
Membre
Lieu : OISE
Distrib. : Debian Testing
Noyau : 3.16 amd64
(G)UI : LXDE-GNOME-KDE
Inscription : 31-05-2009

Re : Install amsn, veut supprimer flash plugin, où est le rapport?

Merci phlinux.

Pour l'install de flashplugin-nonfree, je l'avais fais a partir du gestionnaire aptitude donc se n'est pas apt-get.

Je n'ai pas synaptic car j'ais fais une install de base avec seulement Xorg et fluxbox.

Mais là aptitude a enregistré le fais que je voulais pas qu'il supprime flash donc là j'ai retenté et les quelque truc qui était marqué désinstallé n'y étais plus donc j'en ai profité pour installé amsn.

Donc c'est installez et Flash semble encore marché.

Mais c'est le comportement qui me trouble en fait pourquoi j'avais se résultat la première fois.

Donc j'ai regardé le manuel mais pas évident en console de ce balader là où on veut donc il vaudra que j'y replonge.

Dois-je ouvrir des port pour amsn, car il semble marché(je suis connecté) mais dans les préférences il me marque en rouge que je suis derrière un routeur/parefeu.

N'aurais-tu pas anciennement installé flashplugin-nonfree avec apt-get ou synaptic ? Si c'est la cas tu pourras toujours le réinstaller avec aptitude


A dire vrai mon install est récente et j'ai installé a peine 5 truc depuis l'install il seul les quelque premier ou je faisais apt-get, le reste est maintenant uniquement avec aptitude, soit en ligne de commande soit en passant par le gestionnaire.

Mais peut-être que suivant ton raisonnement, il y ai des dépendances installez avec apt-get qui on du faire vouloir cette suppression.

PS: vivement que la version graphique du gestionnaire aptitude soit prète car la navigation est moins aisé en console. Mais de ce que j'ai vu pour le moment c'est encore en Dev.

Merci beaucoup Phlinux pour ton aide


VM Debian Testing sur Win7

Hors ligne

Pied de page des forums