Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 15-06-2009 17:13:59

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

[résolu] Installation des mises à jour

Bonjour,

    je rencontre deux fois le même problème avec deux logiciels différents.  Oui, les deux sont produits par Sun, mais je ne suis pas sûr que ce soit la source du problème.


   Voici,
          - j'ai téléchargé les fichiers de mise à jour pour OpenOffice et pour VirtualBox
          - j'ai tenté de faire dpkg -i nom_du_fichier_passablement_long.deb dans un terminal en tant qu'admin.

          Je reçois le message d'erreur suivant:

dpkg : concernant virtualbox-2.2_2.2.4-47978_Debian_lenny_i386.deb contenant virtualbox-2.2 :
virtualbox-2.2 entre en conflit avec virtualbox
  « virtualbox-2.1 » fournit « virtualbox » et est présent ainsi de  « installé ».
dpkg : erreur de traitement de virtualbox-2.2_2.2.4-47978_Debian_lenny_i386.deb (--install) :
paquets en conflit - virtualbox-2.2 non installé
Des erreurs ont été rencontrées pendant l'exécution :
virtualbox-2.2_2.2.4-47978_Debian_lenny_i386.deb




    J'ai consulté dpkg --help et quelques sites d'aide pour dpkg, mais je ne trouve nulle part la commande pour faire une MAJ.    Comment faire?

Dernière modification par Patriboom (22-09-2009 18:58:08)


Portez la paix
Patrick Allaire, ptre

Hors ligne

#2 15-06-2009 20:49:02

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : [résolu] Installation des mises à jour

Bjr,
Pour les maj il est préférable de passer par les dépots, surtout pour mettre du Lenny sur du Lenny : ça évite (en général) les conflits de versions

apt-get update && apt-get upgrade


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#3 15-06-2009 23:40:29

Mighty
Membre
Distrib. : Sid
Noyau : 2.6.38 686 Bigmem
(G)UI : Gnome
Inscription : 08-07-2008
Site Web

Re : [résolu] Installation des mises à jour

Salut,

Tu as la version 2.1 de virtualbox d'installée, en passant par les dépots pour installer virtualbox 2.2, la 2.1 sera désinstallée est lors du premier lancement tes machines virtuelles seront convertis vers la nouvelle version. Tu éviteras aussi les problèmes de dépendances.

Pour openoffice, si la version actuellement disponible dans lenny ne te convient pas, le mieux est d'utiliser les dépots testing ou sid. Avec un bon fichier de préférences ça passe tout seul smile

Mighty

Dernière modification par Mighty (15-06-2009 23:41:00)


"Pour faire court, dites tout simplement non à la drogue et peut-être que vous ne finirez pas comme les gars de chez Hurd."

Linus Torvalds

Hors ligne

#4 16-06-2009 02:39:42

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [résolu] Installation des mises à jour

Salut

Comme les autres l'ont dit avant, il est préférable d'installer des applications ou des paquets qui se trouvent dans les dépôts. Aller chercher des fichiers sur des sites doit être la solution de dernier recours.

Afin de pouvoir installer le maximum de choses, je te suggère, si ce n'est déjà fait, de consulter le wiki afin de modifier ton fichier /etc/apt/sources.list. Tu n'as qu'à regarder la section pour la branche stable (ou lenny).

Pour lenny tu trouveras dans le wiki des informations sur le dépôt lenny-backports. Celui-ci te permet d'installer des versions plus récentes d'application comme OpenOffice, par exemple. Dans lenny, tu as la version 2.4 de OpenOffice, dans lenny-backports tu as la version 3.0.

Martin

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#5 16-06-2009 02:40:33

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [résolu] Installation des mises à jour

Bref ... , si je comprends bien, c'est plus simple d'attendre que les paquets soient rendus disponibles pour ma distribution et de les laisser s'installer par la mise à jour automatique de Debian.

Merci.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#6 16-06-2009 04:41:14

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : [résolu] Installation des mises à jour

exactement il est plus simple d attendre les versions dans les depots, sinon il faut penser a passer en instable.

Si tu veux quand meme installer le logiciel, desinstalle la version inferieur avant.

Salutation

\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

#7 16-06-2009 14:53:30

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [résolu] Installation des mises à jour

Est-ce que je peux désinstaller VirtualBox sans désinstaller les machines que VirtualBox fait tourner?

Portez la paix
Patrick Allaire, ptre

Hors ligne

#8 16-06-2009 18:58:11

Mighty
Membre
Distrib. : Sid
Noyau : 2.6.38 686 Bigmem
(G)UI : Gnome
Inscription : 08-07-2008
Site Web

Re : [résolu] Installation des mises à jour

Normalement il va te demander si tu veux les enlever, mais fais une sauvegarde avant. On sait jamais wink

"Pour faire court, dites tout simplement non à la drogue et peut-être que vous ne finirez pas comme les gars de chez Hurd."

Linus Torvalds

Hors ligne

Pied de page des forums