Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 16-06-2009 13:24:38

chris46
Membre
Inscription : 16-06-2009

pas de son flash sous iceweasel debian lenny 5

Bonjour voila je possede un amd 64 athlon 32 bits,sous debian lenny 5 .
J ai deja poste sur debian forum sans succes ,lorsque je vais sur internet les flash fonctionnes mais pas de son,a noter que le son en interne fonctionne normalement.

quand je rentre:

# gedit /etc/apt/sources.list

j obtiens:

deb http://security.debian.org/ lenny/updates main contrib non-free
deb http://ftp.fr.debian.org/debian/ lenny main contrib non-free
deb http://www.debian-multimedia.org lenny main
deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free

deb http://ftp.fr.debian.org/debian/ lenny-proposed-updates contrib non-free main

et pour:  apt-get update && apt-get upgrade

j obtiens:

apt-get update && apt-get upgrade
Atteint http://www.debian-multimedia.org lenny Release.gpg
Atteint http://www.debian-multimedia.org lenny/main Translation-fr
Atteint http://ftp.fr.debian.org lenny Release.gpg
Atteint http://security.debian.org lenny/updates Release.gpg
Ign http://security.debian.org lenny/updates/main Translation-fr
Atteint http://www.debian-multimedia.org lenny Release
Atteint http://volatile.debian.org lenny/volatile Release.gpg
Ign http://volatile.debian.org lenny/volatile/main Translation-fr
Atteint http://ftp.fr.debian.org lenny/main Translation-fr
Ign http://security.debian.org lenny/updates/contrib Translation-fr
Ign http://security.debian.org lenny/updates/non-free Translation-fr
Atteint http://security.debian.org lenny/updates Release
Ign http://volatile.debian.org lenny/volatile/contrib Translation-fr
Ign http://volatile.debian.org lenny/volatile/non-free Translation-fr
Atteint http://www.debian-multimedia.org lenny/main Packages/DiffIndex
Ign http://ftp.fr.debian.org lenny/contrib Translation-fr
Atteint http://volatile.debian.org lenny/volatile Release
Ign http://security.debian.org lenny/updates/main Packages/DiffIndex
Ign http://security.debian.org lenny/updates/contrib Packages/DiffIndex
Ign http://security.debian.org lenny/updates/non-free Packages/DiffIndex
Ign http://ftp.fr.debian.org lenny/non-free Translation-fr
Ign http://volatile.debian.org lenny/volatile/main Packages/DiffIndex
Atteint http://security.debian.org lenny/updates/main Packages
Atteint http://ftp.fr.debian.org lenny Release
Ign http://volatile.debian.org lenny/volatile/contrib Packages/DiffIndex
Ign http://volatile.debian.org lenny/volatile/non-free Packages/DiffIndex
Atteint http://security.debian.org lenny/updates/contrib Packages
Atteint http://volatile.debian.org lenny/volatile/main Packages
Atteint http://volatile.debian.org lenny/volatile/contrib Packages
Atteint http://security.debian.org lenny/updates/non-free Packages
Ign http://ftp.fr.debian.org lenny/main Packages/DiffIndex
Atteint http://volatile.debian.org lenny/volatile/non-free Packages
Ign http://ftp.fr.debian.org lenny/contrib Packages/DiffIndex
Ign http://ftp.fr.debian.org lenny/non-free Packages/DiffIndex
Atteint http://ftp.fr.debian.org lenny/main Packages
Atteint http://ftp.fr.debian.org lenny/contrib Packages
Atteint http://ftp.fr.debian.org lenny/non-free Packages
Lecture des listes de paquets... Fait
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

puis:  apt-cache policy flashplugin-nonfree flashplayer-mozilla

resultat:  flashplugin-nonfree:
  Installé : (aucun)
  Candidat : (aucun)
Table de version :
flashplayer-mozilla:
  Installé : 1:10.0.22.87-0.1
  Candidat : 1:10.0.22.87-0.1
Table de version :
*** 1:10.0.22.87-0.1 0
        500 http://www.debian-multimedia.org lenny/main Packages
        100 /var/lib/dpkg/status


enfin je rentre:  update-alternatives --display flash-mozilla.so


pour obtenir:  flash-mozilla.so - l'état est manual.
le lien pointe actuellement sur /usr/lib/flashplayer-mozilla/libflashplayer.so
/usr/lib/flashplayer-mozilla/libflashplayer.so - priorité 10
La « meilleure » version actuelle est /usr/lib/flashplayer-mozilla/libflashplayer.so.


Bref il y eu un moment ou j avait du son ,mais les flash ne se liseaient plus et afficher un gros lecture gris dans chaque fenetre ou video flash .
Et maintenant c le contraire je n arrive jamais a avoir les 2 etant ultra novice sur debian je vous demande de l aide merci d avance smile

Hors ligne

#2 17-06-2009 03:06:05

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : pas de son flash sous iceweasel debian lenny 5

Salut

J'avais lu ton fil de discussion sur debian-fr.org. Je ne saurais en dire plus que les conseils que talogue t'avais donné. Ton problème provient peut-être du paquet .deb que tu as pris sur le site de Abode.

Je vois que tu as encore le dépôt lenny-proposed-updates dans ton sources.list. Il n'a pas sa place là, donc à retirer.

Ensuite tu peux commencer par enlever tout ce que tu as installé comme paquet pour lire le flash. Tu fais une recherche sur ton ordi pour voir s'il y a des traces de flash encore présente en tapant comme simple utilisateur

$ locate libflashplayer.so


Il ne doit pas en rester. Si c'est le cas, je les supprimerais. Enfin tu peux installer flashplayer-mozilla qui fonctionne normalement très bien.

J'ai une configuration assez semblable à la tienne mais j'utilise sid et tout va bien. Tu aurais du par contre installer une version 64 bits pour profiter pleinement de ton ordi. Le choix de la 32 bit n'est pas le meilleur.

Martin


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#3 17-06-2009 13:14:41

chris46
Membre
Inscription : 16-06-2009

Re : pas de son flash sous iceweasel debian lenny 5

salut martin,merci de me repondre,j ai supprime la ligne dans les sources et quand j entre

$ locate libflashplayer.so


j obtiens :


/usr/lib/adobe-flashplugin/libflashplayer.so


tout est normal?

J ai aussi essayer d enlever les paquets sypnatic flashplugin extrasound et mozilla player , pour reinstaller adbe 10 en terminal su , idem toujours pas de son.
Ce qui m etonne ce que quand j utilisait libswcf j avait du son mais pas de lecture flash normal .. hmm

Hors ligne

#4 18-06-2009 02:33:47

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : pas de son flash sous iceweasel debian lenny 5

Salut

Chez moi un locate libflashplayer.so donne ceci : /usr/lib/flashplayer-mozilla/libflashplayer.so.

Maintenant c'est important de procéder par ordre. Si tu as enlevé tout ce qui concerne le flash, comme je te l'ai suggére, et qui tu as le résultat que tu indiques, /usr/lib/adobe-flashplugin/libflashplayer.so, c'est qu'il te reste des traces du Flash installé par le paquet pris sur le site de Adobe.

Si c'est bien le cas, j'enlèverais le fichier libflashplayer.so dans /usr/lib/adobe-flashplugin (tu peux en faire une copie ailleurs de ce fichier au cas où tu voudrais le remettre). De cette façon, tu repars à zéro sans aucun plugin Flash. Après, j'installerais le paquet flashplayer-mozilla qui fourni le plugin flash proprio d'adobe, mais pas nécessairement la dernière version.

Dans tes messages, donne le plus de détail possible sur ce que tu as fais. C'est plus facile pour te venir en aide. Merci.

Martin

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#5 18-06-2009 13:50:12

chris46
Membre
Inscription : 16-06-2009

Re : pas de son flash sous iceweasel debian lenny 5

salut je ne trouver pas le fichier, en passant par lib.j ai etait dans le gestionnaire sypnatic et j ai enlever le paquet adobe plugin flash pour le remplacer par mozilla player resultat :


locate libflashplayer.so


et en reponse je n ai plus rien...

toujour au meme point image mais pas de son sad

Hors ligne

#6 19-06-2009 02:40:49

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : pas de son flash sous iceweasel debian lenny 5

Salut

Dans ton message précédent (le #3), un

locate libflashplayer.so


donnait

/usr/lib/adobe-flashplugin/libflashplayer.so


Maintenant, tu dis que si tu vas dans le répertoire /usr/lib/adobe-flashplugin/, tu n'as pas de fichier libflashplayer.so. C'est pour le moins étrange. Il a disparu comme ça !

Si je fais un

aptitude install flashplayer-mozilla


(tu pourrais aussi installer le paquet avec synaptic)
et que je fais par la suite un

locate libflashplayer.so


J'obtiens ceci :

/usr/lib/flashplayer-mozilla/libflashplayer.so


Si tu n'as rien de ton côté c'est que l'installation s'est peut-être mal faite.

Que donne un

# update-alternatives --config flash-mozilla.so


(le # signifie d'être en root).


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#7 19-06-2009 13:44:08

chris46
Membre
Inscription : 16-06-2009

Re : pas de son flash sous iceweasel debian lenny 5

salut j ai fait

aptitude install flashplayer-mozilla


rep


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu      
Initialisation de l'état des paquets... Fait
Écriture de l'information d'état étendu... Fait
Lecture des descriptions de tâches... Fait      
Les NOUVEAUX paquets suivants vont être installés :
  flashplayer-mozilla
Les paquets suivants seront ENLEVÉS :
  adobe-flashplugin{a} gstreamer0.10-fluendo-mp3{u}
0 paquets mis à jour, 1 nouvellement installés, 2 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0o/3963ko d'archives. Après dépaquetage, 319ko seront libérés.
Voulez-vous continuer ? [Y/n/?] y
Écriture de l'information d'état étendu... Fait
(Lecture de la base de données... 185923 fichiers et répertoires déjà installés.)
Suppression de adobe-flashplugin ...
Suppression de gstreamer0.10-fluendo-mp3 ...
Sélection du paquet flashplayer-mozilla précédemment désélectionné.
(Lecture de la base de données... 185911 fichiers et répertoires déjà installés.)
Dépaquetage de flashplayer-mozilla (à partir de .../flashplayer-mozilla_1%3a10.0.22.87-0.1_i386.deb) ...
Paramétrage de flashplayer-mozilla (1:10.0.22.87-0.1) ...
Lecture des listes de paquets... Fait            
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu      
Initialisation de l'état des paquets... Fait
Écriture de l'information d'état étendu... Fait
Lecture des descriptions de tâches... Fait      

État actuel : 978 nouveaux paquets [-1].
krizia:/home/krizia#


ensuite:

locate libflashplayer.so


rep :krizia:/home/krizia# locate libflashplayer.so
krizia:/home/krizia#


rien du tout je ne comprend pas


pour finir :

update-alternatives --config flash-mozilla.so


en root


rep: Il n'y a qu'un programme fournissant flash-mozilla.so (/usr/lib/flashplayer-mozilla/libflashplayer.so).
Rien à configurer.
krizia:/home/krizia#


resultat idem pas de son sad

Hors ligne

#8 20-06-2009 04:28:15

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : pas de son flash sous iceweasel debian lenny 5

Un

$locate libflashplayer.so


ne donne rien, mais par contre un update-alternatives montre que tu as /usr/lib/flashplayer-mozilla/libflashplayer.so. Ce qui est correct. Je ne comprend pas pourquoi le locate ne donne rien, cela n'est pas normal.

Maintenant si tu ouvres Iceweasel et que tu tapes about:plugins dans la barre d'adresse, tu as quoi pour Shockwave Flash ?


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#9 20-06-2009 14:53:19

chris46
Membre
Inscription : 16-06-2009

Re : pas de son flash sous iceweasel debian lenny 5

salut 
 
ben la c a ne plus rien y comprendre quand je tape about plugins j atterit sur la page de recherche google et non plus dans la page des plugins comme ct le cas avant.


sad:(

Hors ligne

#10 20-06-2009 19:50:40

lagaffe
Membre
Distrib. : fixe:Lenny/portable:Lenny
Noyau : 2.6.26
(G)UI : Gnome 2.22
Inscription : 04-01-2009

Re : pas de son flash sous iceweasel debian lenny 5

Salut  !

Pour obtenir la liste des plugins installés, tu dois taper "about:plugins" dans la barre d' adresses de Firefox. N'oublies pas les deux points entre about et plugins, sinon tu te retrouves effectivement sur une page Google. Bon courage. smile

Hors ligne

#11 20-06-2009 23:26:31

chris46
Membre
Inscription : 16-06-2009

Re : pas de son flash sous iceweasel debian lenny 5

salut lagaffe j ai fait une erreur sur mon precedent message,meme avec les deux points ca ne fonctionne pas

Dernière modification par chris46 (20-06-2009 23:26:57)

Hors ligne

#12 26-06-2009 12:48:47

Excess
Membre
Distrib. : Testing
Noyau : Kernel 2.6.26-2-686
(G)UI : Gnome
Inscription : 25-06-2009
Site Web

Re : pas de son flash sous iceweasel debian lenny 5

salut à toi

alors d'abord supprime tout ce qui est rapport avec le flash comme l'a si bien dit martin_mtl smile

ensuite go sur le site de adobe http://get.adobe.com/fr/flashplayer/ et choisi l'archive en tar.gz et télécharge la sur ton bureau

ensuite go console et décompresse comme ceci (toute ces commande se font en user normal) :

cd "lieu ou tu as téléchatger larchive"
tar -xvvzf install_flash_player_10_linux.tar.gz
cd install_flash_player_10_linux/
./flashplayer-installer


et voila big_smile

Dernière modification par Excess (30-06-2009 19:57:31)


Le fin de mon éducation est le début de mon ignorance

Hors ligne

#13 30-06-2009 15:31:12

STEF
Membre
Inscription : 30-06-2009

Re : pas de son flash sous iceweasel debian lenny 5

Bonjour.

J'ai le même problème que Chris, sous Iceweasel Debian Lenny 64b.

ensuite go console et décompresse comme ceci (toute ces commande se font en user normal) :

Code:

cd /Desktop
tar -xvvzf install_flash_player_10_linux.tar.gz
cd install_flash_player_10_linux
./install_flash_player_10_linux

et voila big_smile


... en fait dans le répetoire décompressé qui porte donc le nom : install_flash_player_10_linux
=> il n'y a pas de fichier : install_flash_player_10_linux
MAIS : flashplayer-installer

Lorsqu'on execute la commande

./flashplayer-installer


... Debian Lenny 64b sort cette erreur :

ERROR: Your architecture, \'x86_64\', is not supported by the
       Adobe Flash Player installer.


==>> Flash 10  en 64b existe depuis le 24 février 2009, en prerelease à l'adresse : http://labs.adobe.com/downloads/flashplayer10.html

Pour installer Flash 10 64b sur Iceweasel en Lenny 64b : http://www.cpasdemoi.fr/installer-flash … y-64-bits/

++

SteF

Dernière modification par STEF (30-06-2009 15:54:40)

Hors ligne

#14 30-06-2009 19:55:50

Excess
Membre
Distrib. : Testing
Noyau : Kernel 2.6.26-2-686
(G)UI : Gnome
Inscription : 25-06-2009
Site Web

Re : pas de son flash sous iceweasel debian lenny 5

autant pour moi big_smile j'édit le message wink

Le fin de mon éducation est le début de mon ignorance

Hors ligne

Pied de page des forums