Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-07-2016 17:36:59

falou01
Membre
Lieu : Entre Rhône et Saône
Distrib. : HandyLinux-2.5.1
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 19-07-2016

[Clos] Ecran noir après install driver nvidia 304 Cahiers du déb p.121

Bonjour smile,

Alors voilà comment j'en suis arrivé là. A la lecture des Cahiers du débutant (quelle mine d'infos !), j'ai suivi les explications de la rubrique 8.2.4.4 - Configuration d’une carte nVidia

J'ai donc lancé la détection de la carte par

apt update && apt install nvidia-detect



puis

nvidia-detect



Le retour était

Your card is supported by the default drivers and legacy driver series
304.
It is recommended to install the
nvidia-driver
package.



Donc, fort de ces renseignements, ma carte étant une nvidia GeForce GT 610, je me suis rendu à la rubrique 8.2.4.4.2 - Installation du driver série 304 de la page 121, où j'ai entré les commandes proposées et tout s'est bien passé (même si le copier-coller ne copiait qu'une partie des lignes, j'ai complété à la main) puis j'ai redémarré ... et là, je ne peux plus accéder au bureau HL2.5. Après l'affichage du grub, l'écran affiche quelques lignes et le curseur clignote indéfiniment. J'ai essayé le mode "récupération" mais c'est le même résultat : impossible de lancer hl

Je fais ce message depuis Win7 (merci le dual boot), donc je ne peux pas fournir mon info4forum. Les infos ci-dessus ont été copiées depuis "les cahiers". Les infos de mon profil sont-elles suffisantes ?

Merci d'avance pour votre aide

Dernière modification par falou01 (02-08-2016 23:16:00)


Le plaisir s'accroît quand l'effet se recule

Hors ligne

#2 29-07-2016 18:02:19

arpinux
Adhérent(e)
Lieu : @home
Distrib. : Debian Jessie
Noyau : 4.7-amd64
(G)UI : dwm, fluxbox, evilwm, vtwm, spectrwm, pekwm
Inscription : 30-06-2016
Site Web

Re : [Clos] Ecran noir après install driver nvidia 304 Cahiers du déb p.121

bonjour smile

alors déjà, as-tu vraiment besoin des drivers propriétaires ? tu as remarqué un défaut d'affichage, de rendu graphique sur les vidéos ou la navigation internet ?
ensuite, as-tu créé le fichier xorg.conf.d/20-nvidia.conf après avoir installé le driver ?

enfin, pour retrouver ta session, tu lances handylinux en mode recovery, tu arrives sur une console en mode administrateur.
dans cette console, tu vas vérifier le fichier en place en lançant cette commande


cat /etc/X11/xorg.conf.d/20-nvidia.conf
 


si il affiche bien


Section "Device"
    Identifier "My GPU"
    Driver "nvidia"
EndSection
 


c'est qu'il est bien en place mais que pour une raison encore inconnue, ça ne fonctionne pas ... peut-être en raison de ton noyau en backports.
bref. toujours depuis ta console, tu testes le lancement du serveur graphique, on aura au moins les retours d'erreurs.


startx
 


et tu nous dis ce qu'il se passe smile


minibanner.png minibanner-dflinux.png livedf.png bouton3hg.gif

Hors ligne

#3 29-07-2016 18:39:49

falou01
Membre
Lieu : Entre Rhône et Saône
Distrib. : HandyLinux-2.5.1
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 19-07-2016

Re : [Clos] Ecran noir après install driver nvidia 304 Cahiers du déb p.121

Salut arpinux smile,

Merci pour ta réponse rapide. Alors, oui, j'ai bien un affichage "moyen" sur certains jeux, mais c'est pas la cata. Pour ce qui est de :

ensuite, as-tu créé le fichier xorg.conf.d/20-nvidia.conf après avoir installé le driver ?


Je suppose que oui puisque j'ai entré les commandes préconisées

mkdir /etc/X11/xorg.conf.d

puis

echo -e 'Section "Device"\n\tIdentifier "My GPU"\n\tDriver
"nvidia"\nEndSection'
> /etc/X11/xorg.conf.d/20-nvidia.conf


Enfin, je testerai les commandes que tu préconises un peu plus tard, voire demain, car je suis appelé d'urgence pour un apéro chez les voisins, et ça, ça n'attend pas !!! D'autant qu'on doit aussi arroser la naissance de mon petit-fils ... et qu'en rentrant, il y a le golf (dernier tournoi majeur de l'année) aux USA que je regarde sur le net (m...e à Canal+ big_smile).
Donc, merci et à demain. Je te dirai quoi smile


Le plaisir s'accroît quand l'effet se recule

Hors ligne

#4 29-07-2016 18:45:16

arpinux
Adhérent(e)
Lieu : @home
Distrib. : Debian Jessie
Noyau : 4.7-amd64
(G)UI : dwm, fluxbox, evilwm, vtwm, spectrwm, pekwm
Inscription : 30-06-2016
Site Web

Re : [Clos] Ecran noir après install driver nvidia 304 Cahiers du déb p.121

Oh Belle !!! claque la bise au petiot pour le Libre ! big_smile big_smile
++ smile

minibanner.png minibanner-dflinux.png livedf.png bouton3hg.gif

Hors ligne

#5 30-07-2016 09:41:26

falou01
Membre
Lieu : Entre Rhône et Saône
Distrib. : HandyLinux-2.5.1
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 19-07-2016

Re : [Clos] Ecran noir après install driver nvidia 304 Cahiers du déb p.121

Hello smile,

Bon, ce matin, retour à HL pour essayer de retrouver ma session.

J'ai lancé handylinux en mode recovery et j'arrive sur cet écran :
1469863910.jpg
Et là, rien ne bouge,  je ne peux plus rien faire !

Cela commence à me gonfler, j'ai essayé d'améliorer mon affichage et en fait je crois que j'ai encore amélioré mon incompétence à propos de linux !

Merci pour l'aide à venir...

Le plaisir s'accroît quand l'effet se recule

Hors ligne

#6 30-07-2016 10:08:14

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : [Clos] Ecran noir après install driver nvidia 304 Cahiers du déb p.121

Bonjour smile

Encore un coup de systemd... méchant, systemd, méchant ! Et trop g33k pour moi, mais pour en revenir au problème initial, je trouve étonnant le retour de nvidia-detect car la carte graphique (CG) GeForce GT 610 est supportée par les pilotes nvidia 340.96 et 352.79 (cf. ici et ). Par ailleurs, le dernier info4forum que tu as posté sur le forum HL comporte :

00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GF119 [GeForce GT 610] (rev a1)


Quand tu auras retrouvé la console tty, tu pourras confirmer/compléter l'information avec la commande :

lspci -nnk | grep -E 'VGA|nouveau|nvidia'


Remarque : j'ai la même CG que toi et je trouve l'affichage nativement très satisfaisant dès le noyau 3.16 tongue

Dernière modification par èfpé (01-08-2016 11:12:46)

Hors ligne

#7 30-07-2016 10:29:05

falou01
Membre
Lieu : Entre Rhône et Saône
Distrib. : HandyLinux-2.5.1
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 19-07-2016

Re : [Clos] Ecran noir après install driver nvidia 304 Cahiers du déb p.121

'jour smile,

@èfpé, merci de t'intéresser à mon cas.

Quant au coup de systemd : hmm ?????

Pour le moment, je crois effectivement que le plus urgent est de retrouver la console afin que je puisse saisir les commandes suggérées par arpinux et par toi. Mais ça, je ne sais pas faire !

Le plaisir s'accroît quand l'effet se recule

Hors ligne

#8 30-07-2016 16:57:17

arpinux
Adhérent(e)
Lieu : @home
Distrib. : Debian Jessie
Noyau : 4.7-amd64
(G)UI : dwm, fluxbox, evilwm, vtwm, spectrwm, pekwm
Inscription : 30-06-2016
Site Web

Re : [Clos] Ecran noir après install driver nvidia 304 Cahiers du déb p.121

bonjour smile
et ça reste bloqué sur cette ligne ?? pas d'invite de commande avec le curseur qui clignote ??

minibanner.png minibanner-dflinux.png livedf.png bouton3hg.gif

Hors ligne

#9 30-07-2016 17:11:48

falou01
Membre
Lieu : Entre Rhône et Saône
Distrib. : HandyLinux-2.5.1
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 19-07-2016

Re : [Clos] Ecran noir après install driver nvidia 304 Cahiers du déb p.121

'jour arpi smile

Je viens de refaire la manip au cas où, mais rien ne change. C'est le même écran que sur la photo de ce matin et ça reste bloqué sur cette ligne. pas d'invite de commande avec le curseur qui clignote sad

J'ai essayé ctrl+alt+F1 ... à F12, enter, echap, mais rien n'y fait.

Idée : est-ce qu'en démarrant sur clé USB en live, il y aurait une possibilité de débloquer ça ? Si oui, merci pour les manips à effectuer.

Désolé de vous ennuyer avec ça mais mes connaissances sont à peu près nulles pour arriver à me dépatouiller tout seul !

Le plaisir s'accroît quand l'effet se recule

Hors ligne

#10 30-07-2016 17:26:00

arpinux
Adhérent(e)
Lieu : @home
Distrib. : Debian Jessie
Noyau : 4.7-amd64
(G)UI : dwm, fluxbox, evilwm, vtwm, spectrwm, pekwm
Inscription : 30-06-2016
Site Web

Re : [Clos] Ecran noir après install driver nvidia 304 Cahiers du déb p.121

pas désolé smile
non en fait ce qui me gène, c'est le blocage de ta session recovery et aussi ton noyau backports...

et pour le démarrage depusi un live USB, oui, c'est bien aussi.
tu pourrais naviguer jusqu'à ton /etc/X11/xorg.conf.d/20-nvidia.conf et le virer wink

minibanner.png minibanner-dflinux.png livedf.png bouton3hg.gif

Hors ligne

#11 30-07-2016 18:23:30

falou01
Membre
Lieu : Entre Rhône et Saône
Distrib. : HandyLinux-2.5.1
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 19-07-2016

Re : [Clos] Ecran noir après install driver nvidia 304 Cahiers du déb p.121

Re,

Alors j'ai démarré en live usb, je suis dans le dossier /etc/X11/xorg.conf.d/ et là,  j'ai deux fichiers :
     20-nvidia.conf       et    20-nvi

J'ai ouvert les 2 avec mousepad, les 2 fichiers contiennent la même chose.

Quand je clique droit pour supprimer 20-nvidia.conf, je ne peux pas (supprimer est grisé)  sad

Alors j'ai besoin de tes lumières  smile  : comment je supprime ce fichier ... et qu'est-ce que je fais après ?

Merci encore ... smile

Le plaisir s'accroît quand l'effet se recule

Hors ligne

#12 30-07-2016 18:35:34

arpinux
Adhérent(e)
Lieu : @home
Distrib. : Debian Jessie
Noyau : 4.7-amd64
(G)UI : dwm, fluxbox, evilwm, vtwm, spectrwm, pekwm
Inscription : 30-06-2016
Site Web

Re : [Clos] Ecran noir après install driver nvidia 304 Cahiers du déb p.121

deux fichiers ? donc il y a déjà eu manipulation, d'où le bug certainement. tu avais essayé d'installer les drivers selon une autre méthode avant ? si c'est le cas, il faudrait supprimer et nettoyer.
donc tu commences par lancer thunar en mode administrateur depuis le live avec la commande


gksudo thunar
 


une fois dans thunar en admin (tu dois avoir un petit bandeau dans ta fenêtre thunar pour t'avertir des risques), tu navigues jusqu'à ton disque dur installé handy et tu supprimes les deux fichiers dans /etc/xorg.conf.d/

ça c'est pour le graphique, mais en fait, je ne crois pas que ce soit ça qui pose soucis. je crois plutôt à un changement d'UUID de disque vu le message de systemd...
ton system cherche un disque (UUID=xxxxx) qu'il ne trouve pas.
tu as modifié le fichier /etc/fstab de ton système handylinux ?


minibanner.png minibanner-dflinux.png livedf.png bouton3hg.gif

Hors ligne

#13 30-07-2016 18:36:30

falou01
Membre
Lieu : Entre Rhône et Saône
Distrib. : HandyLinux-2.5.1
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 19-07-2016

Re : [Clos] Ecran noir après install driver nvidia 304 Cahiers du déb p.121

Re,

Bon, j'ai supprimé le fichier 20-nvidia.conf (j'ai retrouvé la procédure dans mon cahier de notes ! big_smile

Donc, ça, c'est fait .... et maintenant ???

Le plaisir s'accroît quand l'effet se recule

Hors ligne

#14 30-07-2016 18:44:11

arpinux
Adhérent(e)
Lieu : @home
Distrib. : Debian Jessie
Noyau : 4.7-amd64
(G)UI : dwm, fluxbox, evilwm, vtwm, spectrwm, pekwm
Inscription : 30-06-2016
Site Web

Re : [Clos] Ecran noir après install driver nvidia 304 Cahiers du déb p.121

maintenant on va :
1 - inspecter tes disques présent
2 - comparer avec ton /etc/fstab (le fichier qui identifie les points de montage de ton système)
3 - corriger si neccessaire
4 - redémarrer sur ton handy installée
smile

donc
1 - depuis ta session live, tu envoi dans un terminal la commande


sudo blkid
 


ce qui va te/nous donner la liste des disques connectés avec leurs UUID et leur Label
ensuite tu envoies la commande


cat /adresse de ton disque handy/etc/fstab
 


et tu mets le retour des deux commandes ici pour qu'on compare et corrige si besoin smile

Dernière modification par arpinux (30-07-2016 18:44:58)


minibanner.png minibanner-dflinux.png livedf.png bouton3hg.gif

Hors ligne

#15 30-07-2016 19:05:50

falou01
Membre
Lieu : Entre Rhône et Saône
Distrib. : HandyLinux-2.5.1
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 19-07-2016

Re : [Clos] Ecran noir après install driver nvidia 304 Cahiers du déb p.121

Re smile

Nos messages se sont croisés. Les 2 fichiers sont supprimés.

Est-ce que j'ai modifié /etc/fstab ? C'est bien possible avec toutes les manips que j'ai fait à force de bidouiller pour installer/désinstaller des outils genre skype, googleearth (aie ! on ne frappe pas !), virtualbox, playonlinux, vlc, etc ...

1 - sudo blkid renvoie celà
humain@handylinux ~
$

sudo blkid



/dev/sda1: UUID="44DCCCE0DCCCCD7C" TYPE="ntfs" PARTUUID="1a58f45c-01"
/dev/sda2: UUID="1bc3da45-3c86-4a4c-b68a-5ef495760f3d" TYPE="ext4" PARTUUID="1a58f45c-02"
/dev/sdb1: LABEL="Magasin" UUID="D090779C907787AC" TYPE="ntfs" PARTUUID="c7d423ce-01"
/dev/sdb2: LABEL="Bigstore" UUID="B614B87714B83BE5" TYPE="ntfs" PARTUUID="c7d423ce-02"
/dev/sdb3: LABEL="Marido" UUID="FE8408428407FC41" TYPE="ntfs" PARTUUID="c7d423ce-03"
/dev/sdb5: LABEL="Roger" UUID="A62036A820367EFD" TYPE="ntfs" PARTUUID="c7d423ce-05"
/dev/sdc1: LABEL="SB01" UUID="8A04B1AD04B19D1F" TYPE="ntfs" PARTUUID="87526c2a-01"
/dev/sdc5: LABEL="SB02" UUID="C012C24B12C245DE" TYPE="ntfs" PARTUUID="87526c2a-05"
/dev/sdd1: LABEL="Stockage" UUID="44C4DB3EC4DB30C2" TYPE="ntfs" PARTUUID="0002f147-01"
/dev/sde1: UUID="2016-01-23-20-15-02-00" LABEL="handylinux2" TYPE="iso9660" PARTUUID="5d807006-01"
/dev/loop0: TYPE="squashfs"[quote]
 


Pour le fstab, je l'ai ouvert avec mousepad, et voilà :

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

#Entry for /dev/sda2 :
UUID=1bc3da45-3c86-4a4c-b68a-5ef495760f3d   /    ext4    errors=remount-ro    0    1
#Entry for /dev/sdb2 :
UUID=B614B87714B83BE5    /media/Bigstore    ntfs-3g    defaults,locale=fr_FR.utf8    0    0
#Entry for /dev/sdb1 :
UUID=D090779C907787AC    /media/Magasin    ntfs-3g    defaults,locale=fr_FR.utf8    0    0
#Entry for /dev/sdb3 :
UUID=FE8408428407FC41    /media/Marido    ntfs-3g    defaults,locale=fr_FR.utf8    0    0
#Entry for /dev/sdb5 :
UUID=A62036A820367EFD    /media/Roger    ntfs-3g    defaults,locale=fr_FR.utf8    0    0
#Entry for /dev/sdc1 :
UUID=8A04B1AD04B19D1F    /media/SB01    ntfs-3g    defaults,locale=fr_FR.utf8    0    0
#Entry for /dev/sdc5 :
UUID=C012C24B12C245DE    /media/SB02    ntfs-3g    defaults,locale=fr_FR.utf8    0    0
#Entry for /dev/sda1 :
UUID=44DCCCE0DCCCCD7C  /media/SSD_OCZ    ntfs-3g    defaults,locale=fr_FR.utf8    0    0
#Entry for /dev/sdd1 :
UUID=44C4DB3EC4DB30C2    /media/Stockage    ntfs-3g    defaults,locale=fr_FR.utf8    0    0
#Entry for /dev/sda6 :
#UUID=b6b9c84c-ae95-445e-9fbe-00f5b7dd8968    none    swap    sw    0    0
/dev/sr0    /media/cdrom0    udf,iso9660    user,noauto    0    0
 


Tu as vu juste une fois de plus smile ... mais que faire ?

Merci pour ta patience smile

Edit à toto :
Séparé la ligne de la commande sudo de son retour et mis le fichier fstab sous code.


Le plaisir s'accroît quand l'effet se recule

Hors ligne

#16 30-07-2016 19:24:11

arpinux
Adhérent(e)
Lieu : @home
Distrib. : Debian Jessie
Noyau : 4.7-amd64
(G)UI : dwm, fluxbox, evilwm, vtwm, spectrwm, pekwm
Inscription : 30-06-2016
Site Web

Re : [Clos] Ecran noir après install driver nvidia 304 Cahiers du déb p.121

euh... bah non j'ai rien vu... tes entrées sont bonnes dans ton fstab et correspondent aux UUID de tes disques, donc je vois pas pourquoi systemd cherche tes partitions... elles sont là hmm

tu as commenté la ligne "swap" quand ?

minibanner.png minibanner-dflinux.png livedf.png bouton3hg.gif

Hors ligne

#17 30-07-2016 19:32:47

falou01
Membre
Lieu : Entre Rhône et Saône
Distrib. : HandyLinux-2.5.1
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 19-07-2016

Re : [Clos] Ecran noir après install driver nvidia 304 Cahiers du déb p.121

Re,

Je n'ai pas commenté la ligne swap, cela a du se faire lorsque j'ai changé mon disque dur pour un ssd de plus forte capacité. Je n'ai pas pu copier la partition swap et j'ai décidé de m'en passer (il semble qu'elle ne serve qu'en cas de mise en veille si j'ai bien compris).

Il me semblait voir une erreur dans le fstab ici :

#Entry for /dev/sda2 :
UUID=1bc3da45-3c86-4a4c-b68a-5ef495760f3d   /    ext4    errors=remount-ro    0    1


Moi, dès que je vois "errors" je pense qu'il y a un lézard ! big_smile

Maintenant, pour ce que j'y connais ...


Le plaisir s'accroît quand l'effet se recule

Hors ligne

#18 30-07-2016 19:44:34

arpinux
Adhérent(e)
Lieu : @home
Distrib. : Debian Jessie
Noyau : 4.7-amd64
(G)UI : dwm, fluxbox, evilwm, vtwm, spectrwm, pekwm
Inscription : 30-06-2016
Site Web

Re : [Clos] Ecran noir après install driver nvidia 304 Cahiers du déb p.121

re smile
non, le "error" dans ce fichier veut dire "si il y a une erreur lors du montage, remonte en lecture seule", c'est une instruction de montage, pas une erreur smile

mais maintenant que tu as viré les fichiers de conf xorg. et comme il n'y a pas de bug dans le fstab, il faudrait retenter un démarrage en mode recovery pour virer les paquets nvidia*
laisse systemd râler, et attends un peu avant de forcer l'extinction. quand il y a des erreurs de montage, il arrête de chercher à un moment et monte ce qu'il peut quand même. faut juste attendre 10~15 minutes si tu peux. à moins que l'erreur se répète à l'infini, là tu éteins et on va chercher ailleurs... hmm

minibanner.png minibanner-dflinux.png livedf.png bouton3hg.gif

Hors ligne

#19 30-07-2016 21:53:14

falou01
Membre
Lieu : Entre Rhône et Saône
Distrib. : HandyLinux-2.5.1
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 19-07-2016

Re : [Clos] Ecran noir après install driver nvidia 304 Cahiers du déb p.121

re smile

Bon le démarrage en mode recovery est resté planté sur la même page pendant 1 h 1/2 !

Donc, il va nous falloir trouver une autre solution.

Je lâche l'affaire pour ce soir. A demain pour la poursuite des aventures big_smile

Edit : je reviens car il tombe des cordes dans le New Jersey et le jeu est interrompu !

Dernière modification par falou01 (30-07-2016 21:57:40)


Le plaisir s'accroît quand l'effet se recule

Hors ligne

#20 30-07-2016 23:38:48

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS/Antix/Slackware
Noyau : 4.8.12/4.4.10/4.4.32
(G)UI : Plasma5/Fluxbox/KDE4/Trinity
Inscription : 05-03-2014

Re : [Clos] Ecran noir après install driver nvidia 304 Cahiers du déb p.121

Attention avec les pilotes Nvidia "legacy", moi j'ai eu une incompatibilité avec le 340 et le kernel 4.6 des backports sur mon laptop Toshiba.
Celui-ci a une puce graphique Nvidia GeForce 315M.
Jusqu'au kernel 4.5, le 340 passait, mais pas avec le 4.6. Je suis repassé au 3.16 de base sur cette machine et tout est rentré dans l'ordre.

Quant aux éventuels problèmes de systemd, il est facile, sous Debian, de repasser la main à sysvinit. Chez moi c'est systématique, je ne veux
pas de systemd sur mes machines.

PcLinuxOs KDE Plasma 5.8.4 / Slackware -current KDE 4.14.21 sur workstation bi-processeur AMD Opteron 4234 32 Go DDR-3
antiX 16 rox/fluxbox sur laptop Toshiba Satellite C-660-2D6 Intel core I3 8Go DDR-3
PcLinuxOs Trinity Desktop+Kodi sur media-center HP Intel Celeron 2Go DDR-3

Hors ligne

#21 31-07-2016 04:59:00

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Clos] Ecran noir après install driver nvidia 304 Cahiers du déb p.121

yoshi a écrit :

sous Debian, de repasser la main à sysvinit.


Une petite explication pour ? smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#22 31-07-2016 05:11:24

arpinux
Adhérent(e)
Lieu : @home
Distrib. : Debian Jessie
Noyau : 4.7-amd64
(G)UI : dwm, fluxbox, evilwm, vtwm, spectrwm, pekwm
Inscription : 30-06-2016
Site Web

Re : [Clos] Ecran noir après install driver nvidia 304 Cahiers du déb p.121

o/ yoshi.
on aurait donc l'explication du bug : incompatibilité entre le kernel 4.6 et le driver.

@falou01 : aurais-tu, par chance, conservé le kernel 3.16 installé que cette machine ? si oui, démarres dessus depuis le menu GRUB > Options avancées > Debian GNU/Linux 3.16 smile

minibanner.png minibanner-dflinux.png livedf.png bouton3hg.gif

Hors ligne

#23 31-07-2016 05:37:49

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS/Antix/Slackware
Noyau : 4.8.12/4.4.10/4.4.32
(G)UI : Plasma5/Fluxbox/KDE4/Trinity
Inscription : 05-03-2014

Re : [Clos] Ecran noir après install driver nvidia 304 Cahiers du déb p.121

smolski a écrit :

yoshi a écrit :

sous Debian, de repasser la main à sysvinit.


Une petite explication pour ? smile



C'est assez simple: il suffit de supprimer le paquet systemd-sysv, ce qui va entraîner l'installation de systemd-shim+cgmanager+sysvinit-core.
Au prochain reboot, sysvinit se retrouve en PID 1 et remplace systemd.
On le voit aisément: init: version 2.88 booting. Systemd n'est pas supprimé, il est toujours là, tapis dans l'ombre, mais sysvinit reprend la main.

Après, pour les plus féroces, comme moi, on peut éradiquer complètement systemd de Debian, mais là c'est une autre histoire, certains DE ne
le supporte pas, ou mal. D'autres, comme XFCE et tous les bureaux légers (Openbox, Fluxbox, etc ...) le supporte très bien. Mais c'est plus compliqué et cela demande l'utilisation de dépôts tiers .....
Un tout autre débat qui, en son temps, a fait couler beaucoup d'encre ......

Pour l'incompatibilité kernel 4.6/pilotes Nvidia "legacy", je pense que oui, il y a un problème. Mes deux machines sont quand même très différentes, et j'ai eu ce problème avec le Toshiba et sa puce
Nvidia GT 315M pas vraiment récente. Sur ma tour bi-Opteron, j'ai également une CG Nvidia, mais c'est plus récent, une GeForce 760 GTX. Je suis en kernel 4.6 des backports et niveau pilote, je
suis avec le 367.35, qui est le plus récent je crois. Aucun problème.

Dernière modification par yoshi (31-07-2016 05:46:48)


PcLinuxOs KDE Plasma 5.8.4 / Slackware -current KDE 4.14.21 sur workstation bi-processeur AMD Opteron 4234 32 Go DDR-3
antiX 16 rox/fluxbox sur laptop Toshiba Satellite C-660-2D6 Intel core I3 8Go DDR-3
PcLinuxOs Trinity Desktop+Kodi sur media-center HP Intel Celeron 2Go DDR-3

Hors ligne

#24 31-07-2016 09:19:09

falou01
Membre
Lieu : Entre Rhône et Saône
Distrib. : HandyLinux-2.5.1
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 19-07-2016

Re : [Clos] Ecran noir après install driver nvidia 304 Cahiers du déb p.121

Bonjour à tous smile,

Ah ! Vous ne dormez donc jamais big_smile

@yoshi, merci de t'intéresser à mon cas. Tes explications techniques vont bien au-delà de ma compréhension, j'en suis désolé. Je n'ai que le niveau (!) de pouvoir reproduire ou copier des lignes de commandes dans un terminal pour arriver à une solution éventuelle.

@arpinux, désolé, je n'ai pas dans le GRUB > Options avancées > Debian GNU/Linux 3.16 mais uniquement Linux 4.6.0-0.bpo.1-amd64 sad

Le plaisir s'accroît quand l'effet se recule

Hors ligne

#25 31-07-2016 10:27:28

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Clos] Ecran noir après install driver nvidia 304 Cahiers du déb p.121

il suffit de supprimer le paquet systemd-sysv


D'abord se mettre à jour :

apt-get update


Si tu n'as pas des sources olé-olé :

apt-get dist-upgrade



Sinon :

apt-get upgrade


Puis :

apt-get remove systemd-sysv



Tu as tous les renseignements détaillées dans le tuto apt-get sur le wiki df :
https://debian-facile.org/doc:systeme:apt:apt-get smile


Edit :

Pour le PID, les explications sont ici :
https://debian-facile.org/doc:systeme:p … -processus

Voir aussi le tuto GNU/Linux qui le fait :
https://debian-facile.org/doc:systeme:gnu-linux

Bon, faut lire et pas qu'en diagonale, n'hésitez pas à utiliser le lien dans l'entête "Commentaires sur le forum" pour nous retourner vos questions si vous ne comprenez pas ce qui y est écrit, nous pourront ainsi améliorer le texte avec votre aide afin de le rendre plus accessibles pour tous.

Wouap ! big_smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

Pied de page des forums