Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 31-07-2016 22:24:16

Archerux
Membre
Distrib. : Debian stretch
Noyau : linux 4.8.0.1-amd64
(G)UI : KDE 5
Inscription : 22-03-2016

[Résolu] pb d'installation en dual boot avec window 10

bonjour,

je reviens vers vous apres plusieurs semaines de deplacements...

j'ai "cassé" ma distribution debian 8.5, une erreur de manipulation probablement, en voulant partitionner mon disque dur afin d'installer window 10 pro afin de pouvoir utiliser le logiciel vagcom (diagnostic ODBII pour autos du groupe vag). au redemarrage, plus rien ne s'affichait.

j'ai donc tout reformaté et réinstallé window 10 sur une partition de 50GO, ce qui me laisse pres de 430 GO pour linux. je viens d'effectuer une installation de debian que la partition de 430 Go. au redemarrage, l'ordi démarre directement sur window 10.

j'avais pourtant installé grub sur la partition primaire.

j'avais eu le meme probleme avec mon mac en dual boot, reglé avec refind.

y a t il une manipulation a effectuer afin qu'au démarrage, le choix des OS soit proposé?

bien cordialement,

Dernière modification par Archerux (04-08-2016 21:38:40)

Hors ligne

#2 31-07-2016 22:49:59

capdefradeb
Membre
Distrib. : Portable1:LMDE2 Cinnamon-Portable2:DFLinux
(G)UI : Cinnamon et XFCE
Inscription : 14-07-2016

Re : [Résolu] pb d'installation en dual boot avec window 10

Tu as plusieurs solutions qui peuvent fonctionner :
Rétablir un menu de démarrage qui te redonne le choix de Windows 10 et de Linux.Ca peut se faire avec un CD (ou une clé USB ) sur lequel tu auras installé Boot Repair.
Tu peux aussi prendre le problème du côté de Windows en faisant apparaître au démarrage son gestionnaire de boot et en y rajoutant l'entrée pour Linux. J'ai du faire comme cela sur un de mes ordis qui était récalcitrant à faire fonctionner Grub et le résultat est nickel.Le logiciel le plus pratique pour réaliser ça dans Windows est  EasyBCD.

Hors ligne

#3 01-08-2016 09:17:29

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] pb d'installation en dual boot avec window 10

Oui, on peut tenter diverses solutions à l'aveuglette et espérer que l'une d'elles fonctionnera.
Ou bien, si on est un peu curieux, on peut chercher à comprendre la cause du problème. Un bon début pour cela est d'examiner la table de partition, de préférence avec un des outils de Linux comme fdisk.

Hors ligne

#4 01-08-2016 11:39:28

totophe56
Membre
Distrib. : Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 22-07-2010

Re : [Résolu] pb d'installation en dual boot avec window 10

Bonjour,

50 go pour W$, il va saturer rapidement neutral

Hors ligne

#5 01-08-2016 12:44:10

Archerux
Membre
Distrib. : Debian stretch
Noyau : linux 4.8.0.1-amd64
(G)UI : KDE 5
Inscription : 22-03-2016

Re : [Résolu] pb d'installation en dual boot avec window 10

50go c'est bien suffisant à mon sens puisque je l'utiliserai uniquement pour le vagcom. 
Tu penses qu'il vaudrait mieux lui allouer un plus grand espace?

Pour utiliser l'outil Linux comme fdisk, le pb c'est que je ne peux pas booster sur debian...

Peut être que je devrais tout refaire mais à l'envers, c'est à dire faire une install de debian et ensuite installer Windows?

Hors ligne

#6 01-08-2016 13:34:54

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] pb d'installation en dual boot avec window 10

Archerux a écrit :

Pour utiliser l'outil Linux comme fdisk, le pb c'est que je ne peux pas booster sur debian


Ce n'est pas un problème. Les possibilités existent : système live, installateur Debian en mode rescue...

Hors ligne

#7 01-08-2016 14:22:10

Slyfox
Membre
Lieu : Pays du chocolat
Distrib. : GNU/Linux Debian Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : MATE
Inscription : 15-12-2013

Re : [Résolu] pb d'installation en dual boot avec window 10

Salut,

Peut-être ça... sans aucune conviction roll

Regardes "Résolution des problèmes" à la fin de ce wiki: https://debian-facile.org/doc:install:d … -de-l-uefi

A+

Dernière modification par Slyfox (01-08-2016 14:23:50)

Hors ligne

#8 01-08-2016 14:51:49

Archerux
Membre
Distrib. : Debian stretch
Noyau : linux 4.8.0.1-amd64
(G)UI : KDE 5
Inscription : 22-03-2016

Re : [Résolu] pb d'installation en dual boot avec window 10

D'accord,  merci pour vos conseils, je pense que le mieux serait que je refasse tout au propre, c'est à dire reformater mon disque dur, en commençant par installer debian en partition'ement manuel et finir par une installation de Windows .

Je vous tiens au courant.

@+

Hors ligne

#9 01-08-2016 14:52:39

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] pb d'installation en dual boot avec window 10

Généralement c'est plutôt l'inverse qui est recommandé car le dernier OS installé se met en premier dans l'ordre de démarrage.

Hors ligne

#10 01-08-2016 15:11:12

Archerux
Membre
Distrib. : Debian stretch
Noyau : linux 4.8.0.1-amd64
(G)UI : KDE 5
Inscription : 22-03-2016

Re : [Résolu] pb d'installation en dual boot avec window 10

D'accord je vais faire comme tu le dis.

Bien cordialement,

Hors ligne

#11 01-08-2016 19:37:50

Archerux
Membre
Distrib. : Debian stretch
Noyau : linux 4.8.0.1-amd64
(G)UI : KDE 5
Inscription : 22-03-2016

Re : [Résolu] pb d'installation en dual boot avec window 10

je reviens apres avoir tout formaté et réinstallé...

j'ai essayé la commande

bcdedit /set {bootmgr} path EFI\debian\grubx64.efi



dans l'invite de commande admin dans window, cela ne change rien, l'ordi boote tjs sur window...

la je fais une pause et réessaierai peut etre un peu plus tard...

peut etre avec easyBCD, mais ce logiciel ne repere pas le debian installé sur la grosse partition...

Hors ligne

#12 02-08-2016 09:14:20

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] pb d'installation en dual boot avec window 10

Je renouvelle ma suggestion de relever la liste des partitions présentes sur le disque. Si tu n'arrives pas à le faire depuis un système Linux, alors depuis le gestionnaire de disques de Windows.

Hors ligne

#13 02-08-2016 17:23:46

Archerux
Membre
Distrib. : Debian stretch
Noyau : linux 4.8.0.1-amd64
(G)UI : KDE 5
Inscription : 22-03-2016

Re : [Résolu] pb d'installation en dual boot avec window 10

bonsoir,

je n'ai pas réussi a utiliser fdisk avec le mode rescue de l'installeur debian...

voici la capture de ce que donne le gestionnaire de disques de windows...

naA1JT.png

que dois je faire? le gestionnaire de window ne donne pas toutes les infos...

merci d'avance pour votre aide

Hors ligne

#14 02-08-2016 17:42:57

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] pb d'installation en dual boot avec window 10

C'est pour cela que j'aurais préféré fdisk. Qu'est-ce qui t'a empêché de l'utiliser en mode rescue ?
Je regarderai la capture dès que j'y aurai accès.

Hors ligne

#15 02-08-2016 18:22:14

Archerux
Membre
Distrib. : Debian stretch
Noyau : linux 4.8.0.1-amd64
(G)UI : KDE 5
Inscription : 22-03-2016

Re : [Résolu] pb d'installation en dual boot avec window 10

attends je viens de reussir a faire marcher fdisk avec un live kali

fdisk -l



Disk /dev/sda: 447.1 GiB, 480103981056 bytes, 937703088 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 365DE800-382E-4232-AE73-46C13DE05DC6

Device         Start       End   Sectors   Size Type
/dev/sda1       2048    923647    921600   450M Windows recovery environment
/dev/sda2     923648   1128447    204800   100M EFI System
/dev/sda3    1128448   1161215     32768    16M Microsoft reserved
/dev/sda4    1161216 204802047 203640832  97.1G Microsoft basic data
/dev/sda5  204802048 243863551  39061504  18.6G Linux filesystem
/dev/sda6  243863552 251676671   7813120   3.7G Linux swap
/dev/sda7  251676672 937701375 686024704 327.1G Linux filesystem


 



j'espere que c'est mieux

je quitte kali car difficile clavier qwerty

message reédité depuis un ordi en azerty c'est plus facile.

les infos sont vraiment bien plus riches avec l'outil fdisk...

ce qui est drole c'est qu'au moment de l'installation, j'avais mis 20 go pour le systeme, 4 pour le swap et le reste pour le /home et le resultat est en decimales...

Edit à toto :
Séparation de la igne de commande root de son retour ensuite... Meilleure lecture pour tous que c'est.

Dernière modification par Archerux (02-08-2016 18:31:10)

Hors ligne

#16 03-08-2016 09:39:43

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] pb d'installation en dual boot avec window 10

L'installateur Debian et fdisk ne comptent pas de la même façon. L'installateur utilise des multiplicateurs décimaux (puissance de 1000) et fdisk des multiplicateurs binaires (puissances de 1024). D'ailleurs on voit que fdisk affiche 447 Gio (le "i" sert à indiquer un préfixe multiplicateur binaire) pour le disque de 480 Go (curieux comme capacité, c'est un SSD ?).

Table de partition GPT, partition système EFI -> amorçage de Windows en mode UEFI.
Pas de partition BIOS boot, donc à moins que tu aies fait un partitionnement manuel et ignoré l'avertissement concernant l'absence de partition d'amorçage BIOS, l'installation de Debian s'est faite en mode UEFI aussi. Il arrive que le firmware UEFI de la machine soit un peu deficient et ne gère pas correctement les entrées d'amorçage créées par les systèmes installés. L'idéal, ce serait si tu pouvais lancer l'installateur en mode rescue, suivre les étapes jusqu'à "exécuter un shell sur la racine du système" (sda5 a priori), et exécuter la commande suivante pour afficher les entrées d'amorçage EFI :

efibootmgr -v

Hors ligne

#17 03-08-2016 11:47:08

Antidentity
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4 amd64
(G)UI : Openbox
Inscription : 03-08-2016

Re : [Résolu] pb d'installation en dual boot avec window 10

Bonjour,
Je suis du même avis que raleur. J'ai installé, il n'y a pas tellement longtemps, debian à côté de windows 10. J'avais créé la partition efi mais l'amorçage de ne faisait pas. J'avais ensuite lancé l'installateur en mode rescue qui a réparé tout ça et a permis à l'ordi de s'amorcer.

Par contre je n'avais pas executé de commande shell. J'essaierai cette commande la prochaine fois. smile

Dernière modification par Antidentity (03-08-2016 11:58:30)

Hors ligne

#18 03-08-2016 13:45:03

Archerux
Membre
Distrib. : Debian stretch
Noyau : linux 4.8.0.1-amd64
(G)UI : KDE 5
Inscription : 22-03-2016

Re : [Résolu] pb d'installation en dual boot avec window 10

raleur a écrit :

L'installateur Debian et fdisk ne comptent pas de la même façon. L'installateur utilise des multiplicateurs décimaux (puissance de 1000) et fdisk des multiplicateurs binaires (puissances de 1024). D'ailleurs on voit que fdisk affiche 447 Gio (le "i" sert à indiquer un préfixe multiplicateur binaire) pour le disque de 480 Go (curieux comme capacité, c'est un SSD ?).



effectivement, c'est un ssd que j'ai recuperée.


d'apres tes conseils, j'ai refait l'installation en assisté (la derniere fois, je l'ai fait en manuel et il n'ya pas eu d'avertissement concernant la partition bios. )

au redemarrage, meme probleme : windows s'amorce en premier.

la commande

efibootmgr -v



a été refusé dans le mode rescue.

je refais un fdisk -l ce soir (effectivement, en mode assisté, une partition en plus a été crée...

bon apres midi!! :-)

Hors ligne

#19 03-08-2016 14:06:42

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] pb d'installation en dual boot avec window 10

Archerux a écrit :

la commande efibootmgr -v a été refusé dans le mode rescue.


Tu avais bien lancé un shell dans la racine du système installé ? Si oui, refusée avec quelle erreur ?

Archerux a écrit :

d'apres tes conseils, j'ai refait l'installation en assisté (la derniere fois, je l'ai fait en manuel et il n'ya pas eu d'avertissement concernant la partition bios. )


Je n'ai pas conseillé d'utiliser le partitionnement assisté. Concernant l'avertissement, je ne jurerais pas qu'il existe, je confonds peut-être avec la partition système EFI lorsque l'installateur est amorcé en mode EFI.

Archerux a écrit :

effectivement, en mode assisté, une partition en plus a été crée


Te souviens-tu quel type de partition, quelle taille, pour quelle utilisation... ?

Si c'est une partition pour l'amorçage BIOS, alors cela signifie que l'installateur a été amorcé en mode legacy/CSM de compatibilité BIOS, ce qui n'est pas bon.
Dans ce mode, lors de l'installation de GRUB il demande où il faut installer le chargeur d'amorçage alors qu'il ne le demande pas en mode EFI. T'en souviens-tu ?

Hors ligne

#20 03-08-2016 21:07:29

Archerux
Membre
Distrib. : Debian stretch
Noyau : linux 4.8.0.1-amd64
(G)UI : KDE 5
Inscription : 22-03-2016

Re : [Résolu] pb d'installation en dual boot avec window 10

Tu avais bien lancé un shell dans la racine du système installé ? Si oui, refusée avec quelle erreur ?



non, j'ai ecrit la commande tel quel dans le shell. je n'ai pas pensé à indiquer la racine.
dois je indiquer d'executer la commande dans la racine systeme? quelle est la commande? roll

l'erreur : efi not found... ce qui est logique si la commande a ete faite depuis la clé et que je n'ai pas demandé à executer dans la partition racine.

Je n'ai pas conseillé d'utiliser le partitionnement assisté. Concernant l'avertissement, je ne jurerais pas qu'il existe, je confonds peut-être avec la partition système EFI lorsque l'installateur est amorcé en mode EFI.



c'est vrai, c'était une déduction que j'ai faite....

Te souviens-tu quel type de partition, quelle taille, pour quelle utilisation... ?



partition de 1 mb , boot .

j'ai réinstallé debian en manuel, effectivement, ils me demandent d'installer le Grub, je l'ai installé sur le disque SDA.

Hors ligne

#21 03-08-2016 22:23:15

Archerux
Membre
Distrib. : Debian stretch
Noyau : linux 4.8.0.1-amd64
(G)UI : KDE 5
Inscription : 22-03-2016

Re : [Résolu] pb d'installation en dual boot avec window 10

apres lecture de la documentation debian-facile sur les commandes, si j'ai bien compris, je devrais faire d'abord un

cd /



pour me mettre dans la partition systeme

puis un

pws



pour verifier que je suis dans le bon reperitoire

et enfin, lancer la commande


efibootmgr -v




c'est bien cela? je m'excuse d'avance pour mes questions naives... roll

Hors ligne

#22 03-08-2016 22:26:34

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] pb d'installation en dual boot avec window 10

Archerux a écrit :

non, j'ai ecrit la commande tel quel dans le shell. je n'ai pas pensé à indiquer la racine.
dois je indiquer d'executer la commande dans la racine systeme? quelle est la commande?


Il faut sélectionner "rescue" dans le menu de démarrage de l'installateur. Ensuite, après plusieurs étapes communes avec l'installation, l'installateur demandera de désigner la racine et donnera ensuite la possibilité d'exécuter un shell dans cette racine. Conseil : comme première commande, je recommande "bash" pour lancer le shell habituel au lieu du shell par défaut qui n'est pas aussi pratique.

Archerux a écrit :

partition de 1 mb , boot .
j'ai réinstallé debian en manuel, effectivement, ils me demandent d'installer le Grub


Donc l'installation s'est faite en mode BIOS, et c'est normal que Debian ne démarre pas : le mode UEFI, donc Windows, a la priorité.
Pour lancer Debian il faut forcer le firmware à amorcer le disque en mode BIOS.

Pour que Debian puisse se lancer en mode UEFI, le plus simple est de démarrer l'installateur en mode UEFI, ce qui n'est possible que s'il a été préparé correctement.
Quelle image ISO as-tu utilisée ?
Sur quel support ? Si c'est une clé USB, comment as-tu mis l'image sur la clé ?

Hors ligne

#23 03-08-2016 22:43:49

Archerux
Membre
Distrib. : Debian stretch
Noyau : linux 4.8.0.1-amd64
(G)UI : KDE 5
Inscription : 22-03-2016

Re : [Résolu] pb d'installation en dual boot avec window 10

resultat de la commande

efibootmgr -v



/bin/sh : 2: efibootmgr: not found

Hors ligne

#24 03-08-2016 22:46:02

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] pb d'installation en dual boot avec window 10

Normal, efibootmgr n'est installé par défaut qu'en mode EFI. Laisse tomber et regarde mon message précédent.

Hors ligne

#25 03-08-2016 23:06:31

Archerux
Membre
Distrib. : Debian stretch
Noyau : linux 4.8.0.1-amd64
(G)UI : KDE 5
Inscription : 22-03-2016

Re : [Résolu] pb d'installation en dual boot avec window 10

je n'ai pas repondu à ces questions...

Quelle image ISO as-tu utilisée ?



l'image iso officielle sur le site de debian :
http://cdimage.debian.org/debian-cd/8.5 … -DVD-1.iso


Sur quel support ? Si c'est une clé USB, comment as-tu mis l'image sur la clé ?



sur une clé usb de 8go , iso écrit avec rufus sur window...

Hors ligne

Pied de page des forums