Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 03-08-2016 23:08:27

Archerux
Membre
Distrib. : Debian stretch
Noyau : linux 4.8.0.1-amd64
(G)UI : KDE 5
Inscription : 22-03-2016

Re : [Résolu] pb d'installation en dual boot avec window 10

Archerux a écrit :

je n'ai pas repondu à ces questions...

Quelle image ISO as-tu utilisée ?



l'image iso officielle sur le site de debian :
http://cdimage.debian.org/debian-cd/8.5 … -DVD-1.iso


Sur quel support ? Si c'est une clé USB, comment as-tu mis l'image sur la clé ?



sur une clé usb de 8go , iso écrit avec rufus sur window...



devrais-je utiliser une autre procédure pour préparer ma clé usb? j'ai aussi un mac à coté, devrais je faire la clé en utilisant terminal?

Hors ligne

#27 03-08-2016 23:10:04

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] pb d'installation en dual boot avec window 10

Tu ne l'as peut-être pas fait de la bonne façon. Il faut traiter le fichier comme une image disque, et non comme une image ISO.

Tu as écrit avoir utilisé refind sur un Mac, tu pourrais l'utiliser aussi sur ce PC.

Hors ligne

#28 03-08-2016 23:13:42

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] pb d'installation en dual boot avec window 10

Si tu as un Unix quelconque à disposition, tu peux utiliser cp ou dd pour copier l'image sur la clé.

1) Démonter tout système de fichiers de la clé monté automatiquement.
2) En supposant que la clé USB soit représentée par /dev/sdb,
avec cp :

cp debian-xxx.iso /dev/sdb


ou avec dd :

dd if=debian-xxx.iso of=/dev/sdb bs=4096

Dernière modification par raleur (03-08-2016 23:14:18)

Hors ligne

#29 03-08-2016 23:23:36

Archerux
Membre
Distrib. : Debian stretch
Noyau : linux 4.8.0.1-amd64
(G)UI : KDE 5
Inscription : 22-03-2016

Re : [Résolu] pb d'installation en dual boot avec window 10

je vais essayer le terminal tout de suite.


pour le refind, j'ai un peu de mal avec l'anglais et je n'arrive pas a comprendre comment marche window, c'est le premier que j'ai... ces 20 dernieres années, j'etais sur mac...

Hors ligne

#30 04-08-2016 01:10:08

Archerux
Membre
Distrib. : Debian stretch
Noyau : linux 4.8.0.1-amd64
(G)UI : KDE 5
Inscription : 22-03-2016

Re : [Résolu] pb d'installation en dual boot avec window 10

j'ai refait l'installation avec une clé usb reconstruit via la commande dd...

le probleme reste le meme. j'ai jete un oeil sur le site de refind, si j'ai bien compris, il y a un pb avec window 10 c'est bien ca? ils conseillent de faire l'install depuis un live ubuntu, ca marche aussi avec un live kali, j'imagine?

pour ce soir, je laisse tomber, je m'y remettrais demain ...

bonne nuit et merci pour votre aide jusqu'a maintenant.

Hors ligne

#31 04-08-2016 09:25:12

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] pb d'installation en dual boot avec window 10

Windows n'a rien à voir dans le fait que l'installateur démarre en mode BIOS, cela ne concerne que le firmware UEFI et l'installateur.

Le même problème, c'est-à-dire ? L'installateur démarre en mode BIOS/legacy (menu ISOLinux) et non en mode EFI (menu GRUB), et demande où installer le chargeur d'amorçage ?

Vérifie que l'option "secure boot" est désactivée dans les réglages UEFI. Normalement elle devrait l'être pour autoriser l'amorçage en mode BIOS, mais on ne sait jamais. Tu peux aussi regarder si tu peux désactiver l'option de démarrage en mode de compatibilité BIOS/legacy (CSM) pour empêcher l'installateur de démarrer dans ce mode.

Comment fais-tu pour démarrer sur la clé USB ? Si tu ouvres le menu de démarrage du firmware, il devrait afficher deux entrées pour la clé : une en mode BIOS/legacy/CSM et une en mode UEFI. C'est cette dernière qu'il faut sélectionner. Regarde aussi s'il est possible de spécifier directement le chemin du fichier/shell EFI à démarrer, certains firmwares le permettent. Sur la clé, ce fichier est \EFI\Boot\bootx64.efi.

Plus rare, quelques machines ont un firmware UEFI 32 bits qui ne peut pas démarrer l'installateur 64 bits en mode EFI natif. Mais j'ai vu cela surtout sur des netbooks avec assez peu de mémoire (2 Gio). Dans ce cas, il faut utiliser soit l'installateur 32 bits pour installer un système 32 bits, soit l'installateur multiarch pour installer un système 32 ou 64 bits.

Hors ligne

#32 04-08-2016 18:25:13

Archerux
Membre
Distrib. : Debian stretch
Noyau : linux 4.8.0.1-amd64
(G)UI : KDE 5
Inscription : 22-03-2016

Re : [Résolu] pb d'installation en dual boot avec window 10

bonjour,

par "meme probleme", je veux dire que l'ordinateur boote directement sur window, et impossible de demarrer le debian installé sur une autre partition.

pour booter sur la clé, etant donné que je suis sur thinkpad, j'appuie sur le bouton bleu (thinkVantage) puis sur F12 qui me propose le disque a partir duquel je veux booter.
donc, soit je boote sur l'USB, l'installeur debian demarre si je selectionne le SSD, c'est window qui boote.

le secureboot (sur thinkpad, ca s'appelle secure chip) est bien désactivé.

sur cet ordianateur, debian bootait sans soucis lorsqu'il etait le seul systeme...

en installant debian en manuel, a la fin, l'installeur me demande de choisir le disque sur lequel installer grub, je choisis toujours le SDA (nom du SSD)

la, je viens de désactiver le boot legacy, je verrai si ca marche...

apres, j'essaierai d'installer le refind depuis un live kali (basé sur debian)

a la fin, si je n'y arrive pas, j'installerai debian seul sur le ssd et installerai window sur un vieux disque dur et quand j'aurai besoin de window, je changerai de disque... mais bon, j'aimerais vraiment un dualboot afin de ne pas avoir a me trimballer le second disque dur...

comment je fais pour savoir su l'installeur demarre en mode uefi ou en bios?

Hors ligne

#33 04-08-2016 19:29:15

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] pb d'installation en dual boot avec window 10

L'écran d'accueil est différent : GRUB en UEFI, ISOLinux en BIOS/legacy.

Mais tant que l'installateur demande où installer GRUB, cela veut dire que l'installation se fait en mode BIOS/legacy, et donc que le chargeur UEFI de Windows gardera la priorité sur le chargeur legacy de Debian si les réglages de boot du firmware ne permettent pas de désactiver le boot UEFI ou de donner la priorité au boot legacy. En mode UEFI, l'installateur ne demande pas où installer GRUB puisqu'il l'installe systématiquement dans la partition système EFI. En revanche il demande s'il faut l'installer aussi dans le chemin de périphérique amovible, ce à quoi il est préférable de répondre oui. Cela écrasera le chargeur de secours de Windows; mais pas son chargeur principal.

Debian démarrait quand il était tout seul parce que même installé en mode BIOS il n'y avait pas de chargeur UEFI prenant la priorité.

Je doute que "secure chip" soit l'équivalent du "secure boot" de l'UEFI. Cela me fait plutôt penser à une puce TPM.

Si l'installateur Debian ne peut pas se lancer en mode UEFI, cela peut être parce que
- la copie avec dd n'a pas fonctionné (tester la clé sur un autre PC UEFI ou un Mac UEFI)
- il est incompatible avec le firmware (installateur 64 bits et firmware 32 bits, tester avec l'installateur netinstall 32 bits ou multi-arch)
- le secure boot est activé
- tu ne sélectionnes pas la bonne entrée du menu de boot pour le lancer (dans la majorité des firmwares UEFI que j'ai vus, il y a deux lignes différentes si un périphérique est amorçable à la fois en mode BIOS et en UEFI ; il devrait aussi y avoir une entrée intitulée "Windows Boot Manager")

Si après avoir désactivé le boot legacy l'installateur ne se lance plus, alors ce n'est pas la dernière hypothèse.

Hors ligne

#34 04-08-2016 21:16:08

Archerux
Membre
Distrib. : Debian stretch
Noyau : linux 4.8.0.1-amd64
(G)UI : KDE 5
Inscription : 22-03-2016

Re : [Résolu] pb d'installation en dual boot avec window 10

et voila!!!!!!

apres des heures et des heures à tout refaire, à refaire ma clé d'installation avec DD, effectivement, debian s'est enfin installé en mode uefi!!!!

je pense que c'etait la copie via DD qui était mal passée...

un grand merci à toi, raleur, pour ta patience et tes explications qui ont vraiment eclairci un petit nouveau comme moi...

bonne fin de soirée à toi, je m'en vais finaliser la postinstall : iwlwifi, trackpoint et TLP...

Hors ligne

#35 05-08-2016 09:29:29

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] pb d'installation en dual boot avec window 10

Bravo ! La persévérance a fini par payer.

Hors ligne

#36 05-08-2016 10:00:13

Archerux
Membre
Distrib. : Debian stretch
Noyau : linux 4.8.0.1-amd64
(G)UI : KDE 5
Inscription : 22-03-2016

Re : [Résolu] pb d'installation en dual boot avec window 10

Oui, la persévérance et tes hypothèses/éclaircissements aussi!!!!

Le principal c'est de ne pas laisser tomber...

Merci encore une fois!!!:)

Hors ligne

#37 26-08-2016 22:26:45

Guy19550
Membre
Inscription : 10-08-2016

Re : [Résolu] pb d'installation en dual boot avec window 10

Olala, que dire... depuis Vista, tout me rend malade chez Microsoft, vive XP !

Y a aussi le CD live de gparted qui pourrait aider... et le bootrepair est à mon sens à éviter, j'ai déjà plusieurs fois eu de mauvaises expériences avec le CD avec Debian.

Dernière modification par Guy19550 (26-08-2016 22:29:10)

Hors ligne

Pied de page des forums