Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-08-2016 06:09:55

nazmi
Membre
Lieu : Normandie
Distrib. : GNU/LINUX Debian Jessie
Noyau : Linux 4.3.0-0.bpo.1-amd64
(G)UI : KDE/XFCE
Inscription : 17-07-2015

démarrer en ligne de commande avec le "welcome to GNU/Linux Debian..."

Salut,
Voilà j'aime beaucoup ce message de démarrage et j'aimerais que mon PC démarre avec ça, me donnant ensuite la possibilité de me connecter et de rester en console (rarement) ou démarrer un environnement de bureau, qu'en pensez vous ? possible facilement ? quel genre de commande pour démarrer un environnement de bureau ? startx ?

merci d'avance

Hors ligne

#2 03-08-2016 09:44:54

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : démarrer en ligne de commande avec le "welcome to GNU/Linux Debian..."

Salut smile

Super question qui vaudra une proposition de mise à jour du wiki wink

Avant Jessie, ou avec SysVinit comme système d'init, il fallait changer le runlevel dans le fichier /etc/inittab, ou via telinit par exemple (voir https://debian-facile.org/doc:systeme:g … essus-init

Avec systemd, la manip est légèrement différente. Il faut changer de target avec systemctl set-default.

Dans ton cas, on ferra donc

systemctl set-default multi-user.target

qui correspondra au runlevel 3. Et pour démarrer X, comme tu le disais

startx

ou

systemctl start ton_gestionnaire_de_connexion.service

avec gdm3, kdm, lightdm selon le gestionnaire de connexion que tu utilises.


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#3 03-08-2016 09:53:01

raleur
Membre
Inscription : 03-10-2014

Re : démarrer en ligne de commande avec le "welcome to GNU/Linux Debian..."

Oui. Pour ne pas lancer de gestionnaire de connexion graphique, il suffit de ne pas en installer ou de désactiver son démarrage automatique.

Hors ligne

#4 03-08-2016 09:55:00

raleur
Membre
Inscription : 03-10-2014

Re : démarrer en ligne de commande avec le "welcome to GNU/Linux Debian..."

bendia a écrit :

avec SysVinit comme système d'init, il fallait changer le runlevel dans le fichier /etc/inittab


Ça ne fonctionne pas avec Debian car les runlevels 2 à 5 sont équivalents et lancent tous le gestionnaire de connexion, contrairement à d'autres distributions.

Dernière modification par raleur (03-08-2016 09:55:17)

Hors ligne

#5 03-08-2016 09:59:57

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : démarrer en ligne de commande avec le "welcome to GNU/Linux Debian..."

raleur a écrit :

Ça ne fonctionne pas avec Debian car les runlevels 2 à 5 sont équivalents et lancent tous le gestionnaire de connexion, contrairement à d'autres distributions.

Mince, j'aurais donc mal compris la doc officielle Debian (vrai question hein, c'est pas de l'ironie wink ) ? https://www.debian.org/doc/manuals/debi … e_runlevel

Edit : exact, j'ai mal compris désolé smile

init starts gdm3(1) in runlevel=(3,4,5).

donc, le runlevel 3 démarre GDM

Dernière modification par bendia (03-08-2016 10:15:51)


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#6 03-08-2016 11:09:47

raleur
Membre
Inscription : 03-10-2014

Re : démarrer en ligne de commande avec le "welcome to GNU/Linux Debian..."

bendia a écrit :

init starts gdm3(1) in runlevel=(3,4,5).


Cette phrase se situe dans le cadre d'un exemple où on voudrait vaguement imiter le comportement de Red Hat, qui est différent du comportement par défaut de Debian.

La phrase importante est celle-ci :

The Debian system does not pre-assign any special meaning differences among the runlevels between 2 and 5.

Hors ligne

#7 03-08-2016 11:20:27

wlourf
Membre
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : awesome
Inscription : 19-07-2010

Re : démarrer en ligne de commande avec le "welcome to GNU/Linux Debian..."

Peut être une solution plus simple : sans avoir installé de gestionnaire de connexion graphique, j'ai ce petit script dans mon .bashrc :


# Si on est dans une console, et qu'aucune
# instance de X n'est détecté, demander si
# startx doit être lancé
if [[ -t 0 && $(tty) =~ /dev/tty ]] && ! pgrep -u $USER startx &> /dev/null; then
    echo
    echo -en "\033[1;32mstartx ? \033[0;37m[O|n]"
    read -n 1 start_x
   
    if [[ $start_x == "n" ]]; then
        echo -e "\n"
        echo "on reste en console ..."
        echo ""
    else
        startx
    fi  
fi

 





(trouvé sur arclinux je crois)

@nazmi : tu peux configurer le message de bienvenue dans /etc/issue

Dernière modification par wlourf (03-08-2016 11:20:57)

Hors ligne

#8 03-08-2016 11:26:10

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : démarrer en ligne de commande avec le "welcome to GNU/Linux Debian..."

raleur a écrit :

La phrase importante est celle-ci :

    The Debian system does not pre-assign any special meaning differences among the runlevels between 2 and 5.

Un cours de maths en plus d'un cours d'informatique : implication n'est pas équivalence ! Merci raleur wink

Donc, outre la non installation du gestionnaire de connexion, la bon méthode avec SysVinit pour qu'il ne se lance pas serait par exemple pour gdm3 ?

update-rc.d disable gdm3


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#9 06-08-2016 03:07:55

nazmi
Membre
Lieu : Normandie
Distrib. : GNU/LINUX Debian Jessie
Noyau : Linux 4.3.0-0.bpo.1-amd64
(G)UI : KDE/XFCE
Inscription : 17-07-2015

Re : démarrer en ligne de commande avec le "welcome to GNU/Linux Debian..."

Merci à tous pour les explications, je vais tester à dans quelques minutes, normalement tout est bon, intéressant de voir à quel point le passage à systemd a fait évoluer des trucs (enfin là ça symplifie la chose à ce que je vois tongue )

wlourf a écrit :

@nazmi : tu peux configurer le message de bienvenue dans /etc/issue



merci tu m'as épargné une recherche, le message par défaut est nul par contre:

Debian GNU/Linux 8 \n \l



je vais me dépêcher de changer ça big_smile en mettant quelques touches de couleur là dedans big_smile

Hors ligne

Pied de page des forums