Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-08-2016 16:12:18

AbdelQahar
Membre
Lieu : Marmande
Distrib. : Jessie + Backports
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 14-08-2014

[Résolu] capslock(swapescape)

@ tous : salut

J'ai échanger il y a un certain temps Echa et Caps_Lock (pour vim). Pour se faire j'avais mis une petite ligne dans le fichier /etc/default/keyboard.
Il y a pas longtemps j'ai décidé d'arrêter, alors j'ai enlevé la ligne en question.

Sauf que maintenant une fois sur deux (quand je redémarre l'ordi) ça me refait l'échange. Je n'arrive pas à comprendre pourquoi, et je ne sais pas où je dois intervenir.

Là de suite :

setxkbmap -print


xkb_keymap {
  xkb_keycodes  { include "evdev+aliases(qwerty)" };
  xkb_types     { include "complete"  };
  xkb_compat    { include "complete"  };
  xkb_symbols   { include "pc+us(intl)+inet(evdev)+capslock(swapescape)"  };
  xkb_geometry  { include "pc(pc105)" };
};



EDIT :
Et après un reboot :

xkb_keymap {
  xkb_keycodes  { include "evdev+aliases(qwerty)" };
  xkb_types     { include "complete"  };
  xkb_compat    { include "complete"  };
  xkb_symbols   { include "pc+us(intl)+inet(evdev)" };
  xkb_geometry  { include "pc(pc105)" };
};

Dernière modification par AbdelQahar (23-08-2016 20:30:05)

Hors ligne

#2 09-08-2016 03:31:51

AbdelQahar
Membre
Lieu : Marmande
Distrib. : Jessie + Backports
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 14-08-2014

Re : [Résolu] capslock(swapescape)

Bon, j’ai trouvé comment de rétablir la chose au vol (c’est déjà ça !) :

setxkbmap -symbols "pc+ya+inet(evdev)+capslock(capslock)"


Il fallait aller jeter un coup d’œil au fichier /usr/share/X11/xkb/symbols/capslock :

default  partial hidden modifier_keys
xkb_symbols "capslock" {
    replace key <CAPS> { [ Caps_Lock ] };
    modifier_map Lock { Caps_Lock };
};

partial hidden modifier_keys
xkb_symbols "shiftlock" {
    replace key <CAPS> { [ Shift_Lock ] };
    modifier_map Shift { Shift_Lock };
};

partial hidden modifier_keys
xkb_symbols "grouplock" {
    replace key <CAPS> { [ ISO_Next_Group, Caps_Lock ] };
};

partial hidden modifier_keys
xkb_symbols "swapescape" {
    key <CAPS> { [ Escape ] };
    key <ESC>  { [ Caps_Lock ] };
};

partial hidden modifier_keys
xkb_symbols "groupshift" {
    key <CAPS> {
        type[Group1] = "PC_ALT_LEVEL2",
        [ Mode_switch, Caps_Lock ]
    };
};

partial hidden modifier_keys
xkb_symbols "escape" {
    key <CAPS> { [ Escape ] };
};

partial hidden modifier_keys
xkb_symbols "backspace" {
    key <CAPS> { [ BackSpace ] };
};

partial hidden modifier_keys
xkb_symbols "super" {
    key <CAPS> { [ Super_L ] };
    modifier_map Mod4 { <CAPS> };
};

partial hidden modifier_keys
xkb_symbols "hyper" {
    key <CAPS> { [ Hyper_L ] };
    modifier_map Mod4 { <CAPS> };
};

partial hidden modifier_keys
xkb_symbols "none" {
    key <CAPS> { [ VoidSymbol ] };
};

partial hidden modifier_keys
xkb_symbols "numlock" {
    key <CAPS> { [ Num_Lock ] };
};

// This changes the <CAPS> key to become a Control modifier,
// but it will still produce the Caps_Lock keysym.
partial hidden modifier_keys
xkb_symbols "ctrl_modifier" {
    replace key <CAPS> {
        type[Group1] = "ONE_LEVEL",
        symbols[Group1] = [ Caps_Lock ],
        actions[Group1] = [ SetMods(modifiers=Control) ]
    };
    modifier_map Control { <CAPS> };
};


Mais ça ne me dit toujours pas pourquoi à chaque redémarrage ça change !

Dernière modification par AbdelQahar (09-08-2016 03:33:31)

Hors ligne

#3 09-08-2016 08:00:13

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [Résolu] capslock(swapescape)

Salut,

Est-ce certain que dans tes tentatives pour définir Caps_Lock en tant qu'Echap (ce que tu aurais du faire dans ton  ~/.vimrc plutôt) tu n'aurais pas laissé une instruction dans un autre fichier (/etc/inputrc ?) ou encore défini une commande dans ton ~/.profile ou ~/.bashrc pour modifier ton keymap ?

Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#4 09-08-2016 18:07:02

AbdelQahar
Membre
Lieu : Marmande
Distrib. : Jessie + Backports
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 14-08-2014

Re : [Résolu] capslock(swapescape)

Non, sûr et certain… pour preuve : cela a un impact sur la totalité de mon système, et pas seulement dans vim ou le shell.

Comment on fait ça dans le .vimrc et dans le .inputrc d’ailleurs ? Je ne savais pas que c’était possible.

Dernière modification par AbdelQahar (09-08-2016 18:14:25)

Hors ligne

#5 21-08-2016 21:56:08

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : [Résolu] capslock(swapescape)

Bonsoir,

Alors je n'apporte pas d'explication mais juste une solution de contournement :

setxkbmap -option && setxkbmap -option caps:capslock


afin de rétablir le comportement par défaut pour la session en cours ;

XKBOPTIONS=caps:capslock


à ajouter au fichier /etc/default/keyboard afin que ce soit permanent ;

la liste des options se trouve dans /usr/share/X11/xkb/rules/base.lst.

Dernière modification par èfpé (21-08-2016 22:54:08)

En ligne

#6 23-08-2016 20:29:44

AbdelQahar
Membre
Lieu : Marmande
Distrib. : Jessie + Backports
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 14-08-2014

Re : [Résolu] capslock(swapescape)

èfpé a écrit :

XKBOPTIONS=caps:capslock


Ben oui, tout simplement, je suis bête de ne pas y avoir pensé plus tôt…

Merci, je considère que c’est résolu !

Dernière modification par AbdelQahar (23-08-2016 20:31:27)

Hors ligne

Pied de page des forums