Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 14-08-2016 03:44:35

dum
Membre
Lieu : Paris
Distrib. : Jessie 8.5
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : Xfce 4.10.1
Inscription : 03-08-2016

Re : [RESOLU]Problème de son MERCI l'equipe ;)

Salut,

Je vais tester la version testing Smolski je n'ai pas d'autre solution pour le moment.

èfpé a écrit :

damned, je n'avais pas vu que tu avais installé le pilote propriétaire pour ta carte NVIDIA, pas vraiment assuré là hmm


T'inquiet Efpé, comme je te l'ai dit ce n'est pas grave, "on ne fait pas d'omelette sans casser des oeufs" lol

see you soon


Je suis nouveau sur Debian alors soyez indulgent. Thanks
Je vais adhérer à Debian-Facile, je vous tiens au courant ici même smile

Hors ligne

#27 14-08-2016 04:53:31

dum
Membre
Lieu : Paris
Distrib. : Jessie 8.5
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : Xfce 4.10.1
Inscription : 03-08-2016

Re : [RESOLU]Problème de son MERCI l'equipe ;)

Re,

Je confirme, avec Stretch le son fonctionne par défaut. big_smile
Mais maintenant j'ai un autre problème je ne parviens pas à télécharger le pilote de ma carte graphique dans les dépôts non-free.
N'est-il pas possible d'orienter Stretch exclusivement vers les dépôts de Jessie ?
Est-ce qu'au niveau des outils ou pilotes nécessaires pour smartphone, imprimante... je trouverais l'équivalent sur Stretch ?

Merci

Dum

Je suis nouveau sur Debian alors soyez indulgent. Thanks
Je vais adhérer à Debian-Facile, je vous tiens au courant ici même smile

Hors ligne

#28 14-08-2016 05:17:54

dum
Membre
Lieu : Paris
Distrib. : Jessie 8.5
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : Xfce 4.10.1
Inscription : 03-08-2016

Re : [RESOLU]Problème de son MERCI l'equipe ;)

Bon,

J'ai réussi à télécharger mon pilote de carte graphique mais il n'est pas complet comme sous Jessie car je n'ai aucun panneau nvidia me permettant de paramétrer mon affichage.
Lors de téléchargement des fichier ou de l'installation du pilote de ma carte graphique des fichiers ont été omi cela doit être la cause.
De toute façon ce n'est plus un problème de son, nouveau post à ouvrir.
Y'a toujours quelque chose qui va pas, quand est-ce que je vais pouvoir utiliser ma machine... en paix ?

Merci à vous

Je suis nouveau sur Debian alors soyez indulgent. Thanks
Je vais adhérer à Debian-Facile, je vous tiens au courant ici même smile

Hors ligne

#29 14-08-2016 06:26:55

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [RESOLU]Problème de son MERCI l'equipe ;)

dum a écrit :

J'ai réussi à télécharger mon pilote de carte graphique


D'où l'as-tu téléchargé, des sources officielles debian ? smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#30 14-08-2016 06:45:35

dum
Membre
Lieu : Paris
Distrib. : Jessie 8.5
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : Xfce 4.10.1
Inscription : 03-08-2016

Re : [RESOLU]Problème de son MERCI l'equipe ;)

Salut Smolski, bien dormi ?

j'ai suivie le liens que tu m'a donné pour installer une carte graphique wink puis j'ai saisie la commande

apt-get install nvidia-kernel-dkms nvidia-settings nvidia-driver linux-headers-$(uname -r)


Celle-ci m'indiquait que nvidia-settings n'etait pas présant dans le dépot en revanche il me proposait libxnvctrl-dev.
Voilà mais je fais comment pour avoir le paneau de configuration d'nvidia j'en ai besoin.
Et y'a un truc que je comprends pas si ma carte son fonctionne correctement avec Stretch pourquoi elle n'ai pas bien configuré sous Jessie

Dernière modification par dum (14-08-2016 06:46:04)


Je suis nouveau sur Debian alors soyez indulgent. Thanks
Je vais adhérer à Debian-Facile, je vous tiens au courant ici même smile

Hors ligne

#31 14-08-2016 08:19:20

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [RESOLU]Problème de son MERCI l'equipe ;)

Salut !

dum a écrit :

si ma carte son fonctionne correctement avec Stretch pourquoi elle n'ai pas bien configuré sous Jessie


C'est parce que Stretch (testing) utilise des firmwares (pilotes) que Jessie (stable) se refuse d'utiliser.
Peut-être qu'avec les dépôts backports ajoutés dans les sources de Jessie tu les aurais ?


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#32 14-08-2016 08:28:21

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : [RESOLU]Problème de son MERCI l'equipe ;)

Bonjour smile
nvidia-settings est dans le dépôt contrib de stretch pourtant. As-tu ajouté les dépôts contrib et non-free ?
De même pour jessie, j'ai l'impression en lisant le fil que tu as seulement ajouté le dépôt main des backports ?
Pour pouvoir utiliser le pilote Nvidia des backports qui va avec le noyau des backports (celui ci prendrait mieux en charge l'audio peut être ?) tu as besoin des des dépôts contrib et non-free des backports.

Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#33 14-08-2016 09:36:57

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [RESOLU]Problème de son MERCI l'equipe ;)

chalu a écrit :

As-tu ajouté les dépôts contrib et non-free ?


Voir le tuto :
https://debian-facile.org/doc:systeme:a … t#sections smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#34 14-08-2016 10:51:15

dum
Membre
Lieu : Paris
Distrib. : Jessie 8.5
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : Xfce 4.10.1
Inscription : 03-08-2016

Re : [RESOLU]Problème de son MERCI l'equipe ;)

Re,

Pouvez-vous m'indiquer si mon source.list est correct svp :

deb http://ftp.fr.debian.org/debian/ stretch main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ stretch main contrib non-free

deb http://security.debian.org/debian-security stretch/updates main contrib non-free
deb-src http://security.debian.org/debian-security stretch/updates main contrib non-free

deb http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free

deb http://httpredir.debian.org/debian stretch-backports main contrib non-free



Merci

Dum


Je suis nouveau sur Debian alors soyez indulgent. Thanks
Je vais adhérer à Debian-Facile, je vous tiens au courant ici même smile

Hors ligne

#35 14-08-2016 11:01:21

dum
Membre
Lieu : Paris
Distrib. : Jessie 8.5
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : Xfce 4.10.1
Inscription : 03-08-2016

Re : [RESOLU]Problème de son MERCI l'equipe ;)

C'est pas possible ça ! Pourquoi sous Jessie ma carte son est mal configuré !!!
Pourquoi sous Stretch je n'ai aucun panneau de configuration de ma carte graphique !

Ca fait plus de deux semaines que je me prends la tête avec cette config.
Alors l'ideal pour moi serait d'avoir un Jessie qui prenne en charge ma carte son.
Dans mon install Jessie je n'avais pas mi de dépot backports comme je l'ai fait sous Stretch est ce que cela m'a pu porté defaut pour que le systeme prenne en charge ma carte son ?

Merci à vous

Je suis nouveau sur Debian alors soyez indulgent. Thanks
Je vais adhérer à Debian-Facile, je vous tiens au courant ici même smile

Hors ligne

#36 14-08-2016 11:40:06

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [RESOLU]Problème de son MERCI l'equipe ;)

Oui, il est probable que sans les backports, Jessie ne pouvait trouver les paquets pour le son...
Si tu lis les tutos mis en lien et que tu cherches aussi parmis les autres liens du tuto ouvert, tu trouveras ce que sont les backports pour la stable alors que pour la testing ils sont vides.

En fait les backports des stables contiennent des paquets venues de testing et considérés comme suffisamment stable. smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#37 14-08-2016 11:46:46

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : [RESOLU]Problème de son MERCI l'equipe ;)

Coucou smile

chalu a écrit :

... le noyau des backports (celui-ci prendrait mieux en charge l'audio peut-être ?) ...


Oui, c'était effectivement ça l'idée, d'autant que :

alsa-driver

alsa-driver contains the ALSA components that run in kernel space (e.g. all the modules). It also contains a few user-space components, including the alsasound startup script and a set of ALSA headers.

This package is now obsolete, as kernel.org is now taking updates to the modules directly from the ALSA GIT server.


Source : alsa-project.org
Ceci dit il y a tout le reste de la suite ALSA, qui n'est pas rétroporté ; il faudrait tester !

dum a écrit :

Dans mon install Jessie je n'avais pas mis de dépôt backports comme je l'ai fait sous Stretch est-ce que cela a pu me porter défaut pour que le système prenne en charge ma carte son ?


Comme dit plus haut, ALSA n'est pas rétroporté, or c'est ALSA qui interagit avec le matériel, pas PulseAudio... d'où la proposition d'installer le noyau rétroporté (beaucoup plus proche de celui utilisé par Stretch que celui utilisé par défaut par Jessie) mais il faudra le faire avant d'installer le pilote propriétaire pour la carte graphique.

Bonne continuation et bon dimanche à toutes et tous smile

edit: dégraissage du mammouth

Dernière modification par èfpé (14-08-2016 16:20:36)

En ligne

#38 14-08-2016 15:17:24

dum
Membre
Lieu : Paris
Distrib. : Jessie 8.5
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : Xfce 4.10.1
Inscription : 03-08-2016

Re : [RESOLU]Problème de son MERCI l'equipe ;)

Re à toutes et tous,

J'ai réinstallé Jessie.
modifier le source.list afin d'avoir les contrib, non-free et backports.
j'ai mi à niveau le noyau afin de détecté ma carte son et ca a fonctionné big_smile
en revanche j'ai installé le pilote de ma carte graphique et au redémarrage écran noir avec le curseur, je ne comprends pas il y'a-t-il incompatibilité entre le nouveau noyau et ma carte graphique je ne vois pas ce qui a pu bugger.

Merci à vous

Je suis nouveau sur Debian alors soyez indulgent. Thanks
Je vais adhérer à Debian-Facile, je vous tiens au courant ici même smile

Hors ligne

#39 14-08-2016 16:04:28

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : [RESOLU]Problème de son MERCI l'equipe ;)

Re- à toi,

Cool ça progresse... pour ce qui est de l'écran noir après installation du pilote proprio, je n'avais suivi l'affaire mais il me semble que tu avais eu le même souci avec le noyau 3.16, non ? N'ayant aucune idée de la méthode utilisée, je préfère m'abstenir de toute suggestion à l'aveugle wink

Peux-tu malgré tout nous donner le retour de cette commande :

lspci -nnk | grep -iA2 vga


Et je me permets au passage de saluer ta persévérance.

En ligne

#40 14-08-2016 16:26:09

dum
Membre
Lieu : Paris
Distrib. : Jessie 8.5
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : Xfce 4.10.1
Inscription : 03-08-2016

Re : [RESOLU]Problème de son MERCI l'equipe ;)

Salut Efpé,

Et je me permets au passage de saluer ta persévérance.


Merci, mais il faut pour que ça marche j'ai pas trop le choix. neutral

pour ce qui est de l'écran noir après installation du pilote proprio, je n'avais suivi l'affaire mais il me semble que tu avais eu le même souci avec le noyau 3.16, non ?


Oui, c'est lorsque j'ai tanté de mettre à niveau le noyau mais le problème que tu avais évoqué c'est que j'avais installé avant le pilote propriétaire de ma carte graphique.
Pouvez vous me dire si mon sources.list est correct svp, parce que la j'ai réinstallé Jessie et je m'aprète à mettre à niveau le noyau puis installé le pilote propriétaire de ma carte graphique.

deb http://ftp.fr.debian.org/debian/ jessie main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ jessie main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free

# jessie-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free

deb http://http.debian.net/debian/ jessie-backports main contrib non-free
deb-src http://http.debian.net/debian/ jessie-backports main contrib non-free



Je retante l'installation en espérant qui ai eu un bug quelconque à la seul différence que je n'ai pas fait une instal EFI non je ne sais plus le non la nouvelle technologie au démarrage.
Et j'essai de faire des :

apt-get update


le plus souvant possible.

Voici le résultat de la commande :

lspci -nnk | grep -iA2 vga


01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] [10de:1380] (rev a2)
  Subsystem: Gigabyte Technology Co., Ltd Device [1458:362d]
01:00.1 Audio device [0403]: NVIDIA Corporation Device [10de:0fbc] (rev a1)


J'attends de vos nouvelle avant de faire quoi que ce soit

Merci à vous
Dum


Je suis nouveau sur Debian alors soyez indulgent. Thanks
Je vais adhérer à Debian-Facile, je vous tiens au courant ici même smile

Hors ligne

#41 14-08-2016 17:06:54

èfpé
Membre
Distrib. : Debian
Noyau : Linux
Inscription : 10-07-2016

Re : [RESOLU]Problème de son MERCI l'equipe ;)

Merci dum,

Ton sources.list est correct ; la ligne commentée ne sert à rien et par souci de cohérence j'écrirais :

deb http://ftp.fr.debian.org/debian/ jessie main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ jessie main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free

deb http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free

deb http://ftp.fr.debian.org/debian/ jessie-backports main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ jessie-backports main contrib non-free


Mais on va dire que j'embête les diptères, là.

Sauf erreur de ma part, le retour de la commande lspci (obtenu en console, c'est bien ça ?) montre qu'il n'y a pas de pilote actif pour ce périphérique, ton unique carte graphique en l'occurrence... d'où l'écran noir. Normalement on obtient une sortie du type :

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF119 [GeForce GT 610] [10de:104a] (rev a1)
  Subsystem: Micro-Star International Co., Ltd. Device [1462:809f]
  Kernel driver in use: nvidia


Le kernel driver in use étant typiquement 'nouveau' ou 'nvidia', pour une carte NVIDIA !

Concrètement, puisque le problème de son est résolu, je te propose d'ouvrir un nouveau fil concernant l'installation du pilote propriétaire pour ta carte graphique NVIDIA GeForce GTX 750 Ti, en précisant :

1. le retour de la commande lspci ;
2. la version du noyau installée ;
3. la version du pilote proprio que tu veux installer ;
4. la méthode que tu as employée ;
5. et le pourquoi du pilote proprio.

Mais on va encore dire que j'embête les diptères, là.

Dernière modification par èfpé (14-08-2016 17:16:44)

En ligne

#42 14-08-2016 19:58:19

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [RESOLU]Problème de son MERCI l'equipe ;)

dum a écrit :

Re,

Je confirme, avec Stretch le son fonctionne par défaut. big_smile
Mais maintenant j'ai un autre problème je ne parviens pas à télécharger le pilote de ma carte graphique dans les dépôts non-free.
N'est-il pas possible d'orienter Stretch exclusivement vers les dépôts de Jessie ?
Est-ce qu'au niveau des outils ou pilotes nécessaires pour smartphone, imprimante... je trouverais l'équivalent sur Stretch ?

Merci

Dum



merci d'avoir pris le temps de tester stretch et confirmer ce que je t ai dis  smile
pour les paquets normalement ils sont a jours et dispo
pour le driver nonfree idem c est un jeux d enfant pour l installer soit par le wiki soit par synaptic (en graphique )

sur du materiel récent , un os récent wink  (c'est valable pour tous les os )

Hors ligne

Pied de page des forums